On Sun 2008-02-03 23:27:20, Sam Ravnborg wrote:
> On Sun, Feb 03, 2008 at 11:24:07PM +0100, Pavel Machek wrote:
> > On Sun 2008-02-03 19:49:31, Sam Ravnborg wrote:
> > > On Sun, Feb 03, 2008 at 07:16:48PM +0100, Pavel Machek wrote:
> > > > Hi!
> > > >
> > > > > > This version works on 32-bit, and
Hi!
Here's updated diff. Video & Makefiles by hpa, rest by me ;-).
Pavel
diff --git a/arch/x86/Makefile b/arch/x86/Makefile
index 8978e98..949b8eb 100644
--- a/arch/x86/Makefile
+++ b/arch/x86/Makefile
@@ -192,8 +192,8 @@ drivers-$(C
On Mon 2008-02-04 00:59:38, Rafael J. Wysocki wrote:
> On Monday, 4 of February 2008, Pavel Machek wrote:
> > Hi!
> >
> > > BTW, I don't like the way in which the 'struct wakeup_header' fields are
> > > reproduced in rm/wakeup.S very much, because it makes the code fragile.
> > > It might be bette
On Monday, 4 of February 2008, Pavel Machek wrote:
> Hi!
>
> > - Could the real mode directory be called just "real-mode" or something like
> > this ("rm" is not very meaningful :-))?
> >
> > Apart from the above and the _WAKEUP hacks mentioned elsewhere, it looks
> > okay
> > (from a very hig
On Monday, 4 of February 2008, Pavel Machek wrote:
> Hi!
>
> > BTW, I don't like the way in which the 'struct wakeup_header' fields are
> > reproduced in rm/wakeup.S very much, because it makes the code fragile.
> > It might be better to define the offsets in asm-offsets*.c and refer to them
> > r
Hi!
> BTW, I don't like the way in which the 'struct wakeup_header' fields are
> reproduced in rm/wakeup.S very much, because it makes the code fragile.
> It might be better to define the offsets in asm-offsets*.c and refer to them
> relative to wakeup_header (if possible).
If you can do that.. y
> it looks okay
> (from a very high orbit).
It should look better from closer look. Reusing trampoline_64.S
instead of cut©&paste gets us rid of some really nasty assembly
;-).
Pavel
--
(english) http://www.livejournal.com/~p
On Monday, 4 of February 2008, Pavel Machek wrote:
> On Mon 2008-02-04 00:20:14, Rafael J. Wysocki wrote:
> > On Sunday, 3 of February 2008, Rafael J. Wysocki wrote:
> > > On Sunday, 3 of February 2008, Pavel Machek wrote:
> > > > Hi!
> > > >
> > > > > > This version works on 32-bit, and builds on
Hi!
> - Could the real mode directory be called just "real-mode" or something like
> this ("rm" is not very meaningful :-))?
>
> Apart from the above and the _WAKEUP hacks mentioned elsewhere, it looks okay
> (from a very high orbit).
Wakeup hacks? You mean those #ifdef WAKEUP in video code?
Hi!
> Below is the arch/x86/kernel/acpi/sleep.c part without the warnings
> (untested).
>
> It still contains some hardcoded magic numbers and extern declarations, so
> I guess the #include list is not complete or another header is necessary.
>
> BTW:
> 1) why exactly is acpi_wakeup_address not
On Monday, 4 of February 2008, Rafael J. Wysocki wrote:
> On Sunday, 3 of February 2008, Rafael J. Wysocki wrote:
> > On Sunday, 3 of February 2008, Pavel Machek wrote:
> > > Hi!
> > >
> > > > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > > > sure it does not work. 32-
On Mon 2008-02-04 00:20:14, Rafael J. Wysocki wrote:
> On Sunday, 3 of February 2008, Rafael J. Wysocki wrote:
> > On Sunday, 3 of February 2008, Pavel Machek wrote:
> > > Hi!
> > >
> > > > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > > > sure it does not work. 32-bit
On Sunday, 3 of February 2008, Rafael J. Wysocki wrote:
> On Sunday, 3 of February 2008, Pavel Machek wrote:
> > Hi!
> >
> > > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > > sure it does not work. 32-bit code probably needs to go into rm/)
> > > >
> > >
> > > Do
On Sunday, 3 of February 2008, Pavel Machek wrote:
> Hi!
>
> > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > sure it does not work. 32-bit code probably needs to go into rm/)
> > >
> >
> > Do you have an updated version or is this the latest one?
>
> I'm glad yo
On Sun, Feb 03, 2008 at 11:24:07PM +0100, Pavel Machek wrote:
> On Sun 2008-02-03 19:49:31, Sam Ravnborg wrote:
> > On Sun, Feb 03, 2008 at 07:16:48PM +0100, Pavel Machek wrote:
> > > Hi!
> > >
> > > > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > > > sure it does not
On Sun 2008-02-03 19:49:31, Sam Ravnborg wrote:
> On Sun, Feb 03, 2008 at 07:16:48PM +0100, Pavel Machek wrote:
> > Hi!
> >
> > > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > > sure it does not work. 32-bit code probably needs to go into rm/)
> > > >
> > >
> > >
Sam Ravnborg wrote:
On Sun, Feb 03, 2008 at 07:16:48PM +0100, Pavel Machek wrote:
Hi!
This version works on 32-bit, and builds on 64-bit (but I'm pretty
sure it does not work. 32-bit code probably needs to go into rm/)
Do you have an updated version or is this the latest one?
I'm glad y
On Sun, Feb 03, 2008 at 07:16:48PM +0100, Pavel Machek wrote:
> Hi!
>
> > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > sure it does not work. 32-bit code probably needs to go into rm/)
> > >
> >
> > Do you have an updated version or is this the latest one?
>
>
On Sunday, 3 of February 2008, Pavel Machek wrote:
> Hi!
>
> > > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > > sure it does not work. 32-bit code probably needs to go into rm/)
> > >
> >
> > Do you have an updated version or is this the latest one?
>
> I'm glad yo
Hi!
> > This version works on 32-bit, and builds on 64-bit (but I'm pretty
> > sure it does not work. 32-bit code probably needs to go into rm/)
> >
>
> Do you have an updated version or is this the latest one?
I'm glad you ask ;-). Here's reasonably-recent version (I have
slightly cleaner
On Wednesday, 30 of January 2008, Pavel Machek wrote:
> Hi!
Hi,
> This version works on 32-bit, and builds on 64-bit (but I'm pretty
> sure it does not work. 32-bit code probably needs to go into rm/)
>
Do you have an updated version or is this the latest one?
Rafael
--
To unsubscribe from
Hi!
This version works on 32-bit, and builds on 64-bit (but I'm pretty
sure it does not work. 32-bit code probably needs to go into rm/)
Pavel
diff --git a/arch/x86/boot/Makefile b/arch/x86/boot/Makefile
index 7a3116c..6e
22 matches
Mail list logo