[PATCH] dax: add set_dax_nomc() and set_dax_nocache() stub helpers

2024-02-16 Thread Arnd Bergmann
From: Arnd Bergmann In some randconfig builds, the IS_ERR() check appears to not get completely eliminated, resulting in the compiler to insert references to these two functions that cause a link failure: ERROR: modpost: "set_dax_nocache" [drivers/md/dm-mod.ko] undefined! ERROR: modpost:

Re: [PATCH v1 0/4] perf parse-regs: Cleanup config and building

2024-02-16 Thread Namhyung Kim
On Wed, 14 Feb 2024 19:39:43 +0800, Leo Yan wrote: > Currently, the perf building enables register parsing based on the > target architecture has supported register feature. > > Furthermore, the perf building system needs to maintain a variable > 'NO_PERF_REGS' and defines macro

Re: [PATCH] dax: add set_dax_nomc() and set_dax_nocache() stub helpers

2024-02-16 Thread Mathieu Desnoyers
On 2024-02-16 15:22, Arnd Bergmann wrote: From: Arnd Bergmann In some randconfig builds, the IS_ERR() check appears to not get completely eliminated, resulting in the compiler to insert references to these two functions that cause a link failure: ERROR: modpost: "set_dax_nocache"

Re: [PATCH 1/3] dt-bindings: mfd: qcom,spmi-pmic: Add pbs to SPMI device types

2024-02-16 Thread Bjorn Andersson
On Mon, Feb 05, 2024 at 10:51:38AM +0100, Luca Weiss wrote: > Add the PBS (Programmable Boot Sequencer) to the list of devices. > > Signed-off-by: Luca Weiss Reviewed-by: Bjorn Andersson Regards, Bjorn > --- > Documentation/devicetree/bindings/mfd/qcom,spmi-pmic.yaml | 4 > 1 file

[PATCH v3 3/3] tracing: Move saved_cmdline code into trace_sched_switch.c

2024-02-16 Thread Steven Rostedt
From: "Steven Rostedt (Google)" The code that handles saved_cmdlines is split between the trace.c file and the trace_sched_switch.c. There's some history to this. The trace_sched_switch.c was originally created to handle the sched_switch tracer that was deprecated due to sched_switch trace event

[PATCH v3 2/3] tracing: Move open coded processing of tgid_map into helper function

2024-02-16 Thread Steven Rostedt
From: "Steven Rostedt (Google)" In preparation of moving the saved_cmdlines logic out of trace.c and into trace_sched_switch.c, replace the open coded manipulation of tgid_map in set_tracer_flag() into a helper function trace_alloc_tgid_map() so that it can be easily moved into

[PATCH v3 0/3] tracing: Changes to saved_cmdlines

2024-02-16 Thread Steven Rostedt
Repost of "tracing: Fix wasted memory in saved_cmdlines logic" (hence the v3: v2 at: https://lore.kernel.org/linux-trace-kernel/20240213115232.5fd9e...@gandalf.local.home/) That patch was based on the two other patches in this series, but I forgot to post those two other patches. Instead of

[PATCH v3 1/3] tracing: Have saved_cmdlines arrays all in one allocation

2024-02-16 Thread Steven Rostedt
From: "Steven Rostedt (Google)" The saved_cmdlines have three arrays for mapping PIDs to COMMs: - map_pid_to_cmdline[] - map_cmdline_to_pid[] - saved_cmdlines The map_pid_to_cmdline[] is PID_MAX_DEFAULT in size and holds the index into the other arrays. The map_cmdline_to_pid[] is a mapping

Re: [PATCH] parisc/ftrace: add missing CONFIG_DYNAMIC_FTRACE check

2024-02-16 Thread Helge Deller
On 2/11/24 23:43, Max Kellermann wrote: Fixes a bug revealed by -Wmissing-prototypes when CONFIG_FUNCTION_GRAPH_TRACER is enabled but not CONFIG_DYNAMIC_FTRACE: arch/parisc/kernel/ftrace.c:82:5: error: no previous prototype for 'ftrace_enable_ftrace_graph_caller' [-Werror=missing-prototypes]

Re: [v4 PATCH] ALSA: virtio: Fix "Coverity: virtsnd_kctl_tlv_op(): Uninitialized variables" warning.

2024-02-16 Thread Takashi Iwai
On Fri, 16 Feb 2024 14:48:10 +0100, Michael S. Tsirkin wrote: > > On Fri, Feb 16, 2024 at 02:42:37PM +0100, Takashi Iwai wrote: > > On Fri, 16 Feb 2024 12:27:48 +0100, > > Michael S. Tsirkin wrote: > > > > > > On Fri, Feb 16, 2024 at 11:06:43AM +0100, Aiswarya Cyriac wrote: > > > > This commit

Re: [v4 PATCH] ALSA: virtio: Fix "Coverity: virtsnd_kctl_tlv_op(): Uninitialized variables" warning.

2024-02-16 Thread Michael S. Tsirkin
On Fri, Feb 16, 2024 at 11:06:43AM +0100, Aiswarya Cyriac wrote: > This commit fixes the following warning when building virtio_snd driver. > > " > *** CID 1583619: Uninitialized variables (UNINIT) > sound/virtio/virtio_kctl.c:294 in virtsnd_kctl_tlv_op() > 288 > 289 break; >

Re: [PATCH v7 25/36] arm64: ftrace: Enable HAVE_FUNCTION_GRAPH_FREGS

2024-02-16 Thread Google
On Thu, 15 Feb 2024 11:10:21 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:12:06 +0900 > "Masami Hiramatsu (Google)" wrote: > > > From: Masami Hiramatsu (Google) > > > > Enable CONFIG_HAVE_FUNCTION_GRAPH_FREGS on arm64. Note that this > > depends on HAVE_DYNAMIC_FTRACE_WITH_ARGS which

Re: [PATCH v7 28/36] tracing: Add ftrace_partial_regs() for converting ftrace_regs to pt_regs

2024-02-16 Thread Google
On Thu, 15 Feb 2024 11:11:34 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:12:40 +0900 > "Masami Hiramatsu (Google)" wrote: > > > From: Masami Hiramatsu (Google) > > > > Add ftrace_partial_regs() which converts the ftrace_regs to pt_regs. > > If the architecture defines its own

Re: [v4 PATCH] ALSA: virtio: Fix "Coverity: virtsnd_kctl_tlv_op(): Uninitialized variables" warning.

2024-02-16 Thread Takashi Iwai
On Fri, 16 Feb 2024 12:27:48 +0100, Michael S. Tsirkin wrote: > > On Fri, Feb 16, 2024 at 11:06:43AM +0100, Aiswarya Cyriac wrote: > > This commit fixes the following warning when building virtio_snd driver. > > > > " > > *** CID 1583619: Uninitialized variables (UNINIT) > >

Re: [v4 PATCH] ALSA: virtio: Fix "Coverity: virtsnd_kctl_tlv_op(): Uninitialized variables" warning.

2024-02-16 Thread Michael S. Tsirkin
On Fri, Feb 16, 2024 at 02:42:37PM +0100, Takashi Iwai wrote: > On Fri, 16 Feb 2024 12:27:48 +0100, > Michael S. Tsirkin wrote: > > > > On Fri, Feb 16, 2024 at 11:06:43AM +0100, Aiswarya Cyriac wrote: > > > This commit fixes the following warning when building virtio_snd driver. > > > > > > " >

[PATCH v2] vdpa/mlx5: Allow CVQ size changes

2024-02-16 Thread Jonah Palmer
The MLX driver was not updating its control virtqueue size at set_vq_num and instead always initialized to MLX5_CVQ_MAX_ENT (16) at setup_cvq_vring. Qemu would try to set the size to 64 by default, however, because the CVQ size always was initialized to 16, an error would be thrown when sending

[PATCH] arm64: dts: qcom: sm6350: Add interconnect for MDSS

2024-02-16 Thread Luca Weiss
Add the definition for the interconnect used in the display subsystem. Signed-off-by: Luca Weiss --- arch/arm64/boot/dts/qcom/sm6350.dtsi | 7 +++ 1 file changed, 7 insertions(+) diff --git a/arch/arm64/boot/dts/qcom/sm6350.dtsi b/arch/arm64/boot/dts/qcom/sm6350.dtsi index

[PATCH 1/4] iommu: constify pointer to bus_type

2024-02-16 Thread Krzysztof Kozlowski
Make pointer to bus_type a pointer to const for code safety. Signed-off-by: Krzysztof Kozlowski --- drivers/iommu/iommu-priv.h | 5 +++-- drivers/iommu/iommu.c | 5 +++-- 2 files changed, 6 insertions(+), 4 deletions(-) diff --git a/drivers/iommu/iommu-priv.h b/drivers/iommu/iommu-priv.h

[PATCH 2/4] iommu: constify of_phandle_args in xlate

2024-02-16 Thread Krzysztof Kozlowski
The xlate callbacks are supposed to translate of_phandle_args to proper provider without modifying the of_phandle_args. Make the argument pointer to const for code safety and readability. Signed-off-by: Krzysztof Kozlowski --- drivers/iommu/apple-dart.c | 3 ++-

[PATCH 3/4] iommu: constify fwnode in iommu_ops_from_fwnode()

2024-02-16 Thread Krzysztof Kozlowski
Make pointer to fwnode_handle a pointer to const for code safety. Signed-off-by: Krzysztof Kozlowski --- drivers/iommu/iommu.c | 2 +- include/linux/iommu.h | 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c index

[PATCH 4/4] iommu: re-use local fwnode variable in iommu_ops_from_fwnode()

2024-02-16 Thread Krzysztof Kozlowski
iommu_ops_from_fwnode() stores _spec->np->fwnode in local variable, so use it to simplify the code (iommu_spec is not changed between these dereferences). Signed-off-by: Krzysztof Kozlowski --- drivers/iommu/of_iommu.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[v4 PATCH] ALSA: virtio: Fix "Coverity: virtsnd_kctl_tlv_op(): Uninitialized variables" warning.

2024-02-16 Thread Aiswarya Cyriac
This commit fixes the following warning when building virtio_snd driver. " *** CID 1583619: Uninitialized variables (UNINIT) sound/virtio/virtio_kctl.c:294 in virtsnd_kctl_tlv_op() 288 289 break; 290 } 291 292 kfree(tlv); 293 vvv CID 1583619:

Re: [PATCH v9 09/15] x86/sgx: Charge mem_cgroup for per-cgroup reclamation

2024-02-16 Thread Dave Hansen
On 2/5/24 13:06, Haitao Huang wrote: > @@ -414,7 +416,7 @@ static void sgx_reclaim_pages_global(void) > void sgx_reclaim_direct(void) > { > if (sgx_should_reclaim(SGX_NR_LOW_PAGES)) > - sgx_reclaim_pages_global(); > + sgx_reclaim_pages_global(false); > } > >

Re: [PATCH V2 3/3] vdpa_sim: flush workers on suspend

2024-02-16 Thread Steven Sistare
On 2/15/2024 10:44 AM, Eugenio Perez Martin wrote: > On Wed, Feb 14, 2024 at 8:52 PM Steven Sistare > wrote: >> >> On 2/14/2024 2:39 PM, Eugenio Perez Martin wrote: >>> On Wed, Feb 14, 2024 at 6:50 PM Steven Sistare >>> wrote: On 2/13/2024 11:10 AM, Eugenio Perez Martin wrote: > On

[PATCH] Bluetooth: Add more Bluetooth version defines

2024-02-16 Thread Luca Weiss
1 +#define BLUETOOTH_VER_5_3 12 +#define BLUETOOTH_VER_5_4 13 /* Reserv for core and drivers use */ #define BT_SKB_RESERVE 8 --- base-commit: 841c35169323cd833294798e58b9bf63fa4fa1de change-id: 20240216-bluetooth-defines-b810ce543191 Best regards, -- Luca Weiss

Re: [PATCH RFT] arm64: dts: qcom: sm8350: Reenable crypto & cryptobam

2024-02-16 Thread Luca Weiss
On Mon Jan 8, 2024 at 11:45 PM CET, Dmitry Baryshkov wrote: > On Mon, 8 Jan 2024 at 16:23, Luca Weiss wrote: > > > > On Mon Jan 8, 2024 at 3:18 PM CET, Konrad Dybcio wrote: > > > On 8.01.2024 14:49, Luca Weiss wrote: > > > > When num-channels and qcom,num-ees is not provided in devicetree, the >

Re: [PATCH] parisc/kprobes: always include asm-generic/kprobes.h

2024-02-16 Thread Helge Deller
On 2/12/24 00:09, Max Kellermann wrote: The NOKPROBE_SYMBOL macro (and others) were moved to asm-generic/kprobes.h in 2017 by commit 7d134b2ce639 ("kprobes: move kprobe declarations to asm-generic/kprobes.h"), and this new header was included by asm/kprobes.h unconditionally on all

Re: [PATCH] arm64: dts: qcom: sm6350: Add interconnect for MDSS

2024-02-16 Thread Konrad Dybcio
On 16.02.2024 14:11, Luca Weiss wrote: > Add the definition for the interconnect used in the display subsystem. > > Signed-off-by: Luca Weiss > --- Reviewed-by: Konrad Dybcio Konrad

Re: [PATCH v7 28/36] tracing: Add ftrace_partial_regs() for converting ftrace_regs to pt_regs

2024-02-16 Thread Steven Rostedt
On Fri, 16 Feb 2024 22:09:02 +0900 Masami Hiramatsu (Google) wrote: > On Thu, 15 Feb 2024 11:11:34 -0500 > Steven Rostedt wrote: > > > On Wed, 7 Feb 2024 00:12:40 +0900 > > "Masami Hiramatsu (Google)" wrote: > > > > > From: Masami Hiramatsu (Google) > > > > > > Add ftrace_partial_regs()

Re: [PATCH v9 09/15] x86/sgx: Charge mem_cgroup for per-cgroup reclamation

2024-02-16 Thread Haitao Huang
On Fri, 16 Feb 2024 15:55:10 -0600, Dave Hansen wrote: On 2/16/24 13:38, Haitao Huang wrote: On Fri, 16 Feb 2024 09:15:59 -0600, Dave Hansen wrote: ... Does this 'indirect' change any behavior other than whether it does a search for an mm to find a place to charge the backing storage?

Re: [PATCH v9 09/15] x86/sgx: Charge mem_cgroup for per-cgroup reclamation

2024-02-16 Thread Haitao Huang
On Fri, 16 Feb 2024 09:15:59 -0600, Dave Hansen wrote: On 2/5/24 13:06, Haitao Huang wrote: @@ -414,7 +416,7 @@ static void sgx_reclaim_pages_global(void) void sgx_reclaim_direct(void) { if (sgx_should_reclaim(SGX_NR_LOW_PAGES)) - sgx_reclaim_pages_global(); +

Re: [PATCH v2] acpi/ghes: Prevent sleeping with spinlock held

2024-02-16 Thread Dan Williams
Ira Weiny wrote: [..] > > As Steve said, tp_printk is a hack (a very useful one) and > > hopefully no one runs it in production. > > OMG... I did not realize what tp_printk() was exactly. I should have > looked closer. > > Do we have evidence of its use in production? > > I would love to not

Re: [PATCH] arm64: dts: qcom: sm6350: Add interconnect for MDSS

2024-02-16 Thread Bjorn Andersson
On Fri, 16 Feb 2024 14:11:20 +0100, Luca Weiss wrote: > Add the definition for the interconnect used in the display subsystem. > > Applied, thanks! [1/1] arm64: dts: qcom: sm6350: Add interconnect for MDSS commit: fc48bb313513d140026e4d0c441f290ab9c08577 Best regards, -- Bjorn

Re: [PATCH v2] ARM: dts: qcom: msm8226: Add watchdog node

2024-02-16 Thread Bjorn Andersson
On Wed, 14 Feb 2024 22:46:28 +0100, Luca Weiss wrote: > Add watchdog for MSM8226 platform. > > Applied, thanks! [1/1] ARM: dts: qcom: msm8226: Add watchdog node commit: 9e9c906ede3b7dcf7bf7df61ac712613c7d6c2da Best regards, -- Bjorn Andersson

Re: (subset) [PATCH 0/3] Add PPG support for PMI632 LPG dtsi

2024-02-16 Thread Bjorn Andersson
On Mon, 05 Feb 2024 10:51:37 +0100, Luca Weiss wrote: > Hook up the PBS & SDAM to the PMI632 LPG so that we can use the > hw_pattern for the LEDs. > > Applied, thanks! [3/3] arm64: defconfig: Enable QCOM PBS commit: 9c5c14c066f353ac1f4e3b4dd6e19451eac61e0c Best regards, -- Bjorn

Re: [PATCH v9 09/15] x86/sgx: Charge mem_cgroup for per-cgroup reclamation

2024-02-16 Thread Dave Hansen
On 2/16/24 13:38, Haitao Huang wrote: > On Fri, 16 Feb 2024 09:15:59 -0600, Dave Hansen > wrote: ... >> Does this 'indirect' change any behavior other than whether it does a >> search for an mm to find a place to charge the backing storage? > > No. > >> Instead of passing a flag around, why not

Audio dsp recovery using remoteproc

2024-02-16 Thread noman pouigt
mailbox to dsp_1 is currently modeling platform pcm driver. mailbox to dsp_2 is also doing the same. Platform driver callbacks cause IPC to be sent to dsp's. Lifecycle of two dsp's are managed by separate remoteproc drivers. Single sound card is exposed. Separate watchdog interrupts from the

Re: [PATCH v2] acpi/ghes: Prevent sleeping with spinlock held

2024-02-16 Thread Dan Williams
Ira Weiny wrote: > Ira Weiny wrote: > > Jonathan Cameron wrote: > > > On Wed, 14 Feb 2024 10:23:10 -0500 > > > Steven Rostedt wrote: > > > > > > > On Wed, 14 Feb 2024 12:11:53 + > > > > Jonathan Cameron wrote: > > > > > > > > > So I'm thinking this is a won't fix - wait for the printk

Re: [PATCH v4 0/6] LoongArch: Add pv ipi support on LoongArch VM

2024-02-16 Thread maobibo
On 2024/2/15 下午6:25, WANG Xuerui wrote: On 2/15/24 18:11, WANG Xuerui wrote: Sorry for the late reply (and Happy Chinese New Year), and thanks for providing microbenchmark numbers! But it seems the more comprehensive CoreMark results were omitted (that's also absent in v3)? While the Of

Re: [PATCH v7 21/36] function_graph: Add selftest for passing local variables

2024-02-16 Thread Google
On Thu, 15 Feb 2024 10:02:54 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:11:22 +0900 > "Masami Hiramatsu (Google)" wrote: > > > From: Steven Rostedt (VMware) > > > > Add boot up selftest that passes variables from a function entry to a > > function exit, and make sure that they do

Re: [PATCH v7 23/36] function_graph: Add a new exit handler with parent_ip and ftrace_regs

2024-02-16 Thread Google
On Thu, 15 Feb 2024 10:49:03 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:11:44 +0900 > "Masami Hiramatsu (Google)" wrote: > > > diff --git a/kernel/trace/Kconfig b/kernel/trace/Kconfig > > index 61c541c36596..308b3bec01b1 100644 > > --- a/kernel/trace/Kconfig > > +++

Re: [PATCH v7 23/36] function_graph: Add a new exit handler with parent_ip and ftrace_regs

2024-02-16 Thread Google
On Thu, 15 Feb 2024 10:39:43 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:11:44 +0900 > "Masami Hiramatsu (Google)" wrote: > > > From: Masami Hiramatsu (Google) > > > > Add a new return handler to fgraph_ops as 'retregfunc' which takes > > parent_ip and ftrace_regs instead of

Re: [PATCH v7 23/36] function_graph: Add a new exit handler with parent_ip and ftrace_regs

2024-02-16 Thread Google
On Thu, 15 Feb 2024 11:04:04 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:11:44 +0900 > "Masami Hiramatsu (Google)" wrote: > > > diff --git a/arch/x86/include/asm/ftrace.h b/arch/x86/include/asm/ftrace.h > > index c88bf47f46da..a061f8832b20 100644 > > ---

Re: [PATCH v7 24/36] x86/ftrace: Enable HAVE_FUNCTION_GRAPH_FREGS

2024-02-16 Thread Google
On Thu, 15 Feb 2024 11:08:08 -0500 Steven Rostedt wrote: > On Wed, 7 Feb 2024 00:11:56 +0900 > "Masami Hiramatsu (Google)" wrote: > > > From: Masami Hiramatsu (Google) > > > > Support HAVE_FUNCTION_GRAPH_FREGS on x86-64, which saves ftrace_regs > > on the stack in ftrace_graph return