[PATCH] blk: remove NULL check before freeing functions

2016-05-23 Thread Mike Danese
Coccinelle complains: WARNING: NULL check before freeing functions like kfree, debugfs_remove, debugfs_remove_recursive or usb_free_urb is not needed. Maybe consider reorganizing relevant code to avoid passing NULL values. Signed-off-by: Mike Danese <mikedan...@google.com> --- blo

[PATCH] blk: remove NULL check before freeing functions

2016-05-23 Thread Mike Danese
Coccinelle complains: WARNING: NULL check before freeing functions like kfree, debugfs_remove, debugfs_remove_recursive or usb_free_urb is not needed. Maybe consider reorganizing relevant code to avoid passing NULL values. Signed-off-by: Mike Danese --- block/bio-integrity.c | 7 ++- block

[PATCH] mpssd: fix buffer overflow warning

2016-05-19 Thread Mike Danese
in commit f4a66c204482 ("misc: mic: Update MIC host daemon with COSM changes") and is fixed by reverting the changes to the size argument of these snprintf statements. Cc: Ashutosh Dixit <ashutosh.di...@intel.com> Signed-off-by: Mike Danese <mikedan...@google.com> --- D

[PATCH] mpssd: fix buffer overflow warning

2016-05-19 Thread Mike Danese
in commit f4a66c204482 ("misc: mic: Update MIC host daemon with COSM changes") and is fixed by reverting the changes to the size argument of these snprintf statements. Cc: Ashutosh Dixit Signed-off-by: Mike Danese --- Documentation/mic/mpssd/mpssd.c | 4 ++-- 1 file changed, 2 insert

[PATCH] security: tomoyo: simplify the gc kthread creation

2016-05-19 Thread Mike Danese
The code is doing the equivalent of the kthread_run macro. Signed-off-by: Mike Danese <mikedan...@google.com> --- security/tomoyo/gc.c | 9 ++--- 1 file changed, 2 insertions(+), 7 deletions(-) diff --git a/security/tomoyo/gc.c b/security/tomoyo/gc.c index 986a6a7..540bc29

[PATCH] security: tomoyo: simplify the gc kthread creation

2016-05-19 Thread Mike Danese
The code is doing the equivalent of the kthread_run macro. Signed-off-by: Mike Danese --- security/tomoyo/gc.c | 9 ++--- 1 file changed, 2 insertions(+), 7 deletions(-) diff --git a/security/tomoyo/gc.c b/security/tomoyo/gc.c index 986a6a7..540bc29 100644 --- a/security/tomoyo/gc.c +++ b

Re: [PATCH] net: refactor icmp_global_allow to improve readability and performance.

2016-01-01 Thread Mike Danese
Yes, I completely missed the purpose of that. As a new year's resolution, I resolve to read the comments. Thanks for the review! On Fri, Jan 1, 2016 at 3:07 PM, Eric Dumazet wrote: > On Thu, 2015-12-31 at 23:58 -0800, Mike Danese wrote: >> We can reduce the number of operations

Re: [PATCH] net: refactor icmp_global_allow to improve readability and performance.

2016-01-01 Thread Mike Danese
Yes, I completely missed the purpose of that. As a new year's resolution, I resolve to read the comments. Thanks for the review! On Fri, Jan 1, 2016 at 3:07 PM, Eric Dumazet <eric.duma...@gmail.com> wrote: > On Thu, 2015-12-31 at 23:58 -0800, Mike Danese wrote: >> We can re

[PATCH] net: refactor icmp_global_allow to improve readability and performance.

2015-12-31 Thread Mike Danese
en bucket) and "cbr" (token bucket can be refilled) at the beginning of the routine, we reduce the number of repeated calculations of these two variables. There should be no functional difference. Signed-off-by: Mike Danese --- net/ipv4/icmp.c | 17 - 1 file changed, 8 i

[PATCH] net: refactor icmp_global_allow to improve readability and performance.

2015-12-31 Thread Mike Danese
en bucket) and "cbr" (token bucket can be refilled) at the beginning of the routine, we reduce the number of repeated calculations of these two variables. There should be no functional difference. Signed-off-by: Mike Danese <mikedan...@google.com> --- net/ipv4/icmp.c | 17 ++