Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Andrew Lunn
> nxp-c45-tja11xx is acceptable from my point of view. Great. Enough bike shedding, nxp-c45-tja11xx it is. Andrew

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Christian Herber
On 4/13/2021 3:57 PM, Andrew Lunn wrote: Ok, we can agree that there will not be a perfect naming. Would it be a possibility to rename the existing TJA11xx driver to TJA1100-1-2 or is that unwanted? It is generally a bad idea. It makes back porting fixing harder if the file changes name. If

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Andrew Lunn
> Ok, we can agree that there will not be a perfect naming. Would it be a > possibility to rename the existing TJA11xx driver to TJA1100-1-2 or is that > unwanted? It is generally a bad idea. It makes back porting fixing harder if the file changes name. > If nxp-c45.c is to generic (I take from

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Radu Nicolae Pirea (NXP OSS)
On Mon, 2021-04-12 at 10:50 +0100, Russell King - ARM Linux admin wrote: > On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) wrote: > > +#define B100T1_PMAPMD_CTL  0x0834 > > +#define B100T1_PMAPMD_CONFIG_ENBIT(15) > > +#define B100T1_PMAPMD_MASTER  

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Christian Herber
On 4/13/2021 3:30 PM, Andrew Lunn wrote: On Tue, Apr 13, 2021 at 08:56:30AM +0200, Christian Herber wrote: Hi Andrew, On 4/12/2021 6:52 PM, Andrew Lunn wrote: So what you are say is, you don't care if the IP is completely different, it all goes in one driver. So lets put this driver into

Re: Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Andrew Lunn
On Tue, Apr 13, 2021 at 08:56:30AM +0200, Christian Herber wrote: > Hi Andrew, > > On 4/12/2021 6:52 PM, Andrew Lunn wrote: > > > > So what you are say is, you don't care if the IP is completely > > different, it all goes in one driver. So lets put this driver into > > nxp-tja11xx.c. And then we

Re: Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-13 Thread Christian Herber
Hi Andrew, On 4/12/2021 6:52 PM, Andrew Lunn wrote: So what you are say is, you don't care if the IP is completely different, it all goes in one driver. So lets put this driver into nxp-tja11xx.c. And then we avoid all the naming issues. Andrew As this seems to be a key question, let

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Andrew Lunn
> +static const struct nxp_c45_phy_stats nxp_c45_hw_stats[] = { > + { "phy_symbol_error_cnt", MDIO_MMD_VEND1, SYMBOL_ERROR_COUNTER, 0, > GENMASK(15, 0) }, > + { "phy_link_status_drop_cnt", MDIO_MMD_VEND1, LINK_DROP_COUNTER, 8, > GENMASK(13, 8) }, > + {

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Andrew Lunn
On Mon, Apr 12, 2021 at 05:49:04PM +0300, Radu Nicolae Pirea (NXP OSS) wrote: > On Mon, 2021-04-12 at 16:23 +0200, Andrew Lunn wrote: > > > It is purely a C45 device. > > > > > Even if the PHY will be based on the same IP or not, if it is a C45 > > > PHY, it will be supported by this driver. We

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Radu Nicolae Pirea (NXP OSS)
On Mon, 2021-04-12 at 16:23 +0200, Andrew Lunn wrote: > > It is purely a C45 device. > > > Even if the PHY will be based on the same IP or not, if it is a C45 > > PHY, it will be supported by this driver. We are not talking about > > 2 or > > 3 PHYs. This driver will support all future C45 PHYs.

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Andrew Lunn
> It is purely a C45 device. > Even if the PHY will be based on the same IP or not, if it is a C45 > PHY, it will be supported by this driver. We are not talking about 2 or > 3 PHYs. This driver will support all future C45 PHYs. That's why we > named it "NXP C45". So if in future you produce C45

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Radu Nicolae Pirea (NXP OSS)
On Mon, 2021-04-12 at 14:57 +0200, Andrew Lunn wrote: > On Mon, Apr 12, 2021 at 01:02:07PM +0300, Radu Nicolae Pirea (NXP > OSS) wrote: > > On Fri, 2021-04-09 at 21:36 +0200, Andrew Lunn wrote: > > > On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) > > > wrote: > > > > Add driver for

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Andrew Lunn
On Mon, Apr 12, 2021 at 01:02:07PM +0300, Radu Nicolae Pirea (NXP OSS) wrote: > On Fri, 2021-04-09 at 21:36 +0200, Andrew Lunn wrote: > > On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) wrote: > > > Add driver for tja1103 driver and for future NXP C45 PHYs. > > > > So apart from

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Radu Nicolae Pirea (NXP OSS)
On Fri, 2021-04-09 at 21:36 +0200, Andrew Lunn wrote: > On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) wrote: > > Add driver for tja1103 driver and for future NXP C45 PHYs. > > So apart from c45 vs c22, how does this differ to nxp-tja11xx.c? > Do we really want two different

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Russell King - ARM Linux admin
On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) wrote: > +#define B100T1_PMAPMD_CTL0x0834 > +#define B100T1_PMAPMD_CONFIG_EN BIT(15) > +#define B100T1_PMAPMD_MASTER BIT(14) > +#define MASTER_MODE (B100T1_PMAPMD_CONFIG_EN | >

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-12 Thread Radu Nicolae Pirea (NXP OSS)
On Fri, 2021-04-09 at 21:18 +0200, Heiner Kallweit wrote: > On 09.04.2021 20:41, Radu Pirea (NXP OSS) wrote: > > Add driver for tja1103 driver and for future NXP C45 PHYs. > > > > Signed-off-by: Radu Pirea (NXP OSS) > > > > --- > >  MAINTAINERS   |   6 + > >  drivers/net/phy/Kconfig  

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-10 Thread kernel test robot
Hi "Radu, Thank you for the patch! Yet something to improve: [auto build test ERROR on linus/master] [also build test ERROR on v5.12-rc6 next-20210409] [If your patch is applied to the wrong git tree, kindly drop us a note. And when submitting patch, we suggest to use '--base' as documented in

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-09 Thread Andrew Lunn
On Fri, Apr 09, 2021 at 09:41:06PM +0300, Radu Pirea (NXP OSS) wrote: > Add driver for tja1103 driver and for future NXP C45 PHYs. So apart from c45 vs c22, how does this differ to nxp-tja11xx.c? Do we really want two different drivers for the same hardware? Can we combine them somehow? >

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-09 Thread Jakub Kicinski
On Fri, 9 Apr 2021 21:41:06 +0300 Radu Pirea (NXP OSS) wrote: > Add driver for tja1103 driver and for future NXP C45 PHYs. > > Signed-off-by: Radu Pirea (NXP OSS) drivers/net/phy/nxp-c45: struct mdio_device_id is 8 bytes. The last of 1 is: 0x10 0xb0 0x1b 0x00 0xf0 0xff 0xff 0xff FATAL:

Re: [PATCH] phy: nxp-c45: add driver for tja1103

2021-04-09 Thread Heiner Kallweit
On 09.04.2021 20:41, Radu Pirea (NXP OSS) wrote: > Add driver for tja1103 driver and for future NXP C45 PHYs. > > Signed-off-by: Radu Pirea (NXP OSS) > --- > MAINTAINERS | 6 + > drivers/net/phy/Kconfig | 6 + > drivers/net/phy/Makefile | 1 + > drivers/net/phy/nxp-c45.c

[PATCH] phy: nxp-c45: add driver for tja1103

2021-04-09 Thread Radu Pirea (NXP OSS)
Add driver for tja1103 driver and for future NXP C45 PHYs. Signed-off-by: Radu Pirea (NXP OSS) --- MAINTAINERS | 6 + drivers/net/phy/Kconfig | 6 + drivers/net/phy/Makefile | 1 + drivers/net/phy/nxp-c45.c | 622 ++ 4 files changed,