Re: [PATCH net-next] selftests: hsr: Extend the hsr_redbox.sh test to use fixed MAC addresses

2024-06-05 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski : On Mon, 3 Jun 2024 11:33:22 +0200 you wrote: > Fixed MAC addresses help with debugging as last four bytes identify the > network namespace. > > Moreover, it allows to mimic the real life setup with for example

Re: [PATCH net-next] selftests: hsr: Extend the hsr_ping.sh test to use fixed MAC addresses

2024-06-05 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net-next.git (main) by Jakub Kicinski : On Mon, 3 Jun 2024 11:33:21 +0200 you wrote: > Fixed MAC addresses help with debugging as last four bytes identify the > network namespace. > > Signed-off-by: Lukasz Majewski > --- >

Re: [PATCH net-next] selftests: hsr: Extend the hsr_redbox.sh test to use fixed MAC addresses

2024-06-05 Thread Jakub Kicinski
On Mon, 3 Jun 2024 11:33:22 +0200 Lukasz Majewski wrote: > Fixed MAC addresses help with debugging as last four bytes identify the > network namespace. > > Moreover, it allows to mimic the real life setup with for example bridge > having the same MAC address on each port. Doesn't seem like a

Re: [PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Hangbin Liu
On Wed, Jun 05, 2024 at 11:21:17AM +0200, Matthieu Baerts (NGI0) wrote: > If there is an error to create the first netns with 'setup_ns()', > 'cleanup_ns()' will be called with an empty string as first parameter. > > The consequences is that 'cleanup_ns()' will try to delete an invalid > netns,

Re: [PATCH net 3/3] selftests: net: lib: set 'i' as local

2024-06-05 Thread Hangbin Liu
On Wed, Jun 05, 2024 at 11:21:18AM +0200, Matthieu Baerts (NGI0) wrote: > Without this, the 'i' variable declared before could be overridden by > accident, e.g. > > for i in "${@}"; do > __ksft_status_merge "${i}" ## 'i' has been modified > foo "${i}" ## using 'i'

Re: [PATCH net-next v10 06/14] page_pool: convert to use netmem

2024-06-05 Thread Steven Rostedt
On Thu, 30 May 2024 20:16:05 + Mina Almasry wrote: > @@ -42,51 +42,52 @@ TRACE_EVENT(page_pool_release, > TRACE_EVENT(page_pool_state_release, > > TP_PROTO(const struct page_pool *pool, > - const struct page *page, u32 release), > + netmem_ref netmem, u32

Re: [PATCH net-next v10 05/14] netdev: netdevice devmem allocator

2024-06-05 Thread Steven Rostedt
On Wed, 5 Jun 2024 02:52:29 +0200 Andrew Lunn wrote: > > How is a compiler going to know that? > > It might have some heuristics to try to guess unlikely/likely, but > that is not what we are talking about here. > > How much difference did 'always_inline' and 'noinline' make? Hopefully > the

Re: [PATCH v5 00/16] selftests/resctrl: resctrl_val() related cleanups & improvements

2024-06-05 Thread Moger, Babu
Tested the series. Tested-by: Babu Moger On 5/31/2024 8:11 AM, Ilpo Järvinen wrote: Hi all, This series does a number of cleanups into resctrl_val() and generalizes it by removing test name specific handling from the function. Hopefully these reach also Shuah successfully as I've recently

Re: [PATCH v5 01/11] of/platform: Allow overlays to create platform devices from the root node

2024-06-05 Thread Rob Herring (Arm)
On Mon, 03 Jun 2024 15:37:58 -0700, Stephen Boyd wrote: > We'd like to apply overlays to the root node in KUnit so we can test > platform devices created as children of the root node. > > On some architectures (powerpc), the root node isn't marked with > OF_POPULATED_BUS. If an overlay tries to

Re: [PATCH v5 05/11] of: Add a KUnit test for overlays and test managed APIs

2024-06-05 Thread Rob Herring
On Mon, Jun 03, 2024 at 03:38:02PM -0700, Stephen Boyd wrote: > Test the KUnit test managed overlay APIs. Confirm that platform devices > are created and destroyed properly. This provides us confidence that the > test managed APIs work correctly and can be relied upon to provide tests > with fake

Re: [PATCH v1 2/2] selftests/mm: Guard defines from shm

2024-06-05 Thread Carlos Llamas
On Wed, Jun 05, 2024 at 10:36:35PM +, Edward Liaw wrote: > thuge-gen.c defines SHM_HUGE_* macros that are provided by the uapi > since 4.14. These macros get redefined when compiling with Android's > bionic because its sys/shm.h will import the uapi definitions. > > However if linux/shm.h is

[PATCH v3 4/4] selftests/resctrl: Enable MBA/MBA tests on AMD

2024-06-05 Thread Babu Moger
Enable MBA/MBM tests if UMC (Unified Memory Controller) support is available on the system. Tests will be skipped otherwise. Signed-off-by: Babu Moger --- v3: Separated fix as another patch.

[PATCH v3 3/4] selftests/resctrl: Add support for MBM and MBA tests on AMD

2024-06-05 Thread Babu Moger
Add support to read UMC (Unified Memory Controller) perf events to compare the numbers with QoS monitor for AMD. Signed-off-by: Babu Moger --- v3: Made read_from_mc_dir function generic to both AMD and Intel. Rest are mostly related to rebase. v2: Replace perror with ksft_perror. ---

[PATCH v3 2/4] selftests/resctrl: Pass sysfs controller name of the vendor

2024-06-05 Thread Babu Moger
The test detects number of memory controllers by looking at the sysfs file system. Detect the vendor to pass the controller name appropriately. So, that rest of the code will be generic and can be used to support other vendors. Also change the search to look for the full string "uncore_imc_".

[PATCH v3 1/4] selftests/resctrl: Rename variables and functions to generic names

2024-06-05 Thread Babu Moger
In an effort to support MBM and MBA tests for AMD, renaming for variable and functions to generic names. For Intel, the memory controller is called Integrated Memory Controllers (IMC). For AMD, it is called Unified Memory Controller (UMC). Change the names of variables and functions from imc

[PATCH v3 0/4] selftests/resctrl: Enable MBM and MBA tests on AMD

2024-06-05 Thread Babu Moger
The MBM (Memory Bandwidth Monitoring) and MBA (Memory Bandwidth Allocation) features are not enabled for AMD systems. The reason was lack of perf counters to compare the resctrl test results. Starting with the commit 25e56847821f ("perf/x86/amd/uncore: Add memory controller support"), AMD now

Re: [PATCH v1 1/2] selftests/mm: Include linux/mman.h

2024-06-05 Thread Carlos Llamas
On Wed, Jun 05, 2024 at 10:36:34PM +, Edward Liaw wrote: > thuge-gen defines MAP_HUGE_* macros that are provided by linux/mman.h > since 4.15. Removes the macros and includes linux/mman.h instead. > > Signed-off-by: Edward Liaw > --- > tools/testing/selftests/mm/thuge-gen.c | 5 + > 1

[PATCH] selftests: mm: Make map_fixed_noreplace test names stable

2024-06-05 Thread Mark Brown
uot;mmap() @ 0x%lx-0x%lx p=%p result=%m\n", addr, addr + size, p); + ksft_print_msg("mmap() @ 0x%lx-0x%lx p=%p result=%m\n", addr, addr + size, p); + ksft_test_result_pass("mmap() PAGE_SIZE at base+(4*PAGE_SIZE)\n"); addr = base_addr; size = 5 * page_size; --- base-commit: c3f38fa61af77b49866b006939479069cd451173 change-id: 20240605-kselftest-mm-fixed-noreplace-44e7e55c861a Best regards, -- Mark Brown

[PATCH v1 2/2] selftests/mm: Guard defines from shm

2024-06-05 Thread Edward Liaw
thuge-gen.c defines SHM_HUGE_* macros that are provided by the uapi since 4.14. These macros get redefined when compiling with Android's bionic because its sys/shm.h will import the uapi definitions. However if linux/shm.h is included, with glibc, sys/shm.h will clash on some struct definitions:

[PATCH v1 1/2] selftests/mm: Include linux/mman.h

2024-06-05 Thread Edward Liaw
thuge-gen defines MAP_HUGE_* macros that are provided by linux/mman.h since 4.15. Removes the macros and includes linux/mman.h instead. Signed-off-by: Edward Liaw --- tools/testing/selftests/mm/thuge-gen.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git

[PATCH v1 0/2] selftests/mm: thuge-gen defines

2024-06-05 Thread Edward Liaw
When compiling with Android bionic, the MAP_HUGE_* and SHM_HUGE_* macros are redefined because they are included from the uapi by sys/mman.h and sys/shm.h: INFO: From Compiling common/tools/testing/selftests/mm/thuge-gen.c: common/tools/testing/selftests/mm/thuge-gen.c:32:9: warning:

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Edgecombe, Rick P
On Wed, 2024-06-05 at 16:34 -0500, Sagi Shahar wrote: > > We don't currently have plans to post a whole ~130 patch series. Instead we > > plan > > to post subsections out of the series as they slowly move into a maintainer > > branch. > > So this means that we won't be able to post an updated

[PATCH] selftests/resctrl: Fix noncont_cat_run_test for AMD

2024-06-05 Thread Babu Moger
The selftest noncont_cat_run_test fails on AMD with the warnings. Reason is, AMD supports non contiguous CBM masks but does not report it via CPUID. Update noncont_cat_run_test to check for the vendor when verifying CPUID. Fixes: ae638551ab64 ("selftests/resctrl: Add non-contiguous CBMs CAT

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Sagi Shahar
On Wed, Jun 5, 2024 at 3:56 PM Edgecombe, Rick P wrote: > > On Wed, 2024-06-05 at 15:42 -0500, Sagi Shahar wrote: > > > > Hm you're right, I was looking more narrowly because of the kvm-coco- > > > > queue conflicts, for some of which even v19 might be too old. The MMU > > > > prep series uses a

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Edgecombe, Rick P
On Wed, 2024-06-05 at 15:42 -0500, Sagi Shahar wrote: > > > Hm you're right, I was looking more narrowly because of the kvm-coco- > > > queue conflicts, for some of which even v19 might be too old. The MMU > > > prep series uses a much more recent kvm-coco-queue baseline. > > > > > > Rick, can we

Re: [Bug Report] selftests: arm64: build errors

2024-06-05 Thread Mark Brown
On Tue, Jun 04, 2024 at 01:13:45PM +0500, Muhammad Usama Anjum wrote: > On 6/3/24 6:31 PM, Mark Brown wrote: > > On Mon, Jun 03, 2024 at 06:28:16PM +0500, Muhammad Usama Anjum wrote: > >> test.c: In function ‘handler’: > >> test.c:85:50: error: ‘PSR_BTYPE_MASK’ undeclared (first use in this > >>

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Sagi Shahar
On Wed, Jun 5, 2024 at 3:18 PM Verma, Vishal L wrote: > > On Wed, 2024-06-05 at 20:15 +, Verma, Vishal L wrote: > > On Wed, 2024-06-05 at 15:10 -0500, Sagi Shahar wrote: > > > On Wed, Jun 5, 2024 at 1:38 PM Verma, Vishal L > > > wrote: > > > > > > > > On Tue, 2023-12-12 at 12:46 -0800, Sagi

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Verma, Vishal L
On Wed, 2024-06-05 at 20:15 +, Verma, Vishal L wrote: > On Wed, 2024-06-05 at 15:10 -0500, Sagi Shahar wrote: > > On Wed, Jun 5, 2024 at 1:38 PM Verma, Vishal L > > wrote: > > > > > > On Tue, 2023-12-12 at 12:46 -0800, Sagi Shahar wrote: > > > > Hello, > > > > > > > > This is v4 of the

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Verma, Vishal L
On Wed, 2024-06-05 at 15:10 -0500, Sagi Shahar wrote: > On Wed, Jun 5, 2024 at 1:38 PM Verma, Vishal L > wrote: > > > > On Tue, 2023-12-12 at 12:46 -0800, Sagi Shahar wrote: > > > Hello, > > > > > > This is v4 of the patch series for TDX selftests. > > > > > > It has been updated for Intel’s

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Sagi Shahar
On Wed, Jun 5, 2024 at 1:38 PM Verma, Vishal L wrote: > > On Tue, 2023-12-12 at 12:46 -0800, Sagi Shahar wrote: > > Hello, > > > > This is v4 of the patch series for TDX selftests. > > > > It has been updated for Intel’s v17 of the TDX host patches which was > > proposed here: > >

Re: [PATCH net-next v2 9/9] selftests: openvswitch: add emit_sample test

2024-06-05 Thread Simon Horman
On Mon, Jun 03, 2024 at 08:56:43PM +0200, Adrian Moreno wrote: > Add a test to verify sampling packets via psample works. > > In order to do that, create a subcommand in ovs-dpctl.py to listen to > on the psample multicast group and print samples. > > In order to also test simultaneous sFlow and

Re: [RFC PATCH v5 00/29] TDX KVM selftests

2024-06-05 Thread Verma, Vishal L
On Tue, 2023-12-12 at 12:46 -0800, Sagi Shahar wrote: > Hello, > > This is v4 of the patch series for TDX selftests. > > It has been updated for Intel’s v17 of the TDX host patches which was > proposed here: > https://lore.kernel.org/all/cover.1699368322.git.isaku.yamah...@intel.com/ > > The

Re: [PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Matthieu Baerts
On 05/06/2024 16:30, Petr Machata wrote: > > Matthieu Baerts writes: > >> Hi Petr, >> >> Thank you for the review! >> >> On 05/06/2024 12:38, Petr Machata wrote: >>> >>> "Matthieu Baerts (NGI0)" writes: >>> If there is an error to create the first netns with 'setup_ns()',

Re: [PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Petr Machata
Matthieu Baerts writes: > Hi Petr, > > Thank you for the review! > > On 05/06/2024 12:38, Petr Machata wrote: >> >> "Matthieu Baerts (NGI0)" writes: >> >>> If there is an error to create the first netns with 'setup_ns()', >>> 'cleanup_ns()' will be called with an empty string as first

Re: [PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Matthieu Baerts
Hi Petr, Thank you for the review! On 05/06/2024 12:38, Petr Machata wrote: > > "Matthieu Baerts (NGI0)" writes: > >> If there is an error to create the first netns with 'setup_ns()', >> 'cleanup_ns()' will be called with an empty string as first parameter. >> >> The consequences is that

Re: [PATCH v5 0/8] Support Zve32[xf] and Zve64[xfd] Vector subextensions

2024-06-05 Thread patchwork-bot+linux-riscv
Hello: This series was applied to riscv/linux.git (for-next) by Palmer Dabbelt : On Fri, 10 May 2024 00:26:50 +0800 you wrote: > The series composes of two parts. The first part Specifically, > patch 1 adds a comment at a callsite of riscv_setup_vsize to clarify how > vlenb is observed by the

Re: [PATCH] selftests: arm64: Fix redundancy of a testcase

2024-06-05 Thread Dev Jain
On 6/5/24 17:30, Mark Brown wrote: On Wed, Jun 05, 2024 at 05:24:48PM +0530, Dev Jain wrote: Currently, we are writing the same value as we read, into the TLS register; hence, we cannot confirm updation of the register, making the testcase "verify_tpidr_one" redundant. Fix this; while at it,

[PATCH v5 4/4] KVM: riscv: selftests: Add Svade and Svadu Extension to get-reg-list test

2024-06-05 Thread Yong-Xuan Wang
Update the get-reg-list test to test the Svade and Svadu Extensions are available for guest OS. Signed-off-by: Yong-Xuan Wang --- tools/testing/selftests/kvm/riscv/get-reg-list.c | 8 1 file changed, 8 insertions(+) diff --git a/tools/testing/selftests/kvm/riscv/get-reg-list.c

Re: [PATCH] selftests: arm64: Fix redundancy of a testcase

2024-06-05 Thread Mark Brown
On Wed, Jun 05, 2024 at 05:24:48PM +0530, Dev Jain wrote: > Currently, we are writing the same value as we read, into the TLS > register; hence, we cannot confirm updation of the register, making the > testcase "verify_tpidr_one" redundant. Fix this; while at it, do a style > change. Please don't

[PATCH] selftests: arm64: Fix redundancy of a testcase

2024-06-05 Thread Dev Jain
Currently, we are writing the same value as we read, into the TLS register; hence, we cannot confirm updation of the register, making the testcase "verify_tpidr_one" redundant. Fix this; while at it, do a style change. Signed-off-by: Dev Jain --- tools/testing/selftests/arm64/abi/ptrace.c | 4

Re: [PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Petr Machata
"Matthieu Baerts (NGI0)" writes: > If there is an error to create the first netns with 'setup_ns()', > 'cleanup_ns()' will be called with an empty string as first parameter. > > The consequences is that 'cleanup_ns()' will try to delete an invalid > netns, and wait 20 seconds if the netns list

Re: [PATCH net] selftests: hsr: add missing config for CONFIG_BRIDGE

2024-06-05 Thread patchwork-bot+netdevbpf
Hello: This patch was applied to netdev/net.git (main) by David S. Miller : On Mon, 3 Jun 2024 17:30:19 +0800 you wrote: > hsr_redbox.sh test need to create bridge for testing. Add the missing > config CONFIG_BRIDGE in config file. > > Fixes: eafbf0574e05 ("test: hsr: Extend the hsr_redbox.sh

Re: [PATCH net 1/3] selftests: net: lib: support errexit with busywait

2024-06-05 Thread Matthieu Baerts
Hi Hangbin, Thank you for your reply! On 05/06/2024 11:44, Hangbin Liu wrote: > On Wed, Jun 05, 2024 at 11:21:16AM +0200, Matthieu Baerts (NGI0) wrote: >> If errexit is enabled ('set -e'), loopy_wait -- or busywait and others >> using it -- will stop after the first failure. >> >> Note that if

Re: [PATCH net 1/3] selftests: net: lib: support errexit with busywait

2024-06-05 Thread Hangbin Liu
On Wed, Jun 05, 2024 at 11:21:16AM +0200, Matthieu Baerts (NGI0) wrote: > If errexit is enabled ('set -e'), loopy_wait -- or busywait and others > using it -- will stop after the first failure. > > Note that if the returned status of loopy_wait is checked, and even if > errexit is enabled, Bash

[PATCH net 3/3] selftests: net: lib: set 'i' as local

2024-06-05 Thread Matthieu Baerts (NGI0)
Without this, the 'i' variable declared before could be overridden by accident, e.g. for i in "${@}"; do __ksft_status_merge "${i}" ## 'i' has been modified foo "${i}" ## using 'i' with an unexpected value done After a quick look, it looks like 'i' is currently

[PATCH net 2/3] selftests: net: lib: avoid error removing empty netns name

2024-06-05 Thread Matthieu Baerts (NGI0)
If there is an error to create the first netns with 'setup_ns()', 'cleanup_ns()' will be called with an empty string as first parameter. The consequences is that 'cleanup_ns()' will try to delete an invalid netns, and wait 20 seconds if the netns list is empty. Instead of just checking if the

[PATCH net 1/3] selftests: net: lib: support errexit with busywait

2024-06-05 Thread Matthieu Baerts (NGI0)
If errexit is enabled ('set -e'), loopy_wait -- or busywait and others using it -- will stop after the first failure. Note that if the returned status of loopy_wait is checked, and even if errexit is enabled, Bash will not stop at the first error. Fixes: 25ae948b4478 ("selftests/net: add

[PATCH net 0/3] selftests: net: lib: small fixes

2024-06-05 Thread Matthieu Baerts (NGI0)
+- 1 file changed, 9 insertions(+), 9 deletions(-) --- base-commit: a535d59432370343058755100ee75ab03c0e3f91 change-id: 20240605-upstream-net-20240605-selftests-net-lib-fixes-7a90a1a8d9d2 Best regards, -- Matthieu Baerts (NGI0)

Re: [PATCH net-next v10 02/14] net: page_pool: create hooks for custom page providers

2024-06-05 Thread Christoph Hellwig
On Mon, Jun 03, 2024 at 03:52:32PM +0100, Pavel Begunkov wrote: > The question for Christoph is what exactly is the objection here? Why we > would not be using well defined ops when we know there will be more > users? The point is that there should be no more users. If you need another case you

Re: [PATCH net-next v10 02/14] net: page_pool: create hooks for custom page providers

2024-06-05 Thread Christoph Hellwig
On Mon, Jun 03, 2024 at 07:17:05AM -0700, Mina Almasry wrote: > On Fri, May 31, 2024 at 10:35 PM Christoph Hellwig wrote: > > > > On Thu, May 30, 2024 at 08:16:01PM +, Mina Almasry wrote: > > > I'm unsure if the discussion has been resolved yet. Sending the series > > > anyway to get

Re: [PATCH] selftests/timers: Guard LONG_MAX / LONG_MIN defines

2024-06-05 Thread Nathan Chancellor
On Tue, Jun 04, 2024 at 11:12:18PM +, Edward Liaw wrote: > Add ifndef guards around LONG_MAX / LONG_MIN defines. When building with > Android bionic, these macros are redefined because bionic's time.h will > include linux/time.h, which includes limit.h. > > INFO: From Compiling