RE: [PATCH 07/16] powerpc: mm: Support MAP_BELOW_HINT

2024-08-31 Thread David Laight
From: Christophe Leroy > Sent: 28 August 2024 07:35 > Hi Charlie, > > Le 28/08/2024 à 07:49, Charlie Jenkins a écrit : > > Add support for MAP_BELOW_HINT to arch_get_mmap_base() and > > arch_get_mmap_end(). > > > > Signed-off-by: Charlie Jenkins > > --- > > arch/powerpc/include/asm/task_size_64

RE: [PATCH net] selftests: openvswitch: Use bash as interpreter

2024-06-19 Thread David Laight
From: Simon Horman > Sent: 17 June 2024 11:34 ... > > sidenote: I like very much the idea to use the least powerful tool, like > > sh vs bash, awk vs gawk, but it breaks when we forget what is outside of > > the scope of the former/standard. > > Perhaps for shell, we could convert all the selftests

RE: [PATCH v3] selftests/vDSO: Explicit unsigned char conversion for elf_hash

2024-05-06 Thread David Laight
From: Edward Liaw > Sent: 06 May 2024 18:34 > > On Mon, May 6, 2024 at 10:16 AM Justin Stitt wrote: > > > > On Sun, May 5, 2024 at 6:21 AM David Laight wrote: > > > > > > From: Justin Stitt > > > > Sent: 01 May 2024 20:55 > > > ...

RE: [PATCH v3] selftests/vDSO: Explicit unsigned char conversion for elf_hash

2024-05-05 Thread David Laight
From: Justin Stitt > Sent: 01 May 2024 20:55 ... > > static unsigned long elf_hash(const unsigned char *name) ... > Is it possible to just change the types of the parameters of vdso_sym() > or does that trigger even more warnings on the callsites of vdso_sym()? Isn't the problem the definition of

RE: [PATCH v8 0/4] Introduce mseal

2024-02-04 Thread David Laight
... > IMO, UNIX API design has historically mostly been "play stupid games, > win stupid prizes", which is e.g: why things like close(STDOUT_FILENO) > work. If you close stdout (and don't dup/reopen something to stdout) > and printf(), things will break, and you get to keep both pieces. That is pr

RE: [PATCH] selftests/mm: switch to bash from sh

2024-01-16 Thread David Laight
From: Muhammad Usama Anjum > Sent: 16 January 2024 09:05 > > Running charge_reserved_hugetlb.sh generates errors if sh is set to > dash: > > /charge_reserved_hugetlb.sh: 9: [[: not found > /charge_reserved_hugetlb.sh: 19: [[: not found > /charge_reserved_hugetlb.sh: 27: [[: not found > /charge_re

RE: [RFC PATCH v3 09/12] net: add support for skbs with unreadable frags

2023-11-08 Thread David Laight
From: Mina Almasry > Sent: 06 November 2023 02:44 > > For device memory TCP, we expect the skb headers to be available in host > memory for access, and we expect the skb frags to be in device memory > and unaccessible to the host. We expect there to be no mixing and > matching of device memory fra

RE: [PATCH] KVM: selftests: add -MP to CFLAGS

2023-10-30 Thread David Laight
From: David Woodhouse > Sent: 30 October 2023 09:46 > > On Sun, 2023-10-29 at 21:13 +0000, David Laight wrote: > > From: David Woodhouse > > > Sent: 28 October 2023 20:35 > > > > > > Using -MD without -MP causes build failures when a header file is dele

RE: [PATCH] KVM: selftests: add -MP to CFLAGS

2023-10-29 Thread David Laight
From: David Woodhouse > Sent: 28 October 2023 20:35 > > Using -MD without -MP causes build failures when a header file is deleted > or moved. With -MP, the compiler will emit phony targets for the header > files it lists as dependencies, and the Makefiles won't refuse to attempt > to rebuild a C u

RE: [RFC PATCH v2 0/8] Introduce mseal() syscall

2023-10-19 Thread David Laight
From: jef...@chromium.org > Sent: 17 October 2023 10:08 > > This patchset proposes a new mseal() syscall for the Linux kernel. I'm sure you can give it a better name, there isn't a 6 character limit on identifiers! FWIW you could also use mprotect(addr, len, IMMUTABLE); David - Registe

RE: [RFC PATCH 9/9] iov_iter: Add benchmarking kunit tests for UBUF/IOVEC

2023-09-15 Thread David Laight
From: David Howells > Sent: 15 September 2023 13:36 > > David Laight wrote: > > > I was thinking of import_iovec() - or whatever its current > > name is. > > That doesn't actually access the buffer described by the iovec[]. > > > That really needs a

RE: [RFC PATCH 9/9] iov_iter: Add benchmarking kunit tests for UBUF/IOVEC

2023-09-15 Thread David Laight
From: David Howells > Sent: 15 September 2023 12:23 > > David Laight wrote: > > > > > Some measurements can be made using readv() and writev() > > > > on /dev/zero and /dev/null. > > > > > > Forget /dev/null; that doesn't actually engag

RE: [RFC PATCH 9/9] iov_iter: Add benchmarking kunit tests for UBUF/IOVEC

2023-09-15 Thread David Laight
From: David Howells > Sent: 15 September 2023 11:10 > > David Laight wrote: > > > > Add kunit tests to benchmark 256MiB copies to a UBUF iterator and an IOVEC > > > iterator. This attaches a userspace VM with a mapped file in it > > > temporarily to the t

RE: [RFC PATCH 9/9] iov_iter: Add benchmarking kunit tests for UBUF/IOVEC

2023-09-15 Thread David Laight
From: David Howells > Sent: 14 September 2023 23:15 > > Add kunit tests to benchmark 256MiB copies to a UBUF iterator and an IOVEC > iterator. This attaches a userspace VM with a mapped file in it > temporarily to the test thread. Isn't that going to be completely dominated by the cache fills fr