Re: [GIT PATCHES FOR 2.6.35] More _fmt to _mbus_fmt conversions

2010-05-11 Thread Hans Verkuil
On Monday 10 May 2010 08:42:29 Hans Verkuil wrote: > On Sunday 09 May 2010 15:30:24 Hans Verkuil wrote: > > The following changes since commit 08b8618ac4dbcd05ec1886853b1d865798d26e1d: > > Devin Heitmueller (1): > > V4L/DVB: ngene: Add lgdt3303 and mt2131 deps to Kconfig > > > > are avai

RE: [PATCH 1/7] v4l: videobuf: rename videobuf_alloc to videobuf_alloc_vb

2010-05-11 Thread Pawel Osciak
Mauro: in case you decide to merge this patch and the following one, please add Signed-off-by: Kyungmin Park after my sign-off. Thanks! > Laurent Pinchart wrote: >Subject: [PATCH 1/7] v4l: videobuf: rename videobuf_alloc to >videobuf_alloc_vb > >From: Pawel Osciak > >These functions allocat

Re: [PATCH] Compro Videomate T750F Vista digital+analog support

2010-05-11 Thread davor emard
HI I tried to fix unreliable IR remote keys (cca 10% lost key presses), the similar problem has been reported on the same card with windows driver too and I had other saa7134 analog tv card also loosing IR keys I have tried modifying saa7134-input.c to use gpio polling with interval of 15ms and 5

RE: cx88 pci_abort errors (Hauppauge WinTV Nova-HD-S2)

2010-05-11 Thread hermann pitton
Hi Thierry, Am Dienstag, den 11.05.2010, 16:50 +0200 schrieb Thierry LELEGARD: > I finally gave up using this card. I replaced it with an old > Hauppauge WinTV Nova-S in the same PCI slot and the same transponder > is received fine. No discontinuity is observed. Using the Nova-HD-S2 > in the same

Re: [PATCH] media/IR: Add missing include file to rc-map.c

2010-05-11 Thread Peter Hüwe
Am Mittwoch 05 Mai 2010 17:20:21 schrieb Peter Hüwe: > From: Peter Huewe > > This patch adds a missing include linux/delay.h to prevent > build failures[1-5] > > Signed-off-by: Peter Huewe > --- Any updates on this patch? Issue still exists with today's linux-next tree Thanks, Peter -- To unsu

[cron job] v4l-dvb daily build 2.6.22 and up: ERRORS, 2.6.16-2.6.21: ERRORS

2010-05-11 Thread Hans Verkuil
This message is generated daily by a cron job that builds v4l-dvb for the kernels and architectures in the list below. Results of the daily build of v4l-dvb: date:Tue May 11 19:00:25 CEST 2010 path:http://www.linuxtv.org/hg/v4l-dvb changeset: 14743:8023f45dd06e git master:

RE: cx88 pci_abort errors (Hauppauge WinTV Nova-HD-S2)

2010-05-11 Thread Thierry LELEGARD
I finally gave up using this card. I replaced it with an old Hauppauge WinTV Nova-S in the same PCI slot and the same transponder is received fine. No discontinuity is observed. Using the Nova-HD-S2 in the same PCI slot, on the same transponder, gave a lot of discontinuities, correlated with the pc

[PATCH 3/7] v4l: videobuf: Remove the videobuf_sg_dma_map/unmap functions

2010-05-11 Thread Laurent Pinchart
Instead of creating dirty wrappers around videobuf_dma_map/unmap that create a dummy videobuf_queue structure, modify videobuf_dma_map/unmap to take a device pointer argument and use it directly. The videobuf_sg_dma_map/unmap then become unused and can be removed. Signed-off-by: Laurent Pinchart

[PATCH 5/7] v4l: videobuf: Don't export videobuf_(vmalloc|pages)_to_sg

2010-05-11 Thread Laurent Pinchart
Those functions are only called inside videobuf-dma-sg.c, make them static. Signed-off-by: Laurent Pinchart --- drivers/media/video/videobuf-dma-sg.c | 18 ++ include/media/videobuf-dma-sg.h | 17 - 2 files changed, 14 insertions(+), 21 deletions(-) dif

[PATCH 7/7] v4l: videobuf: Rename vmalloc fields to vaddr

2010-05-11 Thread Laurent Pinchart
The videobuf_dmabuf and videobuf_vmalloc_memory fields have a vmalloc field to store the kernel virtual address of vmalloc'ed buffers. Rename the field to vaddr. Signed-off-by: Laurent Pinchart --- drivers/media/video/cx88/cx88-alsa.c |2 +- drivers/media/video/saa7134/saa7134-alsa.c |

[PATCH 6/7] v4l: videobuf: Remove videobuf_mapping start and end fields

2010-05-11 Thread Laurent Pinchart
The fields are assigned but never used, remove them. Signed-off-by: Laurent Pinchart --- drivers/media/video/videobuf-dma-contig.c |2 -- drivers/media/video/videobuf-dma-sg.c |2 -- drivers/media/video/videobuf-vmalloc.c|2 -- include/media/videobuf-core.h |2

[PATCH 4/7] v4l: Remove videobuf_sg_alloc abuse

2010-05-11 Thread Laurent Pinchart
The cx88 and cx25821 drivers abuse videobuf_buffer to handle audio data. Remove the abuse by creating private audio buffer structures with a videobuf_dmabuf field. Signed-off-by: Laurent Pinchart --- drivers/media/video/cx88/cx88-alsa.c | 29 ++--- drivers/staging/cx2

[PATCH 2/7] v4l: videobuf: rename videobuf_mmap_free and add sanity checks

2010-05-11 Thread Laurent Pinchart
From: Pawel Osciak This function is not specific to mmap, hence the rename. Add a check whether we are not streaming or reading (for read mode that uses the stream queue) before freeing anything. Signed-off-by: Pawel Osciak --- drivers/media/video/videobuf-core.c | 70 +--

[PATCH 1/7] v4l: videobuf: rename videobuf_alloc to videobuf_alloc_vb

2010-05-11 Thread Laurent Pinchart
From: Pawel Osciak These functions allocate videobuf_buffer structures only. Renaming in order to prevent confusion with functions allocating actual video buffer memory. Signed-off-by: Pawel Osciak Rename the functions in videobuf-core.h videobuf-dma-sg.c as well. Signed-off-by: Laurent Pinch

[PATCH 0/7] videobuf cleanup patches

2010-05-11 Thread Laurent Pinchart
Hi everybody, Here are 7 videobuf patches that cleanup the internal API and the videobuf_dma_sg public API. They remove unneeded functions, avoid exporting internal ones, rename some of them to less confusing names and try to stop some API abuse from drivers. One of my goals was to remove videobu

RE: [PATCH 6/6] [RFC] tvp514x: simplify try/g/s_fmt handling

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 6/6] [RFC] tvp514x: simplify try/g/s_fmt handling > > Since there is only one possible format just have al

RE: [PATCH 4/6] [RFC] tvp514x: add missing newlines

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 4/6] [RFC] tvp514x: add missing newlines > > Signed-off-by: Hans Verkuil > --- > drivers/media/video/tvp5

RE: [PATCH 5/6] [RFC] tvp514x: remove obsolete fmt_list

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 5/6] [RFC] tvp514x: remove obsolete fmt_list > > Signed-off-by: Hans Verkuil > --- > drivers/media/video

RE: [PATCH 3/6] [RFC] tvp514x: there is only one supported format, so simplify the code

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 3/6] [RFC] tvp514x: there is only one supported format, so > simplify the code > > Get rid of unnecessary

RE: [PATCH 2/6] [RFC] tvp514x: make std_list const

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 2/6] [RFC] tvp514x: make std_list const > > Signed-off-by: Hans Verkuil > --- > drivers/media/video/tvp5

RE: [PATCH 1/6] [RFC] tvp514x: do NOT change the std as a side effect

2010-05-11 Thread Hiremath, Vaibhav
> -Original Message- > From: Hans Verkuil [mailto:hverk...@xs4all.nl] > Sent: Sunday, May 09, 2010 7:27 PM > To: linux-media@vger.kernel.org > Cc: Hiremath, Vaibhav > Subject: [PATCH 1/6] [RFC] tvp514x: do NOT change the std as a side effect > > Several calls (try_fmt, g_parm among others

[PATCH v3] soc_camera_platform: Add necessary v4l2_subdev_video_ops method

2010-05-11 Thread Kuninori Morimoto
These function are needed to use camera. This patch was tested with sh_mobile_ceu_camera Signed-off-by: Kuninori Morimoto --- v2 -> v3 o use p->format.field instead of V4L2_FIELD_NONE drivers/media/video/soc_camera_platform.c | 42 ++-- 1 files changed, 39 insertions

Re: [PATCH v2] soc_camera_platform: Add necessary v4l2_subdev_video_ops method

2010-05-11 Thread Kuninori Morimoto
Dear Guennadi > @@ -65,6 +65,7 @@ static int soc_camera_platform_try_fmt(struct v4l2_subdev > *sd, > mf->height = p->format.height; > mf->code= p->format.code; > mf->colorspace = p->format.colorspace; > + mf->field = V4L2_FIELD_NONE; I added this in v2.

[PATCH v2] soc_camera_platform: Add necessary v4l2_subdev_video_ops method

2010-05-11 Thread Kuninori Morimoto
These function are needed to use camera. This patch was tested with sh_mobile_ceu_camera Signed-off-by: Kuninori Morimoto --- v1 -> v2 o rename soc_camera_platform_try_fmt => soc_camera_platform_fill_fmt o .try_mbus_fmt / .g_mbus_fmt / .s_mbus_fmt use soc_camera_platform_fill_fmt I tested this

Re: [PATCH] soc_camera_platform: Add necessary v4l2_subdev_video_ops method

2010-05-11 Thread Guennadi Liakhovetski
On Tue, 11 May 2010, Kuninori Morimoto wrote: > > Dear Guennadi > > Thank you for checking patch > > > > +static int soc_camera_platform_s_fmt(struct v4l2_subdev *sd, > > > + struct v4l2_mbus_framefmt *mf) > > > +{ > > > + return 0; > > > > This function needs not

Re: [PATCH] soc_camera_platform: Add necessary v4l2_subdev_video_ops method

2010-05-11 Thread Kuninori Morimoto
Dear Guennadi Thank you for checking patch > > +static int soc_camera_platform_s_fmt(struct v4l2_subdev *sd, > > +struct v4l2_mbus_framefmt *mf) > > +{ > > + return 0; > > This function needs not only return 0, but also fill fmt with the current > pixel format

Re: Confusing mediabus formats

2010-05-11 Thread Guennadi Liakhovetski
On Mon, 10 May 2010, Guennadi Liakhovetski wrote: > (added Laurent to CC as he once asked me about these on IRC too) > > On Sun, 9 May 2010, Hans Verkuil wrote: > > > Hi Guennadi, > > > > I'm preparing a patch series that replaces enum/g/try/s_fmt with > > enum/g/try/s/_mbus_fmt in all subdevs.