Re: [PATCH v4 2/5] MFD: WL1273 FM Radio: MFD driver for the FM radio.

2010-08-19 Thread Matti J. Aaltonen
Hello. On Wed, 2010-08-18 at 20:14 +0200, ext Pavan Savoy wrote: --- On Wed, 7/7/10, Pavan Savoy pavan_sa...@ti.com wrote: From: Pavan Savoy pavan_sa...@ti.com Subject: Re: [PATCH v4 2/5] MFD: WL1273 FM Radio: MFD driver for the FM radio. To: Matti J. Aaltonen

[RFC] Media controller addition: MEDIA_IOC_ENTITY_INFO

2010-08-19 Thread Martin Rubli
Hi all, Following some discussion with Laurent Pinchart I'd like to suggest the addition of a new ioctl to the media controller API: MEDIA_IOC_ENTITY_INFO. The purpose of the ioctl is to allow applications to retrieve advanced information on a given entity. There are two parts: a generic one and

[patch] V4L/DVB: opera1: remove unneeded NULL check

2010-08-19 Thread Dan Carpenter
fw is always a non-NULL pointer at this point, and anyway release_firmware() accepts NULL pointers. Signed-off-by: Dan Carpenter erro...@gmail.com diff --git a/drivers/media/dvb/dvb-usb/opera1.c b/drivers/media/dvb/dvb-usb/opera1.c index 6b22ec6..f896337 100644 ---

[patch] V4L/DVB: pvrusb2: remove unneeded NULL checks

2010-08-19 Thread Dan Carpenter
We dereference maskptr unconditionally at the start of the function and also inside the call to parse_tlist() towards the end of the function. This function is called from store_val_any() and it always passes a non-NULL pointer. Signed-off-by: Dan Carpenter erro...@gmail.com diff --git

[patch] V4L/DVB: saa7164: move dereference under NULL check

2010-08-19 Thread Dan Carpenter
The original code dereferenced port before checking it for NULL. I moved the test down below the check. Also I changed the comparisons a little so people wouldn't get confused and think port and buf were ints instead of pointers. (Probably that's what lead to this issue in the first place.)

Re: [RFC] [PATCH 1/6] SoC Camera: add driver for OMAP1 camera interface

2010-08-19 Thread Janusz Krzysztofik
Monday 16 August 2010 12:17:36 Marin Mitov wrote: On Saturday, August 14, 2010 08:33:09 pm Guennadi Liakhovetski wrote: On Fri, 13 Aug 2010, Janusz Krzysztofik wrote: Friday 13 August 2010 11:11:52 Marin Mitov napisał(a): On Friday, August 13, 2010 11:52:41 am Guennadi Liakhovetski

Re: [RFC] [PATCH 1/6] SoC Camera: add driver for OMAP1 camera interface

2010-08-19 Thread Guennadi Liakhovetski
On Thu, 19 Aug 2010, Janusz Krzysztofik wrote: Hi Marin, Since I've finaly managed to make use of your method without any previously observerd limitations (see below), I'm interested in it being implemented system-wide. Are you going to submit a patch? I'm about to submit a patch, which

Re: [RFC] [PATCH 1/6] SoC Camera: add driver for OMAP1 camera interface

2010-08-19 Thread Marin Mitov
On Thursday, August 19, 2010 02:39:47 pm Guennadi Liakhovetski wrote: On Thu, 19 Aug 2010, Janusz Krzysztofik wrote: Hi Marin, Since I've finaly managed to make use of your method without any previously observerd limitations (see below), I'm interested in it being implemented

Re: [patch] V4L/DVB: pvrusb2: remove unneeded NULL checks

2010-08-19 Thread Mike Isely
Based on the surrounding code (the unconditional dereference), I agree that this particular bit of coding paranoia is not doing much good. Acked-by: Mike Isely is...@pobox.com On Thu, 19 Aug 2010, Dan Carpenter wrote: We dereference maskptr unconditionally at the start of the function and

Re: [PATCH/RFCv3 0/6] The Contiguous Memory Allocator framework

2010-08-19 Thread Konrad Rzeszutek Wilk
On Wed, Aug 18, 2010 at 12:01:35PM +0900, Kyungmin Park wrote: Are there any comments or ack? Is there a git tree and/or link to the latest version that is based on top 2.6.36-rc1?? I somehow seem to have lost the v3 of these patches. -- To unsubscribe from this list: send the line unsubscribe

Re: [PATCH/RFCv3 0/6] The Contiguous Memory Allocator framework

2010-08-19 Thread FUJITA Tomonori
On Wed, 18 Aug 2010 12:01:35 +0900 Kyungmin Park kyungmin.p...@samsung.com wrote: Are there any comments or ack? We hope this method included at mainline kernel if possible. It's really needed feature for our multimedia frameworks. You got any comments from mm people? Virtually, this adds

[RFC][PATCH] add dma_reserve_coherent_memory()/dma_free_reserved_memory() API

2010-08-19 Thread Marin Mitov
Hi all, struct device contains a member: struct dma_coherent_mem *dma_mem; to hold information for a piece of memory declared dma-coherent. Alternatively the same member could also be used to hold preallocated dma-coherent memory for latter per-device use. This tric is already used in

RE: [patch] V4L/DVB: unlock on error path

2010-08-19 Thread Sylwester Nawrocki
Thank you for catching this up. I had this fixed already, but due to hassle caused by having multiple versions of the driver this bug somehow made it unnoticed to mainline. Acked-by: Sylwester Nawrocki s.nawro...@samsung.com -Original Message- From: Dan Carpenter

Re: Linux Plumber's Conference: Call for Working Session Submissions

2010-08-19 Thread Mauro Carvalho Chehab
Em 24-07-2010 17:43, Mauro Carvalho Chehab escreveu: CFP dead line for submitting proposals to LPC/2010 is approaching. For those that intends to submit proposals for it, please do it quickly, as the official dead line is July, 26. Guys, We're trying to close the track definitions and start

Re: [RFC] [PATCH 1/6] SoC Camera: add driver for OMAP1 camera interface

2010-08-19 Thread Janusz Krzysztofik
Thursday 19 August 2010 14:16:21 Marin Mitov napisał(a): On Thursday, August 19, 2010 02:39:47 pm Guennadi Liakhovetski wrote: No, I don't think you should go to the next power of 2 - that's too crude. Try rounding your buffer size to the page size, that should suffice. Guennadi, If you

Re: [RFC] [PATCH 1/6] SoC Camera: add driver for OMAP1 camera interface

2010-08-19 Thread Marin Mitov
On Thursday, August 19, 2010 08:09:27 pm Janusz Krzysztofik wrote: Thursday 19 August 2010 14:16:21 Marin Mitov napisał(a): On Thursday, August 19, 2010 02:39:47 pm Guennadi Liakhovetski wrote: No, I don't think you should go to the next power of 2 - that's too crude. Try rounding your

[PATCH -next] tm6000: depends on IR_CORE

2010-08-19 Thread Randy Dunlap
.ko] undefined! Signed-off-by: Randy Dunlap randy.dun...@oracle.com --- drivers/staging/tm6000/Kconfig |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) --- linux-next-20100819.orig/drivers/staging/tm6000/Kconfig +++ linux-next-20100819/drivers/staging/tm6000/Kconfig @@ -1,6 +1,6

RE: [PATCH] Fixes field names that changed

2010-08-19 Thread Henrique Camargo
Thank you Sergio for your help, I resent the patch a couple of minutes ago taking your changes into account. Best Regards, Henrique Camargo On Wed, 2010-08-18 at 19:18 -0500, Aguirre, Sergio wrote: Oops, fixing my own typo below: -Original Message- From:

[PATCH] mt9t031: Fixes field names that changed

2010-08-19 Thread Henrique Camargo
If CONFIG_VIDEO_ADV_DEBUG was set, the driver failed to compile because the fields get_register and set_register changed names to g_register and s_register in the struct v4l2_subdev_core_ops. Signed-off-by: Henrique Camargo henri...@henriquecamargo.com --- drivers/media/video/mt9t031.c |4

RE: [RFC/PATCH v3 00/10] Media controller (core and V4L2)

2010-08-19 Thread Aguirre, Sergio
Hi Laurent, -Original Message- From: linux-media-ow...@vger.kernel.org [mailto:linux-media- ow...@vger.kernel.org] On Behalf Of Laurent Pinchart Sent: Thursday, July 29, 2010 11:07 AM To: linux-media@vger.kernel.org Cc: sakari.ai...@maxwell.research.nokia.com Subject: [RFC/PATCH v3

Re: [RFC/PATCH v3 00/10] Media controller (core and V4L2)

2010-08-19 Thread Laurent Pinchart
Hi Sergio, On Thursday 19 August 2010 21:09:30 Aguirre, Sergio wrote: -Original Message- From: linux-media-ow...@vger.kernel.org [mailto:linux-media- ow...@vger.kernel.org] On Behalf Of Laurent Pinchart Sent: Thursday, July 29, 2010 11:07 AM To: linux-media@vger.kernel.org Cc:

RE: [RFC/PATCH v3 00/10] Media controller (core and V4L2)

2010-08-19 Thread Aguirre, Sergio
-Original Message- From: Laurent Pinchart [mailto:laurent.pinch...@ideasonboard.com] Sent: Thursday, August 19, 2010 2:12 PM To: Aguirre, Sergio Cc: linux-media@vger.kernel.org; sakari.ai...@maxwell.research.nokia.com Subject: Re: [RFC/PATCH v3 00/10] Media controller (core and

[cron job] v4l-dvb daily build 2.6.22 and up: ERRORS, 2.6.16-2.6.21: ERRORS

2010-08-19 Thread Hans Verkuil
This message is generated daily by a cron job that builds v4l-dvb for the kernels and architectures in the list below. Results of the daily build of v4l-dvb: date:Thu Aug 19 19:00:19 CEST 2010 path:http://www.linuxtv.org/hg/v4l-dvb changeset: 15074:eff98a88caf3 git master:

Re: [PATCH/RFCv3 0/6] The Contiguous Memory Allocator framework

2010-08-19 Thread Michał Nazarewicz
On Thu, 19 Aug 2010 16:47:56 +0200, Konrad Rzeszutek Wilk konrad.w...@oracle.com wrote: Is there a git tree and/or link to the latest version that is based on top 2.6.36-rc1?? I somehow seem to have lost the v3 of these patches. I'm currently working on a v4 of the patchset after some

Re: [PATCH/RFCv3 0/6] The Contiguous Memory Allocator framework

2010-08-19 Thread Michał Nazarewicz
On Thu, 19 Aug 2010 17:15:12 +0200, FUJITA Tomonori fujita.tomon...@lab.ntt.co.jp wrote: On Wed, 18 Aug 2010 12:01:35 +0900 Kyungmin Park kyungmin.p...@samsung.com wrote: Are there any comments or ack? We hope this method included at mainline kernel if possible. It's really needed feature

Re: [PATCH/RFCv3 0/6] The Contiguous Memory Allocator framework

2010-08-19 Thread FUJITA Tomonori
We hope this method included at mainline kernel if possible. It's really needed feature for our multimedia frameworks. You got any comments from mm people? Virtually, this adds a new memory allocator implementation that steals some memory from memory allocator during boot process.