Hi Devin,
On 07/22/2013 09:48 PM, Devin Heitmueller wrote:
> Hello,
>
> I'm doing some cleanup on the au8522 driver, and one thing I noticed
> was that you are actually allowed to issue an S_INPUT while streaming
> is active. This seems like dangerous behavior, since it can result in
> things li
Hi,
On Monday 22 July 2013 08:14 PM, Alan Stern wrote:
> On Mon, 22 Jul 2013, Kishon Vijay Abraham I wrote:
>
>>> The PHY and the controller it is attached to are both physical
>>> devices.
>>>
>>> The connection between them is hardwired by the system
>>> manufacturer and cannot
Hi,
On Monday 22 July 2013 08:34 PM, Greg KH wrote:
> On Mon, Jul 22, 2013 at 12:55:18PM +0530, Kishon Vijay Abraham I wrote:
>>> The issue (or one of the issues) in this discussion is that
>>> Greg does not like the idea of using names or IDs to associate
>>> PHYs with controllers, b
- cleanup tuning code
- fix tuning for some systems/modulations/fecs
- add Digicipher II and DSS tuning abilities
- update the property_cache once tuning succeeds with the actual tuned values
- implement gp8psk_fe_read_ber()
- update .delsys with the new systems
Its a pretty big patch, I can reduc
From: Fabio Estevam
clk_prepare_enable() may fail, so let's check its return value and propagate it
in the case of error.
Signed-off-by: Fabio Estevam
---
- Changes since v2:
- Release the previously acquired resources
Changes since v1:
- Add missing 'if'
drivers/media/platform/coda.c | 17 ++
From: Fabio Estevam
When using devm_ioremap_resource(), we do not need to check the return value of
platform_get_resource(), so just remove it.
Signed-off-by: Fabio Estevam
Acked-by: Philipp Zabel
---
Changes since v2:
- None
Changes since v1:
- None
drivers/media/platform/coda.c | 5 -
From: Fabio Estevam
Some resources were not being released in the error path and some were released
in the incorrect order.
Signed-off-by: Fabio Estevam
---
Changes since v2:
- Newly introduced in this series
drivers/media/platform/coda.c | 32
1 file changed,
By using DTV_SET_PROPERTY I can run though a list of possible systems
to determine what is supported and what isnt. I havent looked too far
but I think it uses delsys to determine this information. Which I can
already get from DTV_ENUM_DELSYS. This functionality could be expanded
to delmod and delf
Hi Thomas,
On 07/15/2013 11:18 AM, Thomas Vajzovic wrote:
On 10 July 2013 20:44 Sylwester Nawrocki wrote:
On 07/07/2013 10:18 AM, Thomas Vajzovic wrote:
On 06 July 2013 20:58 Sylwester Nawrocki wrote:
On 07/05/2013 10:22 AM, Thomas Vajzovic wrote:
I am writing a driver for the sensor MT9D13
On Tue, 2013-07-23 at 00:16 +0300, Antti Palosaari wrote:
> On 07/22/2013 03:15 AM, Joe Perches wrote:
> > commit d7104bffcfb ("[media] MAINTAINERS: add drivers/media/tuners/it913x*")
> > used the incorrect file patterns. Fix it.
[]
> Acked-by: Antti Palosaari
> PS. It wasn't that commit, but som
On 07/22/2013 03:15 AM, Joe Perches wrote:
commit d7104bffcfb ("[media] MAINTAINERS: add drivers/media/tuners/it913x*")
used the incorrect file patterns. Fix it.
Signed-off-by: Joe Perches
cc: Antti Palosaari
cc: Mauro Carvalho Chehab
Acked-by: Antti Palosaari
PS. It wasn't that commit,
On 07/19/2013 08:18 PM, Jan Taegert wrote:
Hello,
when the culprit is the e4000 driver but the old driver from
https://github.com/valtri/DVB-Realtek-RTL2832U-2.2.2-10tuner-mod_kernel-3.0.0
worked for me, then must be somewhere there in the driver sources a
solution for the signal issues.
Does i
On 07/18/2013 12:12 AM, Luis Alves wrote:
v3:
Fixed issues reported by checkpatch script (thanks Antti).
Changed/fixed some stuff as sugested by Mauro Chehab.
Splited cx23885 changes to a separated patch.
Signed-off-by: Luis Alves
Maybbe that one is enough good too. There was still few < 20m
On 07/18/2013 12:12 AM, Luis Alves wrote:
v3:
Fixed issues reported by checkpatch script (thanks Antti).
Changed/fixed some stuff as sugested by Mauro Chehab.
Splited cx23885 changes to a separated patch.
Signed-off-by: Luis Alves
The order of patches is wrong as it will now fail compilation
Hello,
I'm doing some cleanup on the au8522 driver, and one thing I noticed
was that you are actually allowed to issue an S_INPUT while streaming
is active. This seems like dangerous behavior, since it can result in
things like the standard and/or resolution changing while the device
is actively
Buen día,
Somos una empresa FAIRHAVEN INTERNATIONAL LTD. dar préstamos por
correo anuncio. Ofrecemos diversos tipos de préstamos (créditos
blandos para vivienda, préstamos personales, etc.) Por la tasa de
interés del 3%, el plazo de amortización puede ser cualquier cosa
entre 3 y 25 años. Si
These match_* functions are internal callbacks and are always
invoked only after checking asd->bus_type. So drop redundant
checks in match_i2c() and match_platform() functions.
Signed-off-by: Sylwester Nawrocki
Signed-off-by: Kyungmin Park
---
drivers/media/v4l2-core/v4l2-async.c |4 +---
1
Add support for matching by device_node pointer. This allows
the notifier user to simply pass a list of device_node pointers
corresponding to sub-devices.
Signed-off-by: Sylwester Nawrocki
Signed-off-by: Kyungmin Park
---
drivers/media/v4l2-core/v4l2-async.c |9 +
include/media/v4l2
By integrating the v4l2-async API internals a bit more with
the core overall the v4l2-async code becomes a bit simpler
and easier to follow.
Signed-off-by: Sylwester Nawrocki
Signed-off-by: Kyungmin Park
---
drivers/media/v4l2-core/v4l2-async.c | 67 +++---
include
Hello,
This is a few patches for the v4l2-async API I wrote while adding
the asynchronous subdev registration support to the exynos4-is
driver.
The most significant change is addition of V4L2_ASYNC_MATCH_OF
subdev matching method, where host driver can pass a list of
of_node pointers identifying
enum v4l2_async_bus_type also selects a method subdevs are matched
in the notification handlers, rename it to v4l2_async_match_type
so V4L2_ASYNC_MATCH_OF entry can be further added for matching by
device tree node pointer.
Signed-off-by: Sylwester Nawrocki
Signed-off-by: Kyungmin Park
---
driv
This is a purely cosmetic change. Since the 'subdev' member
points to an array of subdevs it seems more intuitive to name
it in plural form.
Signed-off-by: Sylwester Nawrocki
Signed-off-by: Kyungmin Park
---
drivers/media/platform/soc_camera/soc_camera.c |2 +-
drivers/media/v4l2-core/v4l2-
This message is generated daily by a cron job that builds media_tree for
the kernels and architectures in the list below.
Results of the daily build of media_tree:
date: Mon Jul 22 19:00:33 CEST 2013
git branch: test
git hash: c859e6ef33ac0c9a5e9e934fe11a2232752b4e96
gcc versi
On Mon, Jul 22, 2013 at 12:55:18PM +0530, Kishon Vijay Abraham I wrote:
> > The issue (or one of the issues) in this discussion is that
> > Greg does not like the idea of using names or IDs to associate
> > PHYs with controllers, because they are too prone to
> > duplications or ot
On Mon, 22 Jul 2013, Kishon Vijay Abraham I wrote:
> > The PHY and the controller it is attached to are both physical
> > devices.
> >
> > The connection between them is hardwired by the system
> > manufacturer and cannot be changed by software.
> >
> > PHYs are generally des
The following changes since commit 348d1299b808a9e68a7dee2a4de6b555600099de:
s5p-g2d: Fix registration failure (2013-07-22 14:17:28 +0200)
are available in the git repository at:
git://git.linuxtv.org/kdebski/media.git new-for-3.12
for you to fetch changes up to abe28f650794d42c7cc1d0ff3759
The following changes since commit cab602f1930b2c3fb023ff82d371a915f2168457:
Linux 3.11-rc2 (2013-07-22 14:32:12 +0200)
are available in the git repository at:
git://git.linuxtv.org/kdebski/media.git fixes-for-3.11
for you to fetch changes up to 55f8d96dc132fef5b2c3f3d9b4d891d673e8ce33:
Hi Chris,
Em Fri, 19 Jul 2013 14:27:09 -0600
Chris Lee escreveu:
> In frontend.h we have a struct called dvb_frontend_ops, in there we
> have an element called delsys to show the delivery systems supported
> by the tuner, Id like to propose we add onto that with delmod and
> delfec.
>
> Its not
On Saturday 20 July 2013 11:51 AM, Lad, Prabhakar wrote:
> From: "Lad, Prabhakar"
>
> This patch makes the platform data members as array wherever
> possible, so as this makes easier while collecting the data
> in DT case and read the entire array at once.
>
> This patch also makes appropriate c
Hello,
On 21 July 2013 21:38 Sylwester Nawrocki wrote:
>On 07/19/2013 10:28 PM, Sakari Ailus wrote:
>> On Sat, Jul 06, 2013 at 09:58:23PM +0200, Sylwester Nawrocki wrote:
>>> On 07/05/2013 10:22 AM, Thomas Vajzovic wrote:
>>>
The hardware reads AxB sensor pixels from its array, resamples them
From: Srinivas Kandagatla
Thankyou for providing comments on v1 patch.
This patchset adds new members to rc_device structure to open rc device from
code other than rc-main. In the current code rc-device is only opened via input
driver. In cases where rc device is using lirc protocol, it will nev
From: Srinivas Kandagatla
This patch adds user count to rc_dev structure, the reason to add this
new member is to allow other code like lirc to open rc device directly.
In the existing code, rc device is only opened by input subsystem which
works ok if we have any input drivers to match. But in c
From: Srinivas Kandagatla
The use case is simple, if any rc device has allowed protocols =
RC_TYPE_LIRC and map_name = RC_MAP_LIRC set, the driver open will be never
called. The reason for this is, all of the key maps except lirc have some
KEYS in there map, so during rc_register_device process t
Hi Fabio,
Am Samstag, den 20.07.2013, 16:10 -0300 schrieb Fabio Estevam:
> From: Fabio Estevam
>
> clk_prepare_enable() may fail, so let's check its return value and propagate
> it
> in the case of error.
>
> Signed-off-by: Fabio Estevam
>
> ---
> Changes since v1:
> - Add missing 'if'
>
>
Am Samstag, den 20.07.2013, 15:48 -0300 schrieb Fabio Estevam:
> From: Fabio Estevam
>
> When using devm_ioremap_resource(), we do not need to check the return value
> of
> platform_get_resource(), so just remove it.
>
> Signed-off-by: Fabio Estevam
> ---
> drivers/media/platform/coda.c | 5 -
Hi,
On Monday 22 July 2013 12:52 AM, Alan Stern wrote:
> On Sun, 21 Jul 2013, Sylwester Nawrocki wrote:
>
>>> What's wrong with the platform_data structure, why can't that be used
>>> for this?
>>
>> At the point the platform data of some driver is initialized, e.g. in
>> board setup code the PHY
36 matches
Mail list logo