cron job: media_tree daily build: OK

2019-08-22 Thread Hans Verkuil
This message is generated daily by a cron job that builds media_tree for the kernels and architectures in the list below. Results of the daily build of media_tree: date: Fri Aug 23 05:00:12 CEST 2019 media-tree git hash:01faced6f65d0224bf6ce1262a4137771e28519f media_build gi

Re: [PATCH 5/7] media: use the BIT() macro

2019-08-22 Thread Laurent Pinchart
Hi Mauro, Thank you for the patch. On Thu, Aug 22, 2019 at 04:39:32PM -0300, Mauro Carvalho Chehab wrote: > As warned by cppcheck: > > [drivers/media/dvb-frontends/cx24123.c:434]: (error) Shifting signed > 32-bit value by 31 bits is undefined behaviour > [drivers/media/pci/bt8xx/btt

[PATCH] media: bindings: video-interfaces: Update the example

2019-08-22 Thread Jacopo Mondi
The example provided by the video-interface.txt file uses compatible values for drivers which are have been removed a long time ago. To avoid generating confusion, replace the existing example with a new one using upstream maintained and more modern devices. Signed-off-by: Jacopo Mondi --- This

Re: [PATCH 7/7] media: ngene: don't try to memcpy from NULL

2019-08-22 Thread Mauro Carvalho Chehab
Em Thu, 22 Aug 2019 16:39:34 -0300 Mauro Carvalho Chehab escreveu: > [drivers/media/pci/ngene/ngene-i2c.c:122] -> > [drivers/media/pci/ngene/ngene-i2c.c:39]: (error) Null pointer dereference: > out > > Signed-off-by: Mauro Carvalho Chehab > --- > drivers/media/pci/ngene/ngene-i2c.c | 5 -

[PATCH 1/7] media: remove include stdarg.h from some drivers

2019-08-22 Thread Mauro Carvalho Chehab
It doesn't make any sense to have gcc's stdarg.h included inside the Linux Kernel. Get rid of those includes. Signed-off-by: Mauro Carvalho Chehab --- drivers/media/pci/cx18/cx18-mailbox.c | 2 +- drivers/media/pci/ivtv/ivtv-mailbox.c | 2 -- drivers/media/pci/ttpci/av7110_hw.c | 1 - drivers

[PATCH 7/7] media: ngene: don't try to memcpy from NULL

2019-08-22 Thread Mauro Carvalho Chehab
[drivers/media/pci/ngene/ngene-i2c.c:122] -> [drivers/media/pci/ngene/ngene-i2c.c:39]: (error) Null pointer dereference: out Signed-off-by: Mauro Carvalho Chehab --- drivers/media/pci/ngene/ngene-i2c.c | 5 - 1 file changed, 4 insertions(+), 1 deletion(-) diff --git a/drivers/media/pci/nge

[PATCH 3/7] media: aspeed-video: address a protential usage of an unit var

2019-08-22 Thread Mauro Carvalho Chehab
While this might not occur in practice, if the device is doing the right thing, it would be teoretically be possible to have both hsync_counter and vsync_counter negatives. If this ever happen, ctrl will be undefined, but the driver will still call: aspeed_video_update(video, VE_CTRL, 0,

[PATCH 2/7] media: vicodec: make life easier for static analyzers

2019-08-22 Thread Mauro Carvalho Chehab
cppcheck incorrectly produces an error here: [drivers/media/platform/vicodec/vicodec-core.c:1677]: (error) Pointer addition with NULL pointer. While this is actually a false positive, it doesn't hurt to reorder the checks to make the code simpler, handling first the error patch, where no

[PATCH 6/7] media: don't do an unsigned int with a 31 bit shift

2019-08-22 Thread Mauro Carvalho Chehab
Doing something like: i32 foo = 1, bar; bar = foo << 31; has an undefined behavior in C, as warned by cppcheck, as we're shifting a signed integer. Instead, force the numbers to be unsigned, in order to solve this issue. Signed-off-by: Mauro Carvalho Chehab --- drivers/media/

[PATCH 4/7] media: ov9650: add a sanity check

2019-08-22 Thread Mauro Carvalho Chehab
As pointed by cppcheck: [drivers/media/i2c/ov9650.c:706]: (error) Shifting by a negative value is undefined behaviour [drivers/media/i2c/ov9650.c:707]: (error) Shifting by a negative value is undefined behaviour [drivers/media/i2c/ov9650.c:721]: (error) Shifting by a nega

MY $25,000,000.00 INVESTMENT PROPOSAL WITH YOU AND IN YOUR COUNTRY.

2019-08-22 Thread Law firm(Eku and Associates)
-- Dear, With due respect this is not spam or Scam mail, because I have contacted you before and there was no response from you,I apologise if the contents of this mail are contrary to your moral ethics, which I feel may be of great disturbance to your person, but please treat this with absolute c

Re: [RFC,v4,1/4] media: dt-bindings: mt8183: Added camera ISP Pass 1

2019-08-22 Thread Jungo Lin
Hi, Rob: On Wed, 2019-08-21 at 15:17 -0500, Rob Herring wrote: > On Wed, Aug 07, 2019 at 08:48:00PM +0800, Jungo Lin wrote: > > This patch adds DT binding document for the Pass 1 (P1) unit > > in Mediatek's camera ISP system. The Pass 1 unit grabs the sensor > > data out from the sensor interface,

Re: [RFC,v4,1/4] media: dt-bindings: mt8183: Added camera ISP Pass 1

2019-08-22 Thread Jungo Lin
Hi, Rob: On Wed, 2019-08-21 at 14:47 -0500, Rob Herring wrote: > On Wed, Aug 07, 2019 at 08:48:00PM +0800, Jungo Lin wrote: > > This patch adds DT binding document for the Pass 1 (P1) unit > > in Mediatek's camera ISP system. The Pass 1 unit grabs the sensor > > data out from the sensor interface,

Re: [PATCH v4] media: si2168: Refactor command setup code

2019-08-22 Thread Marc Gonzalez
On 22/08/2019 11:10, Sean Young wrote: > On Mon, Aug 19, 2019 at 01:54:53PM +0200, Marc Gonzalez wrote: > >> On 15/07/2019 11:50, Marc Gonzalez wrote: >> >>> Use cmd_init() to fill a struct si2168_cmd command. >>> >>> Signed-off-by: Marc Gonzalez >>> --- >>> Changes from v1: >>> - Use a real func

[PATCH v9 12/13] media: tvp5150: add support to limit sdtv standards

2019-08-22 Thread Marco Felsch
The tvp5150 accepts NTSC(M,J,4.43), PAL (B,D,G,H,I,M,N) and SECAM video data and is able to auto-detect the input signal. The auto-detection does not work if the connector does not receive an input signal and the tvp5150 might not be configured correctly. This misconfiguration leads into wrong deco

[PATCH v9 09/13] media: tvp5150: add s_power callback

2019-08-22 Thread Marco Felsch
Don't en-/disable the interrupts during s_stream because someone can disable the stream but wants to get informed if the stream is locked again. So keep the interrupts enabled the whole time the pipeline is opened. Signed-off-by: Marco Felsch --- drivers/media/i2c/tvp5150.c | 23

[PATCH v9 05/13] media: tvp5150: add input source selection of_graph support

2019-08-22 Thread Marco Felsch
This patch adds the of_graph support to describe the tvp input connections. Physical the TVP5150 has three ports: AIP1A, AIP1B and YOUT. As result of discussion [1],[2] the device-tree maps these ports 1:1. Look at the Documentation for more information. Since the TVP5150 is a converter/bridge the

[PATCH v9 08/13] media: tvp5150: initialize subdev before parsing device tree

2019-08-22 Thread Marco Felsch
From: Michael Tretter There are several debug prints in the tvp5150_parse_dt() function, which do not print the prefix, because the v4l2_subdev is not initialized, yet. Initialize the v4l2_subdev before parsing the device tree to fix the debug messages. Signed-off-by: Michael Tretter Signed-of

[PATCH v9 04/13] partial revert of "[media] tvp5150: add HW input connectors support"

2019-08-22 Thread Marco Felsch
From: Javier Martinez Canillas Commit f7b4b54e6364 ("[media] tvp5150: add HW input connectors support") added input signals support for the tvp5150, but the approach was found to be incorrect so the corresponding DT binding commit 82c2ffeb217a ("[media] tvp5150: document input connectors DT bindi

[PATCH v9 00/13] Add TVP5150 features

2019-08-22 Thread Marco Felsch
Hi, this version is exactly the same as my v8 [1]. I fixed only a leading semicolon issue in patch ("media: v4l2-fwnode: add initial connector parsing support") found by the kbuild test robot. Regards, Marco [1] https://www.spinics.net/lists/linux-media/msg156159.html Javier Martinez Canillas

[PATCH v9 02/13] media: v4l2-fwnode: add v4l2_fwnode_connector

2019-08-22 Thread Marco Felsch
Currently every driver needs to parse the connector endpoints by it self. This is the initial work to make this generic. A generic connector has common members and connector specific members. The common members are: - type - label (optional) - links - nr_of_links The specific members are s

[PATCH v9 13/13] media: tvp5150: make debug output more readable

2019-08-22 Thread Marco Felsch
The debug output for tvp5150_selmux() isn't really intuitive. Register values are printed decimal formatted and the input/output driver states are printed as enum. Even more the "normal" output enum mapps to zero so a active output will printing output=0 and a inactive output=1. Change this by bri

[PATCH v9 11/13] media: dt-bindings: tvp5150: add optional sdtv standards documentation

2019-08-22 Thread Marco Felsch
Document the optional binding to limit the possible sdtv standards on the input connectors. Signed-off-by: Marco Felsch Reviewed-by: Rob Herring v8: - adapt to new sdtv-standards - adapt commit message - fix missing include within example code --- .../devicetree/bindings/media/i2c/tvp5150.txt

[PATCH v9 06/13] media: dt-bindings: tvp5150: Add input port connectors DT bindings

2019-08-22 Thread Marco Felsch
The TVP5150/1 decoders support different video input sources to their AIP1A/B pins. Possible configurations are as follows: - Analog Composite signal connected to AIP1A. - Analog Composite signal connected to AIP1B. - Analog S-Video Y (luminance) and C (chrominance) signals connected to

[PATCH v9 03/13] media: v4l2-fwnode: add initial connector parsing support

2019-08-22 Thread Marco Felsch
The patch adds the initial connector parsing code, so we can move from a driver specific parsing code to a generic one. Currently only the generic fields and the analog-connector specific fields are parsed. Parsing the other connector specific fields can be added by a simple callbacks. Signed-off-

[PATCH v9 10/13] media: dt-bindings: tvp5150: cleanup bindings stlye

2019-08-22 Thread Marco Felsch
Use underlines to highlight optional and required properties. This is quite common for all bindings. Align descriptions and start sentence with uppercase letter. Also reword the usage of the required endpoint properties for the output port in case BT.656 should be used. Signed-off-by: Marco Felsch

[PATCH v9 07/13] media: tvp5150: add FORMAT_TRY support for get/set selection handlers

2019-08-22 Thread Marco Felsch
Since commit 10d5509c8d50 ("[media] v4l2: remove g/s_crop from video ops") the 'which' field for set/get_selection must be FORMAT_ACTIVE. There is no way to try different selections. The patch adds a helper function to select the correct selection memory space (sub-device file handle or driver stat

[PATCH v9 01/13] dt-bindings: connector: analog: add sdtv standards property

2019-08-22 Thread Marco Felsch
Some connectors no matter if in- or output supports only a limited range of sdtv standards. It doesn't matter if the hardware behind that connector supports more than the listed formats since the users are restriced by a label e.g. to plug only a camera into this connector which uses the PAL format