Re: [PATCH v6 05/13] clk: imx7d: reset parent for mipi csi root

2018-06-01 Thread Stephen Boyd
Quoting Rui Miguel Silva (2018-05-22 07:52:37) > To guarantee that we do not get Overflow in image FIFO the outer bandwidth has > to be faster than inputer bandwidth. For that it must be possible to set a > faster frequency clock. So set new parent to sys_pfd3 clock for the mipi csi > block. > > A

Re: [PATCH v6 04/13] clk: imx7d: fix mipi dphy div parent

2018-06-01 Thread Stephen Boyd
Quoting Rui Miguel Silva (2018-05-22 07:52:36) > Fix the mipi dphy root divider to mipi_dphy_pre_div, this would remove a > orphan > clock and set the correct parent. > > before: > cat clk_orphan_summary > enable prepare protect >clock

Re: [PATCH v4 03/12] clk: imx7d: fix mipi dphy div parent

2018-05-17 Thread Stephen Boyd
Quoting Rui Miguel Silva (2018-05-17 05:50:24) > Fix the mipi dphy root divider to mipi_dphy_pre_div, this would remove a > orphan > clock and set the correct parent. > > before: > cat clk_orphan_summary > enable prepare protect >clock

Re: [PATCH v2 03/15] clk: imx7d: fix mipi dphy div parent

2018-05-01 Thread Stephen Boyd
Quoting Rui Miguel Silva (2018-04-23 06:47:38) > Fix the mipi dphy root divider to mipi_dphy_pre_div, this would remove a > orphan > clock and set the correct parent. > > before: > cat clk_orphan_summary > enable prepare protect >clock

Re: [PATCH 1/8] clk: Add clk_bulk_alloc functions

2018-03-15 Thread Stephen Boyd
Quoting Marek Szyprowski (2018-02-20 01:36:03) > Hi Robin, > > On 2018-02-19 17:29, Robin Murphy wrote: > > > > Seeing how every subsequent patch ends up with the roughly this same > > stanza: > > > > x = devm_clk_bulk_alloc(dev, num, names); > > if (IS_ERR(x) > >     return PTR_ERR(x

Re: [PATCH 01/33] clk_ops: change round_rate() to return unsigned long

2018-01-02 Thread Stephen Boyd
On 01/02, Bryan O'Donoghue wrote: > On 02/01/18 19:01, Stephen Boyd wrote: > >On 12/31, Bryan O'Donoghue wrote: > >>On 30/12/17 16:36, Mikko Perttunen wrote: > >>>FWIW, we had this problem some years ago with the Tegra CPU clock > >>>- then it wa

Re: [PATCH 01/33] clk_ops: change round_rate() to return unsigned long

2018-01-02 Thread Stephen Boyd
On 12/31, Bryan O'Donoghue wrote: > On 30/12/17 16:36, Mikko Perttunen wrote: > >FWIW, we had this problem some years ago with the Tegra CPU clock > >- then it was determined that a simpler solution was to have the > >determine_rate callback support unsigned long rates - so clock > >drivers that ne

Re: [RESEND RFC PATCH 3/7] clk: sunxi: Add CLK_SET_RATE_PARENT flag for H3 HDMI clock

2017-11-02 Thread Stephen Boyd
On 09/20, Jernej Skrabec wrote: > When setting the HDMI clock of H3, the PLL_VIDEO clock needs to be set. > > Add CLK_SET_RATE_PARENT flag for H3 HDMI clock. > > Signed-off-by: Jernej Skrabec > Signed-off-by: Icenowy Zheng > --- Acked-by: Stephen Boyd -- Qualcomm Innov

Re: [PATCH v3 3/9] media: venus: adding core part and helper functions

2016-11-11 Thread Stephen Boyd
On 11/11, Stanimir Varbanov wrote: > On 11/10/2016 11:43 PM, Stephen Boyd wrote: > > > > Should this be ret |= ? Only the last time through the loop will > > there be an error. Or perhaps we should be bailing out early from > > this loop? > > I think that even

Re: [PATCH v3 3/9] media: venus: adding core part and helper functions

2016-11-10 Thread Stephen Boyd
On 11/07, Stanimir Varbanov wrote: > diff --git a/drivers/media/platform/qcom/venus/core.c > b/drivers/media/platform/qcom/venus/core.c > new file mode 100644 > index ..7b14b1f12e20 > --- /dev/null > +++ b/drivers/media/platform/qcom/venus/core.c > @@ -0,0 +1,557 @@ > +/* > + * Copyrig

Re: [PATCH v3 8/9] media: venus: add Makefiles and Kconfig files

2016-11-09 Thread Stephen Boyd
On 11/07, Stanimir Varbanov wrote: > diff --git a/drivers/media/platform/qcom/Kconfig > b/drivers/media/platform/qcom/Kconfig > new file mode 100644 > index ..bf4d2fcce924 > --- /dev/null > +++ b/drivers/media/platform/qcom/Kconfig > @@ -0,0 +1,7 @@ > + > +menuconfig VIDEO_QCOM_VENUS >

Re: [PATCH v2 1/2] clk: change clk_ops' ->round_rate() prototype

2015-05-19 Thread Stephen Boyd
On 05/16, Mikko Perttunen wrote: > On 05/15/2015 06:40 PM, Boris Brezillon wrote: > >Hi Stephen, > > > >Adding Mikko in the loop (after all, he was the one complaining about > >this signed long limitation in the first place, and I forgot to add > >him in the Cc list :-/). > > I think I got it thro

Re: [PATCH v2 1/2] clk: change clk_ops' ->round_rate() prototype

2015-05-06 Thread Stephen Boyd
On 04/30, Boris Brezillon wrote: > Clock rates are stored in an unsigned long field, but ->round_rate() > (which returns a rounded rate from a requested one) returns a long > value (errors are reported using negative error codes), which can lead > to long overflow if the clock rate exceed 2Ghz. >

Re: [PATCH 06/14] clkdev: add clkdev_create() helper

2015-04-07 Thread Stephen Boyd
On 04/07/15 05:43, Russell King - ARM Linux wrote: > On Mon, Apr 06, 2015 at 01:19:33PM -0700, Stephen Boyd wrote: >> On 04/03/15 10:12, Russell King wrote: >>> @@ -316,6 +329,29 @@ clkdev_alloc(struct clk *clk, const char *con_id, >>> const char *dev_fmt, ...

Re: [PATCH 06/14] clkdev: add clkdev_create() helper

2015-04-06 Thread Stephen Boyd
On 04/03/15 10:12, Russell King wrote: > @@ -316,6 +329,29 @@ clkdev_alloc(struct clk *clk, const char *con_id, const > char *dev_fmt, ...) > } > EXPORT_SYMBOL(clkdev_alloc); > > +/** > + * clkdev_create - allocate and add a clkdev lookup structure > + * @clk: struct clk to associate with all

Re: [PATCH 05/14] clkdev: use clk_hw internally

2015-04-06 Thread Stephen Boyd
On 04/03/15 10:12, Russell King wrote: > Signed-off-by: Russell King Some commit text would be nice for us 5 years from now when we wonder why this patch was applied. I suspect the commit text would go like this: clk_add_alias() calls clk_get() followed by clk_put() but in between those two cal

Re: [PATCH 03/14] clkdev: get rid of redundant clk_add_alias() prototype in linux/clk.h

2015-04-06 Thread Stephen Boyd
On 04/04/15 05:43, Robert Jarzmik wrote: > Russell King writes: > >> clk_add_alias() is provided by clkdev, and is not part of the clk API. >> Howver, it is prototyped in two locations: linux/clkdev.h and >> linux/clk.h. This is a mess. Get rid of the redundant and unnecessary >> version in linu

Re: [PATCH 05/10] clkdev: add clkdev_create() helper

2015-03-02 Thread Stephen Boyd
On 03/02/15 13:01, Russell King - ARM Linux wrote: > On Mon, Mar 02, 2015 at 11:07:58AM -0800, Stephen Boyd wrote: >> On 03/02/15 09:06, Russell King wrote: >>> Add a helper to allocate and add a clk_lookup structure. This can not >>> only be used in several places

Re: [PATCH 00/10] initial clkdev cleanups

2015-03-02 Thread Stephen Boyd
On 03/02/15 09:05, Russell King - ARM Linux wrote: > Here's some initial clkdev cleanups. These are targetted for the next > merge window, and while the initial patches can be merged independently, > I'd prefer to keep the series together as further work on solving the > problems which unique stru

Re: [PATCH 05/10] clkdev: add clkdev_create() helper

2015-03-02 Thread Stephen Boyd
On 03/02/15 09:06, Russell King wrote: > Add a helper to allocate and add a clk_lookup structure. This can not > only be used in several places in clkdev.c to simplify the code, but > more importantly, can be used by callers of the clkdev code to simplify > their clkdev creation and registration.