Re: [PATCH 4/5] gpiolib: handle deferral probe error

2011-10-12 Thread G, Manjunath Kondaiah
On Fri, Oct 07, 2011 at 04:09:38PM -0600, Grant Likely wrote: On Fri, Oct 7, 2011 at 4:06 AM, Alan Cox a...@lxorguk.ukuu.org.uk wrote: On Fri, 07 Oct 2011 10:33:09 +0500 G, Manjunath Kondaiah manj...@ti.com wrote: The gpio library should return -EPROBE_DEFER in gpio_request if gpio

Re: [PATCH 1/5] drivercore: add new error value for deferred probe

2011-10-12 Thread G, Manjunath Kondaiah
On Sun, Oct 09, 2011 at 06:06:56PM -0700, Greg KH wrote: On Sun, Oct 09, 2011 at 04:59:31PM -0600, Grant Likely wrote: On Fri, Oct 7, 2011 at 6:12 PM, Greg KH g...@kroah.com wrote: On Fri, Oct 07, 2011 at 07:28:33PM -0400, valdis.kletni...@vt.edu wrote: On Fri, 07 Oct 2011 16:12:45 MDT,

Re: [PATCH 2/5] drivercore: Add driver probe deferral mechanism

2011-10-12 Thread G, Manjunath Kondaiah
On Mon, Oct 10, 2011 at 10:37:22AM -0700, Andrei Warkentin wrote: Hi, - Original Message - From: Greg KH g...@kroah.com To: Josh Triplett j...@joshtriplett.org Cc: G, Manjunath Kondaiah manj...@ti.com, linux-arm-ker...@lists.infradead.org, Grant Likely

[RFC/PATCH] mmc: core: Kill block requests if card is removed

2011-10-12 Thread Sujit Reddy Thumma
Kill block requests when the host knows that the card is removed from the slot and is sure that it can no longer accept any requests. Kill this silently so that the block layer don't output error messages unnecessarily. Signed-off-by: Sujit Reddy Thumma sthu...@codeaurora.org diff --git

Re: [PATCH] mmc: mmci: Do not release spinlock in request_end

2011-10-12 Thread Linus Walleij
On Tue, Oct 11, 2011 at 4:06 PM, Ulf Hansson ulf.hans...@stericsson.com wrote: The patch mmc: core: move -request() call from atomic context, is the reason to why this change is possible. This simplifies the error handling code execution path quite a lot and potentially also fixes some error

[PATCH V3 0/3] ARM: SAMSUNG: Add support for sdhci clock lookup using generic names

2011-10-12 Thread Rajeshwari Shinde
This patchset adds support for sdhci controller clock lookup using generic names. With this patchset, there will be no need to pass clock names in sdhci platform data. This patchset depends on the patchset: Add a common macro for creating struct clk_lookup entries. mmc: sdhci-s3c: add default

[PATCH V3 1/3] SDHCI: S3C: Use generic clock names for sdhci bus clock options

2011-10-12 Thread Rajeshwari Shinde
This patch modifies the driver to stop depending on the clock names being passed from the platform and switch over to bus clock lookup using generic clock names. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- drivers/mmc/host/sdhci-s3c.c |6 ++ 1 files changed, 2

[PATCH V3 2/3] ARM: SAMSUNG: Remove SDHCI bus clocks from platform data

2011-10-12 Thread Rajeshwari Shinde
The bus clocks previously sent through platform data to SDHCI controller are removed. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- arch/arm/mach-exynos4/Makefile |1 - arch/arm/mach-exynos4/setup-sdhci.c| 22 ---

[PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-12 Thread Rajeshwari Shinde
Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- arch/arm/mach-exynos4/clock.c | 88 ++--- arch/arm/mach-s3c2416/clock.c

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-12 Thread Sylwester Nawrocki
Hi Rajeshwari, On 10/12/2011 11:43 AM, Rajeshwari Shinde wrote: Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. Signed-off-by: Rajeshwari Shinde rajeshwar...@samsung.com --- arch/arm/mach-exynos4/clock.c

Re: [PATCH] mmc: mmci: Do not release spinlock in request_end

2011-10-12 Thread Adrian Hunter
On 12/10/11 12:41, Linus Walleij wrote: On Tue, Oct 11, 2011 at 4:06 PM, Ulf Hansson ulf.hans...@stericsson.com wrote: The patch mmc: core: move -request() call from atomic context, is the reason to why this change is possible. This simplifies the error handling code execution path quite a

Re: [RFC/PATCH] mmc: core: Kill block requests if card is removed

2011-10-12 Thread Pavan Kondeti
Hello Sujit, On 10/12/2011 1:06 PM, Sujit Reddy Thumma wrote: Kill block requests when the host knows that the card is removed from the slot and is sure that it can no longer accept any requests. Kill this silently so that the block layer don't output error messages unnecessarily.

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-12 Thread Rajeshwari Birje
Hi Sylwester, On Wed, Oct 12, 2011 at 3:54 PM, Sylwester Nawrocki s.nawro...@samsung.com wrote: Hi Rajeshwari, On 10/12/2011 11:43 AM, Rajeshwari Shinde wrote: Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's.

[PATCH] mmc: sdhci: fix debug_quirks2 module parameter description

2011-10-12 Thread Adrian Hunter
debug_quirks2 module parameter description was inadvertently added as debug_quirks. Signed-off-by: Adrian Hunter adrian.hun...@intel.com --- drivers/mmc/host/sdhci.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/mmc/host/sdhci.c b/drivers/mmc/host/sdhci.c

Re: [PATCH RESEND] mmc: sdhci-s3c: fix wrong error-control

2011-10-12 Thread Chris Ball
Hi, On Wed, Oct 12 2011, Jaehoon Chung wrote: If sc-clk_bus[ptr] is NULL, happen NULL pointer error. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com Signed-off-by: Kyungmin Park kyungmin.p...@samsung.com --- drivers/mmc/host/sdhci-s3c.c |6 -- 1 files changed, 4 insertions(+),

Re: [PATCH] mmc: sdhci: fix debug_quirks2 module parameter description

2011-10-12 Thread Chris Ball
Hi Adrian, On Wed, Oct 12 2011, Adrian Hunter wrote: debug_quirks2 module parameter description was inadvertently added as debug_quirks. Signed-off-by: Adrian Hunter adrian.hun...@intel.com --- drivers/mmc/host/sdhci.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff

Re: [PATCH V4 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-12 Thread Sylwester Nawrocki
On 10/12/2011 02:36 PM, Rajeshwari Birje wrote: On Wed, Oct 12, 2011 at 3:54 PM, Sylwester Nawrocki s.nawro...@samsung.com wrote: Hi Rajeshwari, On 10/12/2011 11:43 AM, Rajeshwari Shinde wrote: Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx,

Re: [PATCH 2/5] drivercore: Add driver probe deferral mechanism

2011-10-12 Thread Grant Likely
On Tue, Oct 11, 2011 at 08:29:18PM +0800, Ming Lei wrote: On Tue, Oct 11, 2011 at 1:37 AM, Andrei Warkentin awarken...@vmware.com wrote: Hi, - Original Message - From: Greg KH g...@kroah.com To: Josh Triplett j...@joshtriplett.org Cc: G, Manjunath Kondaiah manj...@ti.com,

Re: [PATCH 1/5] drivercore: add new error value for deferred probe

2011-10-12 Thread Grant Likely
On Wed, Oct 12, 2011 at 11:48:23AM +0530, G, Manjunath Kondaiah wrote: On Sun, Oct 09, 2011 at 06:06:56PM -0700, Greg KH wrote: On Sun, Oct 09, 2011 at 04:59:31PM -0600, Grant Likely wrote: On Fri, Oct 7, 2011 at 6:12 PM, Greg KH g...@kroah.com wrote: On Fri, Oct 07, 2011 at 07:28:33PM

Re: [PATCH 4/5] gpiolib: handle deferral probe error

2011-10-12 Thread Grant Likely
On Wed, Oct 12, 2011 at 11:44:32AM +0530, G, Manjunath Kondaiah wrote: On Fri, Oct 07, 2011 at 04:09:38PM -0600, Grant Likely wrote: On Fri, Oct 7, 2011 at 4:06 AM, Alan Cox a...@lxorguk.ukuu.org.uk wrote: On Fri, 07 Oct 2011 10:33:09 +0500 G, Manjunath Kondaiah manj...@ti.com wrote: