RE: [PATCH v3 1/1] mmc: dw_mmc: Add IDMAC 64-bit address mode support

2013-08-20 Thread Seungwon Jeon
Hi Prabu, On Tue, August 20, 2013, Arnd Bergmann wrote: On Monday 19 August 2013, Prabu Thangamuthu wrote: +#ifdef CONFIG_MMC_DW_IDMAC_64BIT_ADDRESS + u32 des1; /* Reserved */ + + u32 des2; /* Buffer sizes */ +#define IDMAC_SET_BUFFER1_SIZE(d, s) \ +

RE: [PATCH v3 1/1] mmc: dw_mmc: Add IDMAC 64-bit address mode support

2013-08-20 Thread Prabu Thangamuthu
Hi Arnd, Seungwon Jeon, On Tue, August 20, 2013, Seungwon Jeon wrote: Hi Prabu, On Tue, August 20, 2013, Arnd Bergmann wrote: On Monday 19 August 2013, Prabu Thangamuthu wrote: +#ifdef CONFIG_MMC_DW_IDMAC_64BIT_ADDRESS + u32 des1; /* Reserved */ + + u32

RE: [PATCH v3 1/1] mmc: dw_mmc: Add IDMAC 64-bit address mode support

2013-08-20 Thread Seungwon Jeon
On Tue, August 20, 2013, Prabu Thangamuthu wrote: Hi Arnd, Seungwon Jeon, On Tue, August 20, 2013, Seungwon Jeon wrote: Hi Prabu, On Tue, August 20, 2013, Arnd Bergmann wrote: On Monday 19 August 2013, Prabu Thangamuthu wrote: +#ifdef CONFIG_MMC_DW_IDMAC_64BIT_ADDRESS +

RE: [PATCH v3 1/1] mmc: dw_mmc: Add IDMAC 64-bit address mode support

2013-08-20 Thread Prabu Thangamuthu
Hi Seungwon Jeon, On Tue, August 20, 2013, Seungwon Jeon wrote: On Tue, August 20, 2013, Prabu Thangamuthu wrote: Hi Arnd, Seungwon Jeon, On Tue, August 20, 2013, Seungwon Jeon wrote: Hi Prabu, On Tue, August 20, 2013, Arnd Bergmann wrote: On Monday 19 August 2013, Prabu

Re: [RFC 3/3] mmc: dw_mmc: exynos: add a quirk for SMU.

2013-08-20 Thread Alim Akhtar
Hi Yuvaraj On Mon, Aug 19, 2013 at 12:06 PM, Yuvaraj Kumar C D yuvaraj...@gmail.com wrote: Exynos5420 Mobile Storage Host controller has Security Management Unit (SMU) for channel 0 and channel 1 (mainly for eMMC).This patch adds a quirk to bypass SMU as it is not being used yet. This patch

RE: [RFC 2/3] mmc: dw_mmc: move the platform specific init call

2013-08-20 Thread Seungwon Jeon
Hi Yuvaraj, This change affects dw_mci_socfpga_parse_dt of socfpga. It should be considered. Thanks, Seungwon Jeon On Mon, August 19, 2013, Yuvaraj Kumar C D wrote: Current platform specific private data initialisation call dw_mci_exynos_priv_init can be used to do platform specific

Re: SDHCI - Add QUIRK2_BROKEN_WRITE_PROTEXT - Support Xilinx Zynq (Linux 3.9.0)

2013-08-20 Thread Michal Simek
Hi James, isn't it better to implement host-ops-get_ro() function for it? It seems me better choice than introducing new quirk option. Chris: What do you think? Thanks, Michal On 08/16/2013 02:14 PM, James Walmsley wrote: Hi Michal, I have built a Xilinx Zynq based design which doesn't

Re: SDHCI - Add QUIRK2_BROKEN_WRITE_PROTEXT - Support Xilinx Zynq (Linux 3.9.0)

2013-08-20 Thread Chris Ball
Hi, On Tue, Aug 20 2013, Michal Simek wrote: Hi James, isn't it better to implement host-ops-get_ro() function for it? It seems me better choice than introducing new quirk option. Yes, I agree. Thanks, - Chris. -- Chris Ball c...@laptop.org http://printf.net/ -- To unsubscribe from

Re: [PATCH V2] mmc: omap_hsmmc: Fix sleep too long in ISR context.

2013-08-20 Thread Hein Tibosch
Hi, [ added some people from TI ] On 8/7/2013 6:05 PM, majianpeng wrote: V2: clean up code. V1: www.mail-archive.com/linux-omap@vger.../msg93239.html‎ We found a problem when we removed a working sd card that the irqaction of omap_hsmmc can sleep to 3.6s. This cause our

[PATCH 0/3] Fix sd3.0 issues for Realtek card reader

2013-08-20 Thread wei_wang
From: Wei WANG wei_w...@realsil.com.cn Wei WANG (3): mfd:mmc:rtsx: Change default tx phase mmc:rtsx:Clear SD_CLK toggle enable bit if switching voltage fail mmc:memstick:rtsx: Modify copyright comments drivers/memstick/host/rtsx_pci_ms.c |3 +- drivers/mfd/rtl8411.c |

[PATCH 2/3] mmc:rtsx:Clear SD_CLK toggle enable bit if switching voltage fail

2013-08-20 Thread wei_wang
From: Wei WANG wei_w...@realsil.com.cn If switching voltage fails, SD_CLK toggle enable bit should been cleared so that SD host can control SD clock automatically. Signed-off-by: Wei WANG wei_w...@realsil.com.cn --- drivers/mmc/host/rtsx_pci_sdmmc.c |9 - 1 file changed, 8

[PATCH 1/3] mfd:mmc:rtsx: Change default tx phase

2013-08-20 Thread wei_wang
From: Wei WANG wei_w...@realsil.com.cn The default phase can meet most cards' requirement, but it is not the optimal one. In some extreme situation, the rx phase point produced by the following tuning process will drift quite a distance. Before tuning UHS card, this patch will set a more proper

[PATCH 3/3] mmc:memstick:rtsx: Modify copyright comments

2013-08-20 Thread wei_wang
From: Wei WANG wei_w...@realsil.com.cn Update copyright date, and remove author address. Signed-off-by: Wei WANG wei_w...@realsil.com.cn --- drivers/memstick/host/rtsx_pci_ms.c |3 +-- drivers/mmc/host/rtsx_pci_sdmmc.c |3 +-- 2 files changed, 2 insertions(+), 4 deletions(-) diff

[PATCH RESEND] mmc: mmc_spi: use spi_get_drvdata() and spi_set_drvdata()

2013-08-20 Thread Jingoo Han
Use the wrapper functions for getting and setting the driver data using spi_device instead of using dev_{get|set}_drvdata with spi-dev, so we can directly pass a struct spi_device. This is a cosmetic change in order to enhance the readability and make the code simpler. Signed-off-by: Jingoo Han