Re: [PATCH] mmc: enable BKOPS for supported eMMC(4.41)

2013-09-01 Thread Jaehoon Chung
Hi, Prasanna. Why do you use MMC_CAP2_BKOPS_EN? Maybe we had discussed about this point. i know that we can enable the BKOPS with the mmc-util. (Actually, This code had included into my first patch. but it's removed.) Best Regards, Jaehoon Chung On 08/30/2013 09:09 PM, Prasanna NAVARATNA wrote

Re: [PATCH RFT] mmc: sdhci-spear: Convert to use sdhci_pltfm_* APIs

2013-09-01 Thread Viresh Kumar
On Sat, Aug 31, 2013 at 12:11 PM, Axel Lin wrote: > This patch refactors the code to use sdhci_pltfm_* APIs instead of open-coded. > > Signed-off-by: Axel Lin > --- > Hi Viresh, > Looks like this driver can be converted to use sdhci_pltfm_* APIs instead of > open-coded. I don't have this hardware

[PATCH] mmc: mvsdio: use devm_ioremap_resource() instead of devm_request_and_ioremap()

2013-09-01 Thread Jingoo Han
Use devm_ioremap_resource() because devm_request_and_ioremap() is obsoleted by devm_ioremap_resource(). Signed-off-by: Jingoo Han --- drivers/mmc/host/mvsdio.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/mmc/host/mvsdio.c b/drivers/mmc/host/mvsdio.c index

Re: [PATCH V2 1/7] mmc: lock: Use the kernel "KEYS" subsystem to get a card's password

2013-09-01 Thread Chris Ball
Hi, On Sun, Sep 01 2013, Chris Ball wrote: >> +config MMC_LOCK >> +bool "MMC/SD password based card lock/unlock" >> +select KEYS >> +help >> + This will add the ability to lock/unlock SD and MMC cards. >> + >> + If unsure, say N. > > Is there a good reason to have this behind

Re: [PATCH V2 1/7] mmc: lock: Use the kernel "KEYS" subsystem to get a card's password

2013-09-01 Thread Chris Ball
Hi Al, On Fri, Aug 30 2013, Al Cooper wrote: > --- a/drivers/mmc/core/Kconfig > +++ b/drivers/mmc/core/Kconfig > @@ -26,3 +26,11 @@ config MMC_CLKGATE > support handling this in order for it to be of any use. > > If unsure, say N. > + > +config MMC_LOCK > + bool "MMC/SD passw

[PATCH] mmc: omap: Use DIV_ROUND_UP instead of open coded

2013-09-01 Thread Axel Lin
This patch makes the intention of the code more clear. Signed-off-by: Axel Lin --- drivers/mmc/host/omap.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/mmc/host/omap.c b/drivers/mmc/host/omap.c index b94f38e..3187af0 100644 --- a/drivers/mmc/host/omap.c