Re: [PATCH RFT] mmc: wmt-sdmmc: Fix setting BM_EIGHTBIT_MODE bit in wmt_mci_set_ios()

2013-10-22 Thread Axel Lin
2013/10/23 Tony Prisk : > On 22/10/13 21:54, Axel Lin wrote: >> >> For MMC_BUS_WIDTH_8 case, current code missed setting BM_EIGHTBIT_MODE >> bit. >> Also has a small refactor to make the code looks better in readability. >> >> So the bit settings witch below logic: >> >> SDMMC_BUSMODE register: >>

Re: [PATCH 5/7] mmc: sdhci-esdhc-imx: fix cpas over write issue

2013-10-22 Thread Dong Aisheng
On Wed, Oct 23, 2013 at 10:51:48AM +0800, Shawn Guo wrote: > On Mon, Oct 21, 2013 at 10:27:05PM +0800, Dong Aisheng wrote: > > We should use '|=' instead '=', or it may over write > > the original caps assigned before this line. > > > > Signed-off-by: Dong Aisheng > > --- > > drivers/mmc/host/sd

Re: [PATCH 1/7] mmc: sdhci: clear auto cmd setting bits for no data cmds

2013-10-22 Thread Dong Aisheng
On Wed, Oct 23, 2013 at 10:33:28AM +0800, Shawn Guo wrote: > On Mon, Oct 21, 2013 at 10:27:01PM +0800, Dong Aisheng wrote: > > The auto cmd settings bits should be cleared before sending new commands > > or we may receive command timeout error for normal commands due to wrongly > > pre-sent auto cm

Re: [PATCH RFT] mmc: wmt-sdmmc: Fix setting BM_EIGHTBIT_MODE bit in wmt_mci_set_ios()

2013-10-22 Thread Tony Prisk
On 22/10/13 21:54, Axel Lin wrote: For MMC_BUS_WIDTH_8 case, current code missed setting BM_EIGHTBIT_MODE bit. Also has a small refactor to make the code looks better in readability. So the bit settings witch below logic: SDMMC_BUSMODE register: Set EIGHTBIT_MODE bit for 8 bit mode, Set FOURBIT

RE: [PATCH v2] mmc:sdhci-pci: Add Support of O2Mirco/BayHubTech SD Host

2013-10-22 Thread Peter Guo
Hi Chris, Do you have any comments on this patch? Thanks, Peter.Guo -Original Message- From: Adam Lee [mailto:adam@canonical.com] Sent: Wednesday, October 16, 2013 4:16 PM To: Peter Guo; Chris Ball Cc: Adrian Hunter; Greg Kroah-Hartman; Bill Pemberton; Guennadi Liakhovetski; linux-

Re: [PATCH 5/7] mmc: sdhci-esdhc-imx: fix cpas over write issue

2013-10-22 Thread Shawn Guo
On Mon, Oct 21, 2013 at 10:27:05PM +0800, Dong Aisheng wrote: > We should use '|=' instead '=', or it may over write > the original caps assigned before this line. > > Signed-off-by: Dong Aisheng > --- > drivers/mmc/host/sdhci-esdhc-imx.c |2 +- > 1 files changed, 1 insertions(+), 1 deletion

Re: [PATCH 1/7] mmc: sdhci: clear auto cmd setting bits for no data cmds

2013-10-22 Thread Shawn Guo
On Mon, Oct 21, 2013 at 10:27:01PM +0800, Dong Aisheng wrote: > The auto cmd settings bits should be cleared before sending new commands > or we may receive command timeout error for normal commands due to wrongly > pre-sent auto cmd. > > e.g. we receive CMD13 timeout error due to ACMD23 is wrongl

Avoid needless loop in sdhci_irq() for Card Interrupt

2013-10-22 Thread Alexey Neyman
[Patch ping #2] Hi all, I've discovered that the sdhci_irq() function needlessly iterates re-reading the interrupt status and doing nothing (until it runs out of max_loops) when it handles the "Card Interrupt" status in the interrupt status register. The reason is that the "Card Interrupt" bit

Re: [PATCH 1/1] MMC: Detect execution mode errors after r/w command

2013-10-22 Thread Ulf Hansson
On 22 October 2013 13:21, Oskar Andero wrote: > Hi Ulf, > > On 17:01 Wed 16 Oct , Ulf Hansson wrote: >> Hi Oskar / Lars, >> >> Sorry for the delayed response! >> >> On 10 October 2013 15:28, Oskar Andero wrote: >> > From: Lars Svensson >> > >> > Some error bits in the status field of R1/R1b

[PATCH v2 6/7] mmc: sh_mmcif: Simplify clock and power setup in set_ios

2013-10-22 Thread Ulf Hansson
This patch intend to simplify code in sh_mmcif_set_ios for how clock and power are being configured. Cc: Guennadi Liakhovetski Signed-off-by: Ulf Hansson --- drivers/mmc/host/sh_mmcif.c | 41 +++-- 1 file changed, 11 insertions(+), 30 deletions(-) diff --g

[PATCH v2 1/7] mmc: sh_mmcif: Move away from using deprecated APIs

2013-10-22 Thread Ulf Hansson
Suspend and resume of cards are being handled from the protocol layer and consequently the mmc_suspend|resume_host APIs are deprecated. This means we can simplify the suspend|resume callbacks by removing the use of the deprecated APIs. Cc: Guennadi Liakhovetski Signed-off-by: Ulf Hansson --- d

[PATCH v2 2/7] mmc: sh_mmcif: Convert to PM macros when defining dev_pm_ops

2013-10-22 Thread Ulf Hansson
Use SET_SYSTEM_SLEEP_PM_OPS to simplify code. Cc: Guennadi Liakhovetski Signed-off-by: Ulf Hansson --- drivers/mmc/host/sh_mmcif.c | 10 +++--- 1 file changed, 3 insertions(+), 7 deletions(-) diff --git a/drivers/mmc/host/sh_mmcif.c b/drivers/mmc/host/sh_mmcif.c index 6bffebe..32bc412 10

[PATCH v2 7/7] mmc: sh_mmcif: Extend clock gating routine for runtime suspend

2013-10-22 Thread Ulf Hansson
At request inactivity, we don't want to rely on gating the clock only through the clock API since this will depend on the clock tree and the clients using the clocks. To make sure the clock is fully gated towards the card in runtime suspend, we perform clock gating using the internal registers of

[PATCH v2 0/7] mmc: sh_mmcif: Convert to use runtime PM at request idle

2013-10-22 Thread Ulf Hansson
In a step in removing CONFIG_MMC_CLKGATE, host drivers can implement same functionality through runtime PM. This patchset is converting the sh_mmcif accordingly. On the way, it was reasonable to include some minor cleanups to simplify code. The first patch has beend sent through an another patchse

[PATCH v2 4/7] mmc: sh_mmcif: Use runtime PM to keep resourses active during I/O

2013-10-22 Thread Ulf Hansson
While I/O operations are ongoing, make sure the runtime PM resourses are kept active. When returning the resourses, utilize the runtime PM autosuspend feature with a default timeout set to 50 ms. The reason for chosing a 50 ms timeout is to make sure we are able to handle clock gating in a future

[PATCH v2 3/7] mmc: sh_mmcif: Convert to clk_prepare|unprepare

2013-10-22 Thread Ulf Hansson
Previously only clk_enable|disable were being used. Adapt properly to the clock API, by also using clk_prepare|unprepare. Cc: Guennadi Liakhovetski Signed-off-by: Ulf Hansson --- drivers/mmc/host/sh_mmcif.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drive

[PATCH v2 5/7] mmc: sh_mmcif: Move clock handling into runtime PM callbacks

2013-10-22 Thread Ulf Hansson
Implement callbacks for runtime suspend|resume and leave the clock to be handled from there. The .set_ios function is still capable of using the interal registers to gate the clock when the frequency is zero, but the operations needed towards the clk API is now handled from the runtime callbacks.

[GIT PULL] MMC updates for mmc-next

2013-10-22 Thread Ulf Hansson
Hi Chris, I have been posting some various patchsets to the mmc-list since early September. This pull request collects the patches for you to pull in to your mmc tree for the mmc-next branch. I hope you find this convenient. Kind regards Ulf Hansson The following changes since commit 26cb302389

Re: [PATCH 1/1] MMC: Detect execution mode errors after r/w command

2013-10-22 Thread Oskar Andero
Hi Ulf, On 17:01 Wed 16 Oct , Ulf Hansson wrote: > Hi Oskar / Lars, > > Sorry for the delayed response! > > On 10 October 2013 15:28, Oskar Andero wrote: > > From: Lars Svensson > > > > Some error bits in the status field of R1/R1b response are only set > > by the device in response to the

Re: [PATCH] mmc: dw_mmc: exynos: Revert the sdr_timing assignment

2013-10-22 Thread Jaehoon Chung
Acked-by: Jaehoon Chung Reported-by: Grant Grundler On 10/22/2013 06:11 PM, Yuvaraj Kumar C D wrote: > commit 4ad602c9df1e3b04979c260b5612141b4b892257 was wrongly assigning > ddr_timing value to sdr_timing.This patch fix's this by reverting > the sdr_timing assignment statement to the earlier lo

[PATCH v2] mmc: core: Do not poll for busy with status cmd for all switch cmds

2013-10-22 Thread Ulf Hansson
Some switch operations like poweroff notify, shall according to the spec not be followed by any other new commands. For these cases and when the host does'nt support MMC_CAP_WAIT_WHILE_BUSY, we must not send status commands to poll for busy detection. Instead wait for the stated timeout from the EX

[PATCH] mmc: dw_mmc: exynos: Revert the sdr_timing assignment

2013-10-22 Thread Yuvaraj Kumar C D
commit 4ad602c9df1e3b04979c260b5612141b4b892257 was wrongly assigning ddr_timing value to sdr_timing.This patch fix's this by reverting the sdr_timing assignment statement to the earlier location. Signed-off-by: Yuvaraj Kumar C D --- drivers/mmc/host/dw_mmc-exynos.c |3 ++- 1 file changed, 2

[PATCH RFT] mmc: wmt-sdmmc: Fix setting BM_EIGHTBIT_MODE bit in wmt_mci_set_ios()

2013-10-22 Thread Axel Lin
For MMC_BUS_WIDTH_8 case, current code missed setting BM_EIGHTBIT_MODE bit. Also has a small refactor to make the code looks better in readability. So the bit settings witch below logic: SDMMC_BUSMODE register: Set EIGHTBIT_MODE bit for 8 bit mode, Set FOURBIT_MODE bit for 4 bit mode. Clear both

Re: dw_mmc: priv->sdr_timing set wrong

2013-10-22 Thread Yuvaraj Kumar
On Tue, Oct 22, 2013 at 12:15 PM, Jaehoon Chung wrote: > Hi Grant, > > Good catch..sdr-timing is set to wrong value.(set to ddr-timing) > Do you have the plan that send the fixing patch at mailing? Oops.. Grant, Thanks for pointing out this.I will prepare the fix and send soon. > > Best Regards, >

RE: [PATCH] mmc: sdhci-pci: identify correct base addresses for slots

2013-10-22 Thread Shen, Jackey
Hi Chris, Do you have any comments on this patch? Thanks, Jackey -Original Message- From: Jackey Shen [mailto:jackey.s...@amd.com] Sent: Monday, July 01, 2013 5:22 PM To: linux-mmc@vger.kernel.org Cc: Shen, Jackey Subject: [PATCH] mmc: sdhci-pci: identify correct base addresses for slot