[PATCH v2 3/8] mmc: dw_mmc: replace the bus_hz checking point

2014-01-28 Thread Jaehoon Chung
It's right that check immediately whether host-bus_hz is assigned or not. If drv_data-setup_clock is presented, then host-bus_hz should be set at there. When setup_clock didn't present, assigned to value with clk_get_rate(). Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2:

[PATCH v2 0/8] mmc: dw_mmc: minor code cleanup

2014-01-28 Thread Jaehoon Chung
This patch-set is minor code cleanup. Change-log V2: - Add the new patch(mmc: core use the broken-cd for non-removable card - Change the name of hs200 property. - Based on latest mmc-next. Jaehoon Chung (8): mmc: core add the property for hs200 mmc: dw_mmc: use the

[PATCH v2 2/8] mmc: dw_mmc: use the mmc_of_parse() instead of local parser

2014-01-28 Thread Jaehoon Chung
mmc_of_parse() have been already parsed the general capability. Didn't need to use the local parser. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None drivers/mmc/core/host.c |4 ++-- drivers/mmc/host/dw_mmc.c | 49

[PATCH v2 5/8] mmc: dw-mmc: fix minor coding style.

2014-01-28 Thread Jaehoon Chung
Fixed the coding style. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None drivers/mmc/host/dw_mmc.c |5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/mmc/host/dw_mmc.c b/drivers/mmc/host/dw_mmc.c index fed82da..2cdfccb 100644

[PATCH v2 7/8] mmc: dw_mmc: remove the dw_mci_of_cd_gpio()

2014-01-28 Thread Jaehoon Chung
If mmc_of_parse() is used, dw_mci_of_get_cd_gpio didn't need. Already implemented into mmc_of_parse(). Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- drivers/mmc/host/dw_mmc.c | 26 -- 1 file changed, 26 deletions(-) diff --git a/drivers/mmc/host/dw_mmc.c

[PATCH v2 6/8] mmc: dw_mmc: remove the unnecessary function.

2014-01-28 Thread Jaehoon Chung
Remove unnecessary function. This function didn't re-use anywhere. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None drivers/mmc/host/dw_mmc.c |8 +--- 1 file changed, 1 insertion(+), 7 deletions(-) diff --git a/drivers/mmc/host/dw_mmc.c

[PATCH v2 4/8] mmc: dw_mmc: remove unused member variable.

2014-01-28 Thread Jaehoon Chung
Since using the device-tree, didn't use the callback pointer. So removed the unused callback pointer. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None drivers/mmc/host/dw_mmc.c | 33 +++-- include/linux/mmc/dw_mmc.h | 14

[PATCH v2 8/8] mmc: core: use the broken-cd for non-removable card

2014-01-28 Thread Jaehoon Chung
Some SoC is used the broken card-detection. And it should be also used the non-removable. Even if card is non-removable, it didn't always use the cd-gpio. If it's used only broken-cd, then card-detect interrupt is polling. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com ---

[PATCH RESEND] mmc: Allow forward compatibility for e⋅MMC

2014-01-28 Thread Romain Izard
As stated by the e⋅MMC 5.0 specification, a chip should not be rejected only because of the revision stated in the EXT_CSD_REV field of the EXT_CSD register. Remove the control on this value, the control of the CSD_STRUCTURE field should be sufficient to reject future incompatible changes.

Re: [PATCH 1/3] mmc: add support for power-on sequencing through DT

2014-01-28 Thread Ulf Hansson
On 28 January 2014 01:59, Tomasz Figa tomasz.f...@gmail.com wrote: On 27.01.2014 11:19, Ulf Hansson wrote: On 26 January 2014 18:26, Tomasz Figa tomasz.f...@gmail.com wrote: On 21.01.2014 19:34, Tomasz Figa wrote: Hi, On 20.01.2014 04:56, Olof Johansson wrote: This patch enables

Re: [PATCH v2 1/8] mmc: core add the property for hs200

2014-01-28 Thread Ulf Hansson
On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: mmc-hs200-1.8v and mmc-hs200-1.2v can be used to the general capability. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - Rename the mmc-hs200-1_8v/1_2v instead of _caps2_ - Add the

Re: [PATCH v2 1/8] mmc: core add the property for hs200

2014-01-28 Thread Jaehoon Chung
Dear, Ulf. On 01/28/2014 07:17 PM, Ulf Hansson wrote: On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: mmc-hs200-1.8v and mmc-hs200-1.2v can be used to the general capability. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - Rename the

Re: [PATCH v2 1/8] mmc: core add the property for hs200

2014-01-28 Thread Ulf Hansson
On 28 January 2014 11:30, Jaehoon Chung jh80.ch...@samsung.com wrote: Dear, Ulf. On 01/28/2014 07:17 PM, Ulf Hansson wrote: On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: mmc-hs200-1.8v and mmc-hs200-1.2v can be used to the general capability. Signed-off-by: Jaehoon

Re: [PATCH v2 8/8] mmc: core: use the broken-cd for non-removable card

2014-01-28 Thread Jaehoon Chung
Dear, Ulf. On 01/28/2014 07:32 PM, Ulf Hansson wrote: On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: Some SoC is used the broken card-detection. And it should be also used the non-removable. Even if card is non-removable, it didn't always use the cd-gpio. If it's used

[PATCH] mmc: core: Prevent unexpected SD Clock gating during Signal Voltage Switch Procedure

2014-01-28 Thread Vincent Yang
When switching the signal voltage from 3.3V to 1.8V, there should be only one SD Clock gating and un-gating operation. Between them the SD host controller should switch signal level to 1.8V. However, sometimes there is an additional gating and un-gating operation immediately after CMD11. This

Re: [PATCH] mmc: core: Prevent unexpected SD Clock gating during Signal Voltage Switch Procedure

2014-01-28 Thread Ulf Hansson
On 28 January 2014 11:50, Vincent Yang vincent.yang.fuji...@gmail.com wrote: When switching the signal voltage from 3.3V to 1.8V, there should be only one SD Clock gating and un-gating operation. Between them the SD host controller should switch signal level to 1.8V. However, sometimes there

Re: [PATCH v2 8/8] mmc: core: use the broken-cd for non-removable card

2014-01-28 Thread Ulf Hansson
On 28 January 2014 11:51, Jaehoon Chung jh80.ch...@samsung.com wrote: Dear, Ulf. On 01/28/2014 07:32 PM, Ulf Hansson wrote: On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: Some SoC is used the broken card-detection. And it should be also used the non-removable. Even if

Re: [PATCH 04/10] mmc: core: Fixup busy detection for mmc switch operations

2014-01-28 Thread Ulf Hansson
On 27 January 2014 11:40, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 16:11, Ulf Hansson wrote: On 23 January 2014 11:10, Adrian Hunter adrian.hun...@intel.com wrote: On 22/01/14 17:00, Ulf Hansson wrote: If the host controller supports busy detection in HW, we expect the

Re: [PATCH 08/10] mmc: card: Use R1 response for the stop cmd at recovery path

2014-01-28 Thread Ulf Hansson
On 27 January 2014 11:40, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 16:59, Ulf Hansson wrote: On 23 January 2014 15:29, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 15:21, Ulf Hansson wrote: On 23 January 2014 11:09, Adrian Hunter adrian.hun...@intel.com wrote: On

Re: [PATCH 06/10] mmc: core: Respect host's max_busy_timeout when sending sleep cmd

2014-01-28 Thread Ulf Hansson
On 27 January 2014 11:46, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 16:26, Ulf Hansson wrote: On 23 January 2014 11:23, Adrian Hunter adrian.hun...@intel.com wrote: On 22/01/14 17:00, Ulf Hansson wrote: When sending the sleep command for host drivers supporting

RE: [PATCH v2 1/8] mmc: core add the property for hs200

2014-01-28 Thread Seungwon Jeon
On Tuesday, January 28, 2014, Jaehoon Chung wrote: mmc-hs200-1.8v and mmc-hs200-1.2v can be used to the general capability. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - Rename the mmc-hs200-1_8v/1_2v instead of _caps2_ - Add the properties into

RE: [PATCH v2 2/8] mmc: dw_mmc: use the mmc_of_parse() instead of local parser

2014-01-28 Thread Seungwon Jeon
On Tue, January 28, 2014, Jaehoon Chung wrote: mmc_of_parse() have been already parsed the general capability. Didn't need to use the local parser. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None drivers/mmc/core/host.c |4 ++--

RE: [PATCH v2 3/8] mmc: dw_mmc: replace the bus_hz checking point

2014-01-28 Thread Seungwon Jeon
On Tue, January 28, 2014, Jaehoon Chung wrote: It's right that check immediately whether host-bus_hz is assigned or not. If drv_data-setup_clock is presented, then host-bus_hz should be set at there. When setup_clock didn't present, assigned to value with clk_get_rate(). Signed-off-by:

RE: [PATCH 4/7] mmc: sh_mmcif: clarify DDR timing mode between SD-UHS and eMMC

2014-01-28 Thread Seungwon Jeon
Hi Guennadi, Do you have any idea for this change? Could you check? Thanks, Seungwon Jeon On Fri, January 17, 2014, Seungwon Jeon wrote: On Thu, January 16, 2014, Ulf Hansson wrote: On 15 January 2014 15:12, Seungwon Jeon tgih@samsung.com wrote: Replaced UHS_DDR50 with MMC_DDR52.

Re: [PATCH 08/10] mmc: card: Use R1 response for the stop cmd at recovery path

2014-01-28 Thread Adrian Hunter
On 28/01/14 14:39, Ulf Hansson wrote: On 27 January 2014 11:40, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 16:59, Ulf Hansson wrote: On 23 January 2014 15:29, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 15:21, Ulf Hansson wrote: On 23 January 2014 11:09, Adrian

Re: mmc: sh_mobile_sdhi: DT update for R-Car

2014-01-28 Thread Sergei Shtylyov
Hello. On 01/28/2014 07:44 AM, Kuninori Morimoto wrote: Hi Chris These patches updates code for R-Car. Basically, these clarifies chip dependent settings inside driver, and, removed unneeded settings from dtsi file. These are based on latest linus/master branch

Re: [PATCH 08/10] mmc: card: Use R1 response for the stop cmd at recovery path

2014-01-28 Thread Ulf Hansson
On 28 January 2014 15:45, Adrian Hunter adrian.hun...@intel.com wrote: On 28/01/14 14:39, Ulf Hansson wrote: On 27 January 2014 11:40, Adrian Hunter adrian.hun...@intel.com wrote: On 23/01/14 16:59, Ulf Hansson wrote: On 23 January 2014 15:29, Adrian Hunter adrian.hun...@intel.com wrote: On

Re: [PATCH v2 2/8] mmc: dw_mmc: use the mmc_of_parse() instead of local parser

2014-01-28 Thread Jaehoon Chung
On 01/28/2014 09:53 PM, Seungwon Jeon wrote: On Tue, January 28, 2014, Jaehoon Chung wrote: mmc_of_parse() have been already parsed the general capability. Didn't need to use the local parser. Signed-off-by: Jaehoon Chung jh80.ch...@samsung.com --- Changelog V2: - None

Re: [PATCH v2 3/8] mmc: dw_mmc: replace the bus_hz checking point

2014-01-28 Thread Jaehoon Chung
Hi Seungwon, Thanks for review. On 01/28/2014 09:54 PM, Seungwon Jeon wrote: On Tue, January 28, 2014, Jaehoon Chung wrote: It's right that check immediately whether host-bus_hz is assigned or not. If drv_data-setup_clock is presented, then host-bus_hz should be set at there. When

Re: [PATCH v2 8/8] mmc: core: use the broken-cd for non-removable card

2014-01-28 Thread Jaehoon Chung
On 01/28/2014 08:21 PM, Ulf Hansson wrote: On 28 January 2014 11:51, Jaehoon Chung jh80.ch...@samsung.com wrote: Dear, Ulf. On 01/28/2014 07:32 PM, Ulf Hansson wrote: On 28 January 2014 09:24, Jaehoon Chung jh80.ch...@samsung.com wrote: Some SoC is used the broken card-detection. And it

Re: mmc: sh_mobile_sdhi: DT update for R-Car

2014-01-28 Thread Kuninori Morimoto
Hi Sergei, Chris Thank you for your review Kuninori Morimoto (4): mmc: SDHI: tidyup sh_mobile_sdhi_of_match position mmc: SDHI: updata sh_mobile_sdhi_of_data for r8a7778 mmc: SDHI: updata sh_mobile_sdhi_of_data for r8a7779 mmc: SDHI: updata

Re: [PATCH v2] mmc-utils: add eMMC 5.0 FFU support

2014-01-28 Thread Chris Ball
Hi Grant, still one warning/error left: On Thu, Jan 23 2014, Grant Grundler wrote: V2: Fix compiler borkage in use of strncmp(). Use '\0' instead of 0 in char assignment. λ make cc -Wall -Werror -Wuninitialized -Wundef -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2 -g -O2