Re: [PATCH] mmc: core: Remove MMC_CLKGATE

2015-10-12 Thread Ritesh Harjani
Hi Ulf, Wanted to understand this better, related to clk-gating and runtime-PM before we completely remove clk-gating functionality. Inline queries - On Thu, Oct 8, 2015 at 11:05 PM, Ulf Hansson wrote: > On 2 October 2015 at 10:56, Ulf Hansson

Re: mmc_test.ko usage

2015-10-12 Thread Sheetal
On Monday 12 October 2015 11:25 AM, Muni Sekhar wrote: Hi , I tried to use the MMC host test driver (mmc_test.ko) for testing SD Host controller hardware. When I load the driver I noticed that mmc_test_probe() not getting called. Could anyone specify the exact usage of mmc_test.ko? Hello

Re: mmc_test.ko usage

2015-10-12 Thread Sheetal
On Monday 12 October 2015 12:11 PM, Muni Sekhar wrote: On Mon, Oct 12, 2015 at 11:40 AM, Sheetal wrote: On Monday 12 October 2015 11:25 AM, Muni Sekhar wrote: Hi , I tried to use the MMC host test driver (mmc_test.ko) for testing SD Host controller hardware.

[PATCH v3] mmc: core: Fix init_card in 52Mhz

2015-10-12 Thread Chaotian Jing
Suppose that we got a data crc error, and it triggers the mmc_reset. mmc_reset will call mmc_send_status to see if HW reset was supported. before issue CMD13, it will do retune, and if EMMC was in HS400 mode, it will reduce frequency to 52Mhz firstly, then results in card init was doing at 52Mhz.

Re: [PATCH] mmc: core: Remove MMC_CLKGATE

2015-10-12 Thread Ulf Hansson
On 12 October 2015 at 09:53, Ritesh Harjani wrote: > Hi Ulf, > > Wanted to understand this better, related to clk-gating and runtime-PM > before we completely remove clk-gating functionality. > Inline queries - > > > On Thu, Oct 8, 2015 at 11:05 PM, Ulf Hansson

[PATCH v3.1 1/7] mmc: core: move ocr-bit to voltage translation into separate function

2015-10-12 Thread Heiko Stübner
We will shortly need the calculation of an ocr-bit to the actual voltage in a second place too, so move it from mmc_regulator_set_ocr to a common function mmc_ocrbitnum_to_vdd to make that possible. Signed-off-by: Heiko Stuebner --- changes since v3: - move mmc_ocrbitnum_to_vdd

Re: mmc_test.ko usage

2015-10-12 Thread Muni Sekhar
On Mon, Oct 12, 2015 at 11:40 AM, Sheetal wrote: > > On Monday 12 October 2015 11:25 AM, Muni Sekhar wrote: >> >> Hi , >> >> >> I tried to use the MMC host test driver (mmc_test.ko) for testing SD >> Host controller hardware. When I load the driver I noticed that >>

[PATCH v3 2/7] mmc: core: Add mmc_regulator_set_vqmmc()

2015-10-12 Thread Heiko Stuebner
From: Douglas Anderson This adds logic to the MMC core to set VQMMC. This is expected to be called by MMC drivers like dw_mmc as part of (or instead of) their start_signal_voltage_switch() callback. A few notes: * When setting the signal voltage to 3.3V we do our best

[PATCH v3 7/7] ARM: dts: rockchip: add tuning related settings to veyron devices

2015-10-12 Thread Heiko Stuebner
This allows the tuning code to run and use higher speeds on capable cards. Signed-off-by: Heiko Stuebner --- arch/arm/boot/dts/rk3288-veyron-sdmmc.dtsi | 7 ++- arch/arm/boot/dts/rk3288-veyron.dtsi | 6 ++ 2 files changed, 12 insertions(+), 1 deletion(-) diff

[PATCH v3 4/7] mmc: dw_mmc-rockchip: dt-binding: Add tuning related things

2015-10-12 Thread Heiko Stuebner
From: Alexandru M Stan Add ciu_drive, ciu_sample clocks and default-sample-phase. This will later be used by tuning code. We do not touch ciu_drive (and by extension define default-drive-phase). Drive phase is mostly used to define minimum hold times, while one could write

[PATCH v3 6/7] ARM: dts: rockchip: Add drive/sample clocks for rk3288 dw_mmc devices

2015-10-12 Thread Heiko Stuebner
From: Alexandru M Stan The drive/sample clocks can be phase shifted. The drive clock could be used in a future patch to adjust hold times. The sample clock is used for tuning. Signed-off-by: Alexandru M Stan Signed-off-by: Heiko Stuebner

[PATCH v3 1/7] mmc: core: move ocr-bit to voltage translation into separate function

2015-10-12 Thread Heiko Stuebner
We will shortly need the calculation of an ocr-bit to the actual voltage in a second place too, so move it from mmc_regulator_set_ocr to a common function mmc_ocrbitnum_to_vdd to make that possible. Signed-off-by: Heiko Stuebner --- drivers/mmc/core/core.c | 51

[PATCH v3 0/7] mmc: dw_mmc-rockchip: allow tuning using the clk-phase api

2015-10-12 Thread Heiko Stuebner
This series resurrects and adapts some individual patches whose sum enable the dw_mmc hosts on Rockchip socs to tune clock phases using the generic phase api (rk3288 and following have this capability). The changes to the original mmc-phase clocks are expanded by further findings resulting from

[PATCH v3 5/7] mmc: dw_mmc-rockchip: MMC tuning with the clock phase framework

2015-10-12 Thread Heiko Stuebner
From: Alexandru M Stan This algorithm will try 1 degree increments, since there's no way to tell what resolution the underlying phase code uses. As an added bonus, doing many tunings yields better results since some tests are run more than once (ex: if the underlying driver

[PATCH v3 3/7] mmc: dw_mmc: Use mmc_regulator_set_vqmmc in start_signal_voltage_switch

2015-10-12 Thread Heiko Stuebner
From: Douglas Anderson We've introduced a new helper in the MMC core: mmc_regulator_set_vqmmc(). Let's use this in dw_mmc. Using this new helper has some advantages: 1. We get the mmc_regulator_set_vqmmc() behavior of trying to match VQMMC and VMMC when the signal

Re: [PATCH v3 1/7] mmc: core: move ocr-bit to voltage translation into separate function

2015-10-12 Thread Heiko Stübner
bner/mmc-dw_mmc-rockchip > -allow-tuning-using-the-clk-phase-api/20151012-205613 config: > x86_64-randconfig-x011-10121751 (attached as .config) > reproduce: > # save the attached .config to linux build tree > make ARCH=x86_64 > > All warnings (new ones prefixed by &g

Re: [PATCH v3 1/7] mmc: core: move ocr-bit to voltage translation into separate function

2015-10-12 Thread kbuild test robot
Hi Heiko, [auto build test WARNING on rockchip/for-next -- if it's inappropriate base, please suggest rules for selecting the more suitable base] url: https://github.com/0day-ci/linux/commits/Heiko-Stuebner/mmc-dw_mmc-rockchip-allow-tuning-using-the-clk-phase-api/20151012-205613 config

[PATCH v2] mmc: core: Allow specifying current consumption

2015-10-12 Thread Bjorn Andersson
This allows us to specify expected current consumption of the vmmc and vqmmc regulators. This is needed to bring the supplying regulators out of their low-power-mode while accessing the mmc. Signed-off-by: Bjorn Andersson --- The sd specification states that if

[PATCH] mmc: omap_hsmmc: fix initialization order of mmc block devices

2015-10-12 Thread Heiko Schocher
On embedded devices, often there is a combination of removable mmc devices (e.g. MMC/SD cards) and hard wired ones (e.g. eMMC). Depending on the hardware configuration, the 'mmcblkN' node might change if the removable device is available or not at boot time. E.g. if the removable device is