Re: [PATCH] mmc: sdhci-bcm-kona: Fix locking in sdhci_bcm_kona_sd_card_emulate()

2014-03-19 Thread Christian Daudt
On Wed, Mar 5, 2014 at 8:25 PM, Markus Mayer wrote: > Since sdhci_bcm_kona_sd_card_emulate() can be called from interrupt > context, we must use a spinlock instead of a mutex. This change > essentially restores the way things worked before the change to > mutexes in http://www.spinics.net/lists/li

Re: [PATCH v4 5/8] mmc: sdhci-bcm-kona: Add basic use of clocks

2013-12-23 Thread Christian Daudt
On Sat, Dec 14, 2013 at 12:14 AM, Christian Daudt wrote: > On Thu, Dec 5, 2013 at 11:20 AM, Tim Kryger wrote: >> Enable the external clock needed by the host controller during the >> probe and disable it during the remove. >> >> Signed-off-by: Tim Kryger &

Re: [PATCH v4 7/8] clocksource: kona: Add basic use of external clock

2013-12-14 Thread Christian Daudt
On Thu, Dec 5, 2013 at 11:20 AM, Tim Kryger wrote: > When an clock is specified in the device tree, enable it and use it to > determine the external clock frequency. > > Signed-off-by: Tim Kryger > Reviewed-by: Markus Mayer > Reviewed-by: Matt Porter > --- Reviewe

Re: [PATCH v4 6/8] Documentation: dt: kona-timer: Add clocks property

2013-12-14 Thread Christian Daudt
>; > - clock-frequency = <32768>; > + clocks = <&hub_timer_clk>; > }; > > -- > 1.8.0.1 > Reviewed-by: Christian Daudt -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v4 5/8] mmc: sdhci-bcm-kona: Add basic use of clocks

2013-12-14 Thread Christian Daudt
On Thu, Dec 5, 2013 at 11:20 AM, Tim Kryger wrote: > Enable the external clock needed by the host controller during the > probe and disable it during the remove. > > Signed-off-by: Tim Kryger > Reviewed-by: Markus Mayer > Reviewed-by: Matt Porter Reviewed-by: Christian Daudt

Re: [PATCH v2 3/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mmc)

2013-12-13 Thread Christian Daudt
On Mon, Sep 23, 2013 at 10:20 AM, Christian Daudt wrote: > Currently ARCH_BCM has been used for Broadcom > Mobile V7 based SoCs. In order to allow other Broadcom > SoCs to also use mach-bcm directory and files, this patch > renames the original ARCH_BCM to ARCH_BCM_MOBILE, and > u

Re: [PATCH v2 2/4] rename ARCH_BCM to ARCH_BCM_MOBILE (clocksource)

2013-12-13 Thread Christian Daudt
On Fri, Dec 13, 2013 at 12:48 AM, Daniel Lezcano wrote: > On 09/23/2013 07:20 PM, Christian Daudt wrote: >> >> Currently ARCH_BCM has been used for Broadcom >> Mobile V7 based SoCs. In order to allow other Broadcom >> SoCs to also use mach-bcm directory and files

Re: [PATCH v4 4/8] ARM: dts: Specify clocks for SDHCIs on bcm11351

2013-12-13 Thread Christian Daudt
,kona-sdhci"; > reg = <0x3f1a 0x1>; > interrupts = ; > + clocks = <&sdio3_clk>; > status = "disabled"; > }; > > @@ -139,6 +142,7 @@ > compatible = "b

Re: [PATCH v4 8/8] ARM: dts: Specify clocks for timer on bcm11351

2013-12-13 Thread Christian Daudt
timer"; > reg = <0x35006000 0x1000>; > interrupts = ; > - clock-frequency = <32768>; > + clocks = <&hub_timer_clk>; > }; > > gpio: gpio@35003000 { > -- > 1.8.0.1 > R

Re: [PATCH v4 3/8] Documentation: dt: kona-sdhci: Add clocks property

2013-12-13 Thread Christian Daudt
;0x3f1a 0x10000>; > + clocks = <&sdio3_clk>; > interrupts = <0x0 74 0x4>; > }; > > -- > 1.8.0.1 > Reviewed-by: Christian Daudt -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH v4 2/8] ARM: dts: Specify clocks for UARTs on bcm11351

2013-12-12 Thread Christian Daudt
y = <1300>; > + clocks = <&uartb3_clk>; > interrupts = ; > reg-shift = <2>; > reg-io-width = <4>; > @@ -73,7 +73,7 @@ > compatible = "brcm,bcm11351-dw-apb-uart", "snps,dw

Re: [PATCH v4 1/8] ARM: dts: Declare clocks as fixed on bcm11351

2013-12-12 Thread Christian Daudt
On Tue, Dec 10, 2013 at 12:26 PM, Tim Kryger wrote: > On Mon, Dec 9, 2013 at 11:18 PM, Christian Daudt wrote: >> Applied to armsoc/for-3.14/dt > > Could you wait till other maintainers provide their acks and then take > the entire series into a branch that feeds into the arm

Re: [PATCH v4 1/8] ARM: dts: Declare clocks as fixed on bcm11351

2013-12-09 Thread Christian Daudt
Applied to armsoc/for-3.14/dt thanks, csd On Thu, Dec 5, 2013 at 11:20 AM, Tim Kryger wrote: > Declare clocks that are enabled and configured by bootloaders as fixed > rate clocks in the DTS such that device drivers may use standard clock > function calls. > > Signed-off-by: Tim Kryger > R

Re: [RESEND PATCH v2 1/6] ARM: dts: Declare clocks as fixed on bcm11351

2013-11-08 Thread Christian Daudt
I can pick up the dt related changes as long as the other code works as-is both with and without the change (i.e. no backwards/forwards compatibility issues). If this must be introduced alongside the other changes, then the patches will have to be reworked to break them up by subtree so they can go

Re: [PATCH v2 1/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mach-bcm)

2013-10-29 Thread Christian Daudt
On Mon, Oct 28, 2013 at 1:38 PM, Olof Johansson wrote: > On Mon, Sep 23, 2013 at 10:20 AM, Christian Daudt wrote: >> --- a/arch/arm/mach-bcm/Kconfig >> +++ b/arch/arm/mach-bcm/Kconfig >> @@ -1,5 +1,17 @@ >> config ARCH_BCM >> - bool "Broadcom

Re: [RESEND PATCH v2 2/6] ARM: dts: Specify clocks for UARTs on bcm11351

2013-10-16 Thread Christian Daudt
On Wed, Oct 16, 2013 at 2:47 PM, Tim Kryger wrote: > Rather than declaring the frequency of the external clock, specify the > label of the clock such that the driver may determine the frequency on > its own. > > Signed-off-by: Tim Kryger > Reviewed-by: Markus Mayer > Reviewed-by: Matt Porter >

[PATCH v2 2/4] rename ARCH_BCM to ARCH_BCM_MOBILE (clocksource)

2013-09-23 Thread Christian Daudt
-by: Christian Daudt Acked-by: Olof Johansson Changes from v1: - fix alpha ordering in dts/Makefile - break into 4 patches for separate subsys diff --git a/drivers/clocksource/Makefile b/drivers/clocksource/Makefile index 704d6d3..4207ab4 100644 --- a/drivers/clocksource/Makefile +++ b/drivers

[PATCH v2 4/4] rename ARCH_BCM to ARCH_BCM_MOBILE (dt)

2013-09-23 Thread Christian Daudt
-by: Christian Daudt Acked-by: Olof Johansson Changes from v1: - fix alpha ordering in dts/Makefile - break into 4 patches for separate subsys diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile index cc0f1fb..2b07eb8 100644 --- a/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot

[PATCH v2 1/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mach-bcm)

2013-09-23 Thread Christian Daudt
-by: Christian Daudt Acked-by: Olof Johansson Changes from v1: - fix alpha ordering in dts/Makefile - break into 4 patches for separate subsys diff --git a/arch/arm/configs/bcm_defconfig b/arch/arm/configs/bcm_defconfig index 6e49310..efb0132 100644 --- a/arch/arm/configs/bcm_defconfig +++ b

[PATCH v2 3/4] rename ARCH_BCM to ARCH_BCM_MOBILE (mmc)

2013-09-23 Thread Christian Daudt
-by: Christian Daudt Acked-by: Olof Johansson Changes from v1: - fix alpha ordering in dts/Makefile - break into 4 patches for separate subsys diff --git a/drivers/mmc/host/Kconfig b/drivers/mmc/host/Kconfig index 7fc5099..7e89650 100644 --- a/drivers/mmc/host/Kconfig +++ b/drivers/mmc/host

[PATCH v2 0/4] ARCH_BCM rename

2013-09-23 Thread Christian Daudt
(multiplatform) Mobile SoCs. Christian Daudt (4): rename ARCH_BCM to ARCH_BCM_MOBILE (mach-bcm) rename ARCH_BCM to ARCH_BCM_MOBILE (clocksource) rename ARCH_BCM to ARCH_BCM_MOBILE (mmc) rename ARCH_BCM to ARCH_BCM_MOBILE (dt) arch/arm/boot/dts/Makefile |4 ++-- arch/arm/configs

Re: [PATCH] rename ARCH_BCM to ARCH_BCM_MOBILE

2013-09-21 Thread Christian Daudt
[plain-text resend] On Fri, Sep 20, 2013 at 5:23 PM, Olof Johansson wrote: > > On Fri, Sep 20, 2013 at 4:04 PM, Christian Daudt wrote: > > Currently ARCH_BCM has been used for Broadcom > > Mobile V7 based SoCs. In order to allow other Broadcom > > SoCs to also use mach

[PATCH] rename ARCH_BCM to ARCH_BCM_MOBILE

2013-09-20 Thread Christian Daudt
-by: Christian Daudt diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile index cc0f1fb..dd00e22 100644 --- a/arch/arm/boot/dts/Makefile +++ b/arch/arm/boot/dts/Makefile @@ -42,8 +42,6 @@ dtb-$(CONFIG_ARCH_AT91) += sama5d34ek.dtb dtb-$(CONFIG_ARCH_AT91

Re: [PATCH 1/2] mmc: sdhci-bcm-kona: Use sdhci_pltfm_unregister instead of open coded

2013-09-20 Thread Christian Daudt
ver sdhci_bcm_kona_driver = { Acked-by: Christian Daudt Thanks ! csd -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 1/3] mmc: sdhci-bcm-kona: Remove unneeded version.h inclusion

2013-08-22 Thread Christian Daudt
On 13-08-21 11:07 PM, Sachin Kamat wrote: On 20 July 2013 02:01, Christian Daudt wrote: On 13-07-07 11:11 PM, Sachin Kamat wrote: version.h header inclusion is not necessary as detected by versioncheck. Signed-off-by: Sachin Kamat --- drivers/mmc/host/sdhci-bcm-kona.c |1 - 1 file

RE: [patch] mmc: sdhci-bcm-kona: '|' vs '&' typo

2013-08-21 Thread Christian Daudt
- From: Dan Carpenter [mailto:dan.carpen...@oracle.com] Sent: Wednesday, August 21, 2013 1:24 AM To: Chris Ball Cc: Grant Likely; Rob Herring; Christian Daudt; Arnd Bergmann; linux-mmc@vger.kernel.org; devicet...@vger.kernel.org; kernel-janit...@vger.kernel.org Subject: [patch] mmc: sdhc

Re: [PATCH] mmc: change mmc_gpio_get_cd to call non-sleep gpio

2013-08-19 Thread Christian Daudt
On 13-08-08 02:10 PM, Christian Daudt wrote: On 13-08-08 02:06 PM, Guennadi Liakhovetski wrote: On Thu, 8 Aug 2013, Christian Daudt wrote: Given that mmc_gpio_get_cd can be called in softirq context (by sdhci_tasklet_card -> sdhci_card_event -> sdhci_do_get_cd -> mmc_gpio_get_cd

Re: [PATCH] ARM: mmc: fix NONREMOVABLE test in sdhci-bcm-kona

2013-08-19 Thread Christian Daudt
On 13-08-07 11:59 AM, Christian Daudt wrote: sdhci-bcm-kona driver is incorrectly doing "|" to bit-test NONREMOVABLE. Switch to "&" Reviewed-by: Markus Mayer Reviewed-by: Matt Porter Signed-off-by: Christian Daudt diff --git a/drivers/mmc/host/sdhci-bcm-kona.c b/dr

Re: [PATCH] mmc: sdhci-bcm-kona: make linker-section warning go away

2013-08-19 Thread Christian Daudt
TCH=y' Signed-off-by: Markus Mayer Reviewed-by: Christian Daudt Reviewed-by: Matt Porter --- drivers/mmc/host/sdhci-bcm-kona.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/mmc/host/sdhci-bcm-kona.c b/drivers/mmc/host/sdhci-bcm-kona.c index 87175f

Re: [PATCH] mmc: change mmc_gpio_get_cd to call non-sleep gpio

2013-08-08 Thread Christian Daudt
On 13-08-08 02:06 PM, Guennadi Liakhovetski wrote: On Thu, 8 Aug 2013, Christian Daudt wrote: Given that mmc_gpio_get_cd can be called in softirq context (by sdhci_tasklet_card -> sdhci_card_event -> sdhci_do_get_cd -> mmc_gpio_get_cd ), it is necessary for it to use gpio_get_value i

[PATCH] mmc: change mmc_gpio_get_cd to call non-sleep gpio

2013-08-08 Thread Christian Daudt
d related callbacks are aligned with the actual cd detection code. I can submit a follow-up patch with these mods if that sounds like a better way to solve this. Signed-off-by: Christian Daudt diff --git a/drivers/mmc/core/slot-gpio.c b/drivers/mmc/core/slot-gpio.c index 3242351..897b298 100644 --- a/dr

[PATCH] ARM: mmc: fix NONREMOVABLE test in sdhci-bcm-kona

2013-08-07 Thread Christian Daudt
sdhci-bcm-kona driver is incorrectly doing "|" to bit-test NONREMOVABLE. Switch to "&" Reviewed-by: Markus Mayer Reviewed-by: Matt Porter Signed-off-by: Christian Daudt diff --git a/drivers/mmc/host/sdhci-bcm-kona.c b/drivers/mmc/host/sdhci-bcm-kona.c index 87175

Re: [PATCH 1/3] mmc: sdhci-bcm-kona: Remove unneeded version.h inclusion

2013-07-19 Thread Christian Daudt
/sdhci-bcm-kona.c index 87175f9..bca6d55 100644 --- a/drivers/mmc/host/sdhci-bcm-kona.c +++ b/drivers/mmc/host/sdhci-bcm-kona.c @@ -24,7 +24,6 @@ #include #include #include -#include #include #include "sdhci-pltfm.h" Acked-by: Christian Daudt thanks, csd -- To u

Re: [PATCH 3/3] mmc: sdhci-bcm-kona: Staticize sdhci_bcm_kona_card_event

2013-07-19 Thread Christian Daudt
sdhci_bcm_kona_card_event(struct sdhci_host *host) +static void sdhci_bcm_kona_card_event(struct sdhci_host *host) { if (mmc_gpio_get_cd(host->mmc) > 0) { dev_dbg(mmc_dev(host->mmc), Acked-by: Christian Daudt thanks, csd -- To unsubscribe from this list:

Re: [PATCH 2/3] mmc: sdhci-bcm-kona: Remove redundant use of_match_ptr

2013-07-19 Thread Christian Daudt
= __exit_p(sdhci_bcm_kona_remove), Acked-by: Christian Daudt thanks, csd -- To unsubscribe from this list: send the line "unsubscribe linux-mmc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html

Re: [PATCH 1/1] mmc: sdhci-sirf: Fix build breakage

2013-06-21 Thread Christian Daudt
uild error: drivers/mmc/host/sdhci-sirf.c: In function ‘sdhci_sirf_probe’: drivers/mmc/host/sdhci-sirf.c:78:2: error: too few arguments to function ‘sdhci_pltfm_init’ host = sdhci_pltfm_init(pdev, &sdhci_sirf_pdata); Signed-off-by: Sachin Kamat Cc: Christian Daudt Cc: Barry Song --- Com

Re: [PATCH] mmc: sirf: fix sdhci_pltfm_init sequence

2013-06-11 Thread Christian Daudt
his changes the sirf driver to use the new interface, avoiding one warning, and simplifying the init sequence. Since we're here already, this also adds an error path for failed clk_prepare_enable. Signed-off-by: Arnd Bergmann Cc: Christian Daudt Cc: Barry Song Cc: Chris Ball This needs an

Re: [PATCH V2 1/2] ARM: mmc: bcm281xx SDHCI driver

2013-05-21 Thread Christian Daudt
Hi Arnd, Thanks for the review. See below for comments. On 13-05-16 03:09 PM, Arnd Bergmann wrote: On Friday 10 May 2013, Christian Daudt wrote: + +struct sdhci_bcm_kona_cfg { + unsigned intmax_freq; + int is_8bit; + int irq; + int

[PATCH V2 1/2] ARM: mmc: bcm281xx SDHCI driver

2013-05-10 Thread Christian Daudt
Signed-off-by: Christian Daudt diff --git a/arch/arm/configs/bcm_defconfig b/arch/arm/configs/bcm_defconfig index e3bf2d6..65edf6d 100644 --- a/arch/arm/configs/bcm_defconfig +++ b/arch/arm/configs/bcm_defconfig @@ -78,6 +78,13 @@ CONFIG_BACKLIGHT_LCD_SUPPORT=y CONFIG_LCD_CLASS_DEVICE=y

[PATCH V2 2/2] ARM: mmc: bcm281xx SDHCI driver (dt mods)

2013-05-10 Thread Christian Daudt
Add SDHCI driver for the Broadcom 281xx SoCs. Also add bindings for it into bcm281xx dts files. Changes from V1: - split original patch into 2, one for driver and this one for dt Signed-off-by: Christian Daudt diff --git a/Documentation/devicetree/bindings/mmc/bcm,kona-sdhci.txt b

Re: [PATCH] ARM: mmc: bcm281xx SDHCI driver

2013-05-10 Thread Christian Daudt
Thanks for the feedback. On 13-05-08 11:35 PM, Jean-Christophe PLAGNIOL-VILLARD wrote: On 22:55 Wed 08 May , Christian Daudt wrote: Add SDHCI driver for the Broadcom 281xx SoCs. Also add bindings for it into bcm281xx dts files. Still missing: - power managemement split the dts/dtsi in

Re: [PATCH] ARM: mmc: bcm281xx SDHCI driver

2013-05-10 Thread Christian Daudt
Thanks for the feedback. On 13-05-08 11:35 PM, Jean-Christophe PLAGNIOL-VILLARD wrote: On 22:55 Wed 08 May , Christian Daudt wrote: Add SDHCI driver for the Broadcom 281xx SoCs. Also add bindings for it into bcm281xx dts files. Still missing: - power managemement split the dts/dtsi in

Re: [PATCH] ARM: mmc: bcm281xx SDHCI driver

2013-05-10 Thread Christian Daudt
Thanks for the feedback. On 13-05-08 11:35 PM, Jean-Christophe PLAGNIOL-VILLARD wrote: On 22:55 Wed 08 May , Christian Daudt wrote: Add SDHCI driver for the Broadcom 281xx SoCs. Also add bindings for it into bcm281xx dts files. Still missing: - power managemement split the dts/dtsi in

[PATCH] ARM: mmc: bcm281xx SDHCI driver

2013-05-08 Thread Christian Daudt
Add SDHCI driver for the Broadcom 281xx SoCs. Also add bindings for it into bcm281xx dts files. Still missing: - power managemement Signed-off-by: Christian Daudt diff --git a/Documentation/devicetree/bindings/mmc/bcm,kona-sdhci.txt b/Documentation/devicetree/bindings/mmc/bcm,kona-sdhci.txt