Returned mail: Data format error

2018-04-27 Thread Automatic Email Delivery Software
The original message was received at Sat, 28 Apr 2018 11:06:14 +0800 from lists.01.org [176.93.34.168] - The following addresses had permanent fatal errors - - Transcript of session follows - while talking to lists.01.org.: >>> MAIL From:"Automatic

[PATCH v5 4/4] ndctl: convert dimm actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through of busses and dimms. Removing duplicate code for dimm actions and provide filter functions so we can utilize util_filter_walk() and share common code. Signed-off-by: Dave Jiang --- ndctl/dimm.c | 83

[PATCH v5 0/4] ndctl: convert actions to use util_filter_walk

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through bus/dimm/region/namespace that a lot of the operations in ndctl uses. Converting them to common code and reduce maintenance on individual versions of the same code. In this series we are convering namespace, region, and dimm actions. --- v5: - fix

[PATCH v5 1/4] ndctl: convert namespace actions to use util_filter_params

2018-04-27 Thread Dave Jiang
In preparation of moving to using util_filter_walk, moving parts of namespace params to util_filter_params. Signed-off-by: Dave Jiang --- ndctl/namespace.c | 41 - 1 file changed, 20 insertions(+), 21 deletions(-) diff --git

[PATCH v5 2/4] ndctl: convert namespace actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through of busses and regions. Removing duplicate code in namespace ops and provide filter functions so we can utilize util_filter_walk() and share common code. Signed-off-by: Dave Jiang --- ndctl/namespace.c | 163

[PATCH 1/3] nvdimm: fix typo in label-size definition

2018-04-27 Thread Ross Zwisler
Signed-off-by: Ross Zwisler Fixes: commit da6789c27c2e ("nvdimm: add a macro for property "label-size"") Cc: Haozhong Zhang Cc: Michael S. Tsirkin Cc: Stefan Hajnoczi --- hw/mem/nvdimm.c | 2

[PATCH 3/3] nvdimm: platform capabilities command line option

2018-04-27 Thread Ross Zwisler
Add a device command line option to allow the user to control the Platform Capabilities Structure in the virtualized NFIT. Signed-off-by: Ross Zwisler --- docs/nvdimm.txt | 22 ++ hw/acpi/nvdimm.c| 29

[PATCH 2/3] nvdimm, acpi: add NFIT platform capabilities

2018-04-27 Thread Ross Zwisler
Add support for the NFIT Platform Capabilities Structure, newly added in ACPI 6.2 Errata A. Signed-off-by: Ross Zwisler --- hw/acpi/nvdimm.c | 32 1 file changed, 32 insertions(+) diff --git a/hw/acpi/nvdimm.c b/hw/acpi/nvdimm.c

Re: [PATCH v4 2/4] ndctl: convert namespace actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
On 04/27/2018 12:25 PM, Dan Williams wrote: > On Fri, Apr 27, 2018 at 11:18 AM, Dave Jiang wrote: >> util_filter_walk() does the looping through of busses and regions. Removing >> duplicate code in namespace ops and provide filter functions so we can >> utilize

Re: [PATCH v4 2/4] ndctl: convert namespace actions to use util_filter_walk()

2018-04-27 Thread Dan Williams
On Fri, Apr 27, 2018 at 11:18 AM, Dave Jiang wrote: > util_filter_walk() does the looping through of busses and regions. Removing > duplicate code in namespace ops and provide filter functions so we can > utilize util_filter_walk() and share common code. > > Signed-off-by:

Re: [PATCH v3] dax: Change return type to vm_fault_t

2018-04-27 Thread David Rientjes
On Fri, 27 Apr 2018, Matthew Wilcox wrote: > > > Hi Matthew/ Ross, > > > > > > There are two changes exist in mm/huge_memory.c as part of this > > > patch. vmf_insert_pfn_pmd() and vmf_insert_pfn_pud() functions are > > > invoked from this patch. > > > > > > Shall we put both in a single patch

[PATCH v4 4/4] ndctl: convert dimm actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through of busses and dimms. Removing duplicate code for dimm actions and provide filter functions so we can utilize util_filter_walk() and share common code. Signed-off-by: Dave Jiang --- ndctl/dimm.c | 83

[PATCH v4 1/4] ndctl: convert namespace actions to use util_filter_params

2018-04-27 Thread Dave Jiang
In preparation of moving to using util_filter_walk, moving parts of namespace params to util_filter_params. Signed-off-by: Dave Jiang --- ndctl/namespace.c | 41 - 1 file changed, 20 insertions(+), 21 deletions(-) diff --git

[PATCH v4 2/4] ndctl: convert namespace actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through of busses and regions. Removing duplicate code in namespace ops and provide filter functions so we can utilize util_filter_walk() and share common code. Signed-off-by: Dave Jiang --- ndctl/namespace.c | 164

[PATCH v4 3/4] ndctl: convert region actions to use util_filter_walk()

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through of busses and regions. Removing duplicate code in region ops and provide filter functions so we can utilize util_filter_walk() and share common code. Signed-off-by: Dave Jiang --- ndctl/region.c | 59

[PATCH v4 0/4] ndctl: convert actions to use util_filter_walk

2018-04-27 Thread Dave Jiang
util_filter_walk() does the looping through bus/dimm/region/namespace that a lot of the operations in ndctl uses. Converting them to common code and reduce maintenance on individual versions of the same code. In this series we are convering namespace, region, and dimm actions. --- v4: - change

Re: [PATCH v3] dax: Change return type to vm_fault_t

2018-04-27 Thread Matthew Wilcox
On Fri, Apr 27, 2018 at 01:37:02AM -0700, David Rientjes wrote: > On Fri, 27 Apr 2018, Souptick Joarder wrote: > > > Hi Matthew/ Ross, > > > > There are two changes exist in mm/huge_memory.c as part of this > > patch. vmf_insert_pfn_pmd() and vmf_insert_pfn_pud() functions are > > invoked from

Re: [PATCH v3] dax: Change return type to vm_fault_t

2018-04-27 Thread David Rientjes
On Fri, 27 Apr 2018, Souptick Joarder wrote: > Hi Matthew/ Ross, > > There are two changes exist in mm/huge_memory.c as part of this > patch. vmf_insert_pfn_pmd() and vmf_insert_pfn_pud() functions are > invoked from this patch. > > Shall we put both in a single patch that it will easy to

Re: [PATCH v3] dax: Change return type to vm_fault_t

2018-04-27 Thread Souptick Joarder
Hi Matthew/ Ross, There are two changes exist in mm/huge_memory.c as part of this patch. vmf_insert_pfn_pmd() and vmf_insert_pfn_pud() functions are invoked from this patch. Shall we put both in a single patch that it will easy to bisect in case we have any issue ? On Tue, Apr 17, 2018 at 6:58