[PATCH] twl4030-usb: rename twl4030_driver to twl4030_usb_driver.

2008-10-13 Thread Jagadeesh Bhaskar Pakaravoor
The i2c_driver in twl4030-core.c and platform_driver of twl4030-usb.c both has the name twl4030_driver. This leads to unnecessary confusion. So rename the usb platform_driver appropriately to: twl4030_usb_driver. Signed-off-by: Jagadeesh Bhaskar Pakaravoor <[EMAIL PROTECTED]> Index: linux-omap-gi

[patch 2.6.27-omap-git+ 2/5] twl4030-gpio use new gpiolib hooks

2008-10-13 Thread David Brownell
From: David Brownell <[EMAIL PROTECTED]> Use the new gpiolib internal mechanism for tracking gpio usage, making them power the GPIO module on/off, so that the standard gpio_request()/gpio_free() calls can completely replace the twl4030-specific versions. Signed-off-by: David Brownell <[EMAIL PROT

[patch 2.6.27-omap-git+ 5/5] support LED signals on Beagle

2008-10-13 Thread David Brownell
From: David Brownell <[EMAIL PROTECTED]> Export Beagle's third LED to the LED framework, now that it's accessible through the twl4030-gpio code. Claim the VBUS control, defaulting to OFF. Boards that have an EHCI connector (not rev B) will need to update this slightly. (Ideally as part of adding

[patch 2.6.27-omap-git+ 4/5] twl4030-gpio supports LED signals

2008-10-13 Thread David Brownell
From: David Brownell <[EMAIL PROTECTED]> Expose the two TWL4030 LED signals as output-only GPIOs. Boards need to explicitly ask that this be done, to help avoid conflicts on boards using these same pins to hook up to a vibrator motor. Note that these are high drive open drain signals; LEDA is ra

[patch 2.6.27-omap-git+ 3/5] hsmmc.c glue uses standard GPIO calls

2008-10-13 Thread David Brownell
From: David Brownell <[EMAIL PROTECTED]> Convert the hsmmc init code over to standard GPIO calls: gpio_request(), gpio_free(), gpio_get_value_cansleep(). NOTE that this doesn't pass GPIO numbers in to hsmmc_init(); those values are still hard-wired. (For the write protect signal, the LACK of val

[patch 2.6.27-omap-git+ 1/5] gpiolib request/free hooks

2008-10-13 Thread David Brownell
From: David Brownell <[EMAIL PROTECTED]> Add a new internal mechanism to gpiolib to support low power operations by letting gpio_chip instances see when their GPIOs are in use. When no GPIOs are active, chips may be able to enter lower powered runtime states by disabling clocks and/or power doma

[patch 2.6.27-omap-git+ 0/5] twl4030 GPIO updates

2008-10-13 Thread David Brownell
Following this are several patches making the twl4030 GPIO code fit better into the GPIO framework, updating its only current user (hsmmc glue) and adding one more (Beagle). - gpio_request()/gpio_free() hook, now in MM for 2.6.28-rc merge - use that mechanism for twl4040 GPIOs - remove most twl

android on omap, yaffs2 or init problem

2008-10-13 Thread twebb
The issue I'm running into (see further below) in trying to start android on an OMAP is a dalvikvm-gc error during an ashmem allocation immediately at startup. An older posting indicates some differences in the android init/boot model. Can anyone expand on the android init/boot model? I see on t

RE: disable_irq is broken in linux-omap-git

2008-10-13 Thread Woodruff, Richard
> On Mon, Oct 13, 2008 at 2:51 AM, TK, Pratheesh Gangadhar > <[EMAIL PROTECTED]> wrote: > > FYI, this seems to be currently broken as default_disable in > kernel/irq/chip.c is defined to be an EMPTY function. It will affect > drivers using disable_irq and following patch fixes it. > > It has been

RE: disable_irq is broken in linux-omap-git

2008-10-13 Thread TK, Pratheesh Gangadhar
-Original Message- From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On Behalf Of Steve Sakoman Sent: Monday, October 13, 2008 9:21 PM To: linux-omap@vger.kernel.org Subject: Re: disable_irq is broken in linux-omap-git It has been an empty function for more than a year and a half -- see th

Re: [PATCH 1/5] HDQ Driver for OMAP2430/3430

2008-10-13 Thread Andrew Morton
> On Mon, 13 Oct 2008 18:55:43 +0530 "Madhusudhan Chikkature" <[EMAIL > PROTECTED]> wrote: > > - Original Message - > From: "Andrew Morton" <[EMAIL PROTECTED]> > To: "Gadiyar, Anand" <[EMAIL PROTECTED]> > Cc: <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>; ; > <[EMAIL PROTECTED]> > Sent: Satu

Re: disable_irq is broken in linux-omap-git

2008-10-13 Thread Steve Sakoman
On Mon, Oct 13, 2008 at 2:51 AM, TK, Pratheesh Gangadhar <[EMAIL PROTECTED]> wrote: > FYI, this seems to be currently broken as default_disable in > kernel/irq/chip.c is defined to be an EMPTY function. It will affect drivers > using disable_irq and following patch fixes it. It has been an empty

[PATCH 6/7] Generic twl4030 power script for 3430 based boards.

2008-10-13 Thread Peter 'p2' De Schrijver
This is a generic twl4030 power script for 3430 based boards. It handles sleep and wakeup events. In case of a sleep event it will first put the Reset and Control (RC) resources to sleep and then put the voltage regulators to sleep. In case of a wakeup event, the system clock will be started first,

[PATCH 4/7] Hook twl4030 power code into twl4030 core.

2008-10-13 Thread Peter 'p2' De Schrijver
This patch makes twl4030 core call the power code in case the scripts are present in the platform data. Signed-off-by: Peter 'p2' De Schrijver <[EMAIL PROTECTED]> --- drivers/mfd/Kconfig|7 +++ drivers/mfd/Makefile |1 + drivers/mfd/twl4030-core.c | 11 +++ 3

[PATCH 1/7] Remove existing twl4030 power script code.

2008-10-13 Thread Peter 'p2' De Schrijver
First we remove the existing twl4030 power sequencer code. Signed-off-by: Peter 'p2' De Schrijver <[EMAIL PROTECTED]> --- drivers/i2c/chips/Makefile|2 +- drivers/i2c/chips/twl4030-power.c | 343 - 2 files changed, 1 insertions(+), 344 deletions(-)

[PATCH 7/7] omap3 evm, beagle and overo use the generic twl4030 script

2008-10-13 Thread Peter 'p2' De Schrijver
Make omap3 evm, beagle and overo use the generic twl4030 script. Signed-off-by: Peter 'p2' De Schrijver <[EMAIL PROTECTED]> --- arch/arm/mach-omap2/Makefile|9 ++--- arch/arm/mach-omap2/board-omap3beagle.c |4 ++-- arch/arm/mach-omap2/board-omap3evm.c|4 ++-- arch/

[PATCH 5/7] 3430sdp and ldp use custom twl4030 power scripts.

2008-10-13 Thread Peter 'p2' De Schrijver
The TI 3430dsp and ldp boards have a custom power script to handle sleep and off modes. Signed-off-by: Peter 'p2' De Schrijver <[EMAIL PROTECTED]> --- arch/arm/mach-omap2/board-3430sdp.c | 84 +++ arch/arm/mach-omap2/board-ldp.c | 84 ++

[PATCH 3/7] Twl4030 power code updated for new twl4030 core

2008-10-13 Thread Peter 'p2' De Schrijver
This patch adds the twl4030 power handling. It downloads the scripts provided by the board configuration to the twl4030 and configures the chip to call the relevant script for each event (processor group 1 and 2 sleep, processor group 3 sleep, wakeup or warm reset). Signed-off-by: Peter 'p2' De Sc

[PATCH 2/7] Add defines and data types for twl4030.

2008-10-13 Thread Peter 'p2' De Schrijver
This patch adds a bunch of data types and defines to handle the twl4030 power sequence scripts. Signed-off-by: Peter 'p2' De Schrijver <[EMAIL PROTECTED]> --- include/linux/i2c/twl4030.h | 64 +++ 1 files changed, 64 insertions(+), 0 deletions(-) diff -

[PATCH 0/7] Integrate the twl4030 power code into new twl4030 mfd

2008-10-13 Thread Peter 'p2' De Schrijver
This patchset integrates the twl4030 power code into the new twl4030 mfd framework. The scripts will be moved to the board specific data. Peter 'p2' De Schrijver (7): Remove existing twl4030 power script code. Add defines and data types for twl4030. Twl4030 power code updated for new twl403

Re: [PATCH 1/5] HDQ Driver for OMAP2430/3430

2008-10-13 Thread Evgeniy Polyakov
Hi. On Mon, Oct 13, 2008 at 06:55:43PM +0530, Madhusudhan Chikkature ([EMAIL PROTECTED]) wrote: > >> +static int hdq_write_byte(struct hdq_data *hdq_data, u8 val, u8 *status) > >> +{ > >> + int ret; > >> + u8 tmp_status; > >> + unsigned long irqflags; > >> + > >> + *status

Re: git pull request for minimal omap3 support one more time

2008-10-13 Thread Russell King - ARM Linux
On Fri, Oct 10, 2008 at 02:35:34PM +0300, Tony Lindgren wrote: > * Tony Lindgren <[EMAIL PROTECTED]> [081010 12:41]: > > * Tony Lindgren <[EMAIL PROTECTED]> [081010 12:15]: > > > * Russell King - ARM Linux <[EMAIL PROTECTED]> [081010 11:42]: > > > > On Thu, Oct 09, 2008 at 06:17:25PM +0300, Tony Li

Re: [PATCH 1/5] HDQ Driver for OMAP2430/3430

2008-10-13 Thread Madhusudhan Chikkature
- Original Message - From: "Andrew Morton" <[EMAIL PROTECTED]> To: "Gadiyar, Anand" <[EMAIL PROTECTED]> Cc: <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>; ; <[EMAIL PROTECTED]> Sent: Saturday, October 11, 2008 2:08 AM Subject: Re: [PATCH 1/5] HDQ Driver for OMAP2430/3430 > On Wed, 8 Oct 200

[PATCH] n800: usb: fix num_eps and avoid BUG()

2008-10-13 Thread Felipe Balbi
num_eps is 16, not 32. Signed-off-by: Felipe Balbi <[EMAIL PROTECTED]> --- arch/arm/mach-omap2/board-n800-usb.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/arch/arm/mach-omap2/board-n800-usb.c b/arch/arm/mach-omap2/board-n800-usb.c index f8df19e..fc128f2 100644 ---

disable_irq is broken in linux-omap-git

2008-10-13 Thread TK, Pratheesh Gangadhar
FYI, this seems to be currently broken as default_disable in kernel/irq/chip.c is defined to be an EMPTY function. It will affect drivers using disable_irq and following patch fixes it. static void default_disable(unsigned int irq) { + struct irq_desc *desc = irq_desc + irq; + +

Re: [PATCH 5/7] 3430sdp and ldp use custom twl4030 power scripts.

2008-10-13 Thread Peter 'p2' De Schrijver
On Fri, Oct 10, 2008 at 10:53:22AM -0700, ext David Brownell wrote: > On Friday 10 October 2008, Peter 'p2' De Schrijver wrote: > > The TI 3430dsp and ldp boards have a custom power script. > > And for those of us less conversant in this tech ... could > you summarize, in words of one syllable or

Re: [PATCH 7/7] omap3 evm, beagle and overo use the generic twl4030 script

2008-10-13 Thread Peter 'p2' De Schrijver
On Fri, Oct 10, 2008 at 10:50:29AM -0700, ext David Brownell wrote: > On Friday 10 October 2008, Peter 'p2' De Schrijver wrote: > > +extern struct twl4030_power_data generic3430_t2scripts_data; > > Such "extern" decls should as a rule be in header files... > > In this case the rule is appropriate