Re: [PATCH 1/6 Revised] SPI omap2_mcspi.c: Check params before dereference or use

2010-05-22 Thread Grant Likely
On Fri, Mar 12, 2010 at 9:11 AM, Scott Ellis sc...@jumpnowtek.com wrote: This was previously submitted directly to the linux-kernel list. It was incomplete the first time because it failed to also check the chip_select value. Check spi-controller_state before dereference. Check

[PATCH 2/6] OMAP3: WDT: Add watchdog timer HWMOD data for OMAP3

2010-05-22 Thread Charulatha V
Add hwmod structures for Watchdog module on OMAP3 Signed-off-by: Charulatha V ch...@ti.com --- arch/arm/mach-omap2/omap_hwmod_3xxx_data.c | 61 1 files changed, 61 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/omap_hwmod_3xxx_data.c

[PATCH 0/6] OMAP2PLUS: WDT: Implement WDT in HWMOD way

2010-05-22 Thread Charulatha V
This patch series makes OMAP2PLUS Watchdog Timer Module implemented in HWMOD FW way. It also implements OMAP2/3 Watchdog timer driver to use the runtime PM layer. This patch series is created on origin/pm-wip/hwmod-omap4. This patch series is tested on OMAP3430 SDP, OMAP3630 SDP and OMAP4430

[PATCH 3/6] OMAP2420: WDT: Add watchdog timer HWMOD data for OMAP2420

2010-05-22 Thread Charulatha V
Add hwmod structures for Watchdog module on OMAP2420 Signed-off-by: Charulatha V ch...@ti.com --- arch/arm/mach-omap2/omap_hwmod_2420_data.c | 56 1 files changed, 56 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap2/omap_hwmod_2420_data.c

[PATCH 1/6] OMAP2PLUS: WDT: Add ICLKEN, FCLKEN, WKEN shared bits for WDT

2010-05-22 Thread Charulatha V
This patch adds the CM_FCLKEN_WKUP, CM_ICLKEN_WKUP, PM_WKEN_WKUP shared bits for OMAP2PLUS watchdog timer module Signed-off-by: Charulatha V ch...@ti.com --- arch/arm/mach-omap2/prcm-common.h |4 1 files changed, 4 insertions(+), 0 deletions(-) diff --git

[PATCH 5/6] OMAP4: WDT: Enable watchdog timer2 hwmod structure

2010-05-22 Thread Charulatha V
This patch enables the watchdog timer2 hwmod structure Signed-off-by: Charulatha V ch...@ti.com --- arch/arm/mach-omap2/omap_hwmod_44xx_data.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/arch/arm/mach-omap2/omap_hwmod_44xx_data.c

RE: Re: omap_musb_board_data -- trouble specifying 500mA supply

2010-05-22 Thread David Brownell
Actually in OMAP board files, power values have been provided With units of 1mA Everywhere (!!) in the Linux-USB stack, those units should be 2mA (just like in config descriptors) ... which gets divided to half in arch/arm/mach-omap2/usb-musb.c ... which is why there's a divide-by-two

Re: [PATCH v2t2 00/17] omap: mailbox:

2010-05-22 Thread Felipe Contreras
On Sat, May 22, 2010 at 8:14 AM, Hiroshi DOYU hiroshi.d...@nokia.com wrote: From: ext Felipe Contreras felipe.contre...@gmail.com Apparently it's not, so it's not clear to me how omap3-iommu would be loaded since there's no platform: alias. This alias is only necessary for platform drivers.

[PATCH v3 00/14] omap: mailbox: bunch of cleanups

2010-05-22 Thread Felipe Contreras
Hi, These are hopefully non-functional changes. Just shuffling code around, and removing unecessary stuff. In v2 I tried to split platform_device and also make mailbox_mach built-in. Not any more. Comments from Felipe Balbi, Tony Lindgren, Hiroshi DOYU, and Russell King. Felipe Contreras (14):

[PATCH v3 01/14] omap: mailbox: trivial whitespace cleanups

2010-05-22 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- Hiroshi: I think there's something wrong with your editor =/ arch/arm/plat-omap/mailbox.c | 44 +- 1 files changed, 22 insertions(+), 22 deletions(-) diff --git

[PATCH v3 02/14] omap: mailbox: trivial cleanups

2010-05-22 Thread Felipe Contreras
And fix a few compilation warnings. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/devices.c |6 ++ arch/arm/mach-omap1/mailbox.c |2 +- arch/arm/mach-omap2/mailbox.c | 10 ++ 3 files changed, 9 insertions(+), 9 deletions(-) diff --git

[PATCH v3 05/14] omap: mailbox: use correct config for omap1

2010-05-22 Thread Felipe Contreras
CONFIG_OMAP_DSP is not in mainline, CONFIG_OMAP_MBOX_FWK is. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/devices.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/arch/arm/mach-omap1/devices.c b/arch/arm/mach-omap1/devices.c index

[PATCH v3 06/14] omap: mailbox: update omap1 probing

2010-05-22 Thread Felipe Contreras
Based on omap2 code. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/mailbox.c | 28 ++-- 1 files changed, 14 insertions(+), 14 deletions(-) diff --git a/arch/arm/mach-omap1/mailbox.c b/arch/arm/mach-omap1/mailbox.c index

[PATCH v3 07/14] omap: mailbox: don't export unecessary symbols

2010-05-22 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/mailbox.c |1 - arch/arm/mach-omap2/mailbox.c |3 --- 2 files changed, 0 insertions(+), 4 deletions(-) diff --git a/arch/arm/mach-omap1/mailbox.c b/arch/arm/mach-omap1/mailbox.c index 211b9fc..590ac66

[PATCH v3 03/14] omap: mailbox: reorganize structures

2010-05-22 Thread Felipe Contreras
OMAP4 ones messed up the organization. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap2/mailbox.c | 68 + 1 files changed, 35 insertions(+), 33 deletions(-) diff --git a/arch/arm/mach-omap2/mailbox.c

[PATCH v3 08/14] omap: mailbox: remove unecessary fields

2010-05-22 Thread Felipe Contreras
Nobody is using them. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/plat-omap/include/plat/mailbox.h |8 1 files changed, 0 insertions(+), 8 deletions(-) diff --git a/arch/arm/plat-omap/include/plat/mailbox.h b/arch/arm/plat-omap/include/plat/mailbox.h

[PATCH v3 09/14] omap: mailbox: add IRQ names

2010-05-22 Thread Felipe Contreras
Will be useful to identify them later. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/devices.c |1 + arch/arm/mach-omap2/devices.c |4 2 files changed, 5 insertions(+), 0 deletions(-) diff --git a/arch/arm/mach-omap1/devices.c

[PATCH v3 10/14] omap: mailbox: reorganize registering

2010-05-22 Thread Felipe Contreras
It's more extensible this way. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/mailbox.c | 41 +--- arch/arm/mach-omap2/mailbox.c | 106 + 2 files changed, 66 insertions(+), 81 deletions(-) diff --git

[PATCH v3 11/14] omap: mailbox: only compile for configured archs

2010-05-22 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap2/mailbox.c | 14 -- 1 files changed, 12 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-omap2/mailbox.c b/arch/arm/mach-omap2/mailbox.c index f55fa84..1f0c5cd 100644 ---

[PATCH v3 12/14] omap: mailbox: standarize on 'omap-mailbox'

2010-05-22 Thread Felipe Contreras
omap{1,2}-mailbox are modules that provide the 'omap-mailbox' driver. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/devices.c |2 +- arch/arm/mach-omap1/mailbox.c |4 ++-- arch/arm/mach-omap2/devices.c |2 +- arch/arm/mach-omap2/mailbox.c |6

[PATCH v3 13/14] omap: mailbox: simplify omap_mbox_register()

2010-05-22 Thread Felipe Contreras
No need to dynamically register mailboxes one by one. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/mailbox.c | 25 ++-- arch/arm/mach-omap2/mailbox.c | 22 ++- arch/arm/plat-omap/include/plat/mailbox.h |5 +-

[PATCH v3 14/14] omap: mailbox: reorganize headers

2010-05-22 Thread Felipe Contreras
Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap1/mailbox.c |3 --- arch/arm/mach-omap2/mailbox.c |1 - arch/arm/plat-omap/include/plat/mailbox.h |3 ++- arch/arm/plat-omap/mailbox.c |5 ++--- 4 files changed, 4

[RFC/PATCH 0/2] omap: mailbox: hwmod experiment

2010-05-22 Thread Felipe Contreras
Hi, I played a bit with omap_hwmod/omap_device for the mailbox, and this is the result. I only have an OMAP3 (bb), and seems to work fine :) Felipe Contreras (2): omap: mailbox: initial hwmod support omap: mailbox: add omap_device latency information arch/arm/mach-omap2/devices.c

[RFC/PATCH 2/2] omap: mailbox: add omap_device latency information

2010-05-22 Thread Felipe Contreras
So that we can enable the main clock. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap2/devices.c | 12 +++- arch/arm/mach-omap2/mailbox.c | 20 arch/arm/plat-omap/include/plat/mailbox.h |3 +++ 3 files

[RFC/PATCH 1/2] omap: mailbox: initial hwmod support

2010-05-22 Thread Felipe Contreras
Only OMAP3 would work. Signed-off-by: Felipe Contreras felipe.contre...@gmail.com --- arch/arm/mach-omap2/devices.c | 103 +-- arch/arm/mach-omap2/mailbox.c | 14 +--- arch/arm/mach-omap2/omap_hwmod_3xxx_data.c | 45

Re: [RFC] Initial attempt to make ARM use LMB

2010-05-22 Thread Russell King - ARM Linux
I'm going to take a slightly different approach to LMB given the (unique) problems that OMAP has with converting over to LMB. I've been re-ordering my patchset so that we do as many changes as possible to sanitize the code before introducing LMB. So, below is a patch to sanitize the code in

Re: usb_nop_xceiv_register() missing when OTG built as modules

2010-05-22 Thread Amit Kucheria
On 10 Mar 05, Kevin Hilman wrote: m...@felipebalbi.com writes: On Fri, 05 Mar 2010 09:59:52 -0800, Kevin Hilman It would be my fault if I wrote those board files. ;) sure, sorry. Maybe I didn't express myself really well. I suggest you keep usb as a module, but keep nop xceiv

omap: Build failure with tip of Linus' tree

2010-05-22 Thread Amit Kucheria
Tony, I see the following build failure with the latest tip from Linus. I'm not sure if something is yet to be merged for other subsystem trees before -rc1, but a patch to fix the build is attached. Cheers, Amit From 0222c29661c9a36dcf3a1b2786b62b0080b9dc88 Mon Sep 17 00:00:00 2001 Message-Id:

[PATCH 3/6] omap: generic: introduce a single check_revision

2010-05-22 Thread Nishanth Menon
Introduce a single omap generic check_revision that routes the request to the right revision of check_revision. Cc: Tony Lindgren t...@atomide.com Cc: Angelo Arrifano mik...@gmail.com Cc: Zebediah C. McClure z...@lurian.net Cc: Alistair Buxton a.j.bux...@gmail.com Cc: Paul Walmsley p...@pwsan.com

[PATCH 5/6] omap: introduce OMAP_SHOW_FEATURE

2010-05-22 Thread Nishanth Menon
change OMAP3_SHOW_FEATURE into OMAP_SHOW_FEATURE to make the usage generic. Cc: Tony Lindgren t...@atomide.com Cc: Angelo Arrifano mik...@gmail.com Cc: Zebediah C. McClure z...@lurian.net Cc: Alistair Buxton a.j.bux...@gmail.com Cc: Paul Walmsley p...@pwsan.com Cc: Sanjeev Premi pr...@ti.com Cc:

[PATCH 4/6] omap: improve OMAP3_HAS_FEATURE

2010-05-22 Thread Nishanth Menon
Replace OMAP3_HAS_FEATURE with OMAP_HAS_FEATURE allowing us to support multiple chip features Cc: Tony Lindgren t...@atomide.com Cc: Angelo Arrifano mik...@gmail.com Cc: Zebediah C. McClure z...@lurian.net Cc: Alistair Buxton a.j.bux...@gmail.com Cc: Paul Walmsley p...@pwsan.com Cc: Sanjeev Premi

[PATCH 1/6] omap1: rename check_revision

2010-05-22 Thread Nishanth Menon
Rename omap_check_revision to omap1_check_revision to make it evident that this is omap1 features to check. This will allow us to introduce a omap generic check feature capability Cc: Tony Lindgren t...@atomide.com Cc: Angelo Arrifano mik...@gmail.com Cc: Zebediah C. McClure z...@lurian.net Cc:

[PATCH 2/6] omap2/3: id: fix sparse warning

2010-05-22 Thread Nishanth Menon
omap24xx_check_revision, omap3_check_features, omap3_check_revision, omap4_check_revision, omap3_cpuinfo are not used elsewhere, it should be static Also fixes the following sparse warnings: arch/arm/mach-omap2/id.c:105:13: warning: symbol 'omap24xx_check_revision' was not declared. Should it be

[PATCH 0/6] introduce generic OMAP SOC features

2010-05-22 Thread Nishanth Menon
With OMAP4 we have the need to have SOC independent features handling. This makes sense from a long run as other OMAP4 derivatives gets generated in parallel to OMAP3 generation of chips. Example usages: http://marc.info/?t=12737641508r=1w=2

[PATCH 6/6] omap: move generic omap3 features to generic

2010-05-22 Thread Nishanth Menon
sgx, iva, l2cache, sgx, neon, isp are generic features, make them generic features, current OMAP3 detection mechanism is still retained. 192Mhz is more specific OMAP3 feature so it is retained as is Cc: Tony Lindgren t...@atomide.com Cc: Angelo Arrifano mik...@gmail.com Cc: Zebediah C. McClure