Enabling hwmon and lm75 in the omap4 defconfig
Signed-off-by: Shubhrajyoti D
---
arch/arm/configs/omap_4430sdp_defconfig |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
mode change 100644 => 100755 arch/arm/configs/omap_4430sdp_defconfig
diff --git a/arch/arm/configs/omap_4430sdp_
> -Original Message-
> From: linux-omap-ow...@vger.kernel.org
> [mailto:linux-omap-ow...@vger.kernel.org]
> On Behalf Of Abraham Arce
> Sent: Wednesday, June 16, 2010 9:39 PM
> To: linux-in...@vger.kernel.org; linux-omap@vger.kernel.org
> Cc: Arce, Abraham
> Subject: [PATCH v4 2/4] OMAP4
When switching between clocks, The new functional clock is
effective when the next vertical blanking interval occurs.
GOLCD bit has to be set for the new clock to take effect.
Signed-off-by: Kishore Y
Signed-off-by: Mukund Mittal
Signed-off-by: Rajkumar N
---
drivers/video/omap2/dss/dpi.c |
Hi,
On Wed, Jun 16, 2010 at 07:26:30PM +0200, ext Grazvydas Ignotas wrote:
hmm, this gives me:
yeah, funny thing is that this patch was cooking in the mailing list for
over a month since I said I didn't have the boards and they were
compile-tested only. Anyways,
[0.00] WARNING: at
Kevin,
Kevin,
There is no errata in the USB which needs the Enable/Disable wakeup to be done
Seperately. If it can be handled with omap_devie_enable/idle Apis it is
sufficient.
But there is a need of setting the Auto idle bit seperately as for the USBOTG
there is a need to set the Autoidle onl
"Basak, Partha" writes:
> I wanted to close on the introduction of two new OMAP device APIs
> omap_device_enable_wakeup () & omap_device_disable_wakeup() in
> omap_device layer.
>
> These APIs are potentially needed by the USB driver (via function
> pointers) to work around some USB erratum.
>
>
The OPP API has changed to a device-based API. This patch updates
the usage of that API in the voltage layer.
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/voltage.c | 10 +-
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/arch/arm/mach-omap2/voltage.c b/arch/arm/
Add hwmod data for DSP on OMAP3 (a.k.a. IVA2.)
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/omap_hwmod_3xxx_data.c | 41
1 files changed, 41 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/omap_hwmod_3xxx_data.c
b/arch/arm/mach-omap2/omap_hw
Signed-off-by: Kevin Hilman
---
arch/arm/plat-omap/omap-pm-srf.c |7 +++
1 files changed, 7 insertions(+), 0 deletions(-)
diff --git a/arch/arm/plat-omap/omap-pm-srf.c b/arch/arm/plat-omap/omap-pm-srf.c
index 5ebcda3..bf9163e 100644
--- a/arch/arm/plat-omap/omap-pm-srf.c
+++ b/arch/arm/p
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/resource34xx.c | 95 ++-
1 files changed, 60 insertions(+), 35 deletions(-)
diff --git a/arch/arm/mach-omap2/resource34xx.c
b/arch/arm/mach-omap2/resource34xx.c
index 7f39fc3..70b41bc 100644
--- a/arch/arm/mac
The current OPP layer is based on a unique identifier (OPP_MPU,
OPP_DSP, OPP_L3) which is not terribly portable or scalable for future
devices.
Since we'd also like to be able to manage OPPs for any device, this
patch changes the OPP API to be device-based instead of unique-ID
based. Essentially,
Update usage of OPP API to use new device-based API. This requires
getting the 'struct device' for the MPU and using that with the OPP
API.
Signed-off-by: Kevin Hilman
---
arch/arm/plat-omap/cpu-omap.c | 12
1 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/arch/arm/
FIXME: this should be fixed in the SR/voltage v4 series
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/voltage.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/arm/mach-omap2/voltage.c b/arch/arm/mach-omap2/voltage.c
index b6d4f23..6e84ea1 100644
--- a/arch/a
DROP ME: this should be fixed in SR/voltage v4 series
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/sr_device.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/arch/arm/mach-omap2/sr_device.c b/arch/arm/mach-omap2/sr_device.c
index 5ca0253..dbf7603 100644
--- a/ar
Create simple omap_devices for the main processors and busses.
This is required to support the forth-coming device-based OPP
approach, where OPPs are managed and tracked at the omap_device and
hwmod level.
Because these omap_devices are based on platform_devices, they cannot
be created until the
The omap_hwmod struct has a field to track the omap_device that is
attached to it, but it was not being assigned. Fix by assigning omap_device
pointer when omap_device is built.
Signed-off-by: Kevin Hilman
---
arch/arm/plat-omap/omap_device.c |8 ++--
1 files changed, 6 insertions(+), 2
The current OPP layer is based on a unique identifier (OPP_MPU,
OPP_DSP, OPP_L3) which is not terribly portable or scalable for future
devices.
Since we'd also like to be able to manage OPPs for any device (as
recently agreed upon during an OMAP PM meeting in TI Bangalore[1]), this
patch changes t
Add a new hwmod class for DSP devices. To be used when hwmods
are created for DSP on OMAP3 (a.k.a. IVA2.)
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/omap_hwmod_common_data.c |3 +++
arch/arm/mach-omap2/omap_hwmod_common_data.h |1 +
2 files changed, 4 insertions(+), 0 deletions
As per new naming convention for hwmods, remove the redundant _hwmod suffix
from all hwmod names.
Signed-off-by: Kevin Hilman
---
arch/arm/mach-omap2/omap_hwmod_2420_data.c |6 +++---
arch/arm/mach-omap2/omap_hwmod_2430_data.c |6 +++---
arch/arm/mach-omap2/omap_hwmod_3xxx_data.c |8
>From: Felipe Contreras [mailto:felipe.contre...@gmail.com]
>
>Hi,
>
>A few trivial patches. The important one is the fix to build when MCBSP is
>disabled.
>
>Felipe Contreras (4):
> dspbridge: fix build when OMAP_MCBSP=n
> dspbridge: dev: fix dev_create_device()
> dspbridge: remove _tiomap_mmu.
>From: Ramirez Luna, Omar
>
>driver version 0.3
>
>Signed-off-by: Omar Ramirez Luna
>---
> drivers/dsp/bridge/rmgr/drv_interface.c |2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
Pushed to dspbridge.
- omar
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" i
On Wed, 2010-06-16 at 14:13 +0530, Venkatraman S wrote:
> Mathieu Poirier wrote:
> > On Tue, 2010-06-15 at 20:58 +0530, Venkatraman S wrote:
> >> Mathieu Poirier wrote:
> >> > HW: Beagleboard rev. C2 and C4
> >> > Processor: OMAP3
> >> > Kernel: 2.6.35-rc2
> >> > Driver: mmci-omap-hs
> >> >
> >>
The TRM and the OMAP FB driver have different ideas about the widths
of various bit fields in the DISPC_TIMING_{H,V} registers. This patch
is based on what the TRM (TI document SPRUF98G) says.
Note: this patch changes the meanings of the vertical timing values
by one scan line. It still works w
On Mon, Jun 14, 2010 at 11:51 AM, Fernando Guzman Lugo wrote:
> As pointed by Ben Ohand, the variable rq_full flag is a global
> variable, so if there are multiple mailbox users there will be
> conflics. Now there is a full flag per mailbox queue.
>
> Reported-by: Ohad Ben-Cohen
> Signed-off-by:
You can do a telnet to the device... you should be able to work with it but
your serial session will show the garbage.
Regards,
Rene
> -Original Message-
> From: linux-omap-ow...@vger.kernel.org [mailto:linux-omap-
> ow...@vger.kernel.org] On Behalf Of Michael Trimarchi
> Sent: Wednesday
On 6/15/2010 5:05 PM, Varadarajan, Charulatha wrote:
From: Charulatha V
This patch implements GPIO as a platform device. Also it
implements OMAP2PLUS specific GPIO as HWMOD FW adapted device.
OMAP2PLUS GPIO uses runtime APIs.
GPIO APIs are used in machine_init functions. Hence it is
required to
On 6/16/2010 5:41 PM, Varadarajan, Charulatha wrote:
On 6/16/2010 8:54 AM, Varadarajan, Charulatha wrote:
From: Cousson, Benoit
Sent: Tuesday, June 15, 2010 10:10 PM
Hi Charu,
On 6/15/2010 5:05 PM, Varadarajan, Charulatha wrote:
From: Charulatha V
This patch adds gpio_dev_attr to OMAP4 gp
On Mon, May 17, 2010 at 1:02 PM, wrote:
> From: Felipe Balbi
>
> stop using the omap-specific implementations for gpio
> debouncing now that gpiolib provides its own support.
hmm, this gives me:
[0.00] WARNING: at drivers/gpio/gpiolib.c:104
gpio_ensure_requested+0x50/0xcc()
[0.0
From: Syed Rafiuddin
Update OMAP4430 configuration to enable OMAP4 keyboard driver
Signed-off-by: Abraham Arce
---
arch/arm/configs/omap_4430sdp_defconfig |3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
diff --git a/arch/arm/configs/omap_4430sdp_defconfig
b/arch/arm/configs/omap
Keyboard support for SDP OMAP4430
Signed-off-by: Abraham Arce
---
arch/arm/mach-omap2/board-4430sdp.c | 99 +++
1 files changed, 99 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/board-4430sdp.c
b/arch/arm/mach-omap2/board-4430sdp.c
index e4a5d
* Paul Walmsley [100616 12:16]:
> On Mon, 31 May 2010, Tony Lindgren wrote:
>
> > * Paul Walmsley [100520 02:05]:
> > > Hi,
> > >
> > > On Wed, 19 May 2010, Santosh Shilimkar wrote:
> > >
> > > > This patch uses "ENABLE_ON_INIT" flag on the emif clock nodes
> > > > to avoid the emif clk gettin
Register keyboard device with hwmod framework
Signed-off-by: Abraham Arce
---
arch/arm/mach-omap2/devices.c | 50 +
1 files changed, 50 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/devices.c b/arch/arm/mach-omap2/devices.c
index 03e6c9
OMAP4 keyboard controller includes:
- built-in scanning algorithm
- debouncing feature
Driver implementation is based on matrix_keypac.c
Signed-off-by: Syed Rafiuddin
Signed-off-by: Abraham Arce
Signed-off-by: Dmitry Torokhov
---
arch/arm/plat-omap/include/plat/omap4-keypad.h | 19 ++
d
Keyboard controller for OMAP4 includes
- built-in scanning algorithm
- debouncing feature
- handling mechanism up to 9 x 9 keys
- wake-up event generation
Tested using SDP4430 board in Kevin Hillman's tree,
pm-wip/hwmods-omap4 branch
---
v1
http://www.mail-archive.com/linux-omap@vger.kerne
> >>> On 6/15/2010 5:05 PM, Varadarajan, Charulatha wrote:
> From: Charulatha V
>
> This patch adds support for handling GPIO as a HWMOD FW adapted
> platform device for OMAP2PLUS chips.
>
> gpio_init needs to be done before machine_init functions access gpio
>
>
> On 6/16/2010 8:54 AM, Varadarajan, Charulatha wrote:
> >
> >> From: Cousson, Benoit
> >> Sent: Tuesday, June 15, 2010 10:10 PM
> >>
> >> Hi Charu,
> >>
> >> On 6/15/2010 5:05 PM, Varadarajan, Charulatha wrote:
> >>> From: Charulatha V
> >>>
> >>> This patch adds gpio_dev_attr to OMAP4 gpio hwm
> -Original Message-
> From: linux-omap-ow...@vger.kernel.org [mailto:linux-omap-
> ow...@vger.kernel.org] On Behalf Of Basak, Partha
> Sent: Wednesday, June 16, 2010 8:10 PM
> To: p...@pwsan.com
> Cc: khil...@deeprootsystems.com; Kalliguddi, Hema; Nayak, Rajendra; linux-
> o...@vger.kern
Hi
Han Wang wrote:
Hi, michael,
I have the no_console_suspend option in my boot command line, I am
not sure if that is the option you were trying to point me to in the
last email?
I have said that i have no problem when I remove that option.
Can you try to echo 0 to timeout of the serial d
Hi, michael,
I have the no_console_suspend option in my boot command line, I am
not sure if that is the option you were trying to point me to in the
last email?
anyway, I added no_debug_console into my boot command arg, but that
doesn't seem to help with my problem.
any ideas?
Thanks,
Hello Paul,
I wanted to close on the introduction of two new OMAP device APIs
omap_device_enable_wakeup () & omap_device_disable_wakeup() in omap_device
layer.
These APIs are potentially needed by the USB driver (via function pointers) to
work around some USB erratum.
Alternatively, can we c
Hi, Jean,
Yes I looked at the the OMAP_Power_management page, but the known
problem section doesn't seem to describe my problem.
What I am encountering is that the serial console does output
correctly after resume, but everything goes south after a few lines,
thus, the garbage strings...
a
>From 53711271c3f22c8038f4961a9f9c2035b3e82d7f Mon Sep 17 00:00:00 2001
From: Sujeet Baranwal
Date: Tue, 1 Jun 2010 19:29:24 +0530
Subject: [PATCH] OMAP: DSS2: Switching GFX from LCD to TV
1. Added a sysfs entry for setting overlay input_size
in order to switch the GFX pipeline from LCD to TV.
2
Avoid using hwmod lookup using name string rather
retreive port info using the hwmod class interface.
Cc: Kevin Hilman
Signed-off-by: Govindraj.R
---
arch/arm/mach-omap2/serial.c | 71 ++---
1 files changed, 31 insertions(+), 40 deletions(-)
diff --git a/a
Add prepare idle and resume idle call for uart4 used by 3630.
Cc: Kevin Hilman
Signed-off-by: Govindraj.R
---
arch/arm/mach-omap2/pm34xx.c |2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/pm34xx.c b/arch/arm/mach-omap2/pm34xx.c
index a120d4f..50c20a2
This patch makes the following:
- Adds missing wakeup padding register handling.
- Fixes a hardcode to use PER module ONLY on UART3.
- Muxmode usage needed for uart4 for 3630, for padconf
wakeup on uart4_rx line. uart4_rx signal is available
under mode-2 in gpmc_wait3. Thus have to ensure
To standarize among other uarts (1 to 3), we shall now:
- Enable uart4 autodile bit.
- Enable uart4 wakeup in PER.
- Allow uart4 to wakeup the MPU.
Cc: Kevin Hilman
Signed-off-by: Sergio Aguirre
Signed-off-by: Govindraj.R
---
arch/arm/mach-omap2/cm-regbits-34xx.h |2 ++
arch/arm/mach-
Add uart4 clock data.
This is only valid for omap 36xx family of chips.
Cc: Kevin Hilman
Signed-off-by: Sergio Aguirre
Signed-off-by: Govindraj.R
---
arch/arm/mach-omap2/clock3xxx_data.c | 22 ++
1 files changed, 22 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mac
Changes from v1:
* Incorporated : OMAP clock: Add uart4_ick/fck definitions for 3630
* using omap_mux_request_signal to retreive padconf offset
as per Tony's comments.
http://marc.info/?l=linux-omap&m=127609369220618&w=2
This patch series as a dependecy on the patch
for "omap_mux_request_si
Hi Linus,
Please pull these two fixes for the OMAP framebuffer driver.
Tomi
The following changes since commit 67a3e12b05e055c0415c556a315a3d3eb637e29e:
Linus Torvalds (1):
Linux 2.6.35-rc1
are available in the git repository at:
git://gitorious.org/linux-omap-dss2/linux.git for-
patch adds NAND support to zoom3 board.
Signed-off-by: Sukumar Ghorai
Signed-off-by: Vimal Singh
---
arch/arm/mach-omap2/Makefile |1 +
arch/arm/mach-omap2/board-zoom3.c | 43 +
2 files changed, 44 insertions(+), 0 deletions(-)
diff --git a/arch/a
This patch adds NAND support to ZOOM2 board.
Signed-off-by: Sukumar Ghorai
Signed-off-by: Vimal Singh
---
arch/arm/mach-omap2/Makefile |1 +
arch/arm/mach-omap2/board-zoom2.c | 43 +
arch/arm/mach-omap2/include/mach/board-zoom.h |6
add support for NAND, OneNAND, NOR on omap 3630-sdp board.
Signed-off-by: Sukumar Ghorai
---
arch/arm/mach-omap2/Makefile|1 +
arch/arm/mach-omap2/board-3630sdp.c | 120 +++
2 files changed, 121 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mac
update config file to support for NAND, OneNAND, NOR on omap 3630-sdp board.
Signed-off-by: Sukumar Ghorai
---
arch/arm/configs/omap_3630sdp_defconfig | 31 ++-
1 files changed, 30 insertions(+), 1 deletions(-)
diff --git a/arch/arm/configs/omap_3630sdp_defconfig
update config file to support for NAND on zoom3 board.
Signed-off-by: Sukumar Ghorai
---
arch/arm/configs/omap_zoom3_defconfig | 24 +++-
1 files changed, 23 insertions(+), 1 deletions(-)
arch/arm/configs/omap_zoom3_defconfig
diff --git a/arch/arm/configs/omap_zoom3_defco
patch adds NAND support to LDP board.
Signed-off-by: Vimal Singh
Signed-off-by: Sukumar Ghorai
---
arch/arm/mach-omap2/Makefile|1 +
arch/arm/mach-omap2/board-ldp.c | 35 +++
2 files changed, 36 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-
update config file to support for NAND in zoom2.
Signed-off-by: Sukumar Ghorai
---
arch/arm/configs/omap_zoom2_defconfig | 24 +++-
1 files changed, 23 insertions(+), 1 deletions(-)
arch/arm/configs/omap_zoom2_defconfig
diff --git a/arch/arm/configs/omap_zoom2_defconfig
rename board-sdp-flash.c(board-flash.c) and board-sdp.h(board-flash.h) to
used by other board e.g. zoom
Signed-off-by: Sukumar Ghorai
---
arch/arm/mach-omap2/Makefile |2 +-
arch/arm/mach-omap2/board-3430sdp.c| 16 ++-
arch/arm/mach-omap2/board-flash.c
The following set of patches applies on top of for-next branch.
And these are the patches required to enable nand (nor and onenand for sdp
only) for different platform.
v3: patch rebase on latest nand patch and depend on -
http://www.mail-archive.com/linux-omap@vger.kernel.o
On Wed, 2010-06-16 at 12:52 +0200, ext Guruswamy, Senthilvadivu wrote:
> Hi,
>
> When I started with RFC patch "DSS: Movement of base addr, silicon specific
> data from driver to platform_device", I see a lot of encapsulation of OMAP
> DSS IPs into the "omapdss" driver.
>
> The previous RFC pat
Hi,
When I started with RFC patch "DSS: Movement of base addr, silicon specific
data from driver to platform_device", I see a lot of encapsulation of OMAP
DSS IPs into the "omapdss" driver.
The previous RFC patch would only be good enough to handle base address and
IRQ for multi-omap. But it
On 6/16/2010 10:46 AM, Varadarajan, Charulatha wrote:
-Original Message-
From: Shilimkar, Santosh
Sent: Wednesday, June 16, 2010 12:51 PM
To: Varadarajan, Charulatha; Cousson, Benoit
Cc: davi...@pacbell.net; broo...@opensource.wolfsonmicro.com; a...@linux-
foundation.org; linux-omap@vg
On Mon, 31 May 2010, Tony Lindgren wrote:
> * Paul Walmsley [100520 02:05]:
> > Hi,
> >
> > On Wed, 19 May 2010, Santosh Shilimkar wrote:
> >
> > > This patch uses "ENABLE_ON_INIT" flag on the emif clock nodes
> > > to avoid the emif clk getting cut as part of reset un-used clock
> > > routine
From: ext Felipe Contreras
Subject: [PATCH v4 00/14] omap: mailbox: bunch of cleanups
Date: Fri, 11 Jun 2010 17:51:35 +0200
> From: Felipe Contreras <--global>
>
> Hi,
>
> These are hopefully non-functional changes. Just shuffling code around, and
> removing unecessary stuff.
>
> This v4 inclu
On 6/16/2010 9:21 AM, Shilimkar, Santosh wrote:
-Original Message-
From: linux-omap-ow...@vger.kernel.org
[mailto:linux-omap-ow...@vger.kernel.org] On Behalf Of
Varadarajan, Charulatha
Sent: Wednesday, June 16, 2010 12:25 PM
To: Cousson, Benoit
Cc: davi...@pacbell.net; broo...@opensource
On 6/16/2010 8:54 AM, Varadarajan, Charulatha wrote:
From: Cousson, Benoit
Sent: Tuesday, June 15, 2010 10:10 PM
Hi Charu,
On 6/15/2010 5:05 PM, Varadarajan, Charulatha wrote:
From: Charulatha V
This patch adds gpio_dev_attr to OMAP4 gpio hwmod structure. This patch
also corrects the gpio .
> -Original Message-
> From: Shilimkar, Santosh
> Sent: Wednesday, June 16, 2010 12:51 PM
> To: Varadarajan, Charulatha; Cousson, Benoit
> Cc: davi...@pacbell.net; broo...@opensource.wolfsonmicro.com; a...@linux-
> foundation.org; linux-omap@vger.kernel.org; p...@pwsan.com; Nayak, Rajendr
Hi,
On Wed, Jun 16, 2010 at 08:09, Michael Trimarchi
wrote:
> Han Wang wrote:
>>
>> Hi,
>>
>> I am testing the 2.6.35-rc1 pm branch code on Overo. The system
>> boots ok. (I can provide booting log if that is necessary) However,
>> when I use "echo mem > /sys/power/state" to send overo to sleep
Mathieu Poirier wrote:
> On Tue, 2010-06-15 at 20:58 +0530, Venkatraman S wrote:
>> Mathieu Poirier wrote:
>> > HW: Beagleboard rev. C2 and C4
>> > Processor: OMAP3
>> > Kernel: 2.6.35-rc2
>> > Driver: mmci-omap-hs
>> >
>> > I am faced with an SDHC card problem on a beagleboard. Some cards
>> >
* Felipe Contreras [100611 19:03]:
> On Fri, Jun 11, 2010 at 6:07 PM, Laurent Pinchart
> wrote:
> > My understanding is that Linus will remove all ARM defconfigs in 2.6.36,
> > unless someone can convince him not to.
>
> Huh? I thought he was only threatening to remove them[1]. I don't
> think h
> -Original Message-
> From: linux-omap-ow...@vger.kernel.org
> [mailto:linux-omap-ow...@vger.kernel.org] On Behalf Of
> Varadarajan, Charulatha
> Sent: Wednesday, June 16, 2010 12:25 PM
> To: Cousson, Benoit
> Cc: davi...@pacbell.net; broo...@opensource.wolfsonmicro.com;
> a...@linux-fou
70 matches
Mail list logo