Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Tony Lindgren
* Nicolas Pitre [110421 20:20]: > On Thu, 21 Apr 2011, Nicolas Pitre wrote: > > > On Thu, 21 Apr 2011, Nicolas Pitre wrote: > > > > > On Thu, 21 Apr 2011, Tony Lindgren wrote: > > > > > > > Otherwise we end up overwriting ourselves. This fixes booting > > > > on n900 after commit 6d7d0ae5157494

Re: [v2 0/7] OMAP: GPIO: Use PM runtime framework

2011-04-21 Thread Tony Lindgren
* Kevin Hilman [110421 18:12]: > Tony Lindgren writes: > > > > Saw that, looks good :) Need to post it also to lakml BTW. > > Yeah, I only posted to l-o so far because it's not done. I only removed > a few of the #ifdef sections, there are still several more to do. Oh I see. Anyways looks good

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Tony Lindgren
* Nicolas Pitre [110421 16:18]: > On Thu, 21 Apr 2011, Tony Lindgren wrote: > > > Otherwise we end up overwriting ourselves. This fixes booting > > on n900 after commit 6d7d0ae51574943bf571d269da3243257a2d15db > > (ARM: 6750/1: improvements to compressed/head.S). > > > > Signed-off-by: Tony Lind

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Shawn Guo
On Fri, Apr 22, 2011 at 01:19:14PM +0800, Shawn Guo wrote: > > - >8 > > > > From: Nicolas Pitre > > > > ARM: zImage: make sure the stack is 64-bit aligned > > > > With ARMv5+ and EABI, the compiler expects a 64-bit aligned stack so > > instructions like STRD and LDRD can be used. Without t

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Shawn Guo
On Thu, Apr 21, 2011 at 11:23:22PM -0400, Nicolas Pitre wrote: > On Thu, 21 Apr 2011, Nicolas Pitre wrote: > > > On Thu, 21 Apr 2011, Nicolas Pitre wrote: > > > > > On Thu, 21 Apr 2011, Tony Lindgren wrote: > > > > > > > Otherwise we end up overwriting ourselves. This fixes booting > > > > on n9

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Nicolas Pitre
On Thu, 21 Apr 2011, Nicolas Pitre wrote: > On Thu, 21 Apr 2011, Nicolas Pitre wrote: > > > On Thu, 21 Apr 2011, Tony Lindgren wrote: > > > > > Otherwise we end up overwriting ourselves. This fixes booting > > > on n900 after commit 6d7d0ae51574943bf571d269da3243257a2d15db > > > (ARM: 6750/1: im

Re: [Regression?] Removed regulator support in ehci-omap

2011-04-21 Thread Alan Ott
On 04/12/2011 12:20 PM, Keshava Munegowda wrote: >> Ah, so EHCI/OHCI common code was moved into drivers/mfd... Good. >> But seems regulators support was lost somewhere during transition - the >> only mentioning about regulators in omap-usb-host.c is "#include" : >> >> mad@macmini:~/kernel-hack/linu

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Nicolas Pitre
On Thu, 21 Apr 2011, Nicolas Pitre wrote: > On Thu, 21 Apr 2011, Tony Lindgren wrote: > > > Otherwise we end up overwriting ourselves. This fixes booting > > on n900 after commit 6d7d0ae51574943bf571d269da3243257a2d15db > > (ARM: 6750/1: improvements to compressed/head.S). > > > > Signed-off-by:

[PATCH 1/9] OMAP: GPIO: _clear_gpio_irqbank: fix flushing of posted write

2011-04-21 Thread Kevin Hilman
In commit 78a1a6d3411de1a8b0dc1cb92754b5f12f251912 (ARM: OMAP4: Update the GPIO support) braces were mistakenly added to included the register read-back inside the cpu_is_* checking. Remove the braces, ensuring that a register read-back is done, even when the IRQSTATUS2 register is not written. N

[PATCH 2/9] OMAP: GPIO: remove MPUIO handling from _clear_gpio_irqbank()

2011-04-21 Thread Kevin Hilman
Remove the OMAP1 #ifdef and MPUIO special case for _clear_gpio_irqbank() The MPUIOs do not need a register access to ack/clear the IRQ status, since reading the IRQ status clears it. In addition, the MPUIO irq_chip has an empty ack method, so _clear_gpio_irqbank() is never used for MPUIOs. Signe

[PATCH 9/9] OMAP: GPIO: convert MPUIO IRQ over to generic irq_chip

2011-04-21 Thread Kevin Hilman
Signed-off-by: Kevin Hilman --- arch/arm/plat-omap/gpio.c | 74 ++-- 1 files changed, 30 insertions(+), 44 deletions(-) diff --git a/arch/arm/plat-omap/gpio.c b/arch/arm/plat-omap/gpio.c index 8d80bf0..57530c0 100644 --- a/arch/arm/plat-omap/gpio.c +++ b

[PATCH 6/9] OMAP: GPIO: consolidate direction, input, output, remove #ifdefs

2011-04-21 Thread Kevin Hilman
Add register offset fields to GPIO platform_data for registers that control direction, input and output data. Using these register offsets in the common driver allows removal of #ifdefs and greatly improves readability. Signed-off-by: Kevin Hilman --- arch/arm/mach-omap1/gpio15xx.c |

[PATCH 8/9] OMAP: GPIO: conslidate enable/disable of GPIO IRQs, remove ifdefs

2011-04-21 Thread Kevin Hilman
Cleanup GPIO IRQ enable/disable handling by removing SoC-specific Also split enable/disable IRQ into separate functions for better readability and also facilitate potentially moving to generic irq_chip in the future. Signed-off-by: Kevin Hilman --- arch/arm/mach-omap1/gpio15xx.c |4

[PATCH 7/9] OMAP: GPIO: consolidate IRQ status handling, remove #ifdefs

2011-04-21 Thread Kevin Hilman
Cleanup IRQ status handling by by passing IRQ status register offsets via platform data. Cleans up clearing of GPIO IRQ status and GPIO ISR handler. Signed-off-by: Kevin Hilman --- arch/arm/mach-omap1/gpio15xx.c |2 + arch/arm/mach-omap1/gpio16xx.c |4 +- arch/arm/mach-o

[PATCH 5/9] OMAP: GPIO: move register offset defines into gpio.h

2011-04-21 Thread Kevin Hilman
Register offset defines are moved to so they can be used by SoC-specific device init code to fill out platform_data register offsets. Signed-off-by: Kevin Hilman --- arch/arm/plat-omap/gpio.c | 103 arch/arm/plat-omap/include/plat/gpio.h | 103 +++

[PATCH 3/9] OMAP: GPIO: move bank width into struct gpio_bank

2011-04-21 Thread Kevin Hilman
Rather than having a file-global bank_width variable, move it into struct gpio_bank so it can be bank-specific. Note the bank width is already passed per-bank via platform_data, so current code would be incorrect if any banks had different width. Signed-off-by: Kevin Hilman --- arch/arm/plat-o

[PATCH 4/9] OMAP: GPIO: _get_gpio_irqbank_mask: replace hard-coded mask with bank->width

2011-04-21 Thread Kevin Hilman
Replace hard-coded mask values with bank->width which is already coming from platform_data. Signed-off-by: Kevin Hilman --- arch/arm/plat-omap/gpio.c |8 +--- 1 files changed, 1 insertions(+), 7 deletions(-) diff --git a/arch/arm/plat-omap/gpio.c b/arch/arm/plat-omap/gpio.c index d1d339

[PATCH 0/9] OMAP: GPIO: cleanup, consolidation, etc. (v2)

2011-04-21 Thread Kevin Hilman
Here's an updated version of my work-in-progress GPIO cleanups. I now understand that others have some similar work in progress, so these are posted (to linux-omap only, for now) so that we can begin collaboration on the GPIO cleanups. This series applies on top of v2.6.39-rc4 plus the generic ir

Re: [PATCH] OMAP2+: powerdomain: fix typo: lose context --> loose context

2011-04-21 Thread Kevin Hilman
Paul Walmsley writes: > Hi Kevin, > > On Wed, 20 Apr 2011, Kevin Hilman wrote: > >> Before we get any users of this function, fix the name (and comments) >> to use loose instead of lose. >> >> Signed-off-by: Kevin Hilman >> --- >> Applies to v2.6.39-rc4 >> >> arch/arm/mach-omap2/powerdomain.c

Re: [PATCH] OMAP2+: powerdomain: fix typo: lose context --> loose context

2011-04-21 Thread Paul Walmsley
Hi Kevin, On Wed, 20 Apr 2011, Kevin Hilman wrote: > Before we get any users of this function, fix the name (and comments) > to use loose instead of lose. > > Signed-off-by: Kevin Hilman > --- > Applies to v2.6.39-rc4 > > arch/arm/mach-omap2/powerdomain.c |6 +++--- > arch/arm/mach-omap2/

Re: [v2 0/7] OMAP: GPIO: Use PM runtime framework

2011-04-21 Thread Kevin Hilman
Tony Lindgren writes: > * Kevin Hilman [110421 02:56]: >> Hi Tony, >> >> Tony Lindgren writes: >> >> > * Varadarajan, Charulatha [110418 18:00]: >> >> From: Charulatha V >> >> >> >> Use PM runtime framework in OMAP GPIO driver. >> > ... >> > >> >> arch/arm/mach-omap2/gpio.c

Re: [PATCH 0/2] OMAP: GPIO: cleanup: first pass at ifdef removal

2011-04-21 Thread Kevin Hilman
Hi Tarun, "DebBarma, Tarun Kanti" writes: > [...] >> >> This series is a first pass at the #ifdef removal cleanup. >> >> To demonstrate the type of changes needed for the cleanup, the >> direction and data input/output functions are handled first. Register >> offset fields are added to platfo

[PATCH 1/2] arm: omap: fix bug with multiple smsc911x devices

2011-04-21 Thread Igor Grinberg
kobject (c06a4250): tried to init an initialized object, something is seriously wrong. introduced by commit 66293989: (omap: convert boards that use SMSC911x to use gpmc-smsc911x) fixed by allocating struct platform_device dynamically. Signed-off-by: Igor Grinberg --- This has been boot tested

[PATCH 2/2] arm: omap: gpmc-smsc911x: minor style fixes

2011-04-21 Thread Igor Grinberg
replace "printk(KERN_ERR" by "pr_err(" and fix needlessly multi-lined #ifdef Signed-off-by: Igor Grinberg --- arch/arm/mach-omap2/gpmc-smsc911x.c | 14 +++--- arch/arm/plat-omap/include/plat/gpmc-smsc911x.h |3 +-- 2 files changed, 8 insertions(+), 9 deletions(-) diff

[PATCH] mfd: Fix usbhs_enable error handling

2011-04-21 Thread Keshava Munegowda
From: Axel Lin In the case of missing platform_data we do not hold a spin_lock, thus we should not call spin_unlock_irqrestore in the error path. Also simplify the error handling by separating the successful path from error path. I think this change improves readability. Signed-off-by: Axel Lin

[PATCH] omap:usb: add regulator support for EHCI

2011-04-21 Thread Keshava Munegowda
From: Keshava Munegowda in case of ehci phy mode; regulator of phy should be enabled before initializing the usbhs core driver. Signed-off-by: Keshava Munegowda --- drivers/mfd/omap-usb-host.c |1 - drivers/usb/host/ehci-omap.c | 20 2 files changed, 20 insertions(+

[PATCH] omap:usb: fixing ehci phy gpio values for omap3

2011-04-21 Thread Keshava Munegowda
From: Keshava Munegowda The gpio of EHCI phy should be 0 instead of 1; This fixes the hub enumeration issue in beagle xm board. Signed-off-by: Keshava Munegowda --- drivers/mfd/omap-usb-host.c |8 1 files changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/mfd/omap-usb-

Re: [PATCH] OMAP: Added recalculation of clock rate in 'clk_set_rate'

2011-04-21 Thread Gulati, Shweta
Hi, On Thu, Apr 21, 2011 at 1:25 AM, Paul Walmsley wrote: > Hi > > On Wed, 20 Apr 2011, Shweta Gulati wrote: > >> From: Gulati, Shweta >> >> Core Clk Tree shows incorrect Clk rates at OPP50, as >> in commit e07f469d284ca3d1f5dcf5438c22982be98bc071 >> calling of 'recalc' in API clk_set_rate is un

Re: [PATCH] OMAP: Added recalculation of clock rate in 'clk_set_rate'

2011-04-21 Thread Gulati, Shweta
Hi, On Wed, Apr 20, 2011 at 9:12 PM, Sergei Shtylyov wrote: > Hello. > > On 20-04-2011 13:25, Shweta Gulati wrote: > >> From: Gulati, Shweta > >> Core Clk Tree shows incorrect Clk rates at OPP50, as >> in commit e07f469d284ca3d1f5dcf5438c22982be98bc071 > >   Please also specify that commit's summ

Re: [PATCH] OMAP: Added recalculation of clock rate in 'clk_set_rate'

2011-04-21 Thread Gulati, Shweta
Hi, On Wed, Apr 20, 2011 at 7:05 PM, Janorkar, Mayuresh wrote: > > >> -Original Message- >> From: linux-omap-ow...@vger.kernel.org [mailto:linux-omap- >> ow...@vger.kernel.org] On Behalf Of Gulati, Shweta >> Sent: Wednesday, April 20, 2011 2:55 PM >> To: linux-omap@vger.kernel.org >> Cc:

Re: [PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Nicolas Pitre
On Thu, 21 Apr 2011, Tony Lindgren wrote: > Otherwise we end up overwriting ourselves. This fixes booting > on n900 after commit 6d7d0ae51574943bf571d269da3243257a2d15db > (ARM: 6750/1: improvements to compressed/head.S). > > Signed-off-by: Tony Lindgren I don't understand why this is needed.

Re: [PATCH] ARM: omap4: i2c reset regs postidle

2011-04-21 Thread Andy Green
On 04/21/2011 12:47 PM, Somebody in the thread at some point said: Without OMAP_I2C_FLAG_RESET_REGS_POSTIDLE I got i2c controller timeouts on each accsess after an NACK message. Taking this flag fix it. Ahhh that will explain why if you accidentally configure LM75 system monitor support, which

[PATCH] ARM: omap4: i2c reset regs postidle

2011-04-21 Thread Jan Weitzel
Without OMAP_I2C_FLAG_RESET_REGS_POSTIDLE I got i2c controller timeouts on each accsess after an NACK message. Taking this flag fix it. This patch is on top of the i2c feature implementation flags patches Signed-off-by: Jan Weitzel --- arch/arm/mach-omap2/omap_hwmod_44xx_data.c |3 ++- 1 fi

RE: [PATCH 6/7] OMAP4: DSS: Adding a picodlp in OMAP4430 SDP board file

2011-04-21 Thread Janorkar, Mayuresh
> -Original Message- > From: Valkeinen, Tomi > Sent: Tuesday, April 19, 2011 5:24 PM > To: Janorkar, Mayuresh > Cc: linux-omap@vger.kernel.org; K, Mythri P > Subject: Re: [PATCH 6/7] OMAP4: DSS: Adding a picodlp in OMAP4430 SDP > board file > > On Mon, 2011-04-18 at 11:45 +0530, Mayuresh

RE: [PATCH 5/7] OMAP: DSS: Adding initialization routine to picodlp panel

2011-04-21 Thread Janorkar, Mayuresh
> -Original Message- > From: Valkeinen, Tomi > Sent: Tuesday, April 19, 2011 5:23 PM > To: Janorkar, Mayuresh > Cc: linux-omap@vger.kernel.org; K, Mythri P > Subject: Re: [PATCH 5/7] OMAP: DSS: Adding initialization routine to > picodlp panel > > On Mon, 2011-04-18 at 11:45 +0530, Mayure

RE: [PATCH 4/7] OMAP: DSS: Add i2c client driver for picodlp

2011-04-21 Thread Janorkar, Mayuresh
> -Original Message- > From: Valkeinen, Tomi > Sent: Tuesday, April 19, 2011 5:12 PM > To: Janorkar, Mayuresh > Cc: linux-omap@vger.kernel.org; K, Mythri P > Subject: Re: [PATCH 4/7] OMAP: DSS: Add i2c client driver for picodlp > > On Mon, 2011-04-18 at 11:45 +0530, Mayuresh Janorkar wro

RE: [PATCH 3/7] OMAP: DSS: Adding a picodlp panel driver

2011-04-21 Thread Janorkar, Mayuresh
> -Original Message- > From: Valkeinen, Tomi > Sent: Tuesday, April 19, 2011 4:40 PM > To: Janorkar, Mayuresh > Cc: linux-omap@vger.kernel.org; K, Mythri P > Subject: Re: [PATCH 3/7] OMAP: DSS: Adding a picodlp panel driver > > On Mon, 2011-04-18 at 11:45 +0530, Mayuresh Janorkar wrote:

[PATCH] ARM: Fix relocation if image end past uncompressed kernel end

2011-04-21 Thread Tony Lindgren
Otherwise we end up overwriting ourselves. This fixes booting on n900 after commit 6d7d0ae51574943bf571d269da3243257a2d15db (ARM: 6750/1: improvements to compressed/head.S). Signed-off-by: Tony Lindgren --- a/arch/arm/boot/compressed/head.S +++ b/arch/arm/boot/compressed/head.S @@ -282,6 +282,7

Re: [PATCH] OMAP: DSS2: DSI: enable interface for omap4

2011-04-21 Thread Archit Taneja
Hi, On Thursday 21 April 2011 09:01 AM, Pandita, Vikram wrote: From: Vikram Pandita By default, the DSI is not getting enabled for omap4. OMAP2PLUS does not catch this issue since it has ARCH_OMAP3. The issue is only seen when using defconfig with ARCH_OMAP4 only. This looks fine. There isn

Re: [PATCH] omap: Run make savedefconfig on omap2plus_defconfig to shrink it

2011-04-21 Thread Tony Lindgren
* Uwe Kleine-König [110421 01:49]: > On Thu, Apr 21, 2011 at 01:49:10AM -0700, Tony Lindgren wrote: > > * Uwe Kleine-König [110421 01:20]: > > > On Wed, Apr 20, 2011 at 11:44:23PM -0700, Tony Lindgren wrote: > > > > This shrinks it down a bit more and makes it easier > > > > to patch later on. >

Re: [PATCH] omap: Run make savedefconfig on omap2plus_defconfig to shrink it

2011-04-21 Thread Uwe Kleine-König
On Thu, Apr 21, 2011 at 01:49:10AM -0700, Tony Lindgren wrote: > * Uwe Kleine-König [110421 01:20]: > > On Wed, Apr 20, 2011 at 11:44:23PM -0700, Tony Lindgren wrote: > > > This shrinks it down a bit more and makes it easier > > > to patch later on. > > Maybe pointing out why it's shrinkable would

Re: [PATCH] omap: Run make savedefconfig on omap2plus_defconfig to shrink it

2011-04-21 Thread Tony Lindgren
* Uwe Kleine-König [110421 01:20]: > On Wed, Apr 20, 2011 at 11:44:23PM -0700, Tony Lindgren wrote: > > This shrinks it down a bit more and makes it easier > > to patch later on. > Maybe pointing out why it's shrinkable would be nice. > E.g. > > After commit > > ffb63e3 (omap

RE: [PATCH 0/2] OMAP: GPIO: cleanup: first pass at ifdef removal

2011-04-21 Thread DebBarma, Tarun Kanti
[...] > > This series is a first pass at the #ifdef removal cleanup. > > To demonstrate the type of changes needed for the cleanup, the > direction and data input/output functions are handled first. Register > offset fields are added to platform_data so #ifdefs can be removed. > > Similar needs

Re: [PATCH] omap: Run make savedefconfig on omap2plus_defconfig to shrink it

2011-04-21 Thread Uwe Kleine-König
On Wed, Apr 20, 2011 at 11:44:23PM -0700, Tony Lindgren wrote: > This shrinks it down a bit more and makes it easier > to patch later on. Maybe pointing out why it's shrinkable would be nice. E.g. After commit ffb63e3 (omap2/3/4: Select all omaps and boards by default