Re: McBSP functions not exported

2013-01-16 Thread Peter Ujfalusi
Hi, On 01/15/2013 06:43 PM, Paul Barker wrote: > I've written a quick driver which issues SPI reads in response to hrtimer > events > to see if this is possible. I'm getting a rough average latency of 100us > between > calling spi_async() and the clock signal changing. This is no use for reading

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread Igor Grinberg
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 01/16/13 09:26, NeilBrown wrote: > On Wed, 09 Jan 2013 14:54:00 +0200 Igor Grinberg > wrote: > >> On 01/09/13 14:08, Michael Trimarchi wrote: >>> Hi Neil >>> >>> I forget to answer to your questions >>> >>> On 01/09/2013 12:34 PM, NeilBrown wrote:

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread Roger Quadros
On 01/09/2013 12:29 AM, NeilBrown wrote: > > Hi, > I'm trying to get off_mode working reliably on my gta04 mobile phone. > > My current stumbling block is USB. The "Option" GSM module is attached via > USB (there is a separate transceiver chip attached to port 1 which is placed > in OMAP_EHCI_P

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread NeilBrown
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On Wed, 16 Jan 2013 11:28:02 +0200 Igor Grinberg wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > On 01/16/13 09:26, NeilBrown wrote: > > On Wed, 09 Jan 2013 14:54:00 +0200 Igor Grinberg > > wrote: > > > >> On 01/09/13 14:08, Michael T

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread NeilBrown
On Wed, 16 Jan 2013 12:00:48 +0200 Roger Quadros wrote: > On 01/09/2013 12:29 AM, NeilBrown wrote: > > > > Hi, > > I'm trying to get off_mode working reliably on my gta04 mobile phone. > > > > My current stumbling block is USB. The "Option" GSM module is attached via > > USB (there is a separ

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread Roger Quadros
On 01/16/2013 12:27 PM, NeilBrown wrote: > On Wed, 16 Jan 2013 12:00:48 +0200 Roger Quadros wrote: > >> On 01/09/2013 12:29 AM, NeilBrown wrote: >>> >>> Hi, >>> I'm trying to get off_mode working reliably on my gta04 mobile phone. >>> >>> My current stumbling block is USB. The "Option" GSM modu

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread Igor Grinberg
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 01/16/13 12:19, NeilBrown wrote: > On Wed, 16 Jan 2013 11:28:02 +0200 Igor Grinberg > wrote: > >> -BEGIN PGP SIGNED MESSAGE- >> Hash: SHA1 > >> On 01/16/13 09:26, NeilBrown wrote: >>> On Wed, 09 Jan 2013 14:54:00 +0200 Igor Grinberg >>>

Re: Does USB isochronous mode work on EHCI port?

2013-01-16 Thread Roger Quadros
On 01/04/2013 02:20 PM, Gary Thomas wrote: > > > On Thursday, January 3, 2013 9:21:19 AM UTC-7, Felipe Balbi wrote: > > Hi, > > On Wednesday, January 2, 2013 10:44:50 PM UTC+2, Gary Thomas wrote: > > I have a video adapter attached to my EHCI port which runs full > spee

RE: [PATCH 2/2] pwm: pwm-tiecap: Low power sleep support

2013-01-16 Thread Philip, Avinash
On Mon, Jan 14, 2013 at 12:40:34, Thierry Reding wrote: > On Thu, Jan 10, 2013 at 06:33:44PM +0530, Philip Avinash wrote: > > In low power modes of AM33XX platforms, peripherals power is cut off. > > This patch supports low power sleep transition support for ECAP driver. > > > > Signed-off-by: Phi

RE: [PATCH 1/2] pwm: pwm-tiehrpwm: Low power sleep support

2013-01-16 Thread Philip, Avinash
On Mon, Jan 14, 2013 at 12:38:56, Thierry Reding wrote: > On Thu, Jan 10, 2013 at 06:33:43PM +0530, Philip Avinash wrote: > [...] > > diff --git a/drivers/pwm/pwm-tiehrpwm.c b/drivers/pwm/pwm-tiehrpwm.c > [...] > > +static int ehrpwm_pwm_suspend(struct device *dev) > > +{ > > + struct ehrpwm_pwm_

RE: [PATCH v4 0/3] mtd: nand: OMAP: ELM error correction support for BCH ecc

2013-01-16 Thread Philip, Avinash
Hi Artem, On Fri, Jan 04, 2013 at 13:26:48, Philip, Avinash wrote: > Support to use ELM as BCH 4 & 8 bit error correction module. Also performance > enhancement by adding single shot read_page and write_page functions for the > nand flashes with page size less than 4 KB. > > ELM module can be use

Re: [PATCH 1/2] pwm: pwm-tiehrpwm: Low power sleep support

2013-01-16 Thread Thierry Reding
On Wed, Jan 16, 2013 at 12:14:01PM +, Philip, Avinash wrote: > On Mon, Jan 14, 2013 at 12:38:56, Thierry Reding wrote: > > On Thu, Jan 10, 2013 at 06:33:43PM +0530, Philip Avinash wrote: > > [...] > > > diff --git a/drivers/pwm/pwm-tiehrpwm.c b/drivers/pwm/pwm-tiehrpwm.c > > [...] > > > +static

[PATCH 1/3] OMAPDSS: Panel NEC: Set backlight type to remove boot time warning

2013-01-16 Thread Peter Ujfalusi
Fixes the following boot time warning: [2.230865] WARNING: at drivers/video/backlight/backlight.c:315 backlight_device_register+0x184/0x1f4() [2.240386] nec-8048: invalid backlight type We need to pass valid backlight type when the device is registered. Signed-off-by: Peter Ujfalusi ---

[PATCH 3/3] OMAPDSS: Panel NEC: Only register backlight when we have valid callback

2013-01-16 Thread Peter Ujfalusi
Do not register a backlight device when the dssdev->set_backlight callback is not set by the board. In this case either we do not have means to control the backlight or the board is using other means to control it, like bl-pwm. Signed-off-by: Peter Ujfalusi --- .../omap2/displays/panel-nec-nl804

[PATCH 2/3] OMAPDSS: Panel NEC: Get rid of nec_80848_data structure

2013-01-16 Thread Peter Ujfalusi
It has only a pointer to the backlight_device in it. We can just add the pointer to the backlight_device as driver data. Signed-off-by: Peter Ujfalusi --- .../omap2/displays/panel-nec-nl8048hl11-01b.c | 32 +- 1 file changed, 7 insertions(+), 25 deletions(-) diff --git

[PATCH 0/3] OMAPDSS: Panel NEC: backlight handling changes

2013-01-16 Thread Peter Ujfalusi
Hi Tomi, While working with Zoom2 which is using the NEC panel I noticed few issues with the panel driver. The first patch fixes one irritating warning print every time I boot the board. With the third patch we can cleanly move to bl-pwm driver to handle the backlight on Zoom2. In this case we sho

[PATCH] mmc: omap_hsmmc: MAINTAINERS: change omap_hsmmc maintenance to orphan

2013-01-16 Thread Venkatraman S
The specified email id is no longer in service. Update the OMAP HSMMC entry from the MAINTAINERS file as I will no longer be able to maintain this driver. Signed-off-by: Venkatraman S --- MAINTAINERS |4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/MAINTAINERS b/MAINTAIN

[PATCH v2 00/11] MFD: twl-core: Cleanup part 2 for 3.9

2013-01-16 Thread Peter Ujfalusi
Hello Samuel, Changes since v1: - Patch for zoom-display to avoid build issus with this set I had a patch on top of this series to move the zoom board to use bl-pwm for display backlight. Because of this I have not noticed that the zoom-display.c still have twl related code in upstream. Cover le

[PATCH v2 05/11] mfd: twl-core: Allocate twl_modules dynamically

2013-01-16 Thread Peter Ujfalusi
At boot time we can allocate the twl_modules array dynamically based on the twl class we are using with devm_kzalloc() instead of the static twl_modules[] array. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 31 +-- 1 file changed, 21 insertions(+), 10 de

[PATCH v2 09/11] mfd: twl-core: Collect global variables behind one private structure (global)

2013-01-16 Thread Peter Ujfalusi
Gather the global variables under a single structure and allocate it with devm_kzalloc(). It is easier to see them and if in the future we try to add support for multiple instance of twl in the system it is going to be much simpler. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 104

[PATCH v2 11/11] mfd: twl-core: Move twl_i2c_read/write_u8 to header as inline function

2013-01-16 Thread Peter Ujfalusi
twl_i2c_read/write_u8 become as a simple wrapper over the twl_i2c_read/write. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 28 include/linux/i2c/twl.h | 17 +++-- 2 files changed, 11 insertions(+), 34 deletions(-) diff --git a/drivers/mfd/

[PATCH v2 04/11] mfd: twl-core: Use the lookup table to find the correct subchip for the modules

2013-01-16 Thread Peter Ujfalusi
Instead of using SUB_CHIP_ID* or magic numbers use the twl_mapping table to look for the subchip ID. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 56 -- 1 file changed, 27 insertions(+), 29 deletions(-) diff --git a/drivers/mfd/twl-c

[PATCH v2 10/11] mfd: twl-core: Remove no longer valid comment regarding to write buffer size

2013-01-16 Thread Peter Ujfalusi
With the regmap conversion there is no longeer a need to allocate bigger buffer for writes Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 3 --- include/linux/i2c/twl.h | 3 --- 2 files changed, 6 deletions(-) diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c index e2895

[PATCH v2 08/11] mfd: twl-core: Move 'inuse' check early at probe time

2013-01-16 Thread Peter Ujfalusi
We can fail earlier in case multiple instance of the twl-core is tried to be loaded. The twl-core by design only supports one instance. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/drivers/mfd/twl-core.c

[PATCH v2 07/11] mfd: twl-core: Do not create dummy pdata when booted with DT

2013-01-16 Thread Peter Ujfalusi
When booted with DT we can manage without the dummy pdata. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 31 +++ 1 file changed, 7 insertions(+), 24 deletions(-) diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c index 86cca9e..547fed5 100644 -

[PATCH v2 06/11] mfd: twl-core: Do not try to call legacy mfd add_children() when booted with DT

2013-01-16 Thread Peter Ujfalusi
There is really no point to retry to add children devices in case the of_platform_populate() fails. We do not have any information provided via pdata in this case anyways. Depending on the boot type (legacy or DT) only execute either one. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c

[PATCH v2 03/11] mfd: twl-core: No need to check for invalid subchip ID

2013-01-16 Thread Peter Ujfalusi
The module id table no longer can have invalid/unused entries. No need for checking the ID for validity. Signed-off-by: Peter Ujfalusi --- drivers/mfd/twl-core.c | 13 ++--- 1 file changed, 2 insertions(+), 11 deletions(-) diff --git a/drivers/mfd/twl-core.c b/drivers/mfd/twl-core.c ind

[PATCH v2 01/11] ARM: OMAP: zoom-display: Remove the use of TWL4030_MODULE_PWM1

2013-01-16 Thread Peter Ujfalusi
Use the future proof TWL_MODULE_PWM module id instead to aim the twl-core cleanup planed for 3.9 kernel cycle. Signed-off-by: Peter Ujfalusi Acked-by: Tony Lindgren --- arch/arm/mach-omap2/board-zoom-display.c | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/ar

[PATCH v2 02/11] mfd: twl-core: Clean up module id lookup and definitions

2013-01-16 Thread Peter Ujfalusi
Use enums for all module definitions: twl_module_ids for common functionality among twl4030/twl6030 twl4030_module_ids for twl4030 specific ids twl6030_module_ids for twl6030 specific ids In this way the list can be managed easier when new functionality going to be implemented. Signed-off-by: Pet

Re: [PATCH 1/3] mtd nand : onfi need to be probed in 8 bits mode

2013-01-16 Thread Matthieu CASTET
Hi, Paul Walmsley a écrit : > Hi > > On Wed, 2 Jan 2013, Matthieu CASTET wrote: > which did not get merged because Tony requested that it should be > based on top of his cleanup work (which takes priority over adding new > features): > > http://thread.gmane.org/gmane.linux.ports.arm.omap

[RFC PATCH 3/6] usb: otg: utils: change the phy lib to support multiple PHYs of same type

2013-01-16 Thread Kishon Vijay Abraham I
In order to add support for multipe PHY's of the same type, the API's for adding PHY and getting PHY has been changed. Now the binding information of the PHY and controller should be done in platform file using usb_bind_phy API. And for getting a PHY, the device pointer of the USB controller and an

[RFC PATCH 5/6] usb: otg: add device tree support to otg library

2013-01-16 Thread Kishon Vijay Abraham I
Added an API devm_usb_get_phy_by_phandle(), to get usb phy by passing a device node phandle value. This function will return a pointer to the phy on success, -EPROBE_DEFER if there is a device_node for the phandle, but the phy has not been added, or a ERR_PTR() otherwise. Cc: Marc Kleine-Budde Si

[RFC PATCH 4/6] ARM: dts: OMAP: Add phandle to bind PHY with USB controller

2013-01-16 Thread Kishon Vijay Abraham I
Added a phandle in the dt node for usb_otg to bind the PHY with the USB controller and also updated the documentation with the binding information. Signed-off-by: Kishon Vijay Abraham I --- I'll add this patch in this series "usb: musb: add driver for control module" which contains the dt data to

[RFC PATCH 2/6] ARM: OMAP: USB: Add phy binding information

2013-01-16 Thread Kishon Vijay Abraham I
This is in preparation for the changes in PHY library to support adding and getting multiple PHYs of the same type. In the new design, the binding information between the PHY and the USB controller should be specified in the platform specific initialization code. So it's been done for OMAP platform

[RFC PATCH 1/6] usb: otg: Add an API to bind the USB controller and PHY

2013-01-16 Thread Kishon Vijay Abraham I
New platforms are added which has multiple PHY's (of same type) and which has multiple USB controllers. The binding information has to be present in the PHY library (otg.c) in order for it to return the appropriate PHY whenever the USB controller request for the PHY. So added a new API to pass the

[RFC PATCH 0/6] USB: Add multiple PHYs of same type

2013-01-16 Thread Kishon Vijay Abraham I
New platforms are being added which has multiple PHY's (of same type) and which has multiple USB controllers. The binding information has to be present in the PHY library (otg.c) in order for it to return the appropriate PHY whenever the USB controller request for the PHY. So added a new API to pas

[RFC PATCH 6/6] USB: MUSB: OMAP: get PHY by phandle for dt boot

2013-01-16 Thread Kishon Vijay Abraham I
The OMAP glue has been modified to get PHY by phandle for dt boot. Signed-off-by: Kishon Vijay Abraham I --- drivers/usb/musb/omap2430.c |7 ++- 1 file changed, 6 insertions(+), 1 deletion(-) diff --git a/drivers/usb/musb/omap2430.c b/drivers/usb/musb/omap2430.c index 3628a50..08709cf 1

Re: [PATCH 1/3] mtd nand : onfi need to be probed in 8 bits mode

2013-01-16 Thread Paul Walmsley
Hi Matthieu, On Wed, 16 Jan 2013, Matthieu CASTET wrote: > Paul Walmsley a écrit : > > On Wed, 2 Jan 2013, Matthieu CASTET wrote: > > > which did not get merged because Tony requested that it should be > > based on top of his cleanup work (which takes priority over adding new > > features

[PATCH] OMAP: omap4-panda: add WiLink shared transport power functions

2013-01-16 Thread Luciano Coelho
The code to enable and disable the WiLink shared transport has been removed from the TI-ST driver, so it must be implemented in the board files instead. Add the relevant operations to Panda's board file. Additionally, add the UART2 muxing data, so it's properly configured. Signed-off-by: Luciano

[PATCH] am33xx: cpsw: default to ethernet hwaddr from efuse if not defined in dt

2013-01-16 Thread Peter Korsgaard
When booting with CONFIG_ARM_APPENDED_DTB (either because of using an old U-Boot, not wanting the hassle of 2 files or when using Falcon fast boot mode in U-Boot), nothing updates the ethernet hwaddr specified for the CPSW slaves, causing the driver to use a random hwaddr, which is some times troub

Re: [PATCH] OMAP: omap4-panda: add WiLink shared transport power functions

2013-01-16 Thread Fabio Estevam
On Wed, Jan 16, 2013 at 6:34 PM, Luciano Coelho wrote: > +static int wilink_st_init(void) > +{ > + int status; > + > + status = gpio_request(GPIO_BT_EN, "kim"); > + if (status) { > + pr_err("%s: failed to request gpio %d\n", __func__, > + GPIO_

Re: [PATCH] OMAP: omap4-panda: add WiLink shared transport power functions

2013-01-16 Thread Luciano Coelho
On Wed, 2013-01-16 at 19:10 -0200, Fabio Estevam wrote: > On Wed, Jan 16, 2013 at 6:34 PM, Luciano Coelho wrote: > > > +static int wilink_st_init(void) > > +{ > > + int status; > > + > > + status = gpio_request(GPIO_BT_EN, "kim"); > > + if (status) { > > + pr_err("

[[PATCH v2]] OMAP: omap4-panda: add WiLink shared transport power functions

2013-01-16 Thread Luciano Coelho
The code to enable and disable the WiLink shared transport has been removed from the TI-ST driver, so it must be implemented in the board files instead. Add the relevant operations to Panda's board file. Additionally, add the UART2 muxing data, so it's properly configured. Cc: stable [3.7] Sign

[RFC] OMAP: 4430sdp: add shared trasport devices to the board file

2013-01-16 Thread Luciano Coelho
Add the btwilink, nfcwilink and shared transport devices to the board file, including functions to power things on and off. Additionally, add the UART2 muxing data, so it's properly configured. Signed-off-by: Luciano Coelho --- This is pretty much the same as the patch I just sent for panda, bu

Re: Help wanted with USB and OMAP3 off_mode

2013-01-16 Thread NeilBrown
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On Wed, 16 Jan 2013 13:11:26 +0200 Igor Grinberg wrote: > -BEGIN PGP SIGNED MESSAGE- > Hash: SHA1 > > On 01/16/13 12:19, NeilBrown wrote: > > On Wed, 16 Jan 2013 11:28:02 +0200 Igor Grinberg > > wrote: > > > >> -BEGIN PGP SIGNED MESSAG

Re: [RFC PATCH 3/6] usb: otg: utils: change the phy lib to support multiple PHYs of same type

2013-01-16 Thread Simon Horman
On Wed, Jan 16, 2013 at 08:30:59PM +0530, Kishon Vijay Abraham I wrote: > In order to add support for multipe PHY's of the same type, the API's > for adding PHY and getting PHY has been changed. Now the binding > information of the PHY and controller should be done in platform file > using usb_bind