This series updates the device trees for Gumstix Overo COMs with some
minor fixes and support for NAND, the TobiDuo expansion baords, and the
Palo35 board.
Adam YH Lee (3):
omap3: overo: Update LCD panel names
omap3: overo: Enable McBSP2 for all Overo COMs
omap3: overo: Add device tree for P
From: Adam YH Lee
Also, reduce the maximum SPI device speed to the max. supported by the
LCD controller used on the LGPhilips LB035Q02 panel for this board.
Signed-off-by: Ash Charles
---
arch/arm/boot/dts/Makefile | 2 +
arch/arm/boot/dts/omap3-overo-common-lcd35.dtsi
Some Overo COM models include NAND flash in the on-board
package-on-package (PoP) chip. Add this to the base Overo devicetree.
Most commonly, this is 512MB NAND from the Micron MT29C4G96MAZ family
but, as discussed [1], several different sized are possible. To
support different sizes, the last pa
The Gumstix "Tobi-Duo" expansion board [1] can be used with either
OMAP3 Overo or Overo Storm COMs. It provides two NICs using LAN9221
chips.
It is necessary to duplicate the interface information for the
second SMSC9221 chip as discussed [2].
[1] https://store.gumstix.com/index.php/products/241/
From: Adam YH Lee
Both Gumstix Overo and Overo Storm COMs use TWL4030 audio module
connected to the McBSP2. As such, enable the McBSP2 module in the
common device tree file, omap3-overo-base.dtsi, rather than in the
processor-specific device tree files, omap3-overo.dtsi and
omap3-overo-storm.dts
From: Adam YH Lee
For Gumstix Overo COMs, the u-boot bootloader typically passes an
argument specifying the default display via the omapdss.def_disp
parameter. When a default display is specified, DSS2 tries to match
this name with either the device tree label (e.g. label=dvi) or,
failing this,
On Fri, 12 Jun 2015, Rob Herring wrote:
> On Fri, Jun 12, 2015 at 9:05 AM, Hans Ulli Kroll
> wrote:
> >
> >
> > On Tue, 9 Jun 2015, Rob Herring wrote:
> >
> >> set_irq_flags is ARM specific with custom flags which have genirq
> >> equivalents. Convert drivers to use the genirq interfaces direct
On Fri, Jun 12, 2015 at 9:05 AM, Hans Ulli Kroll
wrote:
>
>
> On Tue, 9 Jun 2015, Rob Herring wrote:
>
>> set_irq_flags is ARM specific with custom flags which have genirq
>> equivalents. Convert drivers to use the genirq interfaces directly, so we
>> can kill off set_irq_flags. The translation of
On Tue, 9 Jun 2015, Rob Herring wrote:
> set_irq_flags is ARM specific with custom flags which have genirq
> equivalents. Convert drivers to use the genirq interfaces directly, so we
> can kill off set_irq_flags. The translation of flags is as follows:
>
> IRQF_VALID -> !IRQ_NOREQUEST
> IRQF_PR
From: Thierry Reding
The USB_DWC3_ULPI Kconfig entry uses a UTF-8 non-breaking space (0xca20)
instead of a regular ASCII space (0x20). Commit 2e0d737fc76f ("kconfig:
don't silently ignore unhandled characters") exposes this by warning
about unhandled characters.
Signed-off-by: Thierry Reding
--
On Thu, Jun 04, 2015 at 06:58:06PM +0300, Peter Ujfalusi wrote:
> Vinod,
>
> On 06/02/2015 03:55 PM, Vinod Koul wrote:
> > On Fri, May 29, 2015 at 05:32:50PM +0300, Peter Ujfalusi wrote:
> >> On 05/29/2015 01:18 PM, Vinod Koul wrote:
> >>> On Fri, May 29, 2015 at 11:42:27AM +0200, Geert Uytterhoev
On 09/06/15 01:30, Kees Cook wrote:
> Since kobject_init_and_add takes a format string, make sure that the
> passed in name cannot be accidentally parsed.
>
> Signed-off-by: Kees Cook
> ---
> drivers/video/fbdev/omap2/dss/display-sysfs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
On 10.06.2015 03:26, Rob Herring wrote:
> set_irq_flags is ARM specific with custom flags which have genirq
> equivalents. Convert drivers to use the genirq interfaces directly, so we
> can kill off set_irq_flags. The translation of flags is as follows:
>
> IRQF_VALID -> !IRQ_NOREQUEST
> IRQF_PROB
The if statement condition should have been "!node ||
!of_device_is_available(node)" (&& changed to ||), but let's rewrite
the whole inside of the loop for better readability.
Reported-by: Dan Carpenter
Signed-off-by: Jyri Sarha
---
drivers/gpu/drm/tilcdc/tilcdc_external.c | 19
Since 39b2bbe3d715 (gpio: add flags argument to gpiod_get*() functions)
which appeared in v3.17-rc1, the gpiod_get* functions take an additional
parameter that allows to specify direction and initial value for output.
Furthermore there is devm_gpiod_get_optional which is designed to get
optional g
15 matches
Mail list logo