On Tue, Jul 28, 2015 at 02:11:15PM +0530, Vignesh R wrote:
> Add qspi memory mapped region entries for DRA7xx based SoCs.
>
> Signed-off-by: Vignesh R
> ---
> arch/arm/boot/dts/am4372.dtsi | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/arch/arm/boot/dts/am4372.dtsi
On Tue, Jul 28, 2015 at 02:11:15PM +0530, Vignesh R wrote:
> Add qspi memory mapped region entries for DRA7xx based SoCs.
>
> Signed-off-by: Vignesh R
> qspi: qspi@4790 {
> compatible = "ti,am4372-qspi";
> - reg = <0x4790 0x100>;
>
On Tue, Jul 28, 2015 at 02:11:12PM +0530, Vignesh R wrote:
> Introduce use_mmap_read field in spi_message struct. This can be set by
> mtd devices (m25p80) to indicate to spi-master (ti-qspi) to perform
> memory mapped read. This helps to distinguish whether the spi-message is
> from mtd layer(hen
On Fri, Jul 31, 2015 at 11:29 AM, Ran Shalit wrote:
> On Thu, Jul 30, 2015 at 9:49 PM, Ran Shalit wrote:
>> Hello,
>>
>> I hope some will have some idea:
>> I am using iperf to check bandwidth and I see that with small tcp
>> windows in the test there is always high degredation in performance
>>
On Thu, Jul 30, 2015 at 9:49 PM, Ran Shalit wrote:
> Hello,
>
> I hope some will have some idea:
> I am using iperf to check bandwidth and I see that with small tcp
> windows in the test there is always high degredation in performance
> compared to version without cpuidle.
> I've noticed that C3 s
From: Robert Baldyga
> Sent: 31 July 2015 15:00
> Introduce struct usb_ep_caps which contains information about capabilities
> of usb endpoints - supported transfer types and directions. This structure
> should be filled by UDC driver for each of its endpoints, and will be
> used in epautoconf in n
Hi,
On Fri, Jul 31, 2015 at 03:51:52PM +, David Laight wrote:
> From: Robert Baldyga
> > Sent: 31 July 2015 15:00
> > Introduce struct usb_ep_caps which contains information about capabilities
> > of usb endpoints - supported transfer types and directions. This structure
> > should be filled b
Hi Roger,
Looks good to me. But, I add one comment about mdelay.
If you modify it, you can add my acked-by message.
Acked-by: Chanwoo Choi
Also, You must recevie the ack message from MFD maintainer (Lee Jones).
On Fri, Jul 31, 2015 at 8:08 PM, Roger Quadros wrote:
> Some palmas based chip var
Hi Grygorii,
On Wednesday 29 July 2015 05:39 PM, Grygorii Strashko wrote:
> On 07/29/2015 02:09 PM, Kishon Vijay Abraham I wrote:
>> Since vmmc can be optional for some platforms, use
>> devm_regulator_get_optional() for vmmc. Now return error only
>> in the case of -EPROBE_DEFER and for all other
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/fsl_qe_udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/fsl_qe_udc.c
b/drivers/usb/gadget/udc/fsl_qe_udc.c
index e0822f1..5fb6f8b 10064
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/dwc3/gadget.c | 13 +
1 file changed, 13 insertions(+)
diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
index 2feed9e..bd4c3db 100644
--- a/drivers/usb/dwc3/gadg
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/dwc2/gadget.c | 13 +
1 file changed, 13 insertions(+)
diff --git a/drivers/usb/dwc2/gadget.c b/drivers/usb/dwc2/gadget.c
index 731b13d..3ee5b4c 100644
--- a/drivers/usb/dwc2/gadg
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/chipidea/udc.c | 14 ++
1 file changed, 14 insertions(+)
diff --git a/drivers/usb/chipidea/udc.c b/drivers/usb/chipidea/udc.c
index b7cca3e..4aaa476 100644
--- a/drivers/usb/chipi
So far it was necessary for usb functions to set ep->driver_data in
endpoint obtained from autoconfig to non-null value, to indicate that
endpoint is claimed by function (in autoconfig it was checked if endpoint
has set this field to non-null value, and if it has, it was assumed that
it is claimed)
Hello,
This patch series reworks endpoint matching and claiming mechanism in
epautoconf. From v2 there are couple of new patches adding 'ep_match'
to usb_gadget_ops and removing chip-specific quirk handling from generic
code of autoconfig.
I'm not sure if this patch set isn't too long, as it has
Introduce struct usb_ep_caps which contains information about capabilities
of usb endpoints - supported transfer types and directions. This structure
should be filled by UDC driver for each of its endpoints, and will be
used in epautoconf in new ep matching mechanism which will replace ugly
guessin
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/fotg210-udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/fotg210-udc.c
b/drivers/usb/gadget/udc/fotg210-udc.c
index a99ed6d..6ba122c 10
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/fsl_udc_core.c | 13 +
1 file changed, 13 insertions(+)
diff --git a/drivers/usb/gadget/udc/fsl_udc_core.c
b/drivers/usb/gadget/udc/fsl_udc_core.c
index c60022b..aab52
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/fusb300_udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/fusb300_udc.c
b/drivers/usb/gadget/udc/fusb300_udc.c
index 3970f45..948845c 10
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/at91_udc.c | 38 +-
1 file changed, 29 insertions(+), 9 deletions(-)
diff --git a/drivers/usb/gadget/udc/at91_udc.c
b/drivers/usb/gadget/udc/at
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/dummy_hcd.c | 95 --
1 file changed, 80 insertions(+), 15 deletions(-)
diff --git a/drivers/usb/gadget/udc/dummy_hcd.c
b/drivers/usb/gadget/udc
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/bcm63xx_udc.c | 29 +
1 file changed, 25 insertions(+), 4 deletions(-)
diff --git a/drivers/usb/gadget/udc/bcm63xx_udc.c
b/drivers/usb/gadget/udc/bcm63
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/amd5536udc.c | 88 -
1 file changed, 78 insertions(+), 10 deletions(-)
diff --git a/drivers/usb/gadget/udc/amd5536udc.c
b/drivers/usb/gadget/ud
As function ep_matches() is used to match endpoint with usb descriptor it's
highly unintuitive that it modifies endpoint and descriptor structures fields.
This patch moves code configuring ep and desc from ep_matches() to
usb_ep_autoconfig_ss(), so now function ep_matches() does nothing more than
i
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/mv_u3d_core.c | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/usb/gadget/udc/mv_u3d_core.c
b/drivers/usb/gadget/udc/mv_u3d_core.c
index ea35a24..4c48969 100644
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/gr_udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/gr_udc.c b/drivers/usb/gadget/udc/gr_udc.c
index c886887..8aa2593 100644
--- a/drive
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/mv_udc_core.c | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/usb/gadget/udc/mv_udc_core.c
b/drivers/usb/gadget/udc/mv_udc_core.c
index 5da37c9..339af51 100644
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/goku_udc.c | 8
1 file changed, 8 insertions(+)
diff --git a/drivers/usb/gadget/udc/goku_udc.c
b/drivers/usb/gadget/udc/goku_udc.c
index 9e8d842..46b8d14 100644
--- a/dri
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/lpc32xx_udc.c | 32
1 file changed, 32 insertions(+)
diff --git a/drivers/usb/gadget/udc/lpc32xx_udc.c
b/drivers/usb/gadget/udc/lpc32xx_udc.c
inde
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/pch_udc.c | 14 --
1 file changed, 12 insertions(+), 2 deletions(-)
diff --git a/drivers/usb/gadget/udc/pch_udc.c b/drivers/usb/gadget/udc/pch_udc.c
index dcf5def..fa9e
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/net2272.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/net2272.c b/drivers/usb/gadget/udc/net2272.c
index c2ed5da..18f5ebd 100644
--- a/dr
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/omap_udc.c | 22 ++
1 file changed, 22 insertions(+)
diff --git a/drivers/usb/gadget/udc/omap_udc.c
b/drivers/usb/gadget/udc/omap_udc.c
index e2fcdb8..9b7d394
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/m66592-udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/m66592-udc.c
b/drivers/usb/gadget/udc/m66592-udc.c
index 9704053..b1cfa96 10064
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/net2280.c | 67 +---
1 file changed, 55 insertions(+), 12 deletions(-)
diff --git a/drivers/usb/gadget/udc/net2280.c b/drivers/usb/gadget/udc/ne
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/pxa25x_udc.c | 32
1 file changed, 32 insertions(+)
diff --git a/drivers/usb/gadget/udc/pxa25x_udc.c
b/drivers/usb/gadget/udc/pxa25x_udc.c
index 2
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/pxa27x_udc.h | 40 +++--
1 file changed, 25 insertions(+), 15 deletions(-)
diff --git a/drivers/usb/gadget/udc/pxa27x_udc.h
b/drivers/usb/gadget/ud
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/r8a66597-udc.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/usb/gadget/udc/r8a66597-udc.c
b/drivers/usb/gadget/udc/r8a66597-udc.c
index 0293f71..baa0609
Introduce endpoint matching mechanism basing on endpoint capabilities
flags. We check if endpoint supports transfer type and direction requested
in ep descriptor. Since we have this new endpoint matching mechanism
there is no need to have old code guessing endpoint capabilities basing
on its name,
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/atmel_usba_udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/gadget/udc/atmel_usba_udc.c
b/drivers/usb/gadget/udc/atmel_usba_udc.c
index 37d414e..2
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/s3c2410_udc.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/usb/gadget/udc/s3c2410_udc.c
b/drivers/usb/gadget/udc/s3c2410_udc.c
index 5d9aa81..eb3571e 100
The same effect can be achieved by using capabilities flags, so now we can
get rid of handling of hardware specific limitations in generic code.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/epautoconf.c | 5 -
drivers/usb/gadget/udc/pxa25x_udc.c | 9 +++--
2 files changed, 3
Rework ep_matches() function to make it shorter and more readable.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/epautoconf.c | 87 +
1 file changed, 35 insertions(+), 52 deletions(-)
diff --git a/drivers/usb/gadget/epautoconf.c b/drivers/usb/gadge
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/isp1760/isp1760-udc.c | 11 +++
1 file changed, 11 insertions(+)
diff --git a/drivers/usb/isp1760/isp1760-udc.c
b/drivers/usb/isp1760/isp1760-udc.c
index 3699962..1c3d0fd 100644
---
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/musb/musb_gadget.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/usb/musb/musb_gadget.c b/drivers/usb/musb/musb_gadget.c
index 9e18178..4150baf 100644
--- a/drivers
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/udc-xilinx.c | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/usb/gadget/udc/udc-xilinx.c
b/drivers/usb/gadget/udc/udc-xilinx.c
index 1f24274..1cbb0ac 100644
--
Add callback that is called by epautoconf to allow UDC driver match the
best endpoint for specific descriptor. It's intended to supply mechanism
which allows to get rid of chip-specific endpoint matching code from
epautoconf.
If gadget has set 'ep_match' callback we prefer to call it first, and
if
Add 'match_ep' callback to utilize chip-specific knowledge in endpoint matching
process. Function does the same that was done by chip-specific code inside
of epautoconf. Now this code can be removed from there to separate generic code
from platform specific logic.
Signed-off-by: Robert Baldyga
--
Add 'match_ep' callback to utilize chip-specific knowledge in endpoint matching
process. Function does the same that was done by chip-specific code inside
of epautoconf. Now this code can be removed from there to separate generic code
from platform specific logic.
Signed-off-by: Robert Baldyga
--
Move find_ep() function to gadget.h, rename it to gadget_find_ep_by_name()
and make it static inline. It can be used in UDC drivers, especially in
'match_ep' callback after moving chip-specific endpoint matching logic from
epautoconf to UDC drivers.
Replace all calls of find_ep() function with gad
Add 'match_ep' callback to utilize chip-specific knowledge in endpoint matching
process. Function does the same that was done by chip-specific code inside
of epautoconf. Now this code can be removed from there to separate generic code
from platform specific logic.
Signed-off-by: Robert Baldyga
--
Move ep_matches() function to udc-core and rename it to
usb_gadget_ep_match_desc(). This function can be used by UDC drivers
in 'match_ep' callback to avoid writing lots of repetitive code.
Replace all calls of ep_matches() with usb_gadget_ep_match_desc().
Signed-off-by: Robert Baldyga
---
driv
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/renesas_usbhs/mod_gadget.c | 6 ++
1 file changed, 6 insertions(+)
diff --git a/drivers/usb/renesas_usbhs/mod_gadget.c
b/drivers/usb/renesas_usbhs/mod_gadget.c
index 494dfe0..de4f97d 100
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/s3c-hsudc.c | 15 +++
1 file changed, 15 insertions(+)
diff --git a/drivers/usb/gadget/udc/s3c-hsudc.c
b/drivers/usb/gadget/udc/s3c-hsudc.c
index 85a712a..e9def42 1006
Convert endpoint configuration to new capabilities model.
Signed-off-by: Robert Baldyga
---
drivers/usb/gadget/udc/bdc/bdc_ep.c | 9 +
1 file changed, 9 insertions(+)
diff --git a/drivers/usb/gadget/udc/bdc/bdc_ep.c
b/drivers/usb/gadget/udc/bdc/bdc_ep.c
index b04980c..f9a8f57 100644
--
Add macros useful while initializing array of endpoint capabilities
structures. These macros makes structure initialization more compact
to decrease number of code lines and increase readability of code.
Signed-off-by: Robert Baldyga
---
include/linux/usb/gadget.h | 20
1 fi
Convert endpoint configuration to new capabilities model.
Fixed typo in "epc-nulk" to "epc-bulk".
Signed-off-by: Robert Baldyga
---
drivers/staging/emxx_udc/emxx_udc.c | 73 +
1 file changed, 42 insertions(+), 31 deletions(-)
diff --git a/drivers/staging/emx
On Tuesday 28 July 2015 02:11 PM, Vignesh R wrote:
> Add qspi memory mapped region entries for DRA7xx based SoCs.
>
> Signed-off-by: Vignesh R
> ---
> arch/arm/boot/dts/am4372.dtsi | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/arch/arm/boot/dts/am4372.dtsi b/arch/a
DRA7xx require MSE bit to be cleared to set the master in
standby mode. (In DRA7xx TRM_vE, section 24.9.4.5.2.2.1 PCIe
Controller Master Standby Behavior advises to use the clearing
of the local MSE bit to set the master in standby. Without this
some of the clocks do not idle).
Cleared the MSE bit
Fix the error handling code in case pm_runtime_get_sync fails. Now
when pm_runtime_get_sync fails pm_runtime_disable is invoked so that
there is no unbalanced pm_runtime_enable calls.
Signed-off-by: Kishon Vijay Abraham I
---
drivers/pci/host/pci-dra7xx.c |4 +++-
1 file changed, 3 insertion
Add PM support to pci-dra7xx so that PCI clocks can be disabled
during suspend and enabled back during resume without affecting
PCI functionality.
Signed-off-by: Kishon Vijay Abraham I
---
drivers/pci/host/pci-dra7xx.c | 51 +
1 file changed, 51 insertio
This series adds PM support to pci-dra7xx so that PCI clocks can be disabled
during suspend and enabled back during resume without affecting
PCI functionality.
Changes from v4:
*) Fixed a bug caused by sending incomplete patch.
Changes from v3:
*) Fix compilation errors when individual patches ar
Some palmas based chip variants do not have OTG based ID logic.
For these variants we rely on GPIO based USB ID detection.
These chips do have VBUS comparator for VBUS detection so we
continue to use the old way of detecting VBUS.
Signed-off-by: Roger Quadros
---
v3:
-rebased on extcon-next.
-
On Wed, Jul 08, 2015 at 04:35:27PM +0200, Jan Luebbe wrote:
> At least on the AM335x, enabling OMAP_I2C_SYSTEST_ST_EN is not enough to
> allow direct access to the SCL and SDA pins. In addition to ST_EN, we
> need to set the TMODE to 0b11 (Loop back & SDA/SCL IO mode select).
> Also, as the reset v
On Wed, Jul 08, 2015 at 04:35:06PM +0200, Jan Luebbe wrote:
> Using set_scl may be ineffective before calling the driver specific
> prepare_recovery callback, which might change into a test mode. So
> instead of setting SCL in i2c_generic_scl_recovery, move it to
> i2c_generic_recovery (after the o
On Wed, Jul 29, 2015 at 12:27:30PM +0200, Jan Lübbe wrote:
> On Di, 2015-07-14 at 14:12 +0200, Wolfram Sang wrote:
> > On Tue, Jul 14, 2015 at 03:10:01PM +0300, Grygorii Strashko wrote:
> > > Hi Wolfram,
> > >
> > > On 07/14/2015 02:10 PM, Wolfram Sang wrote:
> > > > On Wed, Jul 08, 2015 at 04:35:
On Tue, Jul 14, 2015 at 02:10:47PM +0200, Wolfram Sang wrote:
> Patch "i2c: omap: abolish variable name confusion" triggered a
> coccinelle warning which we fix here:
>
> drivers/i2c/busses/i2c-omap.c:1333:5-24: pm_runtime_get_sync returns < 0 as
> error. Unecessary IS_ERR_VALUE at line 1334
>
>
On 29/07/15 15:06, Roger Quadros wrote:
> Tony,
>
> On 13/07/15 15:40, Tony Lindgren wrote:
>> * Roger Quadros [150713 03:07]:
>>> Tony,
>>>
>>> On 13/07/15 10:10, Tony Lindgren wrote:
* Roger Quadros [150710 05:26]:
> Since the Interrupt Events are used only by the NAND driver,
> t
Hi Chanwoo,
On 31/07/15 10:46, Chanwoo Choi wrote:
> Hi Roger,
>
> When I apply it for build test, merge conflict happen.
> So, I recommend that you rebase this patchset on extcon-next branch.
Alright.
>
> On 07/27/2015 10:10 PM, Roger Quadros wrote:
>> Some palmas based chip variants do not h
Hi Roger,
When I apply it for build test, merge conflict happen.
So, I recommend that you rebase this patchset on extcon-next branch.
On 07/27/2015 10:10 PM, Roger Quadros wrote:
> Some palmas based chip variants do not have OTG based ID logic.
> For these variants we rely on GPIO based USB ID de
69 matches
Mail list logo