Re: [PATCH v2 00/13] drivers: mailbox: framework creation

2013-02-13 Thread Loic PALLARDY
Hi Suman, I'll send new version of patch 11 taking into account Mark Rutland's comments. Regards, Loic On 02/13/2013 05:41 PM, Anna, Suman wrote: On Wed, Feb 13, 2013 at 02:36:32PM +0100, Linus Walleij wrote: On Tue, Feb 12, 2013 at 5:56 AM, Suman Annas-a...@ti.com wrote: I have hosted

[PATCH v3 10/13] mailbox: create dbx500 mailbox driver

2013-02-13 Thread Loic Pallardy
From: Loic Pallardy loic.palla...@st.com Add STEriccson DBX500 PRCM mailbox support. Change-Id: I36cbef646e26469a9490d46a5e143667aa93d762 Signed-off-by: Loic Pallardy loic.palla...@st.com Signed-off-by: Linus Walleij linus.wall...@linaro.org --- .../devicetree/bindings/mailbox/dbx500

Re: [PATCH v3 10/13] mailbox: create dbx500 mailbox driver

2013-02-13 Thread Loic PALLARDY
Sorry my mistake, I forgot to clean this before sending. Regards, Loic On 02/13/2013 09:55 PM, Greg Kroah-Hartman wrote: On Wed, Feb 13, 2013 at 09:42:07PM +0100, Loic Pallardy wrote: From: Loic Pallardyloic.palla...@st.com Add STEriccson DBX500 PRCM mailbox support. Change-Id

[PATCH v4 10/13] mailbox: create dbx500 mailbox driver

2013-02-13 Thread Loic Pallardy
From: Loic Pallardy loic.palla...@st.com Add STEriccson DBX500 PRCM mailbox support. Signed-off-by: Loic Pallardy loic.palla...@st.com Signed-off-by: Linus Walleij linus.wall...@linaro.org --- .../devicetree/bindings/mailbox/dbx500-mailbox.txt | 27 + drivers/mailbox/Kconfig

Re: [PATCH v2 10/13] mailbox: create dbx500 mailbox driver

2013-02-12 Thread Loic PALLARDY
Hi Mark, Thanks for your comments. On 02/12/2013 11:39 AM, Mark Rutland wrote: Hello, I have a few comments on the devicetree binding and the way it's parsed. +static const struct of_device_id dbx500_mailbox_match[] = { + { .compatible = stericsson,db8500-mailbox, +

Re: [PATCH 1/9] mailbox: OMAP: introduce mailbox framework

2013-01-09 Thread Loic PALLARDY
Hi Vaibhav, On 01/09/2013 01:11 PM, Bedia, Vaibhav wrote: Hi Loic, On Fri, Dec 21, 2012 at 16:23:24, Loic PALLARDY wrote: On 12/21/2012 11:49 AM, Bedia, Vaibhav wrote: On Fri, Dec 21, 2012 at 14:24:26, Loic PALLARDY wrote: I have a few patches which are dependent on this patch series

Re: [PATCH 0/9] drivers: mailbox: framework creation

2012-12-21 Thread Loic PALLARDY
On 12/21/2012 08:31 AM, Ohad Ben-Cohen wrote: On Thu, Dec 20, 2012 at 9:19 PM, Olof Johanssono...@lixom.net wrote: While we can make the branch stable, would it make sense to make remoteproc for omap depend on !multiplatform during the transition, to reduce dependencies a little? Either way

Re: [PATCH 1/9] mailbox: OMAP: introduce mailbox framework

2012-12-21 Thread Loic PALLARDY
On 12/18/2012 05:59 PM, Tony Lindgren wrote: * Loic Pallardyloic.pallardy-...@stericsson.com [121218 05:15]: Signed-off-by: Omar Ramirez Lunaomar.l...@linaro.org AFAIK the first two patches should have: From: Omar Ramirez Lunaomar.l...@linaro.org Yes right, my mistake. I'll fix that on

Re: [PATCH 4/9] mailbox: create opened message type

2012-12-21 Thread Loic PALLARDY
On 12/21/2012 11:28 AM, Bedia, Vaibhav wrote: On Tue, Dec 18, 2012 at 18:40:07, Loic Pallardy wrote: -msg = mbox_read_reg(fifo-data); -msg |= ((mbox_msg_t) mbox_read_reg(fifo-cmd)) 16; +msg-header = mbox_read_reg(fifo-data); +msg-header |= ((mbox_msg_t) mbox_read_reg(fifo

Re: [PATCH 5/9] mailbox: change protection mechanisms

2012-12-21 Thread Loic PALLARDY
On 12/21/2012 11:28 AM, Bedia, Vaibhav wrote: On Tue, Dec 18, 2012 at 18:40:08, Loic Pallardy wrote: TX: replace spin by mutex RX: replace spin_lock_irq by spin_lock_irqsave Can you please add a short note on why this is being done? Ok I'll add more information in commit message in next

Re: [PATCH 1/9] mailbox: OMAP: introduce mailbox framework

2012-12-21 Thread Loic PALLARDY
On 12/21/2012 11:49 AM, Bedia, Vaibhav wrote: On Fri, Dec 21, 2012 at 14:24:26, Loic PALLARDY wrote: I have a few patches which are dependent on this patch series. Could you please keep me in cc for the future versions. Sure, I'll. /Loic Thanks, Vaibhav-- To unsubscribe from this list

[PATCH 0/9] drivers: mailbox: framework creation

2012-12-18 Thread Loic Pallardy
omar.l...@linaro.org Signed-off-by: Loic Pallardy loic.palla...@st.com Based on 3.7-rc7. Loic Pallardy (9): mailbox: OMAP: introduce mailbox framework mailbox: split internal header from API header mailbox: rename omap_mbox in mailbox mailbox: create opened message type mailbox: change

[PATCH 4/9] mailbox: create opened message type

2012-12-18 Thread Loic Pallardy
Current message type is a u32 to fit HW fifo format. This should be extended to support any message exchanges and type of mailbox. Propose structure owns the original u32 and an optional pointer on additional data. Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/Kconfig

[PATCH 1/9] mailbox: OMAP: introduce mailbox framework

2012-12-18 Thread Loic Pallardy
Actually moving it from plat-omap, as this framework/driver code is supposed to be under drivers/ folder. The framework should work with the current supported OMAP processors (OMAP1+) that have mailbox and can be used as a method of interprocessor communication. The mailbox hardware (in OMAP)

[PATCH 6/9] mailbox: add shared memory mailbox type

2012-12-18 Thread Loic Pallardy
Some mailboxes are made up of cross interrupts and associated shared memory. Shared memory mapping is fixed and cross interrupt/shared memory relation make impossible the use of virtio. Mailbox framework must be enough opened to support any kind of mailbox. Signed-off-by: Loic Pallardy loic.palla

[PATCH 3/9] mailbox: rename omap_mbox in mailbox

2012-12-18 Thread Loic Pallardy
In order to create a generic mailbox framework, functions and structures should be renamed in mailbox. Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/Kconfig | 3 +- drivers/mailbox/mailbox-omap1.c | 28 - drivers/mailbox/mailbox-omap2.c | 60

[PATCH 5/9] mailbox: change protection mechanisms

2012-12-18 Thread Loic Pallardy
TX: replace spin by mutex RX: replace spin_lock_irq by spin_lock_irqsave Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/mailbox.c | 10 ++ drivers/mailbox/mailbox.h | 1 + 2 files changed, 7 insertions(+), 4 deletions(-) diff --git a/drivers/mailbox/mailbox.c b

[PATCH 8/9] mailbox: add no_irq send message

2012-12-18 Thread Loic Pallardy
For debug purpose, mailbox must be available when interrupts are disabled to collect dump information. Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/mailbox.c | 66 +++ include/linux/mailbox.h | 3 +++ 2 files changed, 69

[PATCH 9/9] mailbox: create dbx500 mailbox driver

2012-12-18 Thread Loic Pallardy
Add STEriccson DBX500 PRCM mailbox support. Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/Kconfig | 18 +- drivers/mailbox/Makefile | 1 + drivers/mailbox/mailbox-dbx500.c | 601 +++ include

[PATCH 2/9] mailbox: split internal header from API header

2012-12-18 Thread Loic Pallardy
Now internal structures can remain hidden to the user and just API related functions and defines are made available. Signed-off-by: Omar Ramirez Luna omar.l...@linaro.org --- drivers/mailbox/mailbox.c | 34 ++ drivers/mailbox/mailbox.h | 44

[PATCH 7/9] mailbox: add IRQF_NO_SUSPEND flag

2012-12-18 Thread Loic Pallardy
Coprocessor must be accessible during suspend transitions. Signed-off-by: Loic Pallardy loic.palla...@st.com --- drivers/mailbox/mailbox.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/mailbox/mailbox.c b/drivers/mailbox/mailbox.c index c0a8e49..57cb566 100644

Re: [PATCH v2 2/2] mailbox: split internal header from API header

2012-11-06 Thread Loic PALLARDY
On 11/06/2012 03:55 AM, Omar Ramirez Luna wrote: Now internal structures can remain hidden to the user and just API related functions and defines are made available. Signed-off-by: Omar Ramirez Lunaomar.l...@linaro.org --- drivers/mailbox/mailbox.c | 34

Re: [PATCH 1/2] ARM: OMAP2+: move mailbox.h out of plat-omap headers

2012-10-31 Thread Loic PALLARDY
Hi Omar, On 10/31/2012 08:22 AM, Omar Ramirez Luna wrote: As part of plat-omap code cleanup, I was planning to move omap-mailbox framework to a newly drivers/mailbox folder, right now this code is specific to OMAP platforms, but with some clean up it could be the base for a generic