[PATCH] opensm/osm_db_files.c: remove bad free() call

2010-09-07 Thread Yevgeny Kliteynik
p_key is a parameter, and it is char[]. It shouldn't be freed here. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_db_files.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/opensm/opensm/osm_db_files.c b/opensm/opensm/osm_db_files.c

[PATCH] opensm/osm_mtree.c: removing useless 'if' statement

2010-09-07 Thread Yevgeny Kliteynik
p_mtn-max_children is an array - no point checking if it is NULL. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_mtree.c |9 - 1 files changed, 4 insertions(+), 5 deletions(-) diff --git a/opensm/opensm/osm_mtree.c b/opensm/opensm/osm_mtree.c index

[PATCH] opensm/osm_ucast_cache.c: fix potential seg fault

2010-09-07 Thread Yevgeny Kliteynik
Fix potential seg fault when NULL is returned Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_ucast_cache.c |8 1 files changed, 8 insertions(+), 0 deletions(-) diff --git a/opensm/opensm/osm_ucast_cache.c b/opensm/opensm/osm_ucast_cache.c index

[PATCH] opensm/osm_pkey.c: removing unused function

2010-09-07 Thread Yevgeny Kliteynik
Removing unused (and, may I add, buggy) function. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_pkey.c | 10 -- 1 files changed, 0 insertions(+), 10 deletions(-) diff --git a/opensm/opensm/osm_pkey.c b/opensm/opensm/osm_pkey.c index aa7b690..4c5a852

[PATCH] opensm/osm_sminfo_rcv.c: removing unused variable

2010-09-07 Thread Yevgeny Kliteynik
Removing variable that was never used outside CL_ASSERT() statement. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_sminfo_rcv.c |5 + 1 files changed, 1 insertions(+), 4 deletions(-) diff --git a/opensm/opensm/osm_sminfo_rcv.c

[PATCH] opensm/osm_sa_pkey_record.c: removing unused variable

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_sa_pkey_record.c |3 --- 1 files changed, 0 insertions(+), 3 deletions(-) diff --git a/opensm/opensm/osm_sa_pkey_record.c b/opensm/opensm/osm_sa_pkey_record.c index 5b1c794..e4930d0 100644 ---

[PATCH] opensm/osm_node_info_rcv.c: remove useless code line

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_node_info_rcv.c |1 - 1 files changed, 0 insertions(+), 1 deletions(-) diff --git a/opensm/opensm/osm_node_info_rcv.c b/opensm/opensm/osm_node_info_rcv.c index d24e757..1041e42 100644 ---

[PATCH] opensm/osm_sa_vlarb_record.c: removed unused variable

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_sa_vlarb_record.c |3 --- 1 files changed, 0 insertions(+), 3 deletions(-) diff --git a/opensm/opensm/osm_sa_vlarb_record.c b/opensm/opensm/osm_sa_vlarb_record.c index 36cbac1..d32fdb1 100644 ---

[PATCH] opensm/osm_mesh.c: fixing a bug in compare_switches()

2010-09-07 Thread Yevgeny Kliteynik
I'm pretty sure that ; at the end of if statement is not supposed to be there (not sure how it worked till now though). Also, making this condition a bit more readable. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_mesh.c |3 ++- 1 files changed, 2

[PATCH] osmtest/osmtest.c: handle timeouts in PR stress test

2010-09-07 Thread Yevgeny Kliteynik
There was some preparation code for handling PathRecord timeouts in SA stress codes: variable num_timeouts exists, and it's value is checked. What was missing is actually increasing the num_timeouts value when timeout happens. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il ---

[PATCH] opensm/osm_helper.c: fix potential overrun of the array

2010-09-07 Thread Yevgeny Kliteynik
Max index of the ib_sm_method_str[] static array is 0x20. Fixing OSM_SM_METHOD_STR_UNKNOWN_VAL to match this value. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_helper.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git

[PATCH] opensm/osm_helper.c: cosmetics - move define closer to the relevant code

2010-09-07 Thread Yevgeny Kliteynik
OSM_SA_METHOD_STR_UNKNOWN_VAL refers to ib_sa_method_str[]. Moving it closer to the array. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_helper.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git a/opensm/opensm/osm_helper.c

[PATCH] opensm/osm_subnet.c: fixing small bug in error path

2010-09-07 Thread Yevgeny Kliteynik
Closing file on failure Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_subnet.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/opensm/opensm/osm_subnet.c b/opensm/opensm/osm_subnet.c index d5c5ab2..149ab85 100644 ---

[PATCH] opensm/osm_db_files.c: fix small memory leak

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_db_files.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/opensm/opensm/osm_db_files.c b/opensm/opensm/osm_db_files.c index c475004..603bcf2 100644 --- a/opensm/opensm/osm_db_files.c +++

[PATCH] osmtest/osmt_slvl_vl_arb.c: handling fopen() failure

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/osmtest/osmt_slvl_vl_arb.c |9 - 1 files changed, 8 insertions(+), 1 deletions(-) diff --git a/opensm/osmtest/osmt_slvl_vl_arb.c b/opensm/osmtest/osmt_slvl_vl_arb.c index d3919fb..d4a08ff 100644 ---

[PATCH] opensm/osm_ucast_ftree.c: fix small memory leak in error path

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_ucast_ftree.c |4 +++- 1 files changed, 3 insertions(+), 1 deletions(-) diff --git a/opensm/opensm/osm_ucast_ftree.c b/opensm/opensm/osm_ucast_ftree.c index 88ea344..fb46d0f 100644 ---

[PATCH] opensm/osm_console.c: fix memory and file descriptor leaks

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_console.c |9 ++--- 1 files changed, 6 insertions(+), 3 deletions(-) diff --git a/opensm/opensm/osm_console.c b/opensm/opensm/osm_console.c index bc7bea3..29a6c83 100644 --- a/opensm/opensm/osm_console.c

[PATCH] opensm/osm_ucast_lash.c: small bug in calculating allocated size

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_ucast_lash.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/opensm/opensm/osm_ucast_lash.c b/opensm/opensm/osm_ucast_lash.c index 4669946..2081296 100644 ---

[PATCH] opensm/osm_pkey_mgr.c: fixing small memory leak

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_pkey_mgr.c |1 + 1 files changed, 1 insertions(+), 0 deletions(-) diff --git a/opensm/opensm/osm_pkey_mgr.c b/opensm/opensm/osm_pkey_mgr.c index 1e98c82..612130c 100644 --- a/opensm/opensm/osm_pkey_mgr.c +++

[PATCH] opensm/osm_ucast_file.c: closing file descriptor in error path

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_ucast_file.c | 38 ++ 1 files changed, 22 insertions(+), 16 deletions(-) diff --git a/opensm/opensm/osm_ucast_file.c b/opensm/opensm/osm_ucast_file.c index 8cb3cb6..fef77a2

Re: [PATCHv10 02/12] ib_core: IBoE CMA device binding

2010-09-07 Thread Eli Cohen
On Thu, Sep 02, 2010 at 01:10:17PM -0700, Roland Dreier wrote: Please just resend this, thanks. Here's the new code. I added a function that tries to find a match for a given port, istead of ib_find_cached_gid() which searches all the ports. I tested this on a machine with two cards with

Re: [PATCH] opensm/osm_console.c: fix memory and file descriptor leaks

2010-09-07 Thread Yevgeny Kliteynik
On 07-Sep-10 6:20 PM, Ira Weiny wrote: Hi Yevgeny, On Tue, 7 Sep 2010 08:12:58 -0700 Yevgeny Kliteynikklit...@mellanox.co.il wrote: Signed-off-by: Yevgeny Kliteynikklit...@dev.mellanox.co.il --- opensm/opensm/osm_console.c |9 ++--- 1 files changed, 6 insertions(+), 3

[PATCH] RDMA/nes: correct register write in set TX pause param

2010-09-07 Thread Chien Tung
Set TX pause param is writing to the wrong register location causing the adpater to hang. Correct the define used to write the reigster. This fixes OFED bug #2116. https://bugs.openfabrics.org/show_bug.cgi?id=2116 Reported-by: Shiri Franchi shi...@voltaire.com Signed-off-by: Chien Tung

git.openfabrics.org DNS names

2010-09-07 Thread Sasha Khapyorsky
Hi, What is going with git.openfabrics.org names? Seems that it is pointed another machine now without git and gitweb working. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: Multicast group pre-creation for TopSpin old stack

2010-09-07 Thread Sasha Khapyorsky
On 17:13 Mon 06 Sep , Roland Dreier wrote: It's been carried forward just in case anyone was still running the old TS stack. It's always hard to determine the negative (when no one is using it any longer) (with the latest OpenSM) but it may be high time to deprecate this. Is anyone

Re: Multicast group pre-creation for TopSpin old stack

2010-09-07 Thread Roland Dreier
As far as I could understand this TS multicast group only impacts IPoIB communication between two TS stack clients. If so then it is likely that just using old Topspin switch will not activate this flow anyway. Right? I think it would affect IPoIB-ethernet gateway at least. And also

Re: [PATCH] libvendor/osm_vendor_ibumad_sa.c: remove useless if statement

2010-09-07 Thread Hal Rosenstock
On Tue, Sep 7, 2010 at 11:13 AM, Yevgeny Kliteynik klit...@mellanox.co.il wrote: Content of p_query_req_copy is used in the function, so no point checking if it's NULL before the free(). Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il ---  opensm/libvendor/osm_vendor_ibumad_sa.c

Re: [PATCH] opensm/osm_prtn.c: removing TopSpin hack

2010-09-07 Thread Sasha Khapyorsky
On 17:50 Tue 07 Sep , Yevgeny Kliteynik wrote: Removing hack that was supposed to support TopSpin's non-compliant join compmask for IPoIB v4 multicast group ff12:401b:pkey::1 Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this

Re: [PATCH] libvendor/osm_vendor_ibumad_sa.c: remove useless if statement

2010-09-07 Thread Yevgeny Kliteynik
On 07-Sep-10 8:47 PM, Hal Rosenstock wrote: On Tue, Sep 7, 2010 at 11:13 AM, Yevgeny Kliteynik klit...@mellanox.co.il wrote: Content of p_query_req_copy is used in the function, so no point checking if it's NULL before the free(). Signed-off-by: Yevgeny Kliteynikklit...@dev.mellanox.co.il

Re: [PATCH 02/13] drivers/infiniband: Remove unnecessary casts of private_data

2010-09-07 Thread Ralph Campbell
Acked-by: Ralph Campbell ralph.campb...@qlogic.com On Sat, 2010-09-04 at 18:52 -0700, Joe Perches wrote: Signed-off-by: Joe Perches j...@perches.com --- drivers/infiniband/hw/qib/qib_file_ops.c |4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH v2] opensm/osm_console.c: fix memory and file descriptor leaks

2010-09-07 Thread Yevgeny Kliteynik
Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- V2: removed unneeded 'return' opensm/opensm/osm_console.c | 10 ++ 1 files changed, 6 insertions(+), 4 deletions(-) diff --git a/opensm/opensm/osm_console.c b/opensm/opensm/osm_console.c index bc7bea3..5407e9a 100644

[PATCH] libvendor/osm_vendor_mlx_sa.c: remove useless if statement

2010-09-07 Thread Yevgeny Kliteynik
Content of p_query_req_copy is used in the function, so no point checking if it's NULL before the free() Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/libvendor/osm_vendor_mlx_sa.c |3 +-- 1 files changed, 1 insertions(+), 2 deletions(-) diff --git

Re: [PATCH] opensm/osm_db_files.c: remove bad free() call

2010-09-07 Thread Sasha Khapyorsky
On 17:52 Tue 07 Sep , Yevgeny Kliteynik wrote: p_key is a parameter, and it is char[]. It shouldn't be freed here. I don't see this. st_delete() call: if (st_delete(p_domain_imp-p_hash, (void *)p_key, (void *)p_prev_val)) { ...

Re: [PATCH] opensm/osm_trap_rcv.c: fix possible core dump

2010-09-07 Thread Sasha Khapyorsky
On 17:53 Tue 07 Sep , Yevgeny Kliteynik wrote: Handle the case when source physical port for trap 145 wasn't found. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il --- opensm/opensm/osm_trap_rcv.c | 14 ++ 1 files changed, 10 insertions(+), 4 deletions(-)

Re: [PATCH] libvendor/osm_vendor_mlx_sa.c: remove useless if statement

2010-09-07 Thread Sasha Khapyorsky
On 22:34 Tue 07 Sep , Yevgeny Kliteynik wrote: Content of p_query_req_copy is used in the function, so no point checking if it's NULL before the free() Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line

Re: [PATCH] opensm/osm_mtree.c: removing useless 'if' statement

2010-09-07 Thread Sasha Khapyorsky
On 17:53 Tue 07 Sep , Yevgeny Kliteynik wrote: p_mtn-max_children is an array - no point checking if it is NULL. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a

Re: git.openfabrics.org DNS names

2010-09-07 Thread Sasha Khapyorsky
Hi Jeff, On 09:51 Tue 07 Sep , Jeff Becker wrote: Sorry for the outage. It's being worked on... Now I have this for couple of hours: Could not resolve hostname git.openfabrics.org: Name or service not known Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in

[PATCH] opensm/sa: simplify osm_mcmr_rcv_find_or_create_new_mgrp() function call

2010-09-07 Thread Sasha Khapyorsky
Simplify osm_mcmr_rcv_find_or_create_new_mgrp() function call so that it will return the pointer to created of found MC group. Signed-off-by: Sasha Khapyorsky sas...@voltaire.com --- opensm/include/opensm/osm_sa.h | 15 +++ opensm/opensm/osm_prtn.c | 20

Re: [PATCH] opensm/osm_pkey.c: removing unused function

2010-09-07 Thread Sasha Khapyorsky
On 17:55 Tue 07 Sep , Yevgeny Kliteynik wrote: Removing unused (and, may I add, buggy) function. Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a message to

Re: [PATCH] opensm/osm_sa_pkey_record.c: removing unused variable

2010-09-07 Thread Sasha Khapyorsky
On 17:57 Tue 07 Sep , Yevgeny Kliteynik wrote: Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH] opensm/osm_sa_vlarb_record.c: removed unused variable

2010-09-07 Thread Sasha Khapyorsky
On 17:59 Tue 07 Sep , Yevgeny Kliteynik wrote: Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a message to majord...@vger.kernel.org More majordomo info at

Re: [PATCH] opensm/osm_node_info_rcv.c: remove useless code line

2010-09-07 Thread Sasha Khapyorsky
On 17:58 Tue 07 Sep , Yevgeny Kliteynik wrote: Signed-off-by: Yevgeny Kliteynik klit...@dev.mellanox.co.il Applied. Thanks. Sasha -- To unsubscribe from this list: send the line unsubscribe linux-rdma in the body of a message to majord...@vger.kernel.org More majordomo info at

[PATCH] libibmad/fields.c: Change all PortCounter names to match the Specification

2010-09-07 Thread Ira Weiny
From: Ira Weiny wei...@llnl.gov Date: Tue, 3 Aug 2010 10:40:56 -0700 Subject: [PATCH] libibmad/fields.c: Change all PortCounter names to match the Specification Signed-off-by: Ira Weiny wei...@llnl.gov --- libibmad/src/fields.c | 32 1 files changed, 16