Nice. Whenever you see a bug like this, you should report it to
kernel-janitors because you know that 10 other people have made the same
mistake.
I will take care of it.
regards,
dan carpenter
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to m
On Mon, 14 Dec 2015, Nicholas Mc Guire wrote:
> On Thu, Dec 10, 2015 at 11:13:38AM -0500, Mike Marciniszyn wrote:
> > From: Easwar Hariharan
> >
> > A code inspection pointed out that kmalloc_array may return NULL and
> > memset doesn't check the input pointer for NULL, resulting in a possible
Possible off by one, but mostly the whitespace makes me itch.
Jim was not on the CC list.
On Thu, Dec 17, 2015 at 07:24:15PM -0500, Jubin John wrote:
> From: Jim Snow
>
> The link state will transition from ARMED to ACTIVE when a non-SC15
> packet arrives, but the driver might not notice the ch
On Thu, Dec 17, 2015 at 07:31:20PM +0100, Bart Van Assche wrote:
> On 12/17/2015 06:41 PM, Jason Gunthorpe wrote:
> >On Thu, Dec 17, 2015 at 03:44:19PM +0200, Sagi Grimberg wrote:
> >>
> >>>+ ret = ib_query_device(device, &device->attrs);
> >>>+ if (ret) {
> >>>+ printk(KERN_WARNING "Cou
From: Mitko Haralanov
The upcoming TID caching feature requires different data
structures and, by extension, different initialization for each
of the MPI processes.
The two new functions (currently unused) perform the required
initialization and freeing of required resources and structures.
Sig
From: Mitko Haralanov
Definitions and functions use to manage sets of TID/RcvArray groups.
These will be used by the TID cacheline functionality coming with
later patches.
TID groups (or RcvArray groups) are groups of TID/RcvArray entries
organized in sets of 8 and aligned on cacheline boundarie
From: Mitko Haralanov
The exp_lock lock does not need to be a spinlock as
all its uses are in process context and allowing the
process to sleep when the mutex is contended might
be benefitial.
Signed-off-by: Mitko Haralanov
Reviewed-by: Ira Weiny
---
drivers/staging/rdma/hfi1/file_ops.c | 12
From: Mitko Haralanov
There is no need to use a separate variable for a
return value and a label when returning right away
would do just as well.
Signed-off-by: Mitko Haralanov
Reviewed-by: Ira Weiny
---
drivers/staging/rdma/hfi1/file_ops.c | 11 ---
1 file changed, 4 insertions(+), 7
From: Mitko Haralanov
The previous patch in the series added the free/invalidate
function bodies. Now, it's time for the programming side.
This large function takes the user's buffer, breaks it up
into manageable chunks, allocates enough RcvArray groups
and programs the chunks into the RcvArray
From: Mitko Haralanov
This commit "flips the switch" on the TID caching feature
implemented in this patch series.
As well as enabling the new feature by tying the new function
with the PSM API, it also cleans up the old unneeded code,
data structure members, and variables.
Due to difference in
From: Mitko Haralanov
Add mmu notify helper functions and TID caching function
stubs in preparation for the TID caching implementation.
TID caching makes use of the MMU notifier to allow the driver
to respond to the user freeing memory which is allocated to
the HFI.
This patch implements the ba
From: Mitko Haralanov
The HFI1_CAP_TID_UNMAP comment was incorrectly implying the
opposite of what capability actually did. Correct this error.
Reviewed-by: Ira Weiny
Signed-off-by: Mitko Haralanov
---
include/uapi/rdma/hfi/hfi1_user.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
di
From: Mitko Haralanov
In preparation for adding the TID caching support, there is a set
of headers, structures, and variables which will be needed. This
commit adds them to the hfi.h header file.
Signed-off-by: Mitko Haralanov
Reviewed-by: Ira Weiny
---
drivers/staging/rdma/hfi1/hfi.h | 20 ++
From: Mitko Haralanov
Functions added by this patch are building blocks for the upcoming
TID caching functionality. The functions added are currently unsed
(and marked as such.)
The functions' purposes are to find physically contigous pages in
the user's virtual buffer, program the RcvArray grou
From: Mitko Haralanov
TID caching will rely on the MMU notifier to be told
when memory is being invalidated. When the callback
is called, the driver will find all RcvArray entries
that span the invalidated buffer and "schedule" them
to be freed by the PSM library.
This function is currently unus
From: Mitko Haralanov
Convert bit definitions to use BIT() macro as per checkpatch.pl
requirements.
Reviewed-by: Ira Weiny
Signed-off-by: Mitko Haralanov
---
include/uapi/rdma/hfi/hfi1_user.h | 56 +++
1 file changed, 28 insertions(+), 28 deletions(-)
diff
From: Ira Weiny
Expected receives work by user-space libraries (PSM) calling into the driver
with information about the user's receive buffer and have the driver DMA-map
that buffer and program the HFI to receive data directly into it.
This is an expensive operation as it requires the driver to
From: Mitko Haralanov
Up to now, the functions which cleared the programmed
TID entries and gave PSM the list of invalidated TID entries
were just stubs. With this commit, the bodies of these
functions are added.
This commit is a bit asymmetric as it only contains the
free code path. This is don
From: Mitko Haralanov
TID caching will use a new event to signal userland that cache
invalidation has occurred and needs a matching command code that
will be used to read the invalidated TIDs.
Add the event bit and the new command to the exported header file.
The command is also added to the sw
From: Dean Luick
Remove an invalid sanity check that compares the local link
credits with the peer link credits. The two have no dependency
on each other.
Reviewed-by: Dennis Dalessandro
Signed-off-by: Dean Luick
Signed-off-by: Jubin John
---
drivers/staging/rdma/hfi1/chip.c |3 +--
1 f
Fix the spelling of user_credit_return_threshold, it was incorrectly
spelled as user_credit_return_theshold causing two module parameters,
one with typo, to be shown in modinfo
Reviewed-by: Ira Weiny
Reviewed-by: Mike Marciniszyn
Signed-off-by: Jubin John
---
drivers/staging/rdma/hfi1/init.c |
From: Jim Snow
The link state will transition from ARMED to ACTIVE when a non-SC15
packet arrives, but the driver might not notice the change. With this
fix, if the slowpath receive interrupt handler sees a non-SC15 packet
while in the ARMED state, we queue work to call linkstate_active_work
fro
On 12/17/2015 5:50 PM, Christoph Lameter wrote:
> On Thu, 17 Dec 2015, Hal Rosenstock wrote:
>
>> On 12/17/2015 4:28 PM, Christoph Lameter wrote:
>>> So port_check_extended_counters need to return another value for this.
>>> The IETF ones are the uni/mcast xxx counters?
>>
>> Yes
>
> Ok. Then thi
On Thu, 17 Dec 2015, Hal Rosenstock wrote:
> On 12/17/2015 4:28 PM, Christoph Lameter wrote:
> > So port_check_extended_counters need to return another value for this.
> > The IETF ones are the uni/mcast xxx counters?
>
> Yes
Ok. Then this patch on top of the last one should give us all of what y
On 12/17/2015 4:28 PM, Christoph Lameter wrote:
> So port_check_extended_counters need to return another value for this.
> The IETF ones are the uni/mcast xxx counters?
Yes
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.or
On Thu, 17 Dec 2015, Hal Rosenstock wrote:
> > - ret = sysfs_create_group(&p->kobj, &pma_group);
> > + ret = sysfs_create_group(&p->kobj,
> > + port_check_extended_counters(device) ?
> > + &pma_group_ext :
>
> Would be nice to populate 2 different groups based on wh
On Thu, Dec 17, 2015 at 02:23:39PM +0300, Dan Carpenter wrote:
> On Thu, Dec 17, 2015 at 02:00:18AM -0500, ira.we...@intel.com wrote:
> > From: Mitko Haralanov
> > +static int unprogram_rcvarray(struct file *fp, u32 tidinfo,
> > + struct tid_group **grp)
> > +{
> > + stru
On Thu, Dec 17, 2015 at 03:06:45PM +0300, Dan Carpenter wrote:
> On Thu, Dec 17, 2015 at 02:00:23AM -0500, ira.we...@intel.com wrote:
> > + mutex_lock(&uctxt->exp_lock);
> > + /*
> > +* The first step is to program the RcvArray entries which are complete
> > +* groups.
> > +*/
> > +
On Thu, Dec 17, 2015 at 02:59:52PM +0300, Dan Carpenter wrote:
> On Thu, Dec 17, 2015 at 02:00:18AM -0500, ira.we...@intel.com wrote:
> > +}
> > +
> > +static int program_rcvarray(struct file *fp, unsigned long vaddr,
> > + struct tid_group *grp,
> > + st
There are number of minor issues:
Subject: Re: [PATCH 3/3] bject: IB Core: Display extended counter set if
^^^
On Thu, Dec 17, 2015 at 01:52:58PM -0600, Christoph Lameter wrote:
> - in_mad->data[41] = port_num;/* PortSelect field */
> + if (port_num)
> +
On Thu, Dec 17, 2015 at 5:36 PM, Christoph Hellwig wrote:
> [...] I heartily disagree with this approach [...]
OK, I will remove your name and re-submit that
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majord
On 12/17/2015 2:52 PM, Christoph Lameter wrote:
> Create a new function to retrieve performance management
> data from the existing code in get_pma_counter().
>
> Signed-off-by: Christoph Lameter
Reviewed-by: Hal Rosenstock
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma
On 12/17/2015 2:52 PM, Christoph Lameter wrote:
> Add the attr_id on port_table_attribute since we will have to add
> a different port_table_attribute for the extended attribute soon.
>
> Signed-off-by: Christoph Lameter
Reviewed-by: Hal Rosenstock
--
To unsubscribe from this list: send the lin
On 12/17/2015 2:52 PM, Christoph Lameter wrote:
> Check if the extended counters are available and if so
> create the proper extended and additional counters.
>
> Signed-off-by: Christoph Lameter
>
> Index: linux/drivers/infiniband/core/sysfs.c
> =
Add the attr_id on port_table_attribute since we will have to add
a different port_table_attribute for the extended attribute soon.
Signed-off-by: Christoph Lameter
Index: linux/drivers/infiniband/core/sysfs.c
===
--- linux.orig/dri
Check if the extended counters are available and if so
create the proper extended and additional counters.
Signed-off-by: Christoph Lameter
Index: linux/drivers/infiniband/core/sysfs.c
===
--- linux.orig/drivers/infiniband/core/sysf
V1->V2 Add detection of the capability for 64 bit counter support and lots
of improvements as a result of suggestions by Hal Rosenstock.
Currently we only use 32 bits for the packet and byte counters. There have been
extended countes available for some time but we have no support for those
yet u
Create a new function to retrieve performance management
data from the existing code in get_pma_counter().
Signed-off-by: Christoph Lameter
Index: linux/drivers/infiniband/core/sysfs.c
===
--- linux.orig/drivers/infiniband/core/sysf
On 12/17/2015 2:21 PM, Christoph Lameter wrote:
> On Thu, 17 Dec 2015, Hal Rosenstock wrote:
>
>>> I thought a port is always supplied since we get the info for a particular
>>> port and the directory only exists if there is a port?
>>
>> Yes, but there is no port (PortSelect) field in ClassPortIn
On Thu, 17 Dec 2015, Hal Rosenstock wrote:
> > I thought a port is always supplied since we get the info for a particular
> > port and the directory only exists if there is a port?
>
> Yes, but there is no port (PortSelect) field in ClassPortInfo attribute
> unlike the PortCounters and PortExtende
On 12/17/2015 1:54 PM, Christoph Lameter wrote:
> On Thu, 17 Dec 2015, Hal Rosenstock wrote:
>> ClassPortInfo is per class not per class per port so need to indicate to
>> get_mad whether a port is supplied or not or conditionalize based on
>> attr ID.
>
> I thought a port is always supplied si
On Thu, 17 Dec 2015, Hal Rosenstock wrote:
> > + * Get a MAD block of data.
>
> Nit: Get PerfMgt MAD block of data
Ok.
> > + * Returns error code or the number of bytes retrieved.
> > + */
> > +static int get_mad(struct ib_device *dev, int port_num, int attr,
>
> Nit: Maybe this is too verbose b
On 12/17/2015 06:41 PM, Jason Gunthorpe wrote:
On Thu, Dec 17, 2015 at 03:44:19PM +0200, Sagi Grimberg wrote:
+ ret = ib_query_device(device, &device->attrs);
+ if (ret) {
+ printk(KERN_WARNING "Couldn't query the device attributes\n");
+ goto out;
+
On 12/16/2015 2:34 PM, Christoph Lameter wrote:
> On Wed, 16 Dec 2015, Christoph Lameter wrote:
>
>> DRAFT: This is missing the check if this device supports
>> extended counters.
>
> Found some time and here is the patch with the detection of the extended
> attribute through sending a mad reques
On Thu, Dec 17, 2015 at 03:44:19PM +0200, Sagi Grimberg wrote:
>
> >+ret = ib_query_device(device, &device->attrs);
> >+if (ret) {
> >+printk(KERN_WARNING "Couldn't query the device attributes\n");
> >+goto out;
> >+}
> >+
>
> I thought we're all for removing t
On Thu, Dec 17, 2015 at 08:35:53AM -0800, Christoph Hellwig wrote:
On Thu, Dec 17, 2015 at 10:52:29AM -0500, Dennis Dalessandro wrote:
I am not opposed to leaving the code in rdmavt. It gets removed from qib in
the other patch series I posted. My preference is to leave it in rdmavt
since it will
On Thu, Dec 17, 2015 at 10:52:29AM -0500, Dennis Dalessandro wrote:
> I am not opposed to leaving the code in rdmavt. It gets removed from qib in
> the other patch series I posted. My preference is to leave it in rdmavt
> since it will be needed down the road. However I can go either way here, its
> + i40iw_next_iw_state(iwqp, I40IW_QP_STATE_ERROR, 0, 0, 0);
> +
> + if (!iwqp->user_mode) {
> + if (iwqp->iwscq)
> + i40iw_clean_cqes(iwqp, iwqp->iwscq);
> + if ((iwqp->iwrcq) && (iwqp->iwrcq != iwqp->iwscq))
Please try to do a pass ove
> +#ifndef UNREFERENCED_PARAMETER
> +#define UNREFERENCED_PARAMETER(_p) \
> +{\
> + (_p) = (_p);\
> +}
> +#endif
No need for this, just remove it.
> +#define I40E_MASK(mask, shift) (mask << shift)
Please just opencode the shit, this m
On Wed, Dec 16, 2015 at 04:37:39PM +0200, Sagi Grimberg wrote:
This patch exists to provide parity for what is in qib. Should we not
have it? If not, why do we have:
commit 38071a461f0a ("IB/qib: Support the new memory registration API")
That was done by me because I saw this in qib and ass
On Thu, Dec 17, 2015 at 03:18:54PM +0200, Or Gerlitz wrote:
> I used hunks from Christoph's work and mentioned that in the
> change-logs. This can turn to be his signature, if he wants to.
I heartily disagree with this approach, and I'd prefer if you don't
blame any of this horrible scheme on me.
Guys,
Using 4.4-rc5+ [1] and **not** applying any of the patches I sent today,
I noted that RoCE passive side isn't working (rdma-cm, ibv_rc_pingpong
works).
I'm using 4.4-rc2+ and I have RoCE working.
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a m
Guys,
Using 4.4-rc5+ [1] and **not** applying any of the patches I sent today,
I noted that RoCE passive side isn't working (rdma-cm, ibv_rc_pingpong
works).
I have two nodes in ConnectX3 VPI config (port1 IB and port2 Eth), the
one with the 4.4-rc5 kernel can act as both (rping) client/serve
+ ret = ib_query_device(device, &device->attrs);
+ if (ret) {
+ printk(KERN_WARNING "Couldn't query the device attributes\n");
+ goto out;
+ }
+
I thought we're all for removing the call altogether aren't we?
I'd say just call device->query_device
Instead, use the cached copy of the attributes present on the device.
Based on a patch from Christoph Hellwig
Signed-off-by: Or Gerlitz
---
net/sunrpc/xprtrdma/frwr_ops.c | 7 ++---
net/sunrpc/xprtrdma/svc_rdma_transport.c | 48 +---
net/sunrpc/xprtrdma/v
Instead, use the cached copy of the attributes present on the device.
Based on a patch from Christoph Hellwig
Signed-off-by: Or Gerlitz
---
drivers/infiniband/ulp/ipoib/ipoib_cm.c | 19 ---
drivers/infiniband/ulp/ipoib/ipoib_ethtool.c | 14 +++--
drivers/infiniband/ulp/ipoib/i
Instead, use the cached copy of the attributes present on the device.
Based on a patch from Christoph Hellwig
Signed-off-by: Or Gerlitz
---
net/rds/ib.c | 34 +++---
net/rds/iw.c | 23 +--
2 files changed, 16 insertions(+), 41 deletions(-)
diff
Instead, use the cached copy of the attributes present on the device.
Based on a patch from Christoph Hellwig
Signed-off-by: Or Gerlitz
---
drivers/staging/lustre/lnet/klnds/o2iblnd/o2iblnd.c | 21 +
1 file changed, 1 insertion(+), 20 deletions(-)
diff --git a/drivers/stag
Instead, use the cached copy of the attributes present on the device.
Based on a patch from Christoph Hellwig
Signed-off-by: Or Gerlitz
---
drivers/infiniband/core/cm.c | 12 +---
drivers/infiniband/core/cma.c| 8
drivers/infiniband/core/fmr_pool.c | 20 ++--
From: Ira Weiny
This way both the IB core and upper level drivers can access these cached
device attributes rather than querying or caching them on their own.
Signed-off-by: Ira Weiny
Signed-off-by: Or Gerlitz
---
drivers/infiniband/core/device.c | 6 ++
include/rdma/ib_verbs.h |
OK, Doug, this is my suggestion for the dev attr cleanup -- it
has the advantages of leaving the attrs on a well defined location,
a field in the IB device, the ability to get that through smaller
patches, avoid touching any of the HW drivers, etc.
Note that in uverbs there's one spot where ud
On Thu, Dec 17, 2015 at 02:00:23AM -0500, ira.we...@intel.com wrote:
> + mutex_lock(&uctxt->exp_lock);
> + /*
> + * The first step is to program the RcvArray entries which are complete
> + * groups.
> + */
> + while (ngroups && uctxt->tid_group_list.count) {
> +
On Thu, Dec 17, 2015 at 02:00:18AM -0500, ira.we...@intel.com wrote:
> +}
> +
> +static int program_rcvarray(struct file *fp, unsigned long vaddr,
> + struct tid_group *grp,
> + struct tid_pageset *sets,
> + unsigned start, u16
On Thu, Dec 17, 2015 at 02:00:18AM -0500, ira.we...@intel.com wrote:
> From: Mitko Haralanov
> +static int unprogram_rcvarray(struct file *fp, u32 tidinfo,
> + struct tid_group **grp)
> +{
> + struct hfi1_filedata *fd = fp->private_data;
> + struct hfi1_ctxtdata *
> From: linux-rdma-ow...@vger.kernel.org [mailto:linux-rdma-
> ow...@vger.kernel.org] On Behalf Of Doug Ledford
> These patches add the concept of duplicate GIDs that are differentiated by
> their RoCE version (also called network type). So, now, an incoming packet
> could match a couple differen
> No, not true. You are implementing RoCEv2 support, which is an entirely
> new feature. So this feature can't have had a security hole since
> forever as it has never been in the kernel before now. The objections
> are arising because of the ordering of events. Specifically, we added
> the cor
On 12/16/2015 07:16 PM, Jason Gunthorpe wrote:
> On Wed, Dec 16, 2015 at 11:26:39AM +0100, Michael Wang wrote:
[snip]
>>
>> I've rechecked the ib_init_ah_from_path() again, and found it
>> still set IB_AH_GRH when the GID cache missing, but with:
>
> How do you mean?
>
> ah_attr
Looks good,
Reviewed-by: Sagi Grimberg
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Looks good,
Reviewed-by: Sagi Grimberg
--
To unsubscribe from this list: send the line "unsubscribe linux-rdma" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
69 matches
Mail list logo