RE: creating common ib_types.h for linux and windows

2011-09-21 Thread Smith, Stan
-Original Message- From: linux-rdma-ow...@vger.kernel.org [mailto:linux-rdma-ow...@vger.kernel.org] On Behalf Of Alex Netes Sent: Wednesday, September 21, 2011 6:30 AM To: Hefty, Sean Cc: Bart Van Assche; linux-rdma (linux-rdma@vger.kernel.org); Hal Rosenstock (hal.rosenst...@gmail.com);

RE: [PATCH] replace (long*)(long) casting with transportable data type (uintptr_t)

2010-12-07 Thread Smith, Stan
Hal Rosenstock wrote: On 12/6/2010 6:55 PM, Stan C. Smith wrote: Hello, Your suggestion of removing extra casts does operate correctly under windows x64/x86 variants. Windows compilers have improved. thanks, Stan. Signed-off-by: stan smithstan.sm...@intel.com diff --git

RE: [PATCH] replace (long*)(long) casting with transportable data type (uintptr_t)

2010-11-30 Thread Smith, Stan
Sasha Khapyorsky wrote: On 14:12 Thu 09 Sep , Stan C. Smith wrote: Hello, In osm_vendor_ibumad_sa.c the casting of a pointer to a long causes data truncation problems in 64-bit Windows where sizeof(long) != sizeof(void*). 'uintptr_t' is correct in both operating environments.

RE: [PATCH] replace (long*)(long) casting with transportable data type (uintptr_t)

2010-11-30 Thread Smith, Stan
Hefty, Sean wrote: Wouldn't it be better to remove those additional castings at all? Like below? .. p_query_req_copy = (osmv_query_req_t *) p_req_madw-context.ni_context.node_guid; I think the Windows compiler will complain about data loss on a 32-bit system. Only the case @ line

RE: ib mad definitions

2010-10-19 Thread Smith, Stan
Ira Weiny wrote: On Tue, 19 Oct 2010 11:50:46 -0700 Hefty, Sean sean.he...@intel.com wrote: ib_types depends on complib at the moment (fixable) ibutils depends on OpenSM (it will anyway -- non-issue) somethings in ib_types are ugly, byteswapping (non-issue; deal with it later) OpenSM may

RE: IPoIB CM connection establishment protocol question

2010-08-25 Thread Smith, Stan
. Indeed this clears the air; the original Windows IPoIB CM code assumed a single connection. stan. On Thu, Aug 05, 2010 at 10:25:27AM -0700, Smith, Stan wrote: Could someone who is OFED IPoIB knowledgeable help me understand which IPoIB side starts the RC connection establishment (Tx REQ

IPoIB CM connection establishment protocol question

2010-08-05 Thread Smith, Stan
Could someone who is OFED IPoIB knowledgeable help me understand which IPoIB side starts the RC connection establishment (Tx REQ) to an ARP unknown remote host? I tried reading the Linux IPoIB code and realized it's been too many years since writing Linux network drivers (2001) and found

RE: [PATCH] opensm/osm_sa.c: In osm_sa_respond, only fill in attr offset if RMPP method

2010-06-11 Thread Smith, Stan
snip... Following discussion is tangential to Hal's patch. Last night I came across an curious discovery. sizeof(ib_inform_info_t)== 36. sizeof(ib_inform_info_record_t) == 64. My debug version of 'osmtest -f v' trips CL_ASSERT() in ib_get_attr_offset()

RE: [PATCH] opensm/complib use portable macro syntax

2010-05-25 Thread Smith, Stan
Sasha Khapyorsky wrote: Hi Stan, On 09:45 Fri 21 May , Smith, Stan wrote: Use portable macro argument syntax. signed-of-by: stan smith stan.sm...@intel.com Signed-off-by: oops. The patch below is malformed - whitespaces are mangled (please check your mailer

RE: [PATCH] use macro for tmp file path

2010-05-25 Thread Smith, Stan
Sasha Khapyorsky wrote: On 09:51 Fri 21 May , Smith, Stan wrote: Use defined macro for tmp file path signed-off-by: stan smith stan.sm...@intel.com The patch is whitespece-mangled. diff --git a/opensm/opensm/st.c b/opensm/opensm/st.c index ea76038..2d39117 100644 --- a/opensm

[PATCH] opensm/complib use portable macro syntax

2010-05-21 Thread Smith, Stan
Use portable macro argument syntax. signed-of-by: stan smith stan.sm...@intel.com diff --git a/opensm/complib/cl_event_wheel.c b/opensm/complib/cl_event_wheel.c index ef6d598..eb894a6 100644 --- a/opensm/complib/cl_event_wheel.c +++ b/opensm/complib/cl_event_wheel.c @@ -42,7 +42,7 @@ #include

[PATCH] use macro for tmp file path

2010-05-21 Thread Smith, Stan
Use defined macro for tmp file path signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/opensm/st.c b/opensm/opensm/st.c index ea76038..2d39117 100644 --- a/opensm/opensm/st.c +++ b/opensm/opensm/st.c @@ -174,7 +174,7 @@ static int init_st = 0; static void stat_col() { -

[PATCH] osmtest - use helper function

2010-05-21 Thread Smith, Stan
Use defined inline helper function instead of actual implementation. Separate implementation from use. signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/osmtest/osmtest.c b/opensm/osmtest/osmtest.c index 50f94db..5d9c54c 100644 --- a/opensm/osmtest/osmtest.c +++

[PATCH] opensm/libvendor Reduce stack consumption

2010-05-21 Thread Smith, Stan
Reduce stack consumption by using a union of structs instead of individual struct allocations. Code borrowed from osm_vendor_ibumad_sa.c signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/libvendor/osm_vendor_mlx_sa.c b/opensm/libvendor/osm_vendor_mlx_sa.c index

RE: Ok to edit the OpenFabrics wiki?

2010-04-06 Thread Smith, Stan
Justin Clift wrote: Jeff Becker wrote: snip Hi. I'm aware of the problem, and have verified it. Although I spent some time looking at it, I haven't been able to fix it yet. Part of the issue is that we have a new server ready to go, and I am awaiting instructions from an outside review

RE: [ofw] RE: [PATCH] opensm - use C99 transportable data type forpointer storage

2009-11-12 Thread Smith, Stan
Hefty, Sean wrote: Did you send it before morning coffee or after ? :) Maybe, because it seems obvious. All are agree with the elimination of unnecessary #ifndef's. As to me, go ahead, commit it. It needs to be merged into the mgmt.git tree. #include stdlib.h +#include inttypes.h

RE: [PATCH 1/2] contain pthreads defs with ifdef HAVE_LIBPTHREAD

2009-11-04 Thread Smith, Stan
Hefty, Sean wrote: Contain pthread definitions with ifdef HAVE_LIBPTHREAD Signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/include/vendor/osm_vendor_ibumad.h b/opensm/include/vendor/osm_vendor_ibumad.h index 0a4692d..d523412 100644 ---

RE: [ofw] Re: [PATCH] osmtest - Add OSM_CDECL to main() declaration

2009-10-15 Thread Smith, Stan
Hefty, Sean wrote: Sean maintains a separate set of patches applied to IB diags in order to address issues like the x86 requirement for __cdecl on main(). Since OSM_CDECL was already defined in OFED opensm, it did not seem to be a major concession to prefix main() with it. Options: 1)

RE: [PATCH] osmtest - Add OSM_CDECL to main() declaration

2009-10-12 Thread Smith, Stan
Sasha Khapyorsky wrote: On 10:10 Mon 12 Oct , Stan C. Smith wrote: Signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/osmtest/main.c b/opensm/osmtest/main.c index 4bb9f82..287baf3 100644 --- a/opensm/osmtest/main.c +++ b/opensm/osmtest/main.c @@ -285,7 +285,7 @@

RE: [PATCH] remove unnecessary leading '/' from filename

2009-10-12 Thread Smith, Stan
Sasha Khapyorsky wrote: On 16:46 Wed 07 Oct , Stan C. Smith wrote: In osm_db_domain_init() the filename is appended to a path string 'db_dir_name' which contains a trailing '/'. Remove extra '/'. Signed-off-by: stan smith stan.sm...@intel.com diff --git a/opensm/opensm/osm_lid_mgr.c

RE: [ofw] [PATCH] opensm - standardize on a single Windows #define

2009-10-12 Thread Smith, Stan
Sasha Khapyorsky wrote: On 10:16 Thu 08 Oct , Smith, Stan wrote: Hefty, Sean wrote: Code cleanup, standardize on a single Windows #define '__WIN__'; WIN32 -- __WIN__. Flip usage of ifndef WIN32 -- ifdef __GNUC__ GNUC indicates a specific compiler, not a platform, which is what the check

RE: [PATCH] osmtest - Add OSM_CDECL to main() declaration

2009-10-12 Thread Smith, Stan
Sasha Khapyorsky wrote: On 14:58 Mon 12 Oct , Smith, Stan wrote: { static osmtest_t osm_test; osmtest_opt_t opt = { 0 }; Sean maintains a separate set of patches applied to IB diags in order to address issues like the x86 requirement for __cdecl on main(). Since OSM_CDECL

RE: [ofw] [PATCH] opensm - standardize on a single Windows #define

2009-10-08 Thread Smith, Stan
Hefty, Sean wrote: What would you suggest, given you did not like the ifndef __WIN__ in terms of readability? I was saying that it is slightly easier for me to read: #ifdef __WIN__ // windows stuff #else // - not __WIN__ // other stuff #endif versus #ifndef __WIN_ //

RE: [ofw] [PATCH] typeof() not supported in Windows WDK compiler

2009-10-02 Thread Smith, Stan
Hello Sasha, Please skip the patch titled 'typeof() not supported in Windows WDK compiler' as Jason's fix does the job thus requiring no src code changes. Thank you Jason. Stan. Jason Gunthorpe wrote: On Thu, Oct 01, 2009 at 03:59:00PM -0700, Sean Hefty wrote: diff --git

RE: [PATCH] opensm/osm_helper.c: fix compiler warning

2009-10-01 Thread Smith, Stan
Sasha Khapyorsky wrote: Eliminate compiler warning: osm_helper.c:551: warning: missing braces around initializer osm_helper.c:551: warning: (near initialization for 'ib_zero_gid.raw') Signed-off-by: Sasha Khapyorsky sas...@voltaire.com --- opensm/opensm/osm_helper.c |2 +- 1 files

RE: [OPENSM] match functions to prototypes in header file

2009-10-01 Thread Smith, Stan
Sasha Khapyorsky wrote: snip... @@ -1080,7 +1082,8 @@ void osm_dump_node_record(IN osm_log_t * p_log, /** **/ -void osm_dump_path_record(IN osm_log_t *