[PATCH 1/4 v2] drm: rename drm_connector_unplug_all() to drm_connector_unregister_all()

2016-03-21 Thread Alexey Brodkin
Current name is a bit misleading because what that helper function really does it calls drm_connector_unregister() for all connectors. This all has nothing to do with hotplugging so let's name things properly. And while at it remove potentially dangerous locking around drm_connector_unregister()

[PATCH 4/4 v2] drm: rcar-du - use generic drm_connector_register_all() helper

2016-03-21 Thread Alexey Brodkin
Now when generic drm_connector_register_all() helper exists we may safely substiture with it driver-specific implementation of connectors plugging in sysfs. Signed-off-by: Alexey Brodkin Cc: Daniel Vetter Cc: David Airlie Cc: Laurent Pinchart Cc: linux-renesas-soc@vger.kernel.org --- No chang

[PATCH 0/4 v2] drm: introduce drm_connector_register_all() helper

2016-03-21 Thread Alexey Brodkin
As a pair to already existing drm_connector_unplug_all() (which we'll rename in this series to drm_connector_unregister_all()) we're adding generic implementation of what is already done in some drivers for registering all connectors. After implementation of that new helper we're updating 2 driver

Re: [PATCH 1/4 v2] drm: rename drm_connector_unplug_all() to drm_connector_unregister_all()

2016-03-21 Thread Laurent Pinchart
Hi Alexey, Thank you for the patch. On Monday 21 Mar 2016 15:28:37 Alexey Brodkin wrote: > Current name is a bit misleading because what that helper function > really does it calls drm_connector_unregister() for all connectors. > > This all has nothing to do with hotplugging so let's name things

Re: [PATCH 4/4 v2] drm: rcar-du - use generic drm_connector_register_all() helper

2016-03-21 Thread Laurent Pinchart
Hi Alexey, Thank you for the patch. On Monday 21 Mar 2016 15:28:40 Alexey Brodkin wrote: > Now when generic drm_connector_register_all() helper exists we may safely s/Now when/Now that a/ > substiture with it driver-specific implementation of connectors plugging in s/substiture with it/substit

Re: [PATCH v5 3/9] dma-mapping: add dma_{map,unmap}_resource

2016-03-21 Thread Christoph Hellwig
On Thu, Mar 17, 2016 at 01:33:51PM +0200, Laurent Pinchart wrote: > The good news is that, given that no code uses this new API at the moment, > there isn't much to audit. The patch series implements the resource mapping > for arch/arm only, and makes use of it in the rcar-dmac driver only. Would

[PATCH v4 0/2] Add CAN FD driver support to r8a7795 SoC

2016-03-21 Thread Ramesh Shanmugasundaram
Hi All, Thanks for the review comments. This patch is based on linux-can-next tag (linux-can-next-for-4.6-20160310) This patch depends on [RFC] [PATCH v4] can: fix handling of unmodifiable configuration options (http://permalink.gmane.org/gmane.linux.can/9148) Changes since v3:

[PATCH 2/2] can: rcar_can: Move Renesas CAN driver to rcar dir

2016-03-21 Thread Ramesh Shanmugasundaram
This patch clubs the Renesas controller drivers in one rcar dir. Signed-off-by: Ramesh Shanmugasundaram --- drivers/net/can/Kconfig | 10 -- drivers/net/can/Makefile | 1 - drivers/net/can/rcar/Kconfig | 10 ++ drivers/net/can/rcar/Makefile

[PATCH 1/2] can: rcar_canfd: Add Renesas R-Car CAN FD driver

2016-03-21 Thread Ramesh Shanmugasundaram
This patch adds support for the CAN FD controller found in Renesas R-Car SoCs. The controller operates in CAN FD only mode by default. CAN FD mode supports both Classical CAN & CAN FD frame formats. The controller supports ISO 11898-1:2015 CAN FD format only. This controller supports two channels

[RFC 1/5] clk: shmobile: r8a7795: make SD clk definition specific for GEN3

2016-03-21 Thread Wolfram Sang
From: Wolfram Sang About SD clocks: The clock type is Gen3 specific, the callbacks are all Gen3 specific; I think the clock definition should also be Gen3 specific and not in the general header file. Signed-off-by: Wolfram Sang --- drivers/clk/shmobile/r8a7795-cpg-mssr.c | 11 +++ driv

[RFC 2/5] clk: shmobile: cpg-mssr: add generic support for read-only DIV6 clocks

2016-03-21 Thread Wolfram Sang
From: Wolfram Sang Gen3 has two clocks (OSC and R) which look like a DIV6 clock but their divider value is read-only and depends on MD pins at bootup. Add support for such clocks by reading the value and adding a fixed clock. Signed-off-by: Wolfram Sang --- drivers/clk/shmobile/renesas-cpg-mss

[RFC 5/5] clk: shmobile: r8a7795: add stop for R clk

2016-03-21 Thread Wolfram Sang
From: Wolfram Sang Signed-off-by: Wolfram Sang --- drivers/clk/shmobile/r8a7795-cpg-mssr.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/clk/shmobile/r8a7795-cpg-mssr.c b/drivers/clk/shmobile/r8a7795-cpg-mssr.c index 353ea229d73fc5..1bfe9d0924be29 100644 --- a/drivers/clk/shmobil

[RFC 0/5] r8a7795: add clocks for the watchdogs

2016-03-21 Thread Wolfram Sang
So, since the new Gen3 manual has not only the RWDT but also the SWDT watchdog, here is a small series how I'd think we could enable the clocks for them. Only tested for the internal RCLK case, not for EXTALR yet. Release early, so we can talk about the approach... Please let me know if I am on th

[RFC 4/5] WIP: clk: shmobile: r8a7795: add R clk

2016-03-21 Thread Wolfram Sang
From: Wolfram Sang This is a sketch how I think R clk should be handled. During initialization, check if EXTALR is populated. If so, use it as R. If not, use R_Internal. clk_mux doesn't help here because we don't want to switch parents depending on the clock rate. The clock rate (and source) shou

[RFC 3/5] clk: shmobile: r8a7795: add OSC and R_INT clocks

2016-03-21 Thread Wolfram Sang
From: Wolfram Sang Signed-off-by: Wolfram Sang --- drivers/clk/shmobile/r8a7795-cpg-mssr.c | 3 +++ include/dt-bindings/clock/r8a7795-cpg-mssr.h | 5 +++-- 2 files changed, 6 insertions(+), 2 deletions(-) diff --git a/drivers/clk/shmobile/r8a7795-cpg-mssr.c b/drivers/clk/shmobile/r8a7795

Re: [RFC V5 1/4] WIP: clk: r8a7795: add RWDT clock

2016-03-21 Thread Wolfram Sang
> The CPG driver should register a MUX clock that has EXTALR and the internal > RCLK as parents. I don't think this will work. clk_mux will switch parents depending on the rate to be set up. But here we want to select one parent at boot-time (and want to stay with it). I hacked up something. Wil

Re: [PATCH 0/2] ARM: dts: shmobile: Correct interrupt type for ARM TWD

2016-03-21 Thread Simon Horman
Hi Geert, On Fri, Mar 18, 2016 at 11:19:19AM +0100, Geert Uytterhoeven wrote: > Hi Simon, Magnus, Jon, > > This patch series corrects the interrupt type for ARM TWD timers on > SH-Mobile AG5 and R-Car H1. > > The ARM TWD interrupt is a private peripheral interrupt (PPI), and per > the ARM

[PATCH 09/13] ARM: dts: r8a7794: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 08/13] ARM: dts: r8a7793: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 05/13] ARM: dts: r8a7778: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 00/13] ARM, arm64: dts: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
Hi, this series updates the device trees of Renesas ARM based SoCs. * Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names

[PATCH 07/13] ARM: dts: r8a7791: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 02/13] ARM: dts: r8a73a4: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 04/13] ARM: dts: r8a7740: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 10/13] ARM: dts: gose: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 01/13] ARM: dts: r7s72100: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 12/13] ARM: dts: porter: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 03/13] ARM: dts: sh73a0: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 13/13] ARM: dts: lager: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 06/13] ARM: dts: r8a7779: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

[PATCH 11/13] ARM: dts: koelsch: Remove unnecessary clock-output-names properties

2016-03-21 Thread Simon Horman
* Fixed rate and fixed factor clocks do not require an clock-output-names property. * Since 07705583e920fef6 ("clk: shmobile: div6: Make clock-output-names optional") Renesas div6 clocks do not require a clock-output-names property. In the above cases there is only one clock output and its n

Re: [PATCH 1/2] ARM: dts: r8a7794: add IIC clocks

2016-03-21 Thread Simon Horman
On Thu, Mar 17, 2016 at 09:12:05AM +0100, Geert Uytterhoeven wrote: > On Thu, Mar 17, 2016 at 8:33 AM, Simon Horman > wrote: > > Add IIC clocks to r8a7794 device tree. > > > > Based on similar work for the r8a7790 by Wolfram Sang. > > > > CC: Wolfram Sang > > Signed-off-by: Simon Horman > > Rev

Re: [PATCH 2/2] ARM: dts: r8a7794: Add IIC nodes

2016-03-21 Thread Simon Horman
On Thu, Mar 17, 2016 at 09:10:27AM +0100, Geert Uytterhoeven wrote: > On Thu, Mar 17, 2016 at 8:35 AM, Simon Horman > wrote: > > Add IIC nodes to r8a7794 device tree. > > > > Based on similar work for the r8a7793 by Laurent Pinchart. > > > > CC: Laurent Pinchart > > Signed-off-by: Simon Horman >

Re: [PATCH 00/12] ARM, arm64: dts: use generic pinctrl properties

2016-03-21 Thread Simon Horman
On Fri, Mar 18, 2016 at 11:59:25AM +0100, Geert Uytterhoeven wrote: > Hi Simon, > > On Fri, Mar 18, 2016 at 12:59 AM, Simon Horman > wrote: > > Since 16ccaf5bb5a5 ("pinctrl: sh-pfc: Accept standard function, pins and > > groups properties") renesas pfc drivers accept generic "function", "pins" >

RE: [PATCH v2 0/2] usb: renesas_usbhs: fix to avoid unexpected condition

2016-03-21 Thread Yoshihiro Shimoda
Hi Felipe, > From: Yoshihiro Shimoda > Sent: Thursday, March 10, 2016 11:30 AM > > This patch set is based on the latest Felipe's usb.git / testing/next branch. > (commit id = ac5706631325ae3695bfa1527101ab2b2f64859f) Would you review the patch set? I confirmed that the patch set could be applie