RE: [PATCH] ARM: S5PC100: Modified the clock code to conform to Samsung clock API.

2010-05-12 Thread Marek Szyprowski
Hello, On Thursday, May 13, 2010 3:10 AM Kukjin Kim wrote: > From: Thomas Abraham > > Re-worked the existing clock code for Samsung's S5PC100 SoC to be in > sync with new clock API. > > Signed-off-by: Thomas Abraham > Signed-off-by: Abhilash Kesavan > Signed-off-by: Kukjin Kim > --- > arch

Re: [PATCH 11/11] ARM: S5P6440: Remove redundant defines

2010-05-12 Thread Kyungmin Park
On Thu, May 13, 2010 at 11:02 AM, Ben Dooks wrote: > On Thu, May 13, 2010 at 10:49:29AM +0900, Jassi Brar wrote: >> On Thu, May 13, 2010 at 9:28 AM, Kukjin Kim wrote: >> > From: Thomas Abraham >> > --- a/arch/arm/mach-s5p6440/clock.c >> > +++ b/arch/arm/mach-s5p6440/clock.c >> > @@ -357,121 +357

S5PC100 planning

2010-05-12 Thread Ben Dooks
I would like to get an idea of what each group involvedi n the current S5PC100 changes is planning to allow the organisation of what is going on. Firstly, I think Kukjin's clock changes are the first to be applied, followed by looking at what support exists (or is being submitted) in plat-s5p whic

Re: next-samsung: acer n30/n35 updates

2010-05-12 Thread Ben Dooks
On Wed, May 12, 2010 at 03:22:24PM +0200, Pinkava J. wrote: > Dne 11.5.2010 03:03, Ben Dooks napsal(a): > > On Fri, May 07, 2010 at 04:36:58AM +0200, Pinkava J. wrote: > >> Dne 7.5.2010 02:50, Ben Dooks napsal(a): > >>> Acer n35 support has been provisonally merged into the following branch: > >>>

Re: [PATCH 11/11] ARM: S5P6440: Remove redundant defines

2010-05-12 Thread Ben Dooks
On Thu, May 13, 2010 at 10:49:29AM +0900, Jassi Brar wrote: > On Thu, May 13, 2010 at 9:28 AM, Kukjin Kim wrote: > > From: Thomas Abraham > > --- a/arch/arm/mach-s5p6440/clock.c > > +++ b/arch/arm/mach-s5p6440/clock.c > > @@ -357,121 +357,121 @@ static struct clk init_clocks_disable[] = { > >    

Re: [PATCH 11/11] ARM: S5P6440: Remove redundant defines

2010-05-12 Thread Jassi Brar
On Thu, May 13, 2010 at 9:28 AM, Kukjin Kim wrote: > From: Thomas Abraham > --- a/arch/arm/mach-s5p6440/clock.c > +++ b/arch/arm/mach-s5p6440/clock.c > @@ -357,121 +357,121 @@ static struct clk init_clocks_disable[] = { >                .id             = -1, >                .parent         = &cl

Re: [PATCH 04/11] ARM: S5P6440: Remove usage of clk_h and add clk_hclk clock

2010-05-12 Thread Ben Dooks
On Thu, May 13, 2010 at 09:27:09AM +0900, Kukjin Kim wrote: > From: Thomas Abraham > > The clk_h clock is of type 'struct clk' whereas on S5P6440, > the hclk is more suitable to be of type 'struct clksrc_clk' > (since hclk clock is divided version of armclk) ok, so we're replacing the old clk_h

Re: [PATCH] ARM: S5PC100: Modified the clock code to conform to Samsung clock API.

2010-05-12 Thread Ben Dooks
On Thu, May 13, 2010 at 10:10:01AM +0900, Kukjin Kim wrote: > From: Thomas Abraham > > Re-worked the existing clock code for Samsung's S5PC100 SoC to be in > sync with new clock API. > > Signed-off-by: Thomas Abraham > Signed-off-by: Abhilash Kesavan > Signed-off-by: Kukjin Kim > --- > arch/

[PATCH] ARM: S5PC100: Modified the clock code to conform to Samsung clock API.

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham Re-worked the existing clock code for Samsung's S5PC100 SoC to be in sync with new clock API. Signed-off-by: Thomas Abraham Signed-off-by: Abhilash Kesavan Signed-off-by: Kukjin Kim --- arch/arm/mach-s5pc100/Makefile |2 +- arch/arm/mach-s5pc100/cloc

[PATCH 11/11] ARM: S5P6440: Remove redundant defines

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham Remove redundant defines in the clock code. Signed-off-by: Thomas Abraham Signed-off-by: Kukjin Kim --- arch/arm/mach-s5p6440/clock.c | 62 +++--- arch/arm/mach-s5p6440/include/mach/regs-clock.h | 49 -- 2 files change

[PATCH 10/11] ARM: S5P6440: Add clocks of type 'struct clksrc_clk'.

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham This patch adds the following. 1. Add new definitions of clock of type 'struct clksrc_clk'. 2. Add gate control function for GATE_SCLK1 which is required for new clock additions. Signed-off-by: Thomas Abraham Signed-off-by: Kukjin Kim --- arch/arm/mach-s5p6440/clock.c

[PATCH 09/11] ARM: S5P6440: Rename clkset_mmc_spi to clkset_group1

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The clock source options avaialable in the clkset_mmc_spi are applicable to clocks such as sclk_post, sclk_dispcon and sclk_fimgvg. So this set is renamed as clkset_group1 to indicate that it can be used as clock sources for other clocks and not just for sclk_spi and sclk_mmc

[PATCH 08/11] ARM: S5P6440: Add clocks of type 'struct clk'.

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham Add definitions of clocks of type 'struct clk'. Signed-off-by: Thomas Abraham Signed-off-by: Kukjin Kim --- arch/arm/mach-s5p6440/clock.c | 82 - 1 files changed, 80 insertions(+), 2 deletions(-) diff --git a/arch/arm/mach-s5p644

[PATCH 07/11] ARM: S5P6440: Remove usage of clk_p_low and add clk_pclk_low clock

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The pclk_low clock is of type 'struct clk' whereas on S5P6440, the pclk_low clock is more suitable to be of type 'struct clksrc_clk' (since pclk_low clock is a divided clock of hclk_low clock). This patch modifies the following. 1. Removes the definition and usage of clk_p_

[PATCH 06/11] ARM: S5P6440: Remove usage of clk_h_low and add clk_hclk_low clock

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The clk_h_low clock is of type 'struct clk' whereas on S5P6440, the hclk_low clock is more suitable to be of type 'struct clksrc_clk' (since hclk_low clock is derived from a choice of clock sources and then divided by a divisor). This patch modifies the following. 1. Remove

[PATCH 04/11] ARM: S5P6440: Remove usage of clk_h and add clk_hclk clock

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The clk_h clock is of type 'struct clk' whereas on S5P6440, the hclk is more suitable to be of type 'struct clksrc_clk' (since hclk clock is divided version of armclk) This patch modifies the following. 1. Adds the 'clk_hclk' clock which is of type 'struct clksrc_clk'. 2. R

[PATCH 02/11] ARM: S5P6440: Change dout_mpll clock type to clksrc_clk clock type.

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham This patch modifies the following. 1. Modifies the dout_mpll clock type as clksrc_clk clock type. This modification allows the use of common clock code in managing the dout_mpll clock (which otherwise would need custom defined functions such as s5p6440_clk_doutmpll_

[PATCH 03/11] ARM: S5P6440: Remove usage of clk_arm and add clk_armclk clock

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The clk_arm clock is of type 'struct clk' whereas on S5P6440, the arm clock is more suitable to be of type 'struct clksrc_clk' (since arm clock is divided version of apll clock). This patch modifies the following. 1. Removes the usage of clk_arm clock (defined in plat-s5p)

[PATCH 05/11] ARM: S5P6440: Remove usage of clk_p and add clk_pclk clock

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham The clk_p clock is of type 'struct clk' whereas on S5P6440, the pclk is more suitable to be of type 'struct clksrc_clk' (since pclk clock is divided version of hclk). This patch modifies the following. 1. Adds the 'clk_pclk' clock which is of type 'struct clksrc_clk'. 2. Ad

[PATCH 01/11] ARM: S5P6440: Register apll/mpll/epll mout clocks.

2010-05-12 Thread Kukjin Kim
From: Thomas Abraham This patch modifies the following. 1. Registers the mout_apll clksrc_clk clock. 2. The mout_mpll and mout_epll were registered as 'struct clk' types and then their parents were setup using the s3c_set_clksrc function. This patch reduces the two steps into one by regis

Re: current next-samsung

2010-05-12 Thread Mike Solovyev
On Wed, 12 May 2010 09:52:02 +0100 Ben Dooks wrote: > Current contents of next-samsung: > > Arnaud Patard (3): > ARM: h1940: fix touchscreen support > ARM: S3C24XX: fix s3c2410fb platdata passing > ARM: S3C24XX: s3c24xx_mci_set_platdata should be marked __init It will be cool t

Re: next-samsung: acer n30/n35 updates

2010-05-12 Thread Pinkava J.
Dne 11.5.2010 03:03, Ben Dooks napsal(a): > On Fri, May 07, 2010 at 04:36:58AM +0200, Pinkava J. wrote: >> Dne 7.5.2010 02:50, Ben Dooks napsal(a): >>> Acer n35 support has been provisonally merged into the following branch: >>> >>> git://git.fluff.org/bjdooks/linux.git for-2635/acer-n35 >>> >>>

Re: S3C2412 SPI controller in DMA/FIFO mode

2010-05-12 Thread Ben Dooks
On Wed, May 12, 2010 at 10:45:14AM +0100, Jonathan Miles wrote: > Hi! > > Has anyone had any success in getting the S3C2412 SPI controller to work > in FIFO or DMA mode? I've been trying for a while now but not managed to > create anything stable. > > I note that the current kernels have s3c24x

Re: current next-samsung

2010-05-12 Thread Ben Dooks
On Wed, May 12, 2010 at 10:11:20AM +0100, Russell King - ARM Linux wrote: > On Wed, May 12, 2010 at 09:52:02AM +0100, Ben Dooks wrote: > > ARM: Merge $1 > > ARM: Merge $1 > > ARM: Merge $1 > > This looks like a script went wrong. yes. i'll probably rebuild before sending to linu

[PATCH] h1940: framebuffer configuration fix

2010-05-12 Thread Mike Solovyev
Seems like a typo, wrong setup leads to broken image on ipaq screen. Signed-off-by: Mike Solovyev Signed-off-by: Arnaud Patard --- arch/arm/mach-s3c2410/mach-h1940.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) Index: linux-2.6/arch/arm/mach-s3c2410/mach-h1940.c ===

S3C2412 SPI controller in DMA/FIFO mode

2010-05-12 Thread Jonathan Miles
Hi! Has anyone had any success in getting the S3C2412 SPI controller to work in FIFO or DMA mode? I've been trying for a while now but not managed to create anything stable. I note that the current kernels have s3c24xx_fiq - is this because no one else has managed to get FIFO/DMA to work eit

Re: current next-samsung

2010-05-12 Thread Russell King - ARM Linux
On Wed, May 12, 2010 at 09:52:02AM +0100, Ben Dooks wrote: > ARM: Merge $1 > ARM: Merge $1 > ARM: Merge $1 This looks like a script went wrong. -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majord...@vger.kernel.org Mo

current next-samsung

2010-05-12 Thread Ben Dooks
Current contents of next-samsung: Arnaud Patard (3): ARM: h1940: fix touchscreen support ARM: S3C24XX: fix s3c2410fb platdata passing ARM: S3C24XX: s3c24xx_mci_set_platdata should be marked __init Ben Dooks (44): ARM: S3C24XX: Add initial s3c_gpio configuration code

Re: [PATCH 01/15] ARM: S3C: Add S3C2416 detection to uncompress code

2010-05-12 Thread Yauhen Kharuzhy
On Wed, May 12, 2010 at 03:38:45AM +0100, Ben Dooks wrote: > On Wed, May 12, 2010 at 03:35:52AM +0100, Ben Dooks wrote: > > From: Yauhen Kharuzhy > > > > Add S3C2416 serial port setup to uncompress code. > > Yahuen, let me know if you've any objection to this going upstrea. No, don't have. > Fo