[PATCH 3/3] ARM: SAMSUNG: Add lookup of sdhci-s3c clocks using generic names

2011-10-04 Thread Rajeshwari Shinde
Add support for lookup of sdhci-s3c controller clocks using generic names for s3c2416, s3c64xx, s5pc100, s5pv210 and exynos4 SoC's. Signed-off-by: Rajeshwari Shinde --- arch/arm/mach-exynos4/clock.c | 99 ++- arch/arm/mach-s3c2416/clock.c | 68 +--- arch/arm/m

[PATCH 2/3] ARM: SAMSUNG: Remove SDHCI bus clocks from platform data

2011-10-04 Thread Rajeshwari Shinde
The bus clocks previously sent through platform data to SDHCI controller are removed. Signed-off-by: Rajeshwari Shinde --- arch/arm/mach-exynos4/Makefile |1 - arch/arm/mach-exynos4/setup-sdhci.c| 22 --- arch/arm/mach-s3c2416/Makefile |1

[PATCH 1/3] SDHCI: S3C: Use generic clock names for sdhci bus clock options

2011-10-04 Thread Rajeshwari Shinde
This patch modifies the driver to stop depending on the clock names being passed from the platform and switch over to bus clock lookup using generic clock names. Signed-off-by: Rajeshwari Shinde --- drivers/mmc/host/sdhci-s3c.c |6 ++ 1 files changed, 2 insertions(+), 4 deletions(-) dif

[PATCH 0/3] ARM: SAMSUNG: Add support for sdhci clock lookup using generic names

2011-10-04 Thread Rajeshwari Shinde
This patchset adds support for sdhci controller clock lookup using generic names. With this patchset, there will be no need to pass clock names in sdhci platform data. This patchset depends on two other patchsets: mmc: sdhci-s3c: Remove 'clk_type' member from platform data Add a common macro for c

Re: [PATCH] mmc: dw_mmc: Support predefined multiple block transfers.

2011-10-04 Thread Jaehoon Chung
Hi Mr.Jeon One question...if we used predefined transfer, didn't send stop-command? then i think that didn't need to enter this condition..how about this? In __dw_mci_start_reqeust() function(at your patch) if (mrq->stop) host->stop_cmdr = dw_mci_prepare_command(slot->mmc, mrq->stop); I

Re: [PATCH 2/4] ARM: EXYNOS4: Support for generic Clock manipulation PM callbacks

2011-10-04 Thread Chanwoo Choi
Kukjin Kim wrote: > Chanwoo Choi wrote: >> Signed-off-by: Chanwoo Choi >> Signed-off-by: Kyungmin Park >> --- >> arch/arm/mach-exynos4/Makefile |2 +- >> arch/arm/mach-exynos4/pm-runtime.c | 56 >> >> 2 files changed, 57 insertions(+), 1 deletions(

Re: [PATCH 4/4] ARM: EXYNOS4: Add power domain to use generic Power domain Framework

2011-10-04 Thread Chanwoo Choi
Kukjin Kim wrote: > Chanwoo Choi wrote: >> This patch initializes the power domain of EXYNOS4210. The devices >> which suppot runtime-PM have to be added in specific power domain. >> >> Signed-off-by: Chanwoo Choi >> Signed-off-by: Kyungmin Park >> --- >> arch/arm/mach-exynos4/mach-nuri.c

Re: [PATCH 1/4] ARM: EXYNOS4: Support for generic I/O power domains on EXYNOS4210

2011-10-04 Thread Chanwoo Choi
Sylwester Nawrocki wrote: > Hi Chanwoo, > > a few minor comments below... > > On 08/11/2011 06:55 AM, Chanwoo Choi wrote: >> Use the generic power domains support to implement support for >> power domain on EXYNOS4210. >> >> I refer to the following patch to implement what configure >> the clock

RE: [PATCH] gpio/samsung: Move SoC specific codes within macro

2011-10-04 Thread Kukjin Kim
Grant Likely wrote: > > On Mon, Oct 03, 2011 at 08:59:19AM +0530, Tushar Behera wrote: > > In drivers/gpio/gpio-samsung.c, there are certain structures > > and functions which are not getting used if the particular > > CPU is not selected. These code segments are moved under CPU > > specific macro

RE: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Kukjin Kim
Arnd Bergmann wrote: > > On Tuesday 04 October 2011, Kukjin Kim wrote: > > > I think the string concatenation really just obfuscates the code, and > > > it does not actually save much at all. When you replace > > > > > > + [0] = SAMSUNG_RES_MEM(S3C, WDT, SZ_1K), > > > + [1] = SAMSUNG_R

RE: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Kukjin Kim
Kyungmin Park wrote: > > On Wed, Oct 5, 2011 at 12:26 AM, Arnd Bergmann wrote: > > On Tuesday 04 October 2011, Kukjin Kim wrote: > >> > I think the string concatenation really just obfuscates the code, and > >> > it does not actually save much at all. When you replace > >> > > >> > +       [0] =

Re: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Kyungmin Park
On Wed, Oct 5, 2011 at 12:26 AM, Arnd Bergmann wrote: > On Tuesday 04 October 2011, Kukjin Kim wrote: >> > I think the string concatenation really just obfuscates the code, and >> > it does not actually save much at all. When you replace >> > >> > +       [0] = SAMSUNG_RES_MEM(S3C, WDT, SZ_1K), >>

Re: [PATCH] gpio/samsung: Move SoC specific codes within macro

2011-10-04 Thread Grant Likely
On Mon, Oct 03, 2011 at 08:59:19AM +0530, Tushar Behera wrote: > In drivers/gpio/gpio-samsung.c, there are certain structures > and functions which are not getting used if the particular > CPU is not selected. These code segments are moved under CPU > specific macros to remove compilation warnings.

Re: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Arnd Bergmann
On Tuesday 04 October 2011, Kukjin Kim wrote: > > I think the string concatenation really just obfuscates the code, and > > it does not actually save much at all. When you replace > > > > + [0] = SAMSUNG_RES_MEM(S3C, WDT, SZ_1K), > > + [1] = SAMSUNG_RES_IRQ(WDT), > > > > with > > > >

[PATCH V4] mmc: core: HS200 mode support for eMMC 4.5

2011-10-04 Thread Girish K S
This patch adds the support of the HS200 bus speed for eMMC 4.5 devices. The eMMC 4.5 devices have support for 200MHz bus speed. The mmc core and host modules have been touched to add support for this module. It is necessary to know the card type in the sdhci.c file to add support for eMMC tuning f

[GIT PULL] Samsung board-2 for v3.2

2011-10-04 Thread Kukjin Kim
Hi Arnd, This is a second Samsung board stuff for v3.2 and includes new board, SMDK4412. Please pull from: git://github.com/kgene/linux-samsung.git next-samsung-board-2 As a note, since supporting SMDK4412 needs previous next-samsung-board branch so this is based on next-samsung-board which ha

[GIT PULL] Samsung cleanup-2 for v3.2

2011-10-04 Thread Kukjin Kim
Hi Arnd, This is second cleanup for Samsung stuff for v3.2 and includes cleanup header files in plat-s3c24xx and plat-s5p to merge into one plat-samsung directory. Please pull from: git://github.com/kgene/linux-samsung.git next-samsung-cleanup-2 And this is based on previous Samsung cleanup br

Re: [PATCH v4] mmc: core: Add default timeout value for CMD6.

2011-10-04 Thread Adrian Hunter
On 22/09/11 05:12, Seungwon Jeon wrote: EXT_CSD[248] includes the default maximum timeout for CMD6. This field is added at eMMC4.5 Spec. And it can be used for default timeout except for some operations which don't define the timeout(i.e. background operation, sanitize, flush cache) in eMMC4.5 Sp

Re: [GIT PULL] Samsung devel-2 for v3.2

2011-10-04 Thread Mark Brown
On Tue, Oct 04, 2011 at 09:45:16PM +0900, Kukjin Kim wrote: > Mark Brown wrote: > > As I reported the other day this change breaks the boot early on on the > > Cragganmore S3C6410 based systems (I've not actually fired up my > > SMDK6410 but I suspect it may have issues too). I did make some brie

RE: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Kukjin Kim
Sylwester Nawrocki wrote: > > On 10/03/2011 03:13 PM, Kukjin Kim wrote: > > On 10/03/11 12:53, Kyungmin Park wrote: > >> On Mon, Oct 3, 2011 at 12:41 PM, Kukjin Kim > wrote: > >>> > >>> +#define SAMSUNG_RES_MEM(soc, ip, sz) > DEFINE_RES_MEM(soc##_PA_##ip, sz) > >>> +#define SAMSUNG_RES_IRQ(ip)

RE: [PATCH V2 2/2] ARM: SAMSUNG: Cleanup resources by using macro

2011-10-04 Thread Kukjin Kim
Arnd Bergmann wrote: > > On Monday 03 October 2011 12:41:22 Kukjin Kim wrote: > > This patch adds macro SAMSUNG_RES_MEM, SAMSUNG_RES_IRQ > > and so on to cleanup regarding 'struct resource' by using > > defined helpers at . > > > > Cc: Ben Dooks > > Signed-off-by: Kukjin Kim > > When we introdu

RE: [GIT PULL] Samsung devel-2 for v3.2

2011-10-04 Thread Kukjin Kim
Mark Brown wrote: > > On Sun, Oct 02, 2011 at 06:25:36PM +0900, Kukjin Kim wrote: > > > gpio/samsung: gpio-samsung.c to support Samsung GPIOs > > As I reported the other day this change breaks the boot early on on the > Cragganmore S3C6410 based systems (I've not actually fired up my > SMD

RE: [PATCH] ARM: EXYNOS: Add ARCH_EXYNOS and reorganize arch/arm/mach-exynos

2011-10-04 Thread Kukjin Kim
Arnd Bergmann wrote: > > On Monday 03 October 2011 21:40:36 Kukjin Kim wrote: > > Yes, absolutely. As I said, the 'mach-exynos' can support upcoming > > Samsung EXYNOS SoCs and the way is better than making mach-exynos5. > > > > My bigger plan is finally to make current directories to 3 mach- dir.

RE: [PATCH 2/7] s3c-adc: describe features via quirk constants

2011-10-04 Thread Kukjin Kim
Heiko Stübner wrote: > > Hi Kgene, > > Am Sonntag 02 Oktober 2011, 09:38:18 schrieb Kukjin Kim: > > How about following? I think following is also not bad... > ok, I don't claim to have the right solution, so if keeping the TYPE_xxx enum > is better, I will do a rework of the series according to

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, So u mean i dont have to re-do the patch for powerNotify. One more question. Will you add my HS200 patch also to your eMMC4.5 branch. In case yes then i will rebase my branch to ur emmc 4.5 branch and resend my hs200 patch regards Girish K S On 4 October 2011 17:49, Jaehoon Chung

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish. I just modified the MMC_CAP2_POWEROFF_NOTIFY instead of MMC_CAP_POWEROFF_NOTIFY. Regards, Jaehoon Chung On 10/04/2011 09:12 PM, Girish K S wrote: > Dear Mr Chung, > > i saw your pull request with poweroff notify feature. did you modify > anything in the Power Notify feature. > > I

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Dear Mr Chung, i saw your pull request with poweroff notify feature. did you modify anything in the Power Notify feature. I am preparing the patch with your review comment. regards Girish K S On 4 October 2011 17:11, Girish K S wrote: > Hello Mr Chung, > > Since my both patches are dependent o

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, Since my both patches are dependent on each other. i will generate a patch series of HS200 and Power notify. So that they can be applied sequentially. Will update with your mentioned comment. kindly review it after my release. regards Girish K S On 4 October 2011 16:50, Girish K

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, I got your point. My reply was for your comment on "cannot apply this patch on mmc-next branch". regards Girish K S On 4 October 2011 16:46, Jaehoon Chung wrote: > Hi Girish.. > > My means if you use host->caps2, i think right that should be define > MMC_CAP2_XXX. > Am i wrong? >

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. My means if you use host->caps2, i think right that should be define MMC_CAP2_XXX. Am i wrong? Best regards, Jaehoon Chung On 10/04/2011 08:03 PM, Girish K S wrote: > Hello Mr Chung, > > Kindly apply my HS200 feature patch before this patch. then it will work fine. > can you check

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Girish K S
Hello Mr Chung, Kindly apply my HS200 feature patch before this patch. then it will work fine. can you check and let me know if it applies after HS200 patch. If it can be applied i will modify and resend regards Girish K S On 4 October 2011 16:22, Jaehoon Chung wrote: > Hi Girish.. > > i think

Re: [PATCH V7] mmc: core: Add Power Off Notify Feature eMMC 4.5

2011-10-04 Thread Jaehoon Chung
Hi Girish.. i think this patch didn't base on latest for mmc-next.. i commented the below. Regards, Jaehoon Chung On 09/29/2011 07:46 PM, Girish K S wrote: > This patch adds the support for power off notify feature > available in eMMC 4.5 devices. > If the the host has support for this

[PATCH] arm: mm: Fix infinite looping issue

2011-10-04 Thread Girish K S
This patch fixes the problem of infinite looping while booting. The bne instruction expects the z flag to be set to break the loop. The (mov r1, r1, lsr #1) doesn't behave in the expected way. If replaced with the movs instruction then the execution will exit the loop. Signed-off-by: Girish K S

Re: [PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Thomas Abraham
Hi Mr. Park, On 4 October 2011 13:23, Kyungmin Park wrote: > Hi, > > On Tue, Oct 4, 2011 at 4:28 PM, Thomas Abraham > wrote: >> SDHCI controllers on Exynos4 do not include the sdclk divider as per the >> sdhci controller specification. This case can be represented using the >> sdhci quirk SDHCI_

Re: [PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Kyungmin Park
Hi, On Tue, Oct 4, 2011 at 4:28 PM, Thomas Abraham wrote: > SDHCI controllers on Exynos4 do not include the sdclk divider as per the > sdhci controller specification. This case can be represented using the > sdhci quirk SDHCI_QUIRK_NONSTANDARD_CLOCK instead of using an additional > enum type defi

[PATCH 1/3] mmc: sdhci-s3c: Remove usage of clk_type member in platform data

2011-10-04 Thread Thomas Abraham
SDHCI controllers on Exynos4 do not include the sdclk divider as per the sdhci controller specification. This case can be represented using the sdhci quirk SDHCI_QUIRK_NONSTANDARD_CLOCK instead of using an additional enum type definition 'clk_types'. Hence, usage of clk_type member in platform dat

[PATCH 3/3] arm: samsung: remove all uses of clk_type member in sdhci platform data

2011-10-04 Thread Thomas Abraham
The sdhci driver is modified to be independent of clk_type member in the sdhci platform data. Hence, all usage of clk_type in platform code is removed. Cc: Kyungmin Park Cc: JeongHyeon Kim Cc: Kukjin Kim Cc: Changhwan Youn Cc: Alim Akhtar Signed-off-by: Thomas Abraham --- arch/arm/mach-exyn

[PATCH 2/3] arm: exynos4: use 'exynos4-sdhci' as device name for sdhci controllers

2011-10-04 Thread Thomas Abraham
With the addition of platform specific driver data in the sdhci driver for exynos4, the device name of sdhci controllers on exynos4 is changed accordingly. Cc: Kukjin Kim Signed-off-by: Thomas Abraham --- arch/arm/mach-exynos4/clock.c | 16 arch/arm/mach-exynos4/

[PATCH 0/3] mmc: sdhci-s3c: Remove 'clk_type' member from platform data

2011-10-04 Thread Thomas Abraham
This patchset removes all uses of 'clk_type' member from the platform data of sdhci-s3c driver. The clk_type is a SoC specific information and not a board/ machine specific information. Hence, this information can be more aptly represented using SoC specific driver data in the sdhci-s3c driver. He