Re: [PATCH 3/7] s3c-hsudc: add a remove function

2011-12-19 Thread Greg KH
On Sun, Dec 18, 2011 at 09:37:04PM +, Russell King - ARM Linux wrote: > On Sun, Dec 18, 2011 at 09:46:08PM +0100, Heiko Stübner wrote: > > > > kobject: 'holders' (c7addc80): kobject_cleanup > > > > Unable to handle kernel paging request at virtual address bf055504 > > > > pgd = c0004000 > > > >

Re: [PATCH 3/7] s3c-hsudc: add a remove function

2011-12-19 Thread Greg KH
On Sun, Dec 18, 2011 at 07:50:37PM +0100, Heiko Stübner wrote: > Am Sonntag 18 Dezember 2011, 15:43:19 schrieb Russell King - ARM Linux: > > On Sun, Dec 18, 2011 at 02:44:39PM +0100, Heiko Stübner wrote: > > > Am Sonntag 18 Dezember 2011, 09:10:48 schrieb Russell King - ARM Linux: > > > > On Sat, D

Re: [PATCH V6 2/2] mmc: host: Adds support for eMMC 4.5 HS200 mode

2011-12-19 Thread Girish K S
On 19 December 2011 22:24, Philip Rakity wrote: > > HI, > > minor comments below. > > Philip > > On Dec 18, 2011, at 10:36 PM, Girish K S wrote: > >> This patch adds support for the HS200 mode on the host side. >> Also enables the tuning feature required when the HS200 mode >> is selected. >> >> c

Re: [PATCH 2/3] s5p-g2d: add G2D to mach-nuri

2011-12-19 Thread Kyungmin Park
On 12/20/11, Mark Brown wrote: > On Mon, Dec 12, 2011 at 11:32:28PM +0900, Kyungmin Park wrote: >> On Mon, Dec 12, 2011 at 7:03 PM, Mark Brown > >> > I'm not sure I understand why we would not be ready to do things like >> > this? I'd also expect that doing things in a board specific fashion >> >

Re: [PATCH 2/3] s5p-g2d: add G2D to mach-nuri

2011-12-19 Thread Mark Brown
On Mon, Dec 12, 2011 at 11:32:28PM +0900, Kyungmin Park wrote: > On Mon, Dec 12, 2011 at 7:03 PM, Mark Brown > > I'm not sure I understand why we would not be ready to do things like > > this?  I'd also expect that doing things in a board specific fashion > > might create issues with things being

[PATCH 8/8] s3c-hsudc: remove the_controller global

2011-12-19 Thread Heiko Stübner
Instead use container_of to retrieve the s3c_hsudc from the struct usb_gadget pointer. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 11 ++- 1 files changed, 6 insertions(+), 5 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc

[PATCH 7/8] s3c-hsudc: use release_mem_region instead of release_resource

2011-12-19 Thread Heiko Stübner
As the memory region is requested through request_mem_region use the correct paired method to release it in the error path and don't go "beneath the API" as pointed out by Russel King. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |4 +--- 1 files changed, 1 insertions(+),

[PATCH 6/8] s3c-hsudc: Add regulator handling

2011-12-19 Thread Heiko Stübner
The udc has three supplies: vdda (3.3V), vddi (1.2V) and vddosc (1.8-3.3V). Turn these on and off on start and stop calls. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 41 --- 1 files changed, 37 insertions(+), 4 deletions(-) diff --gi

[PATCH 5/8] s3c-hsudc: use udc_start and udc_stop functions

2011-12-19 Thread Heiko Stübner
udc_start and udc_stop reduce code duplication in comparison to start and stop generalising calls done by all drivers (i.e. bind and unbind) and moving these calls to common code. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 44 --- 1 f

[PATCH 4/8] s3c-hsudc: move device registration to probe

2011-12-19 Thread Heiko Stübner
Instead of adding and deleting the gadget device in the start and stop invocations. Use device_register in the probe method to initialize and add the gadget device. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 17 - 1 files changed, 8 insertions(+), 9 dele

[PATCH 3/8] s3c-hsudc: add missing otg_put_transceiver in probe

2011-12-19 Thread Heiko Stübner
The number of get and put calls should always be equal. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc.c index 86e336e..1171efb 100644 --- a/

[PATCH 2/8] s3c-hsudc: add __devinit to probe function

2011-12-19 Thread Heiko Stübner
Fixes possible section mismatch warnings. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc.c index 606b20f..86e336e 100644 --- a/drivers/usb/gad

[PATCH 1/8] s3c-hsudc: move platform_data struct to global header

2011-12-19 Thread Heiko Stübner
Gadget drivers should be compilable on all architectures. This patch removes one dependency on architecture-specific code. Signed-off-by: Heiko Stuebner --- arch/arm/mach-s3c2416/mach-smdk2416.c|1 + arch/arm/plat-samsung/devs.c |1 + arch/arm/plat-samsung/include/plat/ud

[PATCH v4 0/8] s3c-hsudc: regulator handling and a lot of fixes

2011-12-19 Thread Heiko Stübner
In his response to the first submission Felipe Balbi asked to also move the driver to the new udc_start and udc_stop functions and to make an effort to reduce dependencies on archictecture code. v3 of the series does not try to provide a remove function, due to the possible lifetime problem of gad

Re: [PATCH] mmc: core: Fix voltage select in DDR mode

2011-12-19 Thread Philip Rakity
On Dec 15, 2011, at 9:06 AM, Subhash Jadavani wrote: > > >> -Original Message- >> From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- >> ow...@vger.kernel.org] On Behalf Of Girish K S >> Sent: Thursday, December 15, 2011 5:28 PM >> To: linux-...@vger.kernel.org >> Cc: patc...@linar

Re: [PATCH V6 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-19 Thread Philip Rakity
On Dec 18, 2011, at 10:36 PM, Girish K S wrote: > This patch adds the support of the HS200 bus speed for eMMC 4.5 devices. > The eMMC 4.5 devices have support for 200MHz bus speed. The function > prototype of the tuning function is modified to handle the tuning command > number which is different

Re: [PATCH V6 2/2] mmc: host: Adds support for eMMC 4.5 HS200 mode

2011-12-19 Thread Philip Rakity
HI, minor comments below. Philip On Dec 18, 2011, at 10:36 PM, Girish K S wrote: > This patch adds support for the HS200 mode on the host side. > Also enables the tuning feature required when the HS200 mode > is selected. > > cc: Chris Ball > Signed-off-by: Girish K S > --- > drivers/mmc/ho

Re: [PATCH] ARM: restart: S3C64XX: use new restart hook

2011-12-19 Thread Kukjin Kim
On 12/19/11 22:55, Russell King - ARM Linux wrote: On Mon, Dec 19, 2011 at 08:58:20PM +0900, Kukjin Kim wrote: Hook these platforms restart code into the new restart hook rather than using arch_reset(). Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim It would be _much_ better if you

Re: [PATCH] ARM: restart: S3C64XX: use new restart hook

2011-12-19 Thread Russell King - ARM Linux
On Mon, Dec 19, 2011 at 08:58:20PM +0900, Kukjin Kim wrote: > Hook these platforms restart code into the new restart hook rather > than using arch_reset(). > > Cc: Ben Dooks > Cc: Russell King > Signed-off-by: Kukjin Kim It would be _much_ better if you could prepare a set of patches against m

Re: [PATCH 5/7] s3c-hsudc: use udc_start and udc_stop functions

2011-12-19 Thread Felipe Balbi
On Mon, Dec 19, 2011 at 02:26:20PM +0100, Heiko Stübner wrote: > udc_start and udc_stop reduce code duplication in comparison to > start and stop generalising calls done by all drivers > (i.e. bind and unbind) and moving these calls to common code. > > Signed-off-by: Heiko Stuebner > --- > drive

Re: [PATCH 2/7] s3c-hsudc: add __devinit to probe function

2011-12-19 Thread Felipe Balbi
On Mon, Dec 19, 2011 at 02:24:57PM +0100, Heiko Stübner wrote: I need a commit log, even if it's an obvious one. Sorry for the nit-picking. > Signed-off-by: Heiko Stuebner > --- > drivers/usb/gadget/s3c-hsudc.c |2 +- > 1 files changed, 1 insertions(+), 1 deletions(-) > > diff --git a/driv

Re: [PATCH 1/7] s3c-hsudc: move platform_data struct to global header

2011-12-19 Thread Felipe Balbi
Hi, On Mon, Dec 19, 2011 at 02:24:24PM +0100, Heiko Stübner wrote: > diff --git a/include/linux/usb/s3c-hsudc.h b/include/linux/usb/s3c-hsudc.h > new file mode 100644 > index 000..6fa1093 > --- /dev/null > +++ b/include/linux/usb/s3c-hsudc.h > @@ -0,0 +1,34 @@ > +/* > + * S3C24XX USB 2.0 High-

[PATCH 7/7] s3c-hsudc: use release_mem_region instead of release_resource

2011-12-19 Thread Heiko Stübner
As the memory region is requested through request_mem_region use the correct paired method to release it in the error path and don't go "beneath the API" as pointed out by Russel King. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |4 +--- 1 files changed, 1 insertions(+),

[PATCH 6/7] s3c-hsudc: Add regulator handling

2011-12-19 Thread Heiko Stübner
The udc has three supplies: vdda (3.3V), vddi (1.2V) and vddosc (1.8-3.3V). Turn these on and off on start and stop calls. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 41 --- 1 files changed, 37 insertions(+), 4 deletions(-) diff --gi

[PATCH 5/7] s3c-hsudc: use udc_start and udc_stop functions

2011-12-19 Thread Heiko Stübner
udc_start and udc_stop reduce code duplication in comparison to start and stop generalising calls done by all drivers (i.e. bind and unbind) and moving these calls to common code. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 44 --- 1 f

[PATCH 4/7] s3c-hsudc: move device registration to probe

2011-12-19 Thread Heiko Stübner
Instead of adding and deleting the gadget device in the start and stop invocations. Use device_register in the probe method to initialize and add the gadget device. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c | 17 - 1 files changed, 8 insertions(+), 9 dele

[PATCH 3/7] s3c-hsudc: add missing otg_put_transceiver in probe

2011-12-19 Thread Heiko Stübner
The number of get and put calls should always be equal. Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc.c index 3e5673d..6c2b2ce 100644 --- a/

[PATCH 2/7] s3c-hsudc: add __devinit to probe function

2011-12-19 Thread Heiko Stübner
Signed-off-by: Heiko Stuebner --- drivers/usb/gadget/s3c-hsudc.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/drivers/usb/gadget/s3c-hsudc.c b/drivers/usb/gadget/s3c-hsudc.c index 4c1abb1..3e5673d 100644 --- a/drivers/usb/gadget/s3c-hsudc.c +++ b/drivers/usb/gadget/s3

[PATCH 1/7] s3c-hsudc: move platform_data struct to global header

2011-12-19 Thread Heiko Stübner
Gadget drivers should be compilable on all architectures. This patch removes one dependency on architecture-specific code. Signed-off-by: Heiko Stuebner --- arch/arm/mach-s3c2416/mach-smdk2416.c|1 + arch/arm/plat-samsung/devs.c |1 + arch/arm/plat-samsung/include/plat/ud

[PATCH v3 0/7] s3c-hsudc: regulator handling and a lot of fixes

2011-12-19 Thread Heiko Stübner
In his response to the first submission Felipe Balbi asked to also move the driver to the new udc_start and udc_stop functions and to make an effort to reduce dependencies on archictecture code. v3 of the series does not try to provide a remove function, due to the possible lifetime problem of gad

Re: [PATCH] ARM: restart: move SWRST based S3C platforms to machine_desc hook

2011-12-19 Thread Heiko Stübner
Am Montag, 19. Dezember 2011, 13:42:24 schrieb Kukjin Kim: > Heiko Stübner wrote: > > S3C2412/S3C2416/S3C2443 use a special register to signal the reset to > > the processor and used therefore the s3c24xx_reset_hook mechanism in the > > s3c24xx-specific arch reset. > > > > This patch introduces re

RE: [PATCH] ARM: restart: move SWRST based S3C platforms to machine_desc hook

2011-12-19 Thread Kukjin Kim
Heiko Stübner wrote: > > S3C2412/S3C2416/S3C2443 use a special register to signal the reset to > the processor and used therefore the s3c24xx_reset_hook mechanism in the > s3c24xx-specific arch reset. > > This patch introduces restart functions for these architectures, > moves the board files to

[PATCH] ARM: restart: move SWRST based S3C platforms to machine_desc hook

2011-12-19 Thread Heiko Stübner
S3C2412/S3C2416/S3C2443 use a special register to signal the reset to the processor and used therefore the s3c24xx_reset_hook mechanism in the s3c24xx-specific arch reset. This patch introduces restart functions for these architectures, moves the board files to them and removes the s3c24xx_reset_h

RE: [PATCH] ARM: restart: S3C64XX: use new restart hook

2011-12-19 Thread Kukjin Kim
Heiko Stübner wrote: > > Hi Kgene, > > will you also do s3c24xx? > > I'm asking, as I'm currently also looking at this for the 24xx arches and > would like to prevent double work on both our sides. > Sure, I'm sorting out all of Samsung stuff and it will be done tomorrow :) Thanks. Best regar

Re: [PATCH] ARM: restart: S3C64XX: use new restart hook

2011-12-19 Thread Heiko Stübner
Hi Kgene, will you also do s3c24xx? I'm asking, as I'm currently also looking at this for the 24xx arches and would like to prevent double work on both our sides. Thanks Heiko Am Montag, 19. Dezember 2011, 12:58:20 schrieb Kukjin Kim: > Hook these platforms restart code into the new restart ho

[PATCH] ARM: restart: S3C64XX: use new restart hook

2011-12-19 Thread Kukjin Kim
Hook these platforms restart code into the new restart hook rather than using arch_reset(). Cc: Ben Dooks Cc: Russell King Signed-off-by: Kukjin Kim --- arch/arm/mach-s3c64xx/common.c | 10 ++ arch/arm/mach-s3c64xx/common.h |2 ++ arch/arm/

[PATCH] ARM: S3C64XX: Added common.c and common.h for S3C64XX SoCs

2011-12-19 Thread Kukjin Kim
This patch adds common.c and common.h which are used only in the arch/arm/mach-s3c64xx directory. The common.c file includes cpu.c, irq.c and irq-eint.c which are used commonly on S3C64XX SoCs and the common.h file includes plat/s3c6400.h and plat/s3c6410.h files. Cc: Ben Dooks Cc: Russell King

RE: [PATCH V6 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-19 Thread Subhash Jadavani
> -Original Message- > From: Girish K S [mailto:girish.shivananja...@linaro.org] > Sent: Monday, December 19, 2011 4:20 PM > To: Subhash Jadavani > Cc: linux-...@vger.kernel.org; patc...@linaro.org; linux-samsung- > s...@vger.kernel.org; Chris Ball > Subject: Re: [PATCH V6 1/2] mmc: core:

Re: [PATCH V6 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-19 Thread Girish K S
On 19 December 2011 15:40, Subhash Jadavani wrote: > Hi Girish, > > Overall this patch looks good. I have only 2 minor comments inline below. > > Regards, > Subhash > > >> -Original Message- >> From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- >> ow...@vger.kernel.org] On Behalf Of

RE: [PATCH V6 1/2] mmc: core: HS200 mode support for eMMC 4.5

2011-12-19 Thread Subhash Jadavani
Hi Girish, Overall this patch looks good. I have only 2 minor comments inline below. Regards, Subhash > -Original Message- > From: linux-mmc-ow...@vger.kernel.org [mailto:linux-mmc- > ow...@vger.kernel.org] On Behalf Of Girish K S > Sent: Monday, December 19, 2011 12:07 PM > To: linux-.