From: Abhilash Kesavan
The SPI driver makes a gpio_request during initialization. The requested
gpios need to be populated as part of the s3c64xx_spi_driver_data so that
they can be released during suspend and requested again during resume.
Add the missing code to save the requested gpios as par
Linus Walleij wrote:
>
> On Wed, Oct 24, 2012 at 4:37 PM, Tomasz Figa wrote:
>
> > This patch modifies the Samsung GPIO driver to check for pinctrl driver
> > presence earlier and use generic matching instead of a single compatible
> > value.
> >
> > This allows us to fix warning about unrecogni
Kukjin Kim wrote:
>
> Tomasz Figa wrote:
> >
> > This patch adds device tree sources for Exynos4x12 SoC series (currently
> > Exynos4212 and Exynos4412) and enables mach-exynos4-dt to support these
> > SoCs.
> >
> > Signed-off-by: Tomasz Figa
> > Signed-off-by: Kyungmin Park
> > ---
> > arch/ar
Hi,
I have a few comments. Please see below...
On 11/06/2012 04:36 PM, Vivek Gautam wrote:
Adding support for USB3.0 phy for dwc3 controller on
exynso5250 SOC.
exynso -> exynos
Signed-off-by: Vivek Gautam
---
drivers/usb/phy/samsung-usbphy.c| 337 +++
Hi.
> Does the sensor still hang after 0x2f is written to REG_GRCOM instead ?
Work!
I'm looking at drivers/media/usb/gspca/m5602/m5602_ov9650.h
It use significantly different init sequence. Some of settings
described in Application note for ov9650, some look like magic.
> Do you have CONFIG_PM_RU
On Tue, Nov 06, 2012 at 08:58:49PM +0530, Vivek Gautam wrote:
> Adding DWC3 device tree node for Exynos5250 along with the
> device address and clock support needed for the controller.
>
> Signed-off-by: Vivek Gautam
> ---
> arch/arm/boot/dts/exynos5250.dtsi |6 ++
> arch/arm/mach-
Hi,
On Tue, Nov 06, 2012 at 07:23:12PM +0530, Vivek Gautam wrote:
> Hi Balbi,
>
>
> On Tue, Nov 6, 2012 at 6:44 PM, Felipe Balbi wrote:
> > Hi,
> >
> > On Mon, Oct 29, 2012 at 07:12:36PM +0530, Vivek Gautam wrote:
> >> This patchset is based on the work by Praveen Paneri for
> >> samsung-usbphy
Adding base address information and required platform data
support for enabling USB DRD phy on exynos5250 SOC.
Signed-off-by: Vivek Gautam
---
arch/arm/boot/dts/exynos5250.dtsi|3 ++-
arch/arm/mach-exynos/include/mach/regs-pmu.h |4
arch/arm/mach-exynos/setup-usb-phy.c
Adding support for USB3.0 phy for dwc3 controller on
exynso5250 SOC.
Signed-off-by: Vivek Gautam
---
drivers/usb/phy/samsung-usbphy.c| 337 +++
include/linux/usb/samsung_usb_phy.h |1 +
2 files changed, 338 insertions(+), 0 deletions(-)
diff --git a/driv
This patchset is based on the work for USB 2.0 host phy support
for exynos5250
https://lists.ozlabs.org/pipermail/devicetree-discuss/2012-November/021915.html
Based on 'usb-next' branch.
Tested on smdk5250 with following patch-series:
https://lists.ozlabs.org/pipermail/devicetree-discuss/2012-Nove
Adding DWC3 device tree node for Exynos5250 along with the
device address and clock support needed for the controller.
Signed-off-by: Vivek Gautam
---
arch/arm/boot/dts/exynos5250.dtsi |6 ++
arch/arm/mach-exynos/clock-exynos5.c| 24
arch/arm/mach-exy
Here we add the required support for device tree and further
clocks and device reigster base address.
Based on 'for-next' branch of linux-samsung tree.
Tested with required driver DT patches for dwc3-exynos:
http://www.spinics.net/lists/linux-usb/msg73857.html
and USB 3.0 phy support patches:
http
Adding the phy-driver to ohci-exynos. Keeping the platform data
for continuing the smooth operation for boards which still uses it
Signed-off-by: Vivek Gautam
Acked-by: Jingoo Han
---
drivers/usb/host/ohci-exynos.c | 70
1 files changed, 49 insertions(
Adding the phy driver to ehci-s5p. Keeping the platform data
for continuing the smooth operation for boards which still uses it
Signed-off-by: Vivek Gautam
Acked-by: Jingoo Han
---
drivers/usb/host/ehci-s5p.c | 70 ++-
1 files changed, 49 insertions(+),
Adding usbphy node for Exynos5250 along with the platform data
Signed-off-by: Vivek Gautam
---
.../devicetree/bindings/usb/samsung-usbphy.txt | 12 +-
arch/arm/boot/dts/exynos5250.dtsi |5 ++
arch/arm/mach-exynos/Kconfig |1 +
arch/arm/mac
This patch adds host phy support to samsung-usbphy.c and
further adds support for samsung's exynos5250 usb-phy.
Signed-off-by: Vivek Gautam
Signed-off-by: Praveen Paneri
---
arch/arm/mach-exynos/setup-usb-phy.c |2 +-
arch/arm/mach-s3c64xx/setup-usb-phy.c| 18 +-
arch/arm/
Updating the names of usb-phy types to more generic names:
USB_PHY_TYPE_DEIVCE & USB_PHY_TYPE_HOST; and further update its
dependencies.
Signed-off-by: Praveen Paneri
Signed-off-by: Vivek Gautam
---
arch/arm/mach-exynos/setup-usb-phy.c |9 +
arch/arm/mach-s5pv210/setup-usb-p
This patchset is based on the work by Praveen Paneri for
samsung-usbphy driver:
http://www.spinics.net/lists/linux-usb/msg73518.html
Changes from v3:
- Moved enums S5P_USB_PHY_DEVICE, S5P_USB_PHY_HOST from machine to file
include/linux/usb/samsung_usb_phy.h as USB_PHY_TYPE_DEVICE and
USB_PH
Hi Balbi,
On Tue, Nov 6, 2012 at 6:44 PM, Felipe Balbi wrote:
> Hi,
>
> On Mon, Oct 29, 2012 at 07:12:36PM +0530, Vivek Gautam wrote:
>> This patchset is based on the work by Praveen Paneri for
>> samsung-usbphy driver:
>> http://comments.gmane.org/gmane.linux.kernel.samsung-soc/12653
>>
>> Chan
On Tue, Nov 06, 2012 at 08:24:31PM +0900, Kukjin Kim wrote:
> Dave Martin wrote:
> >
>
> [...]
>
> > > >> - asm(".word 0xe320f003\n"
> > > >> + asm(__WFI
> > > >
> > > > Wouldn't using the actual wfi instruction fix this. There is a wfi()
> > > > macro.
> > > >
> > >
Hi,
On Mon, Oct 29, 2012 at 07:12:36PM +0530, Vivek Gautam wrote:
> This patchset is based on the work by Praveen Paneri for
> samsung-usbphy driver:
> http://comments.gmane.org/gmane.linux.kernel.samsung-soc/12653
>
> Changes from v2:
> - Using "EXYNOS5_PHY_" as common prefix along with exact n
Jingoo Han wrote:
>
> This patch reorders inclusions of
> and puts the inclusions with the same kind for readability,
> according to alphabetical ordering.
>
> Signed-off-by: Jingoo Han
> ---
> arch/arm/mach-exynos/dev-audio.c |2 +-
> arch/arm/mach-exynos/dev-ohci.c|
Kukjin Kim wrote:
>
> Thomas Abraham wrote:
> >
> > All the Exynos4x12 based platforms use only device tree based boot. So
> > remove
> > the unused 'init_uarts' callback from exynos cpu_ids table.
> >
> > Signed-off-by: Thomas Abraham
> > ---
> > arch/arm/mach-exynos/common.c |2 --
> > 1 f
Thomas Abraham wrote:
>
> All the Exynos4x12 based platforms use only device tree based boot. So
> remove
> the unused 'init_uarts' callback from exynos cpu_ids table.
>
> Signed-off-by: Thomas Abraham
> ---
> arch/arm/mach-exynos/common.c |2 --
> 1 files changed, 0 insertions(+), 2 deleti
Thomas Abraham wrote:
>
> Add a minimal board dts file for Samsung Exynos4412 based SMDK board.
>
> Signed-off-by: Thomas Abraham
> ---
> This patch depends the on the following patch posted by Tomasz Figa.
> "ARM: dts: exynos4: Add support for Exynos4x12 SoCs"
>
> arch/arm/boot/dts/Makefile
Dave Martin wrote:
>
[...]
> > >> - asm(".word 0xe320f003\n"
> > >> + asm(__WFI
> > >
> > > Wouldn't using the actual wfi instruction fix this. There is a wfi()
> > > macro.
> > >
> > > Or just call cpu_do_idle() which will do any other things needed
> before
> > > w
Linus Walleij wrote:
>
> On Fri, Oct 26, 2012 at 7:55 PM, Kukjin Kim wrote:
>
> > From: Thomas Abraham
> >
> > Add a new pinctrl driver for Samsung EXYNOS5440 SoC. The pin controller
> > module in EXYNOS5440 is different from the pin controller found on other
> > Samsung SoC. Hence, the pin con
Tomasz Figa wrote:
>
> This patch adds device tree sources for Exynos4x12 SoC series (currently
> Exynos4212 and Exynos4412) and enables mach-exynos4-dt to support these
> SoCs.
>
> Signed-off-by: Tomasz Figa
> Signed-off-by: Kyungmin Park
> ---
> arch/arm/boot/dts/exynos4212.dtsi | 28 ++
Mark Brown wrote:
>
> On Fri, Nov 02, 2012 at 01:04:14PM +, Dimitris Papastamos wrote:
> > We are using S3C_EINT(4) instead of S3C_EINT(5).
>
> Reviwed-by: Mark Brown
Reviewed-by?
Applied with fixing typo :-)
Thanks.
Best regards,
Kgene.
--
Kukjin Kim , Senior Engineer,
SW Solution Devel
On Tue, Nov 6, 2012 at 1:40 PM, Mark Brown
wrote:
> On Mon, Nov 05, 2012 at 05:21:03PM +0530, Shubhrajyoti Datta wrote:
>> On Mon, Nov 5, 2012 at 2:03 PM, Mark Brown
>> wrote:
>> > A small code saving and less error handling to worry about.
>
>> Looks good.
>
>> request irq could be devm_* also.
On Mon, Nov 05, 2012 at 05:21:03PM +0530, Shubhrajyoti Datta wrote:
> On Mon, Nov 5, 2012 at 2:03 PM, Mark Brown
> wrote:
> > A small code saving and less error handling to worry about.
> Looks good.
> request irq could be devm_* also. Not an objection though.
devm_ is a much worse idea for IRQ
31 matches
Mail list logo