Hi.
I think .reg_src can be removed? This clock have only one source.
On Thu, Nov 8, 2012 at 2:00 AM, Sylwester Nawrocki
wrote:
> The "camera" clock defined in arch/arm/mach-s3c64xx/clock.c has null
> clock source mux control register as it can have only one parent
> clock. In such cases there i
On 9 November 2012 09:21, Zhang Rui wrote:
> On Thu, 2012-11-08 at 11:56 +0530, Amit Kachhap wrote:
>> On 8 November 2012 11:31, Zhang Rui wrote:
>> > On Thu, 2012-11-08 at 09:56 +0530, Amit Daniel Kachhap wrote:
>> >> This modification adds 2 new thermal trend type THERMAL_TREND_RAISE_FULL
>> >>
On 30 October 2012 14:51, Bartlomiej Zolnierkiewicz
wrote:
>
> Hi,
>
> On Monday 29 October 2012 22:45:48 Jassi Brar wrote:
>> On Mon, Oct 29, 2012 at 10:59 AM, Bartlomiej Zolnierkiewicz
>> wrote:
>> > * Add device tree (DT) property ("pl330,dma-memcpy") for DMA_MEMCPY
>> > capability and inste
Hi Amit/Rui,
> -Original Message-
> From: Zhang, Rui
> Sent: Friday, November 09, 2012 9:21 AM
> To: Amit Kachhap
> Cc: linux...@lists.linux-foundation.org; linux-samsung-
> s...@vger.kernel.org; linux-ker...@vger.kernel.org; R, Durgadoss;
> l...@kernel.org; linux-a...@vger.kernel.org; jon
Hi Rui/Amit,
Sorry for the late response..
> -Original Message-
> From: Amit Kachhap [mailto:amit.kach...@linaro.org]
> Sent: Thursday, November 08, 2012 11:56 AM
> To: Zhang, Rui
> Cc: linux...@lists.linux-foundation.org; linux-samsung-
> s...@vger.kernel.org; linux-ker...@vger.kernel.or
This patch uses the quick thermal cooling trend type macros. This is needed
as exynos5 and other thermal sensors now supports only interrupt method for
thresold temperature check.
Signed-off-by: Amit Daniel Kachhap
Signed-off-by: Amit Daniel Kachhap
---
drivers/thermal/exynos_thermal.c |6 +
On Thu, 2012-11-08 at 11:56 +0530, Amit Kachhap wrote:
> On 8 November 2012 11:31, Zhang Rui wrote:
> > On Thu, 2012-11-08 at 09:56 +0530, Amit Daniel Kachhap wrote:
> >> This modification adds 2 new thermal trend type THERMAL_TREND_RAISE_FULL
> >> and THERMAL_TREND_DROP_FULL. This thermal trend c
On Wed, Nov 7, 2012 at 5:41 AM, Kukjin Kim wrote:
> A commit 1b6056d6 ("pinctrl: samsung: Include bank-specific eint offset in
> bank struct") which is in your pinctrl tree (samsung branch) changed
> macro(EXYNOS_PIN_BANK_EINTG) to add offset. Eventually, this series(due to
> 3rd patch, pinctrl:
Just use BUG_ON() instead of constructions such as:
if (...)
BUG()
A simplified version of the semantic patch that makes this transformation
is as follows: (http://coccinelle.lip6.fr/)
//
@@
expression e;
@@
- if (e) BUG();
+ BUG_ON(e);
//
Signed-off-by: Sasha Levin
-
Just use BUG_ON() instead of constructions such as:
if (...)
BUG()
A simplified version of the semantic patch that makes this transformation
is as follows: (http://coccinelle.lip6.fr/)
//
@@
expression e;
@@
- if (e) BUG();
+ BUG_ON(e);
//
Signed-off-by: Sasha Levin
-
Hi.
On Thu, Nov 8, 2012 at 1:57 AM, Sylwester Nawrocki
wrote:
> On 11/06/2012 10:34 PM, Andrey Gusakov wrote:
>>
>> Hi.
>>
>>> Does the sensor still hang after 0x2f is written to REG_GRCOM instead ?
>>
>> Work!
>> I'm looking at drivers/media/usb/gspca/m5602/m5602_ov9650.h
>> It use significantly
On Tue, Nov 06, 2012 at 08:24:55PM +0530, Vivek Gautam wrote:
> Updating the names of usb-phy types to more generic names:
> USB_PHY_TYPE_DEIVCE & USB_PHY_TYPE_HOST; and further update its
> dependencies.
>
> Signed-off-by: Praveen Paneri
> Signed-off-by: Vivek Gautam
Kukjin, I need your ack on
This patch adds missing USB OTG regulators needed for s3c-hsotg driver
to work on Origen board.
Confirmed with schematics of and tested on Origen board.
Signed-off-by: Tomasz Figa
---
arch/arm/mach-exynos/mach-origen.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/mach-exynos/m
On Thursday 08 November 2012 05:49:47 Kukjin Kim wrote:
> Bartlomiej Zolnierkiewicz wrote:
> >
> > > Hmm...above change and adding definition of EXYNOS_PA_S_MDMA1 address
> > > can fix the problem you commented on EXYNOS4210 Rev0 without others?...
> >
> > The problem is affecting only EXYNOS4210
chan->end is tested for being NULL. However in the event that it is NULL, the
subsequent assignment statement would lead to NULL pointer dereference.
Thus dereferencing it only when it is not NULL.
Signed-off-by: Sachin Kamat
---
Based on Kukjin Kim's for-next branch. Compile tested.
---
arch/ar
Adding DWC3 device tree node for Exynos5250 along with the
device address and clock support needed for the controller.
Signed-off-by: Vivek Gautam
---
.../devicetree/bindings/usb/exynos-usb.txt | 14 +++
arch/arm/boot/dts/exynos5250.dtsi |6 +
arch/arm/
Changes from v1:
- Changed the device node name from 'dwc3' to 'usb@1200'.
- Added the documentation for device tree bindings for dwc3 controller.
Based on changes for USB 2.0:
'https://lists.ozlabs.org/pipermail/devicetree-discuss/2012-November/022046.html'
Tested with required driver DT p
Adding OHCI device tree node for Exynos5250 along with
the device base address.
Signed-off-by: Vivek Gautam
Acked-by: Jingoo Han
---
.../devicetree/bindings/usb/exynos-usb.txt | 15 +++
arch/arm/boot/dts/exynos5250.dtsi |6 ++
arch/arm/mach-exynos/
Adding EHCI device tree node for Exynos5250 along with
the device base adress and gpio line for vbus.
Signed-off-by: Vivek Gautam
Acked-by: Jingoo Han
---
.../devicetree/bindings/usb/exynos-usb.txt | 25
arch/arm/boot/dts/exynos5250-smdk5250.dts |4 ++
Hi all,
On Thu, Nov 8, 2012 at 12:24 PM, Vivek Gautam wrote:
> Adding OHCI device tree node for Exynos5250 along with
> the device base address.
>
> Signed-off-by: Vivek Gautam
> Acked-by: Jingoo Han
> ---
> .../devicetree/bindings/usb/exynos-usb.txt | 15 +++
> arch/arm/
Hi all,
On Thu, Nov 8, 2012 at 12:24 PM, Vivek Gautam wrote:
> Adding EHCI device tree node for Exynos5250 along with
> the device base adress and gpio line for vbus.
>
> Signed-off-by: Vivek Gautam
> Acked-by: Jingoo Han
> ---
> .../devicetree/bindings/usb/exynos-usb.txt | 25
> +++
21 matches
Mail list logo