The following changes since commit 272b98c6455f00884f0350f775c5342358ebb73f:
Linux 3.12-rc1 (2013-09-16 16:17:51 -0400)
are available in the git repository at:
http://git.kernel.org/pub/scm/linux/kernel/git/kgene/linux-samsung.git
tags/samsung-clk-s3c64xx
for you to fetch changes up to 66fc
The following changes since commit 66fcbe6b7c2827866100837611c9838298a28486:
ARM: S3C64XX: Remove old clock management code (2013-09-17 06:47:36 +0900)
are available in the git repository at:
http://git.kernel.org/pub/scm/linux/kernel/git/kgene/linux-samsung.git
tags/samsung-dt-s3c64xx
for
Hi Arnd, Olof and Kevin,
Here is pull-request for s3c64xx common clk and dt for v3.13.
Note, second s3c64xx-dt branch is based on s3c64xx-common-clk branch.
If any problems, please kindly let me know.
Thanks,
Kukjin
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc
Specify the remaining input clocks (pll_ref, pll_in, and sclk_pcm_in)
for the AudioSS clock controller.
Signed-off-by: Andrew Bresticker
---
Changes since v1:
- specified additional input clocks
---
arch/arm/boot/dts/exynos5420.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
dif
The AudioSS block on Exynos 5420 has an additional clock gate for the
ADMA bus clock.
Signed-off-by: Andrew Bresticker
---
Changes since v1:
- added type enum and made comparison against that instead of compatibility
string
---
.../devicetree/bindings/clock/clk-exynos-audss.txt | 7 +++--
d
Specify pll_ref, pll_in, sclk_audio, and sclk_pcm_in for the AudioSS
clock controller.
Signed-off-by: Andrew Bresticker
---
Changes since v1:
- specified additional input clocks
---
arch/arm/boot/dts/exynos5250.dtsi | 2 ++
1 file changed, 2 insertions(+)
diff --git a/arch/arm/boot/dts/exynos5
There is no gate for the PCM clock input to the AudioSS block, so
the parent of sclk_pcm is div_pcm0. Add a clock ID for it so that
we can reference it in device trees.
Signed-off-by: Andrew Bresticker
Reviewed-by: Tomasz Figa
---
Documentation/devicetree/bindings/clock/exynos5250-clock.txt |
This allows the input clocks to the Exynos AudioSS block to be
specified via device-tree bindings. Default names will be used
when an input clock is not given.
Signed-off-by: Andrew Bresticker
---
Changes since v1:
- listed input clocks as required properties
---
.../devicetree/bindings/clock/
The Exynos AudioSS clock controller will later be modified to allow
input clocks to be specified via device-tree in order to support
multiple Exynos SoCs. This will introduce a dependency on the core
SoC clock controller being initialized first so that the AudioSS driver
can look up its input cloc
Hi,
On 09/23/2013 11:25 PM, Andrew Bresticker wrote:
+static int exynos_audss_clk_remove(struct platform_device *pdev)
+{
+ of_clk_del_provider(pdev->dev.of_node);
+
+ return 0;
}
Don't we need to unregister all the registered clocks in remove? This also
leads to another question: Do
To support a wider variety of backlight setups, introduce an optional
enable GPIO. Legacy users of the platform data already have a means of
supporting GPIOs by using the .init(), .exit() and .notify() hooks. DT
users however cannot use those, so an alternative method is required.
In order to ease
In preparation for adding an optional regulator and enable GPIO to the
driver, split the power on and power off sequences into separate
functions to reduce code duplication at the multiple call sites.
Signed-off-by: Thierry Reding
---
drivers/video/backlight/pwm_bl.c | 59 +++
The GPIO API defines 0 as being a valid GPIO number, so this field needs
to be initialized explicitly.
Signed-off-by: Thierry Reding
---
arch/arm/mach-omap2/board-zoom-peripherals.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/arm/mach-omap2/board-zoom-peripherals.c
b/arch/arm/mach-
The GPIO API defines 0 as being a valid GPIO number, so this field needs
to be initialized explicitly.
Signed-off-by: Thierry Reding
---
arch/arm/mach-shmobile/board-armadillo800eva.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/arm/mach-shmobile/board-armadillo800eva.c
b/arch/arm/m
The GPIO API defines 0 as being a valid GPIO number, so this field needs
to be initialized explicitly.
Signed-off-by: Thierry Reding
---
arch/arm/mach-s3c24xx/mach-h1940.c| 1 +
arch/arm/mach-s3c24xx/mach-rx1950.c | 1 +
arch/arm/mach-s3c64xx/mach-crag6410.c | 1 +
arch/arm/mach-s3c64xx/ma
The GPIO API defines 0 as being a valid GPIO number, so this field needs
to be initialized explicitly.
Signed-off-by: Thierry Reding
---
arch/unicore32/kernel/puv3-nb0916.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/arch/unicore32/kernel/puv3-nb0916.c
b/arch/unicore32/kernel/puv3-nb091
Make use of the new enable_gpio field and allow it to be set from DT as
well. Now that all legacy users of platform data have been converted to
initialize this field to an invalid value, it is safe to use the field
from the driver.
Signed-off-by: Thierry Reding
---
.../bindings/video/backlight/p
The GPIO API defines 0 as being a valid GPIO number, so this field needs
to be initialized explicitly.
A special case is the Palm Tungsten|C board. Since it doesn't use any
quirks that would require the existing .init() or .exit() hooks it can
simply use the new enable_gpio field.
Signed-off-by:
The default for backlight devices is to be enabled immediately when
registering with the backlight core. This can be useful for setups that
use a simple framebuffer device and where the backlight cannot otherwise
be hooked up to the panel.
However, when dealing with more complex setups, such as th
Many backlights require a power supply to work properly. This commit
uses a power-supply regulator, if available, to power up and power down
the panel.
Signed-off-by: Thierry Reding
---
.../bindings/video/backlight/pwm-backlight.txt | 2 ++
drivers/video/backlight/pwm_bl.c
This series adds the ability to specify a GPIO and a power supply to
enable a backlight.
Patch 1 refactors the power on and power off sequences into separate
functions in preparation for subsequent patches.
Patch 2 adds an optional GPIO to enable a backlight. This patch only
includes the field wi
On Mon, Sep 23, 2013 at 02:27:39PM -0400, Alan Stern wrote:
> On Thu, 19 Sep 2013, Russell King wrote:
>
> > The correct way for a driver to specify the coherent DMA mask is
> > not to directly access the field in the struct device, but to use
> > dma_set_coherent_mask(). Only arch and bus code s
On 13-09-23 10:45 AM, Matt Porter wrote:
On 09/22/2013 08:14 AM, Sebastian Hesselbarth wrote:
On 09/20/2013 09:16 PM, Matt Porter wrote:
On Wed, Sep 18, 2013 at 07:53:33PM +0200, Sebastian Hesselbarth wrote:
This is a patch set based on an RFC [1][2] sent earlier to provide a
common
arch/arm i
On 09/22/2013 08:14 AM, Sebastian Hesselbarth wrote:
On 09/20/2013 09:16 PM, Matt Porter wrote:
On Wed, Sep 18, 2013 at 07:53:33PM +0200, Sebastian Hesselbarth wrote:
This is a patch set based on an RFC [1][2] sent earlier to provide a
common
arch/arm init for DT clock providers. Currently, the
On Monday 23 of September 2013 19:03:10 Bartlomiej Zolnierkiewicz wrote:
>
> Hi,
>
> On Wednesday, September 18, 2013 12:20:31 PM Leela Krishna Amudala wrote:
> > Tomasz,
> >
> > On Wed, Sep 18, 2013 at 10:04 AM, Doug Anderson
> > wrote:
> > > Tomasz,
> > >
> > > On Tue, Sep 17, 2013 at 6:30 A
Hi,
On Wednesday, September 18, 2013 12:20:31 PM Leela Krishna Amudala wrote:
> Tomasz,
>
> On Wed, Sep 18, 2013 at 10:04 AM, Doug Anderson wrote:
> > Tomasz,
> >
> > On Tue, Sep 17, 2013 at 6:30 AM, Tomasz Figa wrote:
> >>> --- a/Documentation/devicetree/bindings/watchdog/samsung-wdt.txt
> >>
Hi Kukjin,
Could you please apply this patch?
Best regards,
--
Bartlomiej Zolnierkiewicz
Samsung R&D Institute Poland
Samsung Electronics
On Tuesday, August 20, 2013 01:22:45 PM Bartlomiej Zolnierkiewicz wrote:
> Revision 0 of Exynos4210 SoC (used on Universal C210 board) requires
> 'secure' PL
On Sat, Sep 21, 2013 at 04:24:59PM +0100, Tomasz Figa wrote:
> Hi Yuvaraj,
>
> On Wednesday 18 of September 2013 15:41:53 Yuvaraj Kumar C D wrote:
> > Without the "clock-frequency" property in arch timer node, could able
> > to see the below crash dump.
> [snip]
> > diff --git a/arch/arm/boot/dts/
On Mon, Sep 23, 2013 at 02:06:48PM +0100, Mateusz Krawczuk wrote:
> This patch add clk and device tree nodes for samsung onenand driver.
>
> since v1:
> Updated Documentation according to Mark Rutland notes.
>
> Signed-off-by: Mateusz Krawczuk
> Signed-off-by: Kyungmin Park
> ---
> .../devicet
Hi Mark,
On Monday 23 of September 2013 14:50:42 Mark Brown wrote:
> On Mon, Sep 23, 2013 at 11:45:45AM +0200, Mateusz Krawczuk wrote:
> > Add compatibles for s3c6410, s5pc100 and s5pc110/s5pv210 boards.
>
> > static const struct of_device_id s3c64xx_spi_dt_match[] = {
> > + { .compatible = "s
Hi Mateusz,
On Monday 23 of September 2013 15:06:48 Mateusz Krawczuk wrote:
> This patch add clk and device tree nodes for samsung onenand driver.
>
> since v1:
> Updated Documentation according to Mark Rutland notes.
>
> Signed-off-by: Mateusz Krawczuk
> Signed-off-by: Kyungmin Park
> ---
>
On Mon, Sep 23, 2013 at 11:45:45AM +0200, Mateusz Krawczuk wrote:
> Add compatibles for s3c6410, s5pc100 and s5pc110/s5pv210 boards.
> static const struct of_device_id s3c64xx_spi_dt_match[] = {
> + { .compatible = "samsung,s3c2443-spi",
> + .data = (void *)&s3c2443_spi_po
This patch add clk and device tree nodes for samsung onenand driver.
since v1:
Updated Documentation according to Mark Rutland notes.
Signed-off-by: Mateusz Krawczuk
Signed-off-by: Kyungmin Park
---
.../devicetree/bindings/mtd/samsung-onenand.txt| 44 ++
drivers/mtd/one
Hi Mateusz,
On Monday 23 of September 2013 12:14:49 Mateusz Krawczuk wrote:
> It prevents from executing platform code, when booting from device tree.
>
> Signed-off-by: Mateusz Krawczuk
> Signed-off-by: Kyungmin Park
> ---
> arch/arm/plat-samsung/init.c | 3 +++
> 1 file changed, 3 insertions
On Monday 23 of September 2013 12:23:51 Bartlomiej Zolnierkiewicz wrote:
> Hi Tomek,
>
> On Tuesday, September 17, 2013 12:45:21 PM Tomasz Figa wrote:
> > Hi Bart,
[snip]
> > > + select ARM_AMBA
> > > + select CLKSRC_OF
> > > + select CLKSRC_SAMSUNG_PWM if CPU_EXYNOS4210
> > > + select CPU_EXYNOS4
On 20/09/2013 00:02, Russell King :
Signed-off-by: Russell King
---
drivers/usb/chipidea/ci_hdrc_imx.c |4 +---
drivers/usb/dwc3/dwc3-exynos.c |4 +---
drivers/usb/host/ehci-atmel.c |4 +---
For Atmel driver:
Acked-by: Nicolas Ferre
[..]
diff --git a/drivers/usb/ho
On Monday 23 of September 2013 12:13:42 Mateusz Krawczuk wrote:
> It prevents from executing code already called by device tree.
I'd say that it prevents from executing code handling things that, when
booting with device tree, are already handled by other code, namely the
pinctrl-exynos driver.
On 20/09/2013 00:01, Russell King :
The correct way for a driver to specify the coherent DMA mask is
not to directly access the field in the struct device, but to use
dma_set_coherent_mask(). Only arch and bus code should access this
member directly.
Convert all direct write accesses to using t
Hi Chander,
On Monday 23 of September 2013 17:33:35 Chander Kashyap wrote:
> Replace irq_domain_add_simple with "irq_domain_add_linear" in order to
> use linear irq domain, and to remove hardcoded irq_base_value.
>
> Signed-off-by: Chander Kashyap
> ---
> Changes since v1:
> - Replaced irq
Replace irq_domain_add_simple with "irq_domain_add_linear" in order to use
linear irq domain, and to remove hardcoded irq_base_value.
Signed-off-by: Chander Kashyap
---
Changes since v1:
- Replaced irq_domain_add_simple with irq_domain_add_linear,
as suggested by Tomasz
driver
On 17 September 2013 18:07, Tomasz Figa wrote:
> Hi Chander,
>
> On Monday 16 of September 2013 11:01:22 Chander Kashyap wrote:
>> Pass '0' in place of hardcoded "irq_base" value as "first_irq" parameter
>> to "irq_domain_add_simple" in order to use linear irq domain.
>>
>> Signed-off-by: Chander
On Mon, Sep 23, 2013 at 03:55:33PM +0530, Vinod Koul wrote:
> On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote:
> > register_platform_device_full() can setup the DMA mask provided the
> > appropriate member is set in struct platform_device_info. So lets
> > make that be the case. This
On Sat, Sep 21, 2013 at 09:00:00PM +0100, Russell King - ARM Linux wrote:
> On Fri, Sep 20, 2013 at 07:26:27PM +0200, Heiko Stübner wrote:
> > Am Donnerstag, 19. September 2013, 23:49:01 schrieb Russell King:
> > > The DMA API requires drivers to call the appropriate dma_set_mask()
> > > functions
On Fri, Sep 20, 2013 at 12:15:39AM +0100, Russell King wrote:
> register_platform_device_full() can setup the DMA mask provided the
> appropriate member is set in struct platform_device_info. So lets
> make that be the case. This avoids a direct reference to the DMA
> masks by this driver.
>
> S
On Thu, Sep 19, 2013 at 10:48:01PM +0100, Russell King wrote:
> The DMA API requires drivers to call the appropriate dma_set_mask()
> functions before doing any DMA mapping. Add this required call to
> the AMBA PL08x driver.
>
> Signed-off-by: Russell King
Acked-by: Vinod Koul
~Vinod
> ---
>
Hi Mateusz,
On 23 September 2013 15:44, Mateusz Krawczuk
wrote:
> It prevents from executing platform code, when booting from device tree.
>
> Signed-off-by: Mateusz Krawczuk
> Signed-off-by: Kyungmin Park
> ---
nit: Please format the patch title appropriately. In this case, it
should start wi
Hi Tomek,
On Tuesday, September 17, 2013 12:45:21 PM Tomasz Figa wrote:
> Hi Bart,
>
> On Friday 13 of September 2013 11:28:31 Bartlomiej Zolnierkiewicz wrote:
> > EXYNOS is now Device Tree (DT) only platform so it makes no sense to have
> > config options responsible for enabling platform speci
It prevents from executing platform code, when booting from device tree.
Signed-off-by: Mateusz Krawczuk
Signed-off-by: Kyungmin Park
---
arch/arm/plat-samsung/init.c | 3 +++
1 file changed, 3 insertions(+)
diff --git a/arch/arm/plat-samsung/init.c b/arch/arm/plat-samsung/init.c
index aa9511b
It prevents from executing code already called by device tree.
Signed-off-by: Mateusz Krawczuk
Signed-off-by: Kyungmin Park
---
arch/arm/plat-samsung/s5p-irq-eint.c | 4
1 file changed, 4 insertions(+)
diff --git a/arch/arm/plat-samsung/s5p-irq-eint.c
b/arch/arm/plat-samsung/s5p-irq-eint
Add compatibles for s3c6410, s5pc100 and s5pc110/s5pv210 boards.
Signed-off-by: Mateusz Krawczuk
Signed-off-by: Kyungmin Park
---
drivers/spi/spi-s3c64xx.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/spi/spi-s3c64xx.c b/drivers/spi/spi-s3c64xx.c
index 8bed27a..84cc
Most DT ARM machs require common clock providers initialized before timers.
Currently, arch/arm machs use .init_time to call of_clk_init right before
clocksource_of_init. This prevents to remove that callback and use the default
one instead.
This patch adds a call to of_clk_init() to the default .
51 matches
Mail list logo