[PATCH v3 7/17] arcmsr: revise message_isr_bh_fn to remove duplicate code

2014-08-18 Thread Ching Huang
From: Ching Huang Revise message_isr_bh_fn to remove the duplicate code for each adapter type. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c --- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-14 18:36:38.0 +0800 +++ b/drive

[PATCH v3 6/17] arcmsr: precise checking adapter ID

2014-08-18 Thread Ching Huang
From: Ching Huang change since v2: 1. This patch pre-define the adapter->type in private data of struct pci_device_id. 2. Remove arcmsr_define_adapter_type function. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c --- a/drivers/s

[PATCH v3 5/17] arcmsr: bugfix - return status of abort command

2014-08-18 Thread Ching Huang
From: Ching Huang This patch fixed the wrong return status of abort command. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c --- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-08 19:35:46.0 +0800 +++ b/drivers/scsi/arcmsr/arc

[PATCH v3 4/17] arcmsr: limit max. number of SCSI command request

2014-08-18 Thread Ching Huang
From: Ching Huang This patch limits the max. number of SCSI command request to avoid command overflow. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h --- a/drivers/scsi/arcmsr/arcmsr.h 2014-05-06 15:24:06.0 +0800 +++ b/driv

Ignore the [PATCH v4 4/17]

2014-08-18 Thread Ching Huang
Please ignore the patch [PATCH v4 4/17], I will resend the patch [PATCH v3 4/17]. Regards, Ching Huang -- To unsubscribe from this list: send the line "unsubscribe linux-scsi" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.htm

[PATCH v7 2/3] ahci_xgene: Skip the PHY and clock initialization if already configured by the firmware.

2014-08-18 Thread Suman Tripathi
This patch implements the feature to skip the PHY and clock initialization if it is already configured by the firmware. Signed-off-by: Loc Ho Signed-off-by: Suman Tripathi --- drivers/ata/ahci_xgene.c | 17 + 1 file changed, 17 insertions(+) diff --git a/drivers/ata/ahci_xgene.

[PATCH v7 0/3] ahci_xgene: Fixes related to APM X-Gene SATA host controller driver.

2014-08-18 Thread Suman Tripathi
This patch set contains a couple of fixes related to APM X-Gene SATA controller driver. v2 Change: 1. Drop the Link down retry patch from this patch set. v4 Change: 1. Drop the patch to fix the csr-mask in dts for PHY clock node of SATA Host Controller 1. 2. Add the patch to correct

[PATCH v7 1/3] arm64: Fix the csr-mask for APM X-Gene SoC AHCI SATA PHY clock DTS node.

2014-08-18 Thread Suman Tripathi
The value of the csr-mask of the SATA PHY clock DTS node has a wrong value resulting a kernel panic as the clock/reset is not proper for the PHY of the SATA host controller 1. This patch fixes the correct csr-mask value of the SATA PHY clock DTS node for the SATA Host controller 1. As the 'ok' is

[PATCH v7 3/3] ahci_xgene: Fix the link down in first attempt for the APM X-Gene SoC AHCI SATA host controller driver.

2014-08-18 Thread Suman Tripathi
The link down issue in first attempt happens due to 2 H/W errata below: 1. Due to HW errata, during speed negotiation, sometimes controller is not able to detect ALIGN at GEN3(6Gbps) within 54.6us results in a timeout. This issue can be recovered by issuing a COMRESET again. 2. Due to HW errata,

RE: [PATCH v3] uas: replace WARN_ON_ONCE() with lockdep_assert_held()

2014-08-18 Thread Sharma, Sanjeev
Hi Greg, Any feedback on this patch ? Regards Sanjeev Sharma -Original Message- From: Sharma, Sanjeev Sent: Tuesday, August 12, 2014 12:07 PM To: 'Hans de Goede' Cc: gre...@linuxfoundation.org; kra...@redhat.com; mdharm-...@one-eyed-alien.net; linux-...@vger.kernel.org; linux-ker...@v

[PATCH v4 4/17] arcmsr: limit max. number of SCSI command request

2014-08-18 Thread Ching Huang
From: Ching Huang This patch limits the max. number of SCSI commmand request to avoid command overflow. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h --- a/drivers/scsi/arcmsr/arcmsr.h 2014-05-06 15:24:06.0 +0800 +++ b/dri

[PATCH v3 3/17] arcmsr: Add code to support hibernation

2014-08-18 Thread Ching Huang
From: Ching Huang This patch adds code to support system hibernation. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr_hba.c b/drivers/scsi/arcmsr/arcmsr_hba.c --- a/drivers/scsi/arcmsr/arcmsr_hba.c 2014-08-01 17:54:46.0 +0800 +++ b/drivers/scsi/arcmsr/arcmsr_hba

[PATCH v3 2/17] arcmsr: Add code to support MSI-X, MSI interrupt

2014-08-18 Thread Ching Huang
From: Ching Huang This patch adds code to support MSI, MSI-X interrupt. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h --- a/drivers/scsi/arcmsr/arcmsr.h 2014-04-28 16:02:46.0 +0800 +++ b/drivers/scsi/arcmsr/arcmsr.h 20

[PATCH v3 1/17] arcmsr: Revised interrupt service routine relate function to fix bug

2014-08-18 Thread Ching Huang
From: Ching Huang This patch rewrite the interrupt service routine relate function to fix command timeout when controller has very heavy loading. Signed-off-by: Ching Huang --- diff -uprN a/drivers/scsi/arcmsr/arcmsr.h b/drivers/scsi/arcmsr/arcmsr.h --- a/drivers/scsi/arcmsr/arcmsr.h 201

[PATCH v3 0/17] arcmsr: change note since v13 or v2

2014-08-18 Thread Ching Huang
Change note: 1,5,7~17/17 since v1.3 are not change. 2,3,4/17 since v2 are not change. 6/17 since v2: 1. pre-define adapter_type value in private data of pci_device_id. 2. remove the arcmsr_define_adapter_type function. Ching Huang -- To unsubscribe from this list: send the line "unsubscribe li

Re: [PATCH v3 1/3] init / kthread: add module_long_probe_init() and module_long_probe_exit()

2014-08-18 Thread Luis R. Rodriguez
On Mon, Aug 18, 2014 at 10:19 AM, Oleg Nesterov wrote: > And, again, I do not really know which version is better. In Chicago right now -- feedback was it seems the that generally splitting up probe from init might be good in the end, if we do this we won't need a work around for drivers that wai

RE: [PATCH 13/14] scsi: add support for a blk-mq based I/O path.

2014-08-18 Thread Kashyap Desai
> -Original Message- > From: linux-scsi-ow...@vger.kernel.org [mailto:linux-scsi- > ow...@vger.kernel.org] On Behalf Of Christoph Hellwig > Sent: Friday, July 18, 2014 3:43 PM > To: James Bottomley; linux-scsi@vger.kernel.org > Cc: Jens Axboe; Bart Van Assche; Mike Christie; Martin K. Peter

Re: [PATCH] scsi: ufs: fix Command Type issue according to UFS 2.0 spec

2014-08-18 Thread Santosh Y
On Fri, Aug 1, 2014 at 1:30 PM, Chuanxiao Dong wrote: > UFS 2.0 spec defines that the command type in transfer descriptor > is always 0x1 instead of different values as shown in UFSHC1.0/1.1. > > This patch will distingwish v1.0/v1.1 UFSHC and later UFSHC when > setting CT > > Signed-off-by: Chuan

Re: [PATCH] fusion: fix excess parameter kernel-doc warning

2014-08-18 Thread Ewan Milne
On Sat, 2014-08-16 at 14:15 -0700, Randy Dunlap wrote: > From: Randy Dunlap > > Fix kernel-doc excess parameter warning: > > Warning(..//drivers/message/fusion/mptbase.c:1411): Excess function parameter > 'prod_name' description in 'mpt_get_product_name' > > Signed-off-by: Randy Dunlap > Cc:

Re: [PATCH] scsi: fix various kernel-doc problems in scsi_error.c

2014-08-18 Thread Ewan Milne
On Sat, 2014-08-16 at 14:15 -0700, Randy Dunlap wrote: > From: Randy Dunlap > > Convert spaces to tabs in kernel-doc notation. > Correct duplicated (copy-paste) kernel-doc comments that are incorrect. > Fix kernel-doc warning: > > Warning(..//drivers/scsi/scsi_error.c:1647): No description found

Re: [PATCH v3 1/3] init / kthread: add module_long_probe_init() and module_long_probe_exit()

2014-08-18 Thread Oleg Nesterov
On 08/18, Takashi Iwai wrote: > > At Mon, 18 Aug 2014 14:22:17 +0200, > Oleg Nesterov wrote: > > > > On 08/18, Takashi Iwai wrote: > > > > > > #define module_long_probe_init(initfn)\ > > > static int _long_probe_##initfn(void *arg) \ > > > {

[PATCH] libfs: Replace rcu_assign_pointer() with RCU_INIT_POINTER()

2014-08-18 Thread Andreea-Cristina Bernat
The uses of "rcu_assign_pointer()" are NULLing out the pointers. According to RCU_INIT_POINTER()'s block comment: "1. This use of RCU_INIT_POINTER() is NULLing out the pointer" it is better to use it instead of rcu_assign_pointer() because it has a smaller overhead. The following Coccinelle sema

Re: [PATCH v3 1/3] init / kthread: add module_long_probe_init() and module_long_probe_exit()

2014-08-18 Thread Takashi Iwai
At Mon, 18 Aug 2014 14:22:17 +0200, Oleg Nesterov wrote: > > On 08/18, Takashi Iwai wrote: > > > > #define module_long_probe_init(initfn) \ > > static int _long_probe_##initfn(void *arg) \ > > {

Re: [PATCH 3/3] scsi_debug: bump inquiry version to SPC-4, update version descriptors

2014-08-18 Thread Martin K. Petersen
> "Doug" == Douglas Gilbert writes: Doug> Since a lot of functionality from SPC-4 is supported by this Doug> driver (e.g. LBP and PI) then bump the default INQUIRY version Doug> from SPC-3 to SPC-4. Also update the INQUIRY version descriptors. Doug> Signed-off-by: Douglas Gilbert Reviewed-

Re: [PATCH 1/3] scsi_debug: scsi_cmnd->cmnd check and casts unnecessary

2014-08-18 Thread Martin K. Petersen
> "Doug" == Douglas Gilbert writes: Doug> This patch removes a NULL check for the scsi_cmnd::cmnd pointer Doug> since many other instances in this driver and elsewhere assume it Doug> is valid. Also redundant casts to 'unsigned char *' are removed as Doug> the pointer has that type. Doug> Si

Re: [PATCH 2/3] scsi_debug: give unit attention and other errors precedence over TSF

2014-08-18 Thread Martin K. Petersen
> "Doug" == Douglas Gilbert writes: Doug> Give existing errors priority over the generation of Task Set Full Doug> (TSF) errors. So that max_queue is not exceeded, existing errors Doug> may be sent back in the invocation thread. This is done so errors Doug> like Unit Attentions are not hidde

Re: [PATCH v3 1/3] init / kthread: add module_long_probe_init() and module_long_probe_exit()

2014-08-18 Thread Oleg Nesterov
On 08/18, Takashi Iwai wrote: > > #define module_long_probe_init(initfn)\ > static int _long_probe_##initfn(void *arg) \ > { \ > module_put_and_exit(initfn());

[PATCH] tcm_fc: Replace rcu_assign_pointer() with RCU_INIT_POINTER()

2014-08-18 Thread Andreea-Cristina Bernat
The use of "rcu_assign_pointer()" is NULLing out the pointer. According to RCU_INIT_POINTER()'s block comment: "1. This use of RCU_INIT_POINTER() is NULLing out the pointer" it is better to use it instead of rcu_assign_pointer() because it has a smaller overhead. The following Coccinelle semanti

[PATCH V5 5/5] add xen pvscsi maintainer

2014-08-18 Thread jgross
From: Juergen Gross Add myself as maintainer for the Xen pvSCSI stuff. Signed-off-by: Juergen Gross --- MAINTAINERS | 8 1 file changed, 8 insertions(+) diff --git a/MAINTAINERS b/MAINTAINERS index aefa948..360f86f 100644 --- a/MAINTAINERS +++ b/MAINTAINERS @@ -10086,6 +10086,14 @@ S

[PATCH V5 0/5] Add XEN pvSCSI support

2014-08-18 Thread jgross
This series adds XEN pvSCSI support. With pvSCSI it is possible to use physical SCSI devices from a XEN domain. The support consists of a backend in the privileged Domain-0 doing the real I/O and a frontend in the unprivileged domU passing I/O-requests to the backend. The code is taken (and adapt

[PATCH V5 1/5] xen/events: support threaded irqs for interdomain event channels

2014-08-18 Thread jgross
From: Juergen Gross Export bind_interdomain_evtchn_to_irq() so drivers can use threaded interrupt handlers with: irq = bind_interdomain_evtchn_to_irq(remote_dom, remote_port); if (irq < 0) /* error */ ret = request_threaded_irq(...); Signed-off-by: Juergen Gross Acked-by: David Vrabel

[PATCH V5 2/5] Add XEN pvSCSI protocol description

2014-08-18 Thread jgross
From: Juergen Gross Add the definition of pvSCSI protocol used between the pvSCSI frontend in a XEN domU and the pvSCSI backend in a XEN driver domain (usually Dom0). This header was originally provided by Fujitsu for XEN based on Linux 2.6.18. Changes are: - added comment - adapt to Linux style

[PATCH V5 3/5] Introduce xen-scsifront module

2014-08-18 Thread jgross
From: Juergen Gross Introduces the XEN pvSCSI frontend. With pvSCSI it is possible for a XEN domU to issue SCSI commands to a SCSI LUN assigned to that domU. The SCSI commands are passed to the pvSCSI backend in a driver domain (usually Dom0) which is owner of the physical device. This allows e.g

[PATCH V5 4/5] Introduce XEN scsiback module

2014-08-18 Thread jgross
From: Juergen Gross Introduces the XEN pvSCSI backend. With pvSCSI it is possible for a XEN domU to issue SCSI commands to a SCSI LUN assigned to that domU. The SCSI commands are passed to the pvSCSI backend in a driver domain (usually Dom0) which is owner of the physical device. This allows e.g.

Re: [Xen-devel] [PATCH V4 3/4] Introduce XEN scsiback module

2014-08-18 Thread Juergen Gross
On 08/17/2014 04:38 AM, Nicholas A. Bellinger wrote: On Thu, 2014-08-14 at 12:14 +0200, Juergen Gross wrote: On 08/14/2014 10:53 AM, Juergen Gross wrote: Nicholas, just one more question (see below): On 08/12/2014 11:13 PM, Nicholas A. Bellinger wrote: Hi Juergen & Co, Finally had a chance

[PATCH v3 12/13] pmcraid: Get rid of a redundant assignment

2014-08-18 Thread Alexander Gordeev
Signed-off-by: Alexander Gordeev Cc: Anil Ravindranath Cc: linux-scsi@vger.kernel.org Cc: linux-...@vger.kernel.org --- drivers/scsi/pmcraid.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/scsi/pmcraid.c b/drivers/scsi/pmcraid.c index 6f3275d..6e575ed 100644 --- a/drivers/scsi/pmcra

[PATCH v3 06/13] mpt3sas: Use pci_enable_msix_exact() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 01/13] hpsa: Fallback to MSI rather than to INTx if MSI-X failed

2014-08-18 Thread Alexander Gordeev
Currently the driver falls back to INTx mode when MSI-X initialization failed. This is a suboptimal behaviour for chips that also support MSI. This update changes that behaviour and falls back to MSI mode in case MSI-X mode initialization failed. Signed-off-by: Alexander Gordeev Acked-by: "Stephe

[PATCH v3 07/13] qla2xxx: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Log

[PATCH v3 10/13] csiostor: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 02/13] hpsa: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 13/13] pmcraid: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 05/13] mpt2sas: Use pci_enable_msix_exact() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 09/13] csiostor: Remove superfluous call to pci_disable_msix()

2014-08-18 Thread Alexander Gordeev
There is no need to call pci_disable_msix() in case the previous call to pci_enable_msix() failed Signed-off-by: Alexander Gordeev Cc: Naresh Kumar Inna Cc: Arvind Bhushan Cc: linux-scsi@vger.kernel.org Cc: linux-...@vger.kernel.org --- drivers/scsi/csiostor/csio_isr.c | 4 +--- 1 file changed

[PATCH v3 11/13] lpfc: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 04/13] megaraid: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() or pci_enable_msi_exact() and pci_enable_msix_range() or pci_enable_msix_exact() interfaces. Sign

[PATCH v3 03/13] megaraid: Fail resume if MSI-X re-initialization failed

2014-08-18 Thread Alexander Gordeev
Currently the driver fails to analize MSI-X re-enablement status on resuming and always assumes the success. This update checks the MSI-X initialization result and fails to resume if MSI-Xs re-enablement failed. Signed-off-by: Alexander Gordeev Acked-by: Kashyap Desai Cc: Neela Syam Kolli Cc: l

[PATCH v3 08/13] be2iscsi: Use pci_enable_msix_range()

2014-08-18 Thread Alexander Gordeev
As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block() all drivers using these two interfaces need to be updated to use the new pci_enable_msi_range() and pci_enable_msix_range() interfaces. Signed-off-by: Alexander Gordeev Cc: Jayamohan Kallickal

[PATCH v3 00/13] scsi: Use pci_enable_msix_range() instead of pci_enable_msix()

2014-08-18 Thread Alexander Gordeev
Hello, This series is against 3.17-rc1. Patches 0-7 have been acked. Patches 8-13 still need reviews and are resent without changes except 'lpfc' which concerns latest James comments. Thanks! As result of deprecation of MSI-X/MSI enablement functions pci_enable_msix() and pci_enable_msi_block()

Re: [PATCH v3 1/3] init / kthread: add module_long_probe_init() and module_long_probe_exit()

2014-08-18 Thread Takashi Iwai
At Sun, 17 Aug 2014 20:21:38 +0200, Oleg Nesterov wrote: > > On 08/17, Luis R. Rodriguez wrote: > > > > In the last iteration that I have stress tested for corner cases I just > > get_task_struct() on the init and then put_task_struct() at the exit, is > > that > > fine too or are there reasons t