Hi Bryant & Co,
On Tue, 2017-05-30 at 13:31 -0500, Bryant G. Ly wrote:
> This patch consists of adding a netlink to allow for reconfiguration
> of a device in tcmu.
>
> It also changes and adds some attributes that are reconfigurable:
> write_cache, device size, and device path.
>
> Bryant G. Ly
On Fri, Jun 02, 2017 at 03:01:29PM +0200, walter harms wrote:
>
>
> Am 02.06.2017 14:39, schrieb Milan P. Gandhi:
> > Simplify the check for return code of fcoe_if_init routine
> > in fcoe_init function such that we could eliminate need for
> > extra 'out_free' label and duplicate mutex_unlock st
I'm fine with this version...
regards,
dan carpenter
On Thu, Jun 01, 2017 at 05:38:55PM +0530, Milan P. Gandhi wrote:
> This patch removes an extra out label in _fcoe_create function
> where we return if creation of FCOE interface is failed.
>
> Signed-off-by: Milan P. Gandhi
> ---
> drivers/scsi/fcoe/fcoe.c | 4 ++--
> 1 file changed, 2 insertion
Chad,
> sc_cmd->sense_buffer is not guaranteed to be allocated so we need to
> sc_cmd->check
> if the pointer is NULL before trying to copy anything into it.
Applied to 4.13/scsi-queue.
--
Martin K. Petersen Oracle Linux Engineering
Nicholas,
> The people who are actively using iblock_execute_write_same_direct()
> are doing so in the context of ESX VAAI BlockZero, together with
> EXTENDED_COPY and COMPARE_AND_WRITE primitives.
>
> In practice though I've not seen any users of IBLOCK WRITE_SAME for
> anything other than VAAI
Chad,
> Please apply the following patches to the scsi tree at your earliest
> convenience.
Applied to 4.13/scsi-queue, thank you!
--
Martin K. Petersen Oracle Linux Engineering
Himanshu,
> This series contains patches that were dropped from 4.12.0-rc3
> inclusion, since they can go to 4.13 merge window.
Applied to 4.13/scsi-queue. Thank you!
--
Martin K. Petersen Oracle Linux Engineering
On Fri, 2017-06-02 at 09:11 -0700, Himanshu Madhani wrote:
> This series contains patches that were dropped from 4.12.0-rc3 inclusion,
> since
> they can go to 4.13 merge window.
>
> Changes from v2 --> v3
> o Added Reviewed-by tag from Bart.
> o Droped couple patches for rework.
> o Addressed
On Fri, 2017-06-02 at 13:32 +0200, Corentin Labbe wrote:
> Instead of rewriting write/readq, use linux/io-64-nonatomic-lo-hi.h which
> already have them.
Reviewed-by: Bart Van Assche
On Fri, 2017-06-02 at 10:00 +0800, Ming Lei wrote:
> On Thu, Jun 01, 2017 at 11:09:00PM +, Bart Van Assche wrote:
> > My opinion is that scsi_internal_device_block() and
> > scsi_internal_device_unblock()
> > should be changed as follows for the scsi-mq code path:
> > * scsi_internal_device_bl
Varun,
> T6 FCoE support is added in fw version 1.16.45.0 so return error if fw
> version < 1.16.45.0 for T6 adapters.
Applied to 4.13/scsi-queue. Thanks!
--
Martin K. Petersen Oracle Linux Engineering
Serializing SCSI device state changes avoids that two state changes
can occur concurrently, e.g. the state changes in scsi_target_block()
and __scsi_remove_device(). This serialization is essential to make
patch "Make __scsi_remove_device go straight from BLOCKED to DEL"
work reliably.
Enable this
Milan,
> This patch removes an extra out label in _fcoe_create function
> where we return if creation of FCOE interface is failed.
Applied to 4.13/scsi-queue.
--
Martin K. Petersen Oracle Linux Engineering
Milan,
> This patch does a cleanup and fixes few small typos in fcoe.c
Applied to 4.13/scsi-queue.
--
Martin K. Petersen Oracle Linux Engineering
This patch reduces code duplication. There are two functional changes
in this patch:
- It causes scsi_mq_prep_fn() to clear driver-private
command data, just like the already upstream commit 1bad6c4a57ef
("scsi: zero per-cmd private driver data for each MQ I/O").
- The initialization of .prot_s
Just like for the scsi-mq code path, in the single queue SCSI code
path only add commands to the per-device command list if required
by the SCSI LLD. This patch will make it easier to merge the
single-queue and multiqueue command initialization code.
Signed-off-by: Bart Van Assche
Reviewed-by: Ch
This patch does not change any functionality but makes the next
patch easier to read.
Signed-off-by: Bart Van Assche
Reviewed-by: Christoph Hellwig
Cc: Hannes Reinecke
Cc: Johannes Thumshirn
---
drivers/scsi/scsi_lib.c | 19 ++-
1 file changed, 10 insertions(+), 9 deletions(-)
Since the SCSI core zeroes driver-private command data, remove
that code from the xen-scsifront driver.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Reviewed-by: Juergen Gross
Reviewed-by: Christoph Hellwig
Cc: xen-de...@lists.xenproject.org
Cc: Johannes Thumshirn
---
drivers/
Since the SCSI core zeroes driver-private command data, remove
that code from the snic driver.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Reviewed-by: Narsimhulu Musini
Reviewed-by: Christoph Hellwig
Cc: Sesidhar Baddela
Cc: Johannes Thumshirn
---
drivers/scsi/snic/snic_scs
Dereferencing shost from scsi_exit_rq() is not safe because the
SCSI host may already have been freed when scsi_exit_rq() is
called. Increasing the shost reference count in scsi_init_rq()
and dropping that reference in scsi_exit_rq() is nontrivial since
scsi_host_dev_release() may sleep and since s
Since the SCSI core zeroes driver-private command data, remove
that code from the virtio driver.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Reviewed-by: Christoph Hellwig
Cc: Michael S. Tsirkin
Cc: Johannes Thumshirn
---
drivers/scsi/virtio_scsi.c | 1 -
1 file changed, 1 de
This patch does not change any functionality.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Reviewed-by: Christoph Hellwig
Cc: Israel Rukshin
Cc: Max Gurtovoy
Cc: Benjamin Block
---
drivers/scsi/scsi_lib.c | 25 +++--
drivers/scsi/scsi_priv.h | 1 +
2 fil
Instead of passing a "wait" argument to scsi_internal_device_block(),
split this function into a function that waits and a function that
doesn't wait. This will make it easier to serialize SCSI device state
changes through a mutex.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Revi
This will make it easier to serialize SCSI device state changes
through a mutex.
Signed-off-by: Bart Van Assche
Reviewed-by: Hannes Reinecke
Reviewed-by: Johannes Thumshirn
Reviewed-by: Christoph Hellwig
Cc: Sreekanth Reddy
---
drivers/scsi/mpt3sas/mpt3sas_scsih.c | 4 ++--
drivers/scsi/scs
If a device is blocked, make __scsi_remove_device() cause it to
transition to the DEL state. This means that all the commands
issued in .shutdown() will error in the mid-layer, thus making
the removal proceed without being stopped.
This patch is a slightly modified version of a patch from James
Bo
Hello Martin,
This patch series consists of the bug fixes and improvements I came up with
during the past two months. This patch series has been developed on top of
your 4.13/scsi-queue branch. Please consider these patches for kernel v4.13.
Thanks,
Bart.
The changes compared to v2 of this patc
On Fri, 2017-06-02 at 17:08 -0400, Martin K. Petersen wrote:
> > This patch series consists of the bug fixes and improvements I came up
> > with during the past two months. Please consider these patches for
> > kernel v4.13.
>
> Does this series have dependencies on stuff that went into block for
Bart,
> This patch series consists of the bug fixes and improvements I came up
> with during the past two months. Please consider these patches for
> kernel v4.13.
Does this series have dependencies on stuff that went into block for
4.13?
--
Martin K. Petersen Oracle Linux Engineering
On Fri, 2017-06-02 at 09:23 +0200, Christoph Hellwig wrote:
> Nit: the driver name is virtio_scsi, not just virtio.
Hello Christoph,
I will update the patch title.
Bart.
On Fri, 2017-06-02 at 09:18 +0200, Christoph Hellwig wrote:
> On Thu, Jun 01, 2017 at 04:27:05PM -0700, Bart Van Assche wrote:
> > If a device is blocked, make __scsi_remove_device() cause it to
> > transition to the DEL state. This means that all the commands
> > issued in .shutdown() will error i
Alexander,
> - Ultra320 bus does not work physically, too many errors.
> - Ultra160 bus works relable, no errors.
Ultra320 was generally problematic. I worked on two different hardware
platforms that both gave up on the original plan of using 320 and went
back to an Ultra160 ASIC between prototy
NOTE: This should be applied after the series 'qedf: Update driver to
version 8.18.22.0.'
sc_cmd->sense_buffer is not guaranteed to be allocated so we need to check
if the pointer is NULL before trying to copy anything into it.
Fixes the crash:
[ 143.793176] [:00:00.0]:[qedf_eh_device
Varun,
> If logout response is not received and ->ep_disconnect() is called
> then close tcp conn by RST instead of FIN to cleanup conn resources
> immediately.
>
> Also move ->csk_push_tx_frames() above 'done:' to avoid calling
> ->csk_push_tx_frames() in error cases.
Applied to 4.12/scsi-fixes
On Fri, 2017-06-02 at 09:22 +0200, Christoph Hellwig wrote:
> I like this idea, but..
>
> > -void scsi_init_command(struct scsi_device *dev, struct scsi_cmnd *cmd)
> > +void scsi_init_command(struct scsi_device *dev, struct scsi_cmnd *cmd,
> > + struct scsi_data_buffer *prot_sdb)
From: Quinn Tran
Assign unique id to all traces and logs for debug purpose.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_attr.c | 2 +-
drivers/scsi/qla2xxx/qla_bsg.c| 2 +-
drivers/scsi/qla2xxx/qla_dbg.c| 2 +-
drivers/scsi/qla2xxx/ql
From: Quinn Tran
When driver is unloaded, all sessions are torn down, all
commmands are flushed, chip is reset to ensure there is
no knowledge of target mode in ISP. The irq_cmd_count field
was used to make sure all commands are processed on top of that.
The irq_cmd_count is now redundant and not
From: Quinn Tran
Current code already destroy all target sessions when
target Mode is stopped. Target core would waits for
all commands that belong to each session to purge.
The extra wait for interrupts to settle down is not
relevant.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
From: Quinn Tran
Remove extra register read in each interrupt processing
to improve performance.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_iocb.c | 4 +++-
drivers/scsi/qla2xxx/qla_target.c | 11 ++-
2 files changed, 5 insertions(+), 10
From: Quinn Tran
In case of hardware queue full, commands can loop between
TCM stack and tcm_qla2xx shim layers for retry. While command
is waiting for retry, task mgmt can get ahead and abort the
cmmand that encountered queue full condition. Fix this by
dropping the command, if task mgmt has alr
From: Quinn Tran
Accelerate generation of SCSI busy to let initiators slow
down when target is running low in resources.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_init.c | 13 +++--
drivers/scsi/qla2xxx/qla_mbx.c | 2 ++
2 files changed,
From: Quinn Tran
Previously, the ql2xexchoffld module parameter was used to control
the max number of exchanges to be offload onto host memory.
Module parameter ql_dm_tgt_ex_pct was used to control the percentage
of exchanges allocated to the Target side.
With this patch, module parameter ql_dm
From: Quinn Tran
Tell FW to track exchange/cmd state to prevent driver
from using stale exchange or exchange that is not meant
for this command.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
drivers/scsi/qla2xxx/qla_init.c | 18 ++
drivers/scsi/qla2xxx/qla_ta
From: Joe Carnuccio
Signed-off-by: Joe Carnuccio
Signed-off-by: Himanshu Madhani
Reviewed-by: Bart Van Assche
---
drivers/scsi/qla2xxx/qla_init.c | 8
drivers/scsi/qla2xxx/qla_tmpl.c | 16 +---
2 files changed, 13 insertions(+), 11 deletions(-)
diff --git a/drivers/scsi
From: Quinn Tran
Acked-by: Nicholas Bellinger
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
Reviewed-by: Bart Van Assche
---
drivers/scsi/qla2xxx/qla_target.c | 32 +++-
drivers/scsi/qla2xxx/qla_target.h | 4 ++--
drivers/scsi/qla2xxx/tcm_qla2xxx.c
From: Quinn Tran
Name server login is normally handle by FW. In some
rare case where one of the switches is being updated,
name server login could get affected. Trigger relogin
to name server when driver detects this condition.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
---
dri
From: Quinn Tran
If the port is moved/changed, current code would trigger
a deletion. If the port is already deleted, then do relogin.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
Reviewed-by: Bart Van Assche
---
drivers/scsi/qla2xxx/qla_gs.c | 21 -
1 file c
From: Sawan Chandak
There is already flag defined PFLG_DISCONNECTED, which is set
for PCI or register disconnect error condition. There is no need to have
flag PCI_ERR, which has same purpose. Remove use of PCI_ERR flag and use
PFLG_DISCONNECTED flag during error condition.
Signed-off-by: Sawan
From: Quinn Tran
Convert usage of spin_lock to spin_lock_irqsave because qla2xxx driver
can access all the data structures in an interrupt context.
Signed-off-by: Quinn Tran
Signed-off-by: Himanshu Madhani
Reviewed-by: Bart Van Assche
---
drivers/scsi/qla2xxx/qla_target.c | 26 ++
From: Quinn Tran
Driver added mechanism to move ABTS/PUREX/RIDA mailbox to
ATIO queue as part of commit id 41dc529a4602ac737020f423f84686a81de38e6d
("qla2xxx: Improve RSCN handling in driver").
This patch adds a check to only allow ABTS/PURX/RIDA
to be moved to ATIO Queue for ISP83XX and ISP27XX
Hi Martin,
This series contains patches that were dropped from 4.12.0-rc3 inclusion, since
they can go to 4.13 merge window.
Changes from v2 --> v3
o Added Reviewed-by tag from Bart.
o Droped couple patches for rework.
o Addressed minor comments from Bart where applicable.
Changes from v1 -->
On Fri, 2 Jun 2017, walter harms wrote:
>
>
> Am 02.06.2017 14:39, schrieb Milan P. Gandhi:
> > Simplify the check for return code of fcoe_if_init routine
> > in fcoe_init function such that we could eliminate need for
> > extra 'out_free' label and duplicate mutex_unlock statement.
> >
> > Sign
On Fri, 2 Jun 2017, Milan P. Gandhi wrote:
> Simplify the check for return code of fcoe_if_init routine
> in fcoe_init function such that we could eliminate need for
> extra 'out_free' label and duplicate mutex_unlock statement.
>
> Signed-off-by: Milan P. Gandhi
> ---
> drivers/scsi/fcoe/fcoe
From: Yuval Mintz
Date: Fri, 2 Jun 2017 08:58:29 +0300
> This series is intended to add additional information and features
> to the API between qed and its storage protocol drivers [qedi, qedf].
>
> Patch #2 adds some information stored on device such as wwpn & wwnn
> to allow qedf utilize it;
Am 02.06.2017 14:39, schrieb Milan P. Gandhi:
> Simplify the check for return code of fcoe_if_init routine
> in fcoe_init function such that we could eliminate need for
> extra 'out_free' label and duplicate mutex_unlock statement.
>
> Signed-off-by: Milan P. Gandhi
> ---
> drivers/scsi/fcoe/f
Simplify the check for return code of fcoe_if_init routine
in fcoe_init function such that we could eliminate need for
extra 'out_free' label and duplicate mutex_unlock statement.
Signed-off-by: Milan P. Gandhi
---
drivers/scsi/fcoe/fcoe.c | 7 +++
1 file changed, 3 insertions(+), 4 deletion
On 06/02/2017 11:19 AM, Julia Lawall wrote:
>
>
> On Fri, 2 Jun 2017, Milan P. Gandhi wrote:
>
>> On 06/01/2017 08:32 PM, Dan Carpenter wrote:
>>> On Thu, Jun 01, 2017 at 05:41:06PM +0530, Milan P. Gandhi wrote:
Simplify the check for return code of fcoe_if_init routine
in fcoe_init fu
Instead of rewriting write/readq, use linux/io-64-nonatomic-lo-hi.h which
already have them.
Signed-off-by: Corentin Labbe
---
drivers/scsi/qla2xxx/qla_nx.h | 17 ++---
1 file changed, 2 insertions(+), 15 deletions(-)
diff --git a/drivers/scsi/qla2xxx/qla_nx.h b/drivers/scsi/qla2xxx
Looks fine,
Reviewed-by: Christoph Hellwig
Nit: the driver name is virtio_scsi, not just virtio.
Otherwise this looks fine:
Reviewed-by: Christoph Hellwig
Looks fine,
Reviewed-by: Christoph Hellwig
I like this idea, but..
> -void scsi_init_command(struct scsi_device *dev, struct scsi_cmnd *cmd)
> +void scsi_init_command(struct scsi_device *dev, struct scsi_cmnd *cmd,
> +struct scsi_data_buffer *prot_sdb)
> {
> void *buf = cmd->sense_buffer;
> - void *prot = cmd
Looks fine,
Reviewed-by: Christoph Hellwig
On Thu, Jun 01, 2017 at 04:27:05PM -0700, Bart Van Assche wrote:
> If a device is blocked, make __scsi_remove_device() cause it to
> transition to the DEL state. This means that all the commands
> issued in .shutdown() will error in the mid-layer, thus making
> the removal proceed without being sto
Looks fine,
Reviewed-by: Christoph Hellwig
Looks fine,
Reviewed-by: Christoph Hellwig
On Thu, Jun 01, 2017 at 04:27:03PM -0700, Bart Van Assche wrote:
> Enable this mechanism for all scsi_target_*block() callers but not
> for the scsi_internal_device_unblock() calls from the mpt3sas driver
> because that driver can call scsi_internal_device_unblock() from
> atomic context.
This is
Yes, much better:
Reviewed-by: Christoph Hellwig
Looks fine,
Reviewed-by: Christoph Hellwig
69 matches
Mail list logo