On Sat, Jun 10, 2017 at 9:21 AM, butao wrote:
> add hi3660 ufs driver code
>
> Signed-off-by: Geng Jianfeng
> Signed-off-by: Bu Tao
> Signed-off-by: Zang Leigang
> Signed-off-by: Yu Jianfeng
> ---
> drivers/scsi/ufs/Kconfig | 8 +
> drivers/scsi/ufs/Makefile | 1 +
> drivers/scsi
Bu Tao,
One other issue: the 'sender' of your patchset is "butao". For
upstreaming purpose, it is recommended to use your full name, in
"first name" + "Surname" format. In your case, you need to specify it
in your commit message:
$ git commit --amend --author="Bu Tao "
You may also want to add t
On Sat, Jun 10, 2017 at 9:20 AM, butao wrote:
> add ufs node for hi3660
>
> Signed-off-by: Bu Tao
> ---
> arch/arm64/boot/dts/hisilicon/hi3660.dtsi | 20
> 1 file changed, 20 insertions(+)
> mode change 100644 => 100755 arch/arm64/boot/dts/hisilicon/hi3660.dtsi
Mode change
Bu Tao,
1. Subject line of this patch goes something like "arm64: dts: hi3660:
add ufs support xxx"
2. Have you run "./scripts/get_maintainer.pl *.patch" to get the
correct maintainers to include into your patch review?
I don't think so. Because this is a dts change, however in your
email's to/ c
--
Dear Friend,
I Know That This Mail Will Come To You As A Surprise As We Never Met
Before. I Need Your Urgent Assistance in Transferring the Sum Of
($15.5m) Into Your Bank Account in your conutry, After Hearing from
You I Will Give You More Details about the Transaction. Your full
data’s will
add ufs node for hi3660
Signed-off-by: Bu Tao
---
arch/arm64/boot/dts/hisilicon/hi3660.dtsi | 20
1 file changed, 20 insertions(+)
mode change 100644 => 100755 arch/arm64/boot/dts/hisilicon/hi3660.dtsi
diff --git a/arch/arm64/boot/dts/hisilicon/hi3660.dtsi
b/arch/arm64/bo
add hi3660 ufs driver code
Signed-off-by: Geng Jianfeng
Signed-off-by: Bu Tao
Signed-off-by: Zang Leigang
Signed-off-by: Yu Jianfeng
---
drivers/scsi/ufs/Kconfig | 8 +
drivers/scsi/ufs/Makefile | 1 +
drivers/scsi/ufs/ufs-hi3660.c | 715 ++
add Auto-Hibernate Idle Timer value for hi3660 ufs
Signed-off-by: Bu Tao
Signed-off-by: Geng Jianfeng
Signed-off-by: Zang Leigang
Signed-off-by: Yu Jianfeng
---
drivers/scsi/ufs/ufshci.h | 3 +++
1 file changed, 3 insertions(+)
mode change 100644 => 100755 drivers/scsi/ufs/ufshci.h
diff --g
Hi Bart,
> On Jun 7, 2017, at 3:45 PM, Bart Van Assche
> wrote:
>
> On Wed, 2017-06-07 at 14:43 -0700, Himanshu Madhani wrote:
>> +enum {
>> +TYPE_SRB,
>> +TYPE_TGT_CMD,
>> +};
>> +
>> typedef struct srb {
>> +/*
>> + * Do not move cmd_type field, it needs to
>> + * line up
On 06/08/17 22:52, Nicholas A. Bellinger wrote:
> Because qla2xxx doesn't reuse tags, it's not a problem since it's the
> only consumer of TARGET_SCF_LOOKUP_LUN_FROM_TAG.
Hello Nic,
Can you clarify this? Since all target drivers and also the target core
use a finite number of bits to represent ta
This is a note to let you know that I've just added the patch titled
scsi: ibmvscsi_tgt: remove use of class_attrs
to my driver-core git tree which can be found at
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
in the driver-core-next branch.
The patch will show up
Hi Arnd,
> On Jun 9, 2017, at 3:46 AM, Arnd Bergmann wrote:
>
> On 32-bit architectures, we using %lx to print a size_t causes a harmless
> warning:
>
> qla2xxx/qla_init.c: In function 'qla24xx_load_risc_flash':
> qla2xxx/qla_init.c:6407:7: error: format '%lx' expects argument of type 'long
>
From: Xiang Chen
Add code to prepare ATA frame for v3 hw
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 106 +
1 file changed, 106 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers/sc
From: Xiang Chen
For ECC 1bit error, logic can recover it, so we only print a warning.
For ECC multi-bit and AXI bus fatal error, we panic.
Note: once v3 hw controller reset support is added, the panic will
be replaced by a controller reset, like v2 hw.
Signed-off-by: John Garry
Signed-o
Move the functionality to retrieve the fw info into
a dedicated device type-agnostic function,
hisi_sas_get_fw_info().
The reasoning is that this function will be required
for future pci-based platforms.
Also add some debug logs for failure.
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/
From: Xiang Chen
Add code to fill the interface of phy_hard_reset, phy_get_max_linkrate,
and phy enable/disable.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 39 ++
1 file changed, 39 insertions(+)
diff --git
From: Xiang Chen
Add code to configure PHYs for v3 hw.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 127 -
1 file changed, 126 insertions(+), 1 deletion(-)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
Since hip08 SAS controller is based on pci device, add hisi_hba.pci_dev
for hip08 (will be v3), and also rename hisi_hba.pdev to .platform_dev
for clarity.
In addition, for common code which wants to reference the controller
device struct, add hisi_hba.dev, and change the common code to use
it.
S
Currently hisi_sas_device.device_id is a u64. This can create a
problem in selecting the queue for a device, in that this code
does a 64b division on device id. For some 32b systems, 64b division
is slow and the lib reference must be explicitly included.
The device id does not need to be 64b in si
Add the code to initialise the controller which is based on pci
device in hisi_sas_v3_hw.c
The core controller routines are still in hisi_sas_main.c; some
common initialisation functions are also exported from
hisi_sas_main.c
For pci-based controller, the device properties, like
phy count and sas
From: Xiang Chen
We need to check for timeout before task status, or the task will be
mistook as completed internal abort command.
Also add protection for sas_task.task_state_flags in
hisi_sas_tmf_timedout().
Signed-off-by: Xiang Chen
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/hisi_s
From: Xiang Chen
There is a change for abort dev for v3 hw: add registers to configure
unaborted iptt for a device, and then inform this to logic.
Signed-off-by: Xiang Chen
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/hisi_sas.h | 2 ++
drivers/scsi/hisi_sas/hisi_sas_main.c | 1
From: Xiang Chen
Relocate get_ata_protocol() to a common location, as future hw
versions will require it.
Also rename with "hisi_sas_" prefix for consistency.
Signed-off-by: Xiang Chen
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/hisi_sas.h | 2 ++
drivers/scsi/hisi_sas/hisi_sas
From: Xiang Chen
Relocate get_ncq_tag_v2_hw() to a common location, as
future hw versions will require it.
Also rename with "hisi_sas_" prefix for consistency.
Signed-off-by: Xiang Chen
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/hisi_sas.h | 1 +
drivers/scsi/hisi_sas/hisi_sas
Add skeleton driver for v3 hw in hisi_sas_v3_hw.c
File hisi_sas_v3_hw.c will serve 2 purposes:
- probing and initialisation of the controller based on pci device
- hw layer for v3-based controllers
The controller design is quite similar to v2 hw in hip07.
However key differences include:
-All v2
From: Xiang Chen
Add code for interface get_wideport_bitmap.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 13 +
1 file changed, 13 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers/scsi/hisi_sas/hisi_s
From: Xiang Chen
Add code to prepare SMP frame.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 74 ++
1 file changed, 74 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers/scsi/hisi_sa
From: Xiang Chen
Add code to prepare internal abort command.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 38 ++
1 file changed, 38 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers
From: Xiang Chen
Add code to prepare SSP frame and deliver it to hardware.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 208 +
1 file changed, 208 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_
From: Xiang Chen
Add code to itct setup and free for v3 hw.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 114 +
1 file changed, 114 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers
From: Xiang Chen
Add v3 cq interrupt handler slot_complete_v3_hw().
Note: The slot error handling needs to be further
refined in the future to examine all fields
in the error record, and handle appropriately,
instead of current solution - just report
SAS_OPEN_REJECT.
Sig
From: Xiang Chen
Add code to initialise v3 hardware.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 277 +
1 file changed, 277 insertions(+)
diff --git a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
b/drivers/scsi/h
This patchset adds support for the HiSilicon SAS controller
in the hip08 chipset.
The key difference compared to earlier chipsets is that the
controller is an integrated PCI endpoint in hip08.
As such, the controller is a pci device (not a platform device,
like v2 hw in hip07).
The driver is refa
From: Xiang Chen
Relocate get_ata_protocol() to a common location, as future
hw versions will require it.
Also rename with "hisi_sas_" prefix for consistency.
Signed-off-by: Xiang Chen
Signed-off-by: John Garry
---
drivers/scsi/hisi_sas/hisi_sas.h | 7
drivers/scsi/hisi_sas/hisi_s
From: Xiang Chen
Currently hisi_hba.lock is locked to deliver and receive a
command to/from any hw queue. This causes much
contention at high data-rates.
To boost performance, lock on a per queue basis for
sending and receiving commands to/from hw.
Certain critical regions still need to be lock
From: Xiang Chen
Add code to initialise interrupts and add some interrupt handlers.
Also add function hisi_sas_v3_destroy_irqs() to clean-up
irqs upon module unloading.
Signed-off-by: John Garry
Signed-off-by: Xiang Chen
---
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 283 ++
On 32-bit architectures, we using %lx to print a size_t causes a harmless
warning:
qla2xxx/qla_init.c: In function 'qla24xx_load_risc_flash':
qla2xxx/qla_init.c:6407:7: error: format '%lx' expects argument of type 'long
unsigned int', but argument 5 has type 'unsigned int' [-Werror=format=]
qla2x
This is a note to let you know that I've just added the patch titled
scsi: ibmvscsi_tgt: remove use of class_attrs
to my driver-core git tree which can be found at
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
in the driver-core-testing branch.
The patch will show
On Thu, 2017-06-08 at 07:34 -0500, Bryant G. Ly wrote:
> > Thanks Nic,
> >
> > applied to the configfs-for-next tree. I'm not entirely sure if we
> > should bother adding this to 4.12 or if it hits rarely enough?
> >
> It hits for us pretty often when we have a GPFS setup with 10 hosts and 1k+
>
39 matches
Mail list logo