[PATCH 2/2] scsi: qedi: Use 'dma_zalloc_coherent' to reduce code verbosity.

2017-06-10 Thread Christophe JAILLET
Replace some 'dma_alloc_coherent+memset' by some quivalent 'dma_zalloc_coherent' in order to reduce code verbosity Signed-off-by: Christophe JAILLET --- This patch generates some checkpatch errors about the use of space to indent code. I've left it as-is to keep consistency with the style used i

[PATCH 1/2] scsi: qedi: Fix a return value in case of error in 'qedi_alloc_global_queues'

2017-06-10 Thread Christophe JAILLET
We should return -ENOMEM in case of memory allocation error, as done elsewhere in this function. Fixes: ace7f46ba5fde ("scsi: qedi: Add QLogic FastLinQ offload iSCSI driver framework.") Signed-off-by: Christophe JAILLET --- drivers/scsi/qedi/qedi_main.c | 1 + 1 file changed, 1 insertion(+) di

[PATCH 0/2] Fix a return value + some cleanups

2017-06-10 Thread Christophe JAILLET
This patch serie first fixes a case where an error code was missing. The other path is just a cleanup in the same area. Christophe JAILLET (2): scsi: qedi: Fix a return value in case of error in 'qedi_alloc_global_queues' scsi: qedi: Use 'dma_zalloc_coherent' to reduce code verbosity. dr

[PATCH 2/3] scsi: qedf: Use 'dma_zalloc_coherent' to reduce code verbosity.

2017-06-10 Thread Christophe JAILLET
Replace some 'dma_alloc_coherent+memset' by some quivalent 'dma_zalloc_coherent' in order to reduce code verbosity Signed-off-by: Christophe JAILLET --- drivers/scsi/qedf/qedf_main.c | 19 ++- 1 file changed, 6 insertions(+), 13 deletions(-) diff --git a/drivers/scsi/qedf/qedf_m

[PATCH 3/3] scsi: qedf: Merge a few quoted strings split across lines

2017-06-10 Thread Christophe JAILLET
Merge some quoted strings to improve readability and to save some lines of code. Signed-off-by: Christophe JAILLET --- drivers/scsi/qedf/qedf_main.c | 18 ++ 1 file changed, 6 insertions(+), 12 deletions(-) diff --git a/drivers/scsi/qedf/qedf_main.c b/drivers/scsi/qedf/qedf_main

[PATCH 1/3] scsi: qedf: Fix a return value in case of error in 'qedf_alloc_global_queues'

2017-06-10 Thread Christophe JAILLET
We should return -ENOMEM in case of memory allocation error, as done elsewhere in this function. Fixes: 61d8658b4a435 ("scsi: qedf: Add QLogic FastLinQ offload FCoE driver framework.") Signed-off-by: Christophe JAILLET --- drivers/scsi/qedf/qedf_main.c | 1 + 1 file changed, 1 insertion(+) dif

[PATCH 0/3] scsi: qedf: Fix a return value + some cleanups

2017-06-10 Thread Christophe JAILLET
This patch serie first fixes a case where an error code was missing. The 2 other patches are just cleanups in the same area. Christophe JAILLET (3): scsi: qedf: Fix a return value in case of error in 'qedf_alloc_global_queues' scsi: qedf: Use 'dma_zalloc_coherent' to reduce code verbosity.

[PATCH] scsi: mpt3sas: Fix value returned by 'mpt3sas_base_attach' in case of error

2017-06-10 Thread Christophe JAILLET
'r' is known to be zero here, so it must be set to -ENOMEM is one of these 'kzalloc' fails. Fixes: c696f7b83edea ("scsi: mpt3sas: Implement device_remove_in_progress check in IOCTL path") Signed-off-by: Christophe JAILLET --- drivers/scsi/mpt3sas/mpt3sas_base.c | 8 ++-- 1 file changed, 6 i

[GIT PULL] SCSI fixes for 4.12-rc4

2017-06-10 Thread James Bottomley
This is a set of user visible fixes (excepting one format string change). Four of the qla2xxx fixes only affect the firmware dump path, but it's still important to the enterprise. The rest are various NULL pointer crash conditions or outright driver hangs. The patch is available here: git://git

Re: [PATCH] scsi: remove useless variable assignment

2017-06-10 Thread James Bottomley
On Thu, 2017-05-18 at 12:41 -0500, Gustavo A. R. Silva wrote: > Hi James, > > Quoting James Bottomley : > > > On Wed, 2017-05-17 at 19:30 -0500, Gustavo A. R. Silva wrote: > > > Remove this assignment once the value stored in variable _k_ is > > > overwritten after a few lines. > > > > > > Addre

Re: [PATCH v5 03/23] scsi: hisi_sas: optimise the usage of hisi_hba.lock

2017-06-10 Thread kbuild test robot
Hi Xiang, [auto build test WARNING on mkp-scsi/for-next] [also build test WARNING on v4.12-rc4 next-20170609] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/linux/commits/John-Garry/hisi_sas-hip08-support/201

[PATCH] scsi: aacraid: Fix some error code

2017-06-10 Thread Christophe JAILLET
If 'scsi_host_alloc', 'kzalloc' or '(*aac_drivers[index].init)' fail, the function will return 0, because 'error' is known to be 0 at this point. Return -ENOMEM in the 2 first cases and -ENODEV in the third one. This patch also removes a useless 'error = -ENODEV'. Signed-off-by: Christophe JAIL