Re: [PATCH] ARC: adjust memblock_reserve of kernel memory

2018-12-19 Thread Vineet Gupta
On 12/19/18 8:16 AM, Eugeniy Paltsev wrote: > In setup_arch_memory we reserve the memory area wherein the kernel > is located. Current implementation may reserve more memory than > it actually required in case of CONFIG_LINUX_LINK_BASE is not > equal to CONFIG_LINUX_RAM_BASE. This happens because

Re: [PATCH] ARC: adjust memblock_reserve of kernel memory

2018-12-19 Thread Vineet Gupta
On 12/19/18 8:16 AM, Eugeniy Paltsev wrote: > In setup_arch_memory we reserve the memory area wherein the kernel > is located. Current implementation may reserve more memory than > it actually required in case of CONFIG_LINUX_LINK_BASE is not > equal to CONFIG_LINUX_RAM_BASE. This happens because

Re: [PATCH 1/2] ARC: show_regs: avoid page allocator

2018-12-19 Thread Vineet Gupta
On 12/19/18 9:04 AM, Eugeniy Paltsev wrote: > As I can see x86 use print_vma_addr() in their show_signal_msg() > function which allocate page with __get_free_page(GFP_NOWAIT); Indeed with that the __get_free_page() lockdep splat is gone. There's a different one now hence my other patch. |

Re: [PATCH 00/21] glibc port to ARC processors

2018-12-19 Thread Vineet Gupta
On 12/19/18 4:14 PM, Joseph Myers wrote: > On Wed, 19 Dec 2018, Vineet Gupta wrote: > >> On 12/18/18 3:11 PM, Joseph Myers wrote: >>> Another general point: when posting a new port, could you include pointers >>> to architecture and ABI reference manuals in case those are of relevance >>> to

Re: [PATCH 00/21] glibc port to ARC processors

2018-12-19 Thread Joseph Myers
On Wed, 19 Dec 2018, Vineet Gupta wrote: > On 12/18/18 3:11 PM, Joseph Myers wrote: > > Another general point: when posting a new port, could you include pointers > > to architecture and ABI reference manuals in case those are of relevance > > to the review? (URLs going directly to PDFs of

Re: [PATCH 00/21] glibc port to ARC processors

2018-12-19 Thread Vineet Gupta
On 12/18/18 3:11 PM, Joseph Myers wrote: > Another general point: when posting a new port, could you include pointers > to architecture and ABI reference manuals in case those are of relevance > to the review? (URLs going directly to PDFs of those manuals are > preferred.) The PRM

Re: ARC vs. generic sigaction (was Re: [PATCH 08/21] ARC: Linux Syscall Interface)

2018-12-19 Thread Vineet Gupta
On 12/19/18 2:00 PM, Adhemerval Zanella wrote: > > > One possibility is to define an arch-specific __sigset_t.h with a custom > _SIGSET_NWORDS value and add an optimization on Linux sigaction.c to check > if both kernel_sigaction and glibc sigaction share same size and internal > layout to use

Re: [PATCH 13/21] ARC: Build Infrastructure

2018-12-19 Thread Joseph Myers
On Wed, 19 Dec 2018, Vineet Gupta wrote: > Indeed with current glibc port, we do build/test/run a bunch of packages > relying on PIE (dumpcap, openssh come to mind) successfully. So yes PIE > should work in general for ARC now. FWIW this could also explain the > following current results. I

Re: ARC vs. generic sigaction (was Re: [PATCH 08/21] ARC: Linux Syscall Interface)

2018-12-19 Thread Adhemerval Zanella
On 19/12/2018 15:58, Vineet Gupta wrote: > On 12/18/18 6:39 PM, Vineet Gupta wrote: diff --git a/sysdeps/unix/sysv/linux/arc/sigaction.c b/sysdeps/unix/sysv/linux/arc/sigaction.c >>> Why do you need this, rather than using the unified version (possibly with >>> a few macros defined

Re: [PATCH 13/21] ARC: Build Infrastructure

2018-12-19 Thread Vineet Gupta
On 12/18/18 3:44 PM, Joseph Myers wrote: > On Tue, 18 Dec 2018, Vineet Gupta wrote: > >> +libc { >> + GLIBC_2.29 { >> +__adddf3; __addsf3; __divdf3; __divsf3; __eqdf2; __eqsf2; __extendsfdf2; >> +__fixdfdi; __fixdfsi; __fixsfdi; __fixsfsi; >> +__fixunsdfdi; __fixunsdfsi;

Re: [PATCH 1/2] ARC: show_regs: avoid page allocator

2018-12-19 Thread Vineet Gupta
On 12/19/18 12:46 PM, William Kucharski wrote: > I would rather see 256 as a #define somewhere rather than a magic number > sprinkled > around arch/arc/kernel/troubleshoot.c. That bothered me as well, but I was too lazy to define one and the existing ones don't apply. PATH_MAX is 4K which will

Re: [PATCH 1/2] ARC: show_regs: avoid page allocator

2018-12-19 Thread William Kucharski
> On Dec 18, 2018, at 11:53 AM, Vineet Gupta wrote: > > Use on-stack smaller buffers instead of dynamic pages. > > The motivation for this change was to address lockdep splat when > signal handling code calls show_regs (with preemption disabled) and > ARC show_regs calls into sleepable page

Re: [PATCH 03/21] ARC: ABI Implementation

2018-12-19 Thread Joseph Myers
On Wed, 19 Dec 2018, Vineet Gupta wrote: > On 12/19/18 9:40 AM, Joseph Myers wrote: > > Architecture maintainers need wiki accounts in any case (to post test > > results for their architectures during every release freeze period), so > > you should create an account and post its name so someone

Re: [PATCH 09/21] ARC: Linux ABI

2018-12-19 Thread Joseph Myers
On Wed, 19 Dec 2018, Vineet Gupta wrote: > So perhaps we keep the ARC header above, with matching layout, while > switching to generic sigaction() still. OK ? If the different userspace layout is better, it should be better for all future ports as well. Duplicating all the SA_* constants in

Re: [PATCH 14/21] ARC: Enable __start as entry point vs. canonical _start

2018-12-19 Thread Vineet Gupta
On 12/18/18 1:28 PM, Florian Weimer wrote: > I think this change and the test suite fixes should be folded into the > initial addition of these files. Or is there a reason for not doing > this? As suggested by other reviewers too, I'm folding all fixes into initial files. Thx, -Vineet

Re: [PATCH 10/21] ARC: Linux Startup and Dynamic Loading

2018-12-19 Thread Vineet Gupta
On 12/18/18 3:49 PM, Joseph Myers wrote: > On Tue, 18 Dec 2018, Vineet Gupta wrote: > >> diff --git a/sysdeps/unix/sysv/linux/arc/ldconfig.h >> b/sysdeps/unix/sysv/linux/arc/ldconfig.h > > This header should only be needed if you support multiple ABIs > simultaneously on the same system; note

Re: [PATCH 03/21] ARC: ABI Implementation

2018-12-19 Thread Vineet Gupta
On 12/19/18 9:40 AM, Joseph Myers wrote: > Architecture maintainers need wiki accounts in any case (to post test > results for their architectures during every release freeze period), so > you should create an account and post its name so someone can add it to > EditorGroup so you can edit.

Re: [PATCH 09/21] ARC: Linux ABI

2018-12-19 Thread Vineet Gupta
On 12/18/18 3:38 PM, Joseph Myers wrote: > On Tue, 18 Dec 2018, Vineet Gupta wrote: > >> +typedef unsigned short int __pr_uid_t; >> +typedef unsigned short int __pr_gid_t; > > Are you sure? No I'm not :-) There were some interim sweeping changes in this area since when I started so this

Re: ARC vs. generic sigaction (was Re: [PATCH 08/21] ARC: Linux Syscall Interface)

2018-12-19 Thread Joseph Myers
On Wed, 19 Dec 2018, Vineet Gupta wrote: > I took a stab at this but not really happy with taking this approach. > > (1). Common code assumes disparate kernel and userland sigaction struct even > though there's no reason for a *new* port to be: its not like all glibc code > is > shared/common

Re: [PATCH 21/21] NEWS: mention ARC port

2018-12-19 Thread Vineet Gupta
On 12/18/18 3:45 PM, Joseph Myers wrote: > Obviously this belongs under 2.29, or whatever version gets the port, not > 2.26. oops, left over from original code, now fixed and beefed up the details a bit. ___ linux-snps-arc mailing list

Re: [PATCH] ARC: adjust memblock_reserve of kernel memory

2018-12-19 Thread Sasha Levin
Hi, [This is an automated email] This commit has been processed because it contains a -stable tag. The stable tag indicates that it's relevant for the following trees: all The bot has tested the following trees: v4.19.10, v4.14.89, v4.9.146, v4.4.168, v3.18.130, v4.19.10: Build OK! v4.14.89:

ARC vs. generic sigaction (was Re: [PATCH 08/21] ARC: Linux Syscall Interface)

2018-12-19 Thread Vineet Gupta
On 12/18/18 6:39 PM, Vineet Gupta wrote: >>> diff --git a/sysdeps/unix/sysv/linux/arc/sigaction.c >>> b/sysdeps/unix/sysv/linux/arc/sigaction.c >> Why do you need this, rather than using the unified version (possibly with >> a few macros defined first)? > > The only syscall ABI requirement is

Re: [PATCH 03/21] ARC: ABI Implementation

2018-12-19 Thread Joseph Myers
On Tue, 18 Dec 2018, Vineet Gupta wrote: > P.S. Is there a lint file or are these style guidelines in wiki > somewhere. If not I can volunteer to capture them in a wiki/readme for > future port submissions. In addition to the GNU Coding Standards (which cover many things such as comment

Re: [PATCH 1/2] ARC: show_regs: avoid page allocator

2018-12-19 Thread Vineet Gupta
On 12/19/18 9:04 AM, Eugeniy Paltsev wrote: > Just curious: isn't that enough to use GFP_NOWAIT instead > of GFP_KERNEL when we allocate page in show_regs()? > > As I can see x86 use print_vma_addr() in their show_signal_msg() > function which allocate page with __get_free_page(GFP_NOWAIT); I'm

Re: [PATCH 1/2] ARC: show_regs: avoid page allocator

2018-12-19 Thread Eugeniy Paltsev
Hi Vineet, Just curious: isn't that enough to use GFP_NOWAIT instead of GFP_KERNEL when we allocate page in show_regs()? As I can see x86 use print_vma_addr() in their show_signal_msg() function which allocate page with __get_free_page(GFP_NOWAIT); On Tue, 2018-12-18 at 10:53 -0800, Vineet

Re: ensure dma_alloc_coherent always returns zeroed memory

2018-12-19 Thread Christoph Hellwig
FYI, I've picked this up for dma-mapping for-next now. ___ linux-snps-arc mailing list linux-snps-arc@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-snps-arc

Re: [PATCH v2 2/2] kgdb/treewide: constify struct kgdb_arch arch_kgdb_ops

2018-12-19 Thread Daniel Thompson
On Thu, Dec 06, 2018 at 08:07:40PM +, Christophe Leroy wrote: > checkpatch.pl reports the following: > > WARNING: struct kgdb_arch should normally be const > #28: FILE: arch/mips/kernel/kgdb.c:397: > +struct kgdb_arch arch_kgdb_ops = { > > This report makes sense, as all other ops

Re: [PATCH v2 1/2] mips/kgdb: prepare arch_kgdb_ops for constness

2018-12-19 Thread Daniel Thompson
On Thu, Dec 06, 2018 at 08:07:38PM +, Christophe Leroy wrote: > MIPS is the only architecture modifying arch_kgdb_ops during init. > This patch makes the init static, so that it can be changed to > const in following patch, as recommended by checkpatch.pl > > Suggested-by: Paul Burton >

Re: [REPOST PATCH v6 2/4] kgdb: Fix kgdb_roundup_cpus() for arches who used smp_call_function()

2018-12-19 Thread Daniel Thompson
On Tue, Dec 04, 2018 at 07:38:26PM -0800, Douglas Anderson wrote: > When I had lockdep turned on and dropped into kgdb I got a nice splat > on my system. Specifically it hit: > DEBUG_LOCKS_WARN_ON(current->hardirq_context) > > Specifically it looked like this: > sysrq: SysRq : DEBUG >

Re: [REPOST PATCH v6 1/4] kgdb: Remove irq flags from roundup

2018-12-19 Thread Daniel Thompson
On Tue, Dec 04, 2018 at 07:38:25PM -0800, Douglas Anderson wrote: > The function kgdb_roundup_cpus() was passed a parameter that was > documented as: > > > the flags that will be used when restoring the interrupts. There is > > local_irq_save() call before kgdb_roundup_cpus(). > > Nobody used

Re: [PATCH] arc: remove redundant kernel-space generic-y

2018-12-19 Thread Vineet Gupta
On 12/19/18 7:16 AM, Masahiro Yamada wrote: > Could you pick this up to your arc tree? Done, will push it in a day or so ! Thx, -Vineet ___ linux-snps-arc mailing list linux-snps-arc@lists.infradead.org

Re: [PATCH] arc: remove redundant kernel-space generic-y

2018-12-19 Thread Masahiro Yamada
Hi Vineet, On Mon, Dec 17, 2018 at 2:07 PM Vineet Gupta wrote: > > On 12/16/18 6:17 AM, Masahiro Yamada wrote: > > This commit removes redundant generic-y defines in > > arch/arc/include/asm/Kbuild. > > > > It is redundant to define generic-y when arch-specific implementation > > exists in

Re: [PATCH 12/21] ARC: Update syscall-names.list for ARC specific syscalls

2018-12-19 Thread Florian Weimer
* Vineet Gupta: > On 12/18/18 1:26 PM, Florian Weimer wrote: >> This should come in with a sync with a released upstream kernel. Will >> the port be in Linux 4.20? > > linux port was upstreamed in 2013 in v3.9 Ah, right, we add system calls to the lists only for our ports. Thanks, Florian