Re: [PATCH v2 2/3] arch: simplify architecture specific page size configuration

2024-03-07 Thread Michael Ellerman
.h| 10 +- > arch/powerpc/Kconfig | 31 ++- > arch/powerpc/include/asm/page.h | 2 +- > scripts/gdb/linux/constants.py.in | 2 +- > scripts/gdb/linux/mm.py | 2 +- > 10 files changed, 32

Re: [PATCH v2 1/3] arch: consolidate existing CONFIG_PAGE_SIZE_*KB definitions

2024-03-06 Thread Michael Ellerman
Hi Arnd, Arnd Bergmann writes: > From: Arnd Bergmann > > These four architectures define the same Kconfig symbols for configuring > the page size. Move the logic into a common place where it can be shared > with all other architectures. > > Signed-off-by: Arnd Bergmann > --- > Changes from v1:

Re: [PATCH 4/4] vdso: avoid including asm/page.h

2024-02-27 Thread Michael Ellerman
Christophe Leroy writes: > Le 26/02/2024 à 17:14, Arnd Bergmann a écrit : >> From: Arnd Bergmann >> >> The recent change to the vdso_data_store broke building compat VDSO >> on at least arm64 because it includes headers outside of the include/vdso/ >> namespace: > > I understand that powerpc64

Re: [PATCH 15/22] arch: vdso: consolidate gettime prototypes

2023-11-09 Thread Michael Ellerman
Christophe Leroy writes: > Le 09/11/2023 à 11:18, Michael Ellerman a écrit : >> "Arnd Bergmann" writes: >>> On Wed, Nov 8, 2023, at 19:31, Christophe Leroy wrote: >>>> Le 08/11/2023 à 13:58, Arnd Bergmann a écrit : >>> >>>> power

Re: [PATCH 15/22] arch: vdso: consolidate gettime prototypes

2023-11-09 Thread Michael Ellerman
"Arnd Bergmann" writes: > On Wed, Nov 8, 2023, at 19:31, Christophe Leroy wrote: >> Le 08/11/2023 à 13:58, Arnd Bergmann a écrit : > >> powerpc has functions doing more or less the same, they are called >> __c_kernel_clock_gettime() and alike with their prototypes siting in >>

Re: [PATCH] treewide: drop CONFIG_EMBEDDED

2023-08-16 Thread Michael Ellerman
s/ps3_defconfig |2 +- Acked-by: Michael Ellerman (powerpc) ... > diff -- a/init/Kconfig b/init/Kconfig > --- a/init/Kconfig > +++ b/init/Kconfig > @@ -1790,14 +1790,6 @@ config DEBUG_RSEQ > > If unsure, say N. > > -config EMBEDDED > - boo

Re: [PATCH v2 15/19] arch/powerpc: Implement with generic helpers

2023-04-12 Thread Michael Ellerman
Thomas Zimmermann writes: > Replace the architecture's fb_is_primary_device() with the generic > one from . No functional changes. > > Signed-off-by: Thomas Zimmermann > Cc: Michael Ellerman > Cc: Nicholas Piggin > Cc: Christophe Leroy > --- > arch/powerpc/include

Re: [PATCH v6 13/41] mm: Make pte_mkwrite() take a VMA

2023-02-19 Thread Michael Ellerman
arch/powerpc/include/asm/book3s/64/pgtable.h | 4 ++-- > arch/powerpc/include/asm/nohash/32/pgtable.h | 2 +- > arch/powerpc/include/asm/nohash/32/pte-8xx.h | 2 +- > arch/powerpc/include/asm/nohash/64/pgtable.h | 2 +- Looks like you discovered the joys of ppc's at-least 5 different M

Re: [PATCH v3 09/24] powerpc: Remove COMMAND_LINE_SIZE from uapi

2023-02-14 Thread Michael Ellerman
nclude/uapi/asm/setup.h | 2 -- > 2 files changed, 1 insertion(+), 3 deletions(-) Acked-by: Michael Ellerman (powerpc) cheers ___ linux-snps-arc mailing list linux-snps-arc@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-snps-arc

Re: [PATCH mm-unstable v1 17/26] powerpc/mm: support __HAVE_ARCH_PTE_SWP_EXCLUSIVE on 32bit book3s

2023-02-09 Thread Michael Ellerman
B 2 / MSB 29. There seems to be no real reason why that bit cannot > be used, and reusing it avoids having to steal one bit from the swap > offset. > > While at it, mask the type in __swp_entry(). > > Cc: Michael Ellerman > Cc: Nicholas Piggin > Cc: Christophe Leroy > Signed-off-

Re: [PATCH v2 4/4] mm, arch: add generic implementation of pfn_valid() for FLATMEM

2023-01-29 Thread Michael Ellerman
- > arch/m68k/include/asm/page_no.h| 2 -- > arch/microblaze/include/asm/page.h | 1 - > arch/mips/include/asm/page.h | 13 - > arch/nios2/include/asm/page.h | 9 - > arch/openrisc/include/asm/page.h | 2 -- > arch/parisc/include/asm/page

Re: [PATCH] arch: mm: rename FORCE_MAX_ZONEORDER to ARCH_FORCE_MAX_ORDER

2022-08-17 Thread Michael Ellerman
arch/powerpc/configs/85xx/ge_imp3a_defconfig | 2 +- > arch/powerpc/configs/fsl-emb-nonhw.config| 2 +- Acked-by: Michael Ellerman (powerpc) cheers ___ linux-snps-arc mailing list linux-snps-arc@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-snps-arc

Re: [PATCH V3 04/30] powerpc/mm: Enable ARCH_HAS_VM_GET_PAGE_PROT

2022-03-01 Thread Michael Ellerman
et_page_prot() as powerpc_vm_get_page_prot() and moves > it near vm_get_page_prot(). > > Cc: Michael Ellerman > Cc: Paul Mackerras > Cc: linuxppc-...@lists.ozlabs.org > Cc: linux-ker...@vger.kernel.org > Signed-off-by: Anshuman Khandual > --- > arch/powerpc/Kconfig

Re: [PATCH -next] trap: Cleanup trap_init()

2021-08-12 Thread Michael Ellerman
> Cc: Stafford Horne > Cc: James E.J. Bottomley > Cc: Helge Deller > Cc: Michael Ellerman > Cc: Benjamin Herrenschmidt > Cc: Paul Mackerras > Cc: Paul Walmsley > Cc: Jeff Dike > Cc: Richard Weinberger > Cc: Anton Ivanov > Cc: Andrew Morton > Signed

Re: [PATCH 2/3] trace: refactor TRACE_IRQFLAGS_SUPPORT in Kconfig

2021-08-01 Thread Michael Ellerman
_SUPPORT > bool > default y > @@ -271,6 +267,7 @@ config PPC > select STRICT_KERNEL_RWX if STRICT_MODULE_RWX > select SYSCTL_EXCEPTION_TRACE > select THREAD_INFO_IN_TASK > + select TRACE_IRQFLAGS_SUPPORT >

Re: [PATCH 0/2] Change struct page layout for page_pool

2021-04-19 Thread Michael Ellerman
"Matthew Wilcox (Oracle)" writes: > The first patch here fixes two bugs on ppc32, and mips32. It fixes one > bug on arc and arm32 (in certain configurations). It probably makes > sense to get it in ASAP through the networking tree. I'd like to see > testing on those four architectures if

Re: [PATCH 2/6] mm: Generalize SYS_SUPPORTS_HUGETLBFS (rename as ARCH_SUPPORTS_HUGETLBFS)

2021-03-09 Thread Michael Ellerman
duplication and makes it cleaner. > > Cc: Russell King > Cc: Catalin Marinas > Cc: Will Deacon > Cc: Thomas Bogendoerfer > Cc: "James E.J. Bottomley" > Cc: Helge Deller > Cc: Michael Ellerman > Cc: Benjamin Herrenschmidt > Cc: Paul Mackerras > Cc: Pau

Re: [PATCH v3 2/5] powerpc: module_[32|64].c: replace swap function with built-in one

2020-06-08 Thread Michael Ellerman
ented > without them, an "optimized" custom swap function is now > a waste of time as well as code. > > Signed-off-by: Andrey Abramov > Reviewed by: George Spelvin > Acked-by: Michael Ellerman (powerpc) Applied to powerpc next, thanks. https://git.kernel.org/powerpc

Re: [PATCH V1 00/10] Remove duplicated kmap code

2020-04-30 Thread Michael Ellerman
ira.we...@intel.com writes: > From: Ira Weiny > > The kmap infrastructure has been copied almost verbatim to every architecture. > This series consolidates obvious duplicated code by defining core functions > which call into the architectures only when needed. > > Some of the k[un]map_atomic()

Re: [RESEND PATCH v2 1/9] iomap: Constify ioreadX() iomem argument (as in generic implementation)

2020-03-12 Thread Michael Ellerman
oid *dst, unsigned long count) > { > readsb(addr, dst, count); > } > -void ioread16_rep(void __iomem *addr, void *dst, unsigned long count) > +void ioread16_rep(const void __iomem *addr, void *dst, unsigned long count) > { > readsw(addr, dst, count); > } &g

Re: [PATCH V8] mm/debug: Add tests validating architecture page table helpers

2019-11-07 Thread Michael Ellerman
Anshuman Khandual writes: > On 11/06/2019 12:11 PM, Christophe Leroy wrote: >> Le 06/11/2019 à 04:22, Anshuman Khandual a écrit : >>> On 10/28/2019 10:59 AM, Anshuman Khandual wrote: +    --- +    | arch |status| +    --- +    |  

Re: [PATCH v2 2/5] powerpc: module_[32|64].c: replace swap function with built-in one

2019-04-01 Thread Michael Ellerman
Andrey Abramov writes: > Replace relaswap with built-in one, because relaswap > does a simple byte to byte swap. I replied to v1 with an ack, which stands, this is just a clarification. > Since Spectre mitigations have made indirect function calls more > expensive, and the default simple byte

Re: [PATCH v2 10/21] memblock: refactor internal allocation functions

2019-02-03 Thread Michael Ellerman
Mike Rapoport writes: > Currently, memblock has several internal functions with overlapping > functionality. They all call memblock_find_in_range_node() to find free > memory and then reserve the allocated range and mark it with kmemleak. > However, there is difference in the allocation

Re: [PATCH v2 09/21] memblock: drop memblock_alloc_base()

2019-01-29 Thread Michael Ellerman
ck.h| 2 -- > mm/memblock.c | 14 -- > 6 files changed, 17 insertions(+), 21 deletions(-) Acked-by: Michael Ellerman (powerpc) cheers ___ linux-snps-arc mailing list linux-snps-arc@lists.infradead.org http://lists

Re: [PATCH v2 06/21] memblock: memblock_phys_alloc_try_nid(): don't panic

2019-01-29 Thread Michael Ellerman
Michael Ellerman writes: > Mike Rapoport writes: > >> diff --git a/arch/arm64/mm/numa.c b/arch/arm64/mm/numa.c >> index ae34e3a..2c61ea4 100644 >> --- a/arch/arm64/mm/numa.c >> +++ b/arch/arm64/mm/numa.c >> @@ -237,6 +237,10 @@ static void __init setup_node_

Re: [PATCH v2 06/21] memblock: memblock_phys_alloc_try_nid(): don't panic

2019-01-29 Thread Michael Ellerman
pr_info("Initmem setup node %d []\n", nid); > > nd_pa = memblock_phys_alloc_try_nid(nd_size, SMP_CACHE_BYTES, nid); > + if (!nd_pa) > + panic("Cannot allocate %zu bytes for node %d data\n", > + nd_size, nid); &

Re: [PATCH v2 02/21] powerpc: use memblock functions returning virtual address

2019-01-29 Thread Michael Ellerman
el/paca.c| 6 +- > arch/powerpc/kernel/prom.c| 5 - > arch/powerpc/kernel/setup_32.c| 26 -- > 5 files changed, 26 insertions(+), 19 deletions(-) LGTM. Acked-by: Michael Ellerman cheers __

Re: [PATCH v2 2/2] kgdb/treewide: constify struct kgdb_arch arch_kgdb_ops

2018-12-07 Thread Michael Ellerman
remove_breakpoint(struct kgdb_bkpt *bpt) > /* > * Global data > */ > -struct kgdb_arch arch_kgdb_ops; > +const struct kgdb_arch arch_kgdb_ops; > > static int kgdb_not_implemented(struct pt_regs *regs) > { Acked-by: Michael Ellerman (powerpc) cheers ___

Re: [PATCH v2 16/15] syscall_get_arch: add "struct task_struct *" argument

2018-11-27 Thread Michael Ellerman
) ? AUDIT_ARCH_PPC : AUDIT_ARCH_PPC64; > + int arch; > + > + if (IS_ENABLED(CONFIG_PPC64) && !test_tsk_thread_flag(task, TIF_32BIT)) > + arch = AUDIT_ARCH_PPC64; > + else > + arch = AUDIT_ARCH_PPC; > + > #ifdef __LITTLE_ENDIAN__

Re: [PATCH] fix double ;;s in code

2018-02-19 Thread Michael Ellerman
Daniel Vetter writes: > On Sun, Feb 18, 2018 at 11:00:56AM +0100, Christophe LEROY wrote: >> Le 17/02/2018 à 22:19, Pavel Machek a écrit : >> > >> > Fix double ;;'s in code. >> > >> > Signed-off-by: Pavel Machek >> >> A summary of the files modified on top of

Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_

2018-01-02 Thread Michael Ellerman
Geert Uytterhoeven <ge...@linux-m68k.org> writes: > On Tue, Jan 2, 2018 at 10:45 AM, Michael Ellerman <m...@ellerman.id.au> wrote: >> Christoph Hellwig <h...@lst.de> writes: >> >>> We want to use the dma_direct_ namespace for a generic implementation

Re: [PATCH 16/67] powerpc: rename dma_direct_ to dma_nommu_

2018-01-02 Thread Michael Ellerman
Christoph Hellwig writes: > We want to use the dma_direct_ namespace for a generic implementation, > so rename powerpc to the second best choice: dma_nommu_. I'm not a fan of "nommu". Some of the users of direct ops *are* using an IOMMU, they're just setting up a 1:1 mapping once

Re: [PATCH 1/3] futex: remove duplicated code

2017-03-04 Thread Michael Ellerman
eded > assembly which is now in arch_futex_atomic_op_inuser. Looks OK and boots on powerpc. But I don't think anything's actually calling those futex ops. Is there a test suite I should run? Acked-by: Michael Ellerman <m...@ellerman.id.au> (powerpc) cheers

Re: Build regressions/improvements in v4.9-rc1

2016-10-26 Thread Michael Ellerman
Alexey Brodkin <alexey.brod...@synopsys.com> writes: > On Wed, 2016-10-19 at 22:50 +1100, Michael Ellerman wrote: >> Vineet Gupta <vineet.gup...@synopsys.com> writes: >> > On 10/17/2016 02:02 PM, Arnd Bergmann wrote: >> > > On Monday, October 1

Re: Build regressions/improvements in v4.9-rc1

2016-10-19 Thread Michael Ellerman
Vineet Gupta writes: > On 10/17/2016 02:02 PM, Arnd Bergmann wrote: >> On Monday, October 17, 2016 9:59:24 AM CEST Vineet Gupta wrote: >>> On 10/17/2016 12:34 AM, Geert Uytterhoeven wrote: > 48 error regressions: >> +

Re: kisskb: FAILED linux-next/axs103_smp_defconfig/arcv2 Thu Jun 09, 17:31

2016-06-09 Thread Michael Ellerman
On Thu, 2016-06-09 at 08:44 +, Alexey Brodkin wrote: > Hi Michael, > > On Thu, 2016-06-09 at 14:02 +0530, Vineet Gupta wrote: > > Hi Michael, > > > > On Thursday 09 June 2016 01:02 PM, nore...@ellerman.id.au wrote: > > > > > > FAILED linux-next/axs103_smp_defconfig/arcv2 Thu Jun 09, 17:31 >

Re: kisskb: FAILED linux-next/axs103_smp_defconfig/arcv2 Thu Dec 10, 17:33

2015-12-10 Thread Michael Ellerman
On Thu, 2015-12-10 at 07:05 +, Vineet Gupta wrote: > On Thursday 10 December 2015 12:05 PM, nore...@ellerman.id.au wrote: > > FAILED linux-next/axs103_smp_defconfig/arcv2 Thu Dec 10, 17:33 > > > > http://kisskb.ellerman.id.au/kisskb/buildresult/12564629/ > > > > Commit: Add linux-next