Re: [PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Greg KH
On Mon, Oct 05, 2015 at 12:08:26AM +0300, Sergei Shtylyov wrote: > Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Why? I hate PCI_VDEVICE(), it's impossible to grep for things and does not help with readability and is pointless. My one wish was that when I was the PCI

Re: [PATCH 0/9] USB 3.1 initial support for usb core and xhci

2015-10-04 Thread Greg KH
On Thu, Oct 01, 2015 at 06:40:30PM +0300, Mathias Nyman wrote: > This patchseries adds the USB 3.1 groundwork. > > USB 3.1 specification includes a new SuperSpeedPlus protocol supporting > up to 10Gbps speeds. USB 3.1 devices using the new SuperSpeedPlus protocol > are called USB 3.1 Gen2

Re: [PATCH 1/1] usb: misc: usbtest: add bulk queue test

2015-10-04 Thread Greg KH
On Mon, Sep 07, 2015 at 02:13:57PM +0800, Peter Chen wrote: > The bulk queue tests are used to show 'best performance' for bulk > transfer, we are often asked this question by users. The implementation > is the same with iso test, that is queue request at interrupt completion, > so we reuse the

Re: Problems with printk logs and my driver

2015-10-04 Thread Eric Curtin
On 30 September 2015 at 13:07, Austin S Hemmelgarn wrote: > On 2015-09-29 18:11, Eric Curtin wrote: >> >> On 25 September 2015 at 16:45, Austin S Hemmelgarn >> wrote: >>> >>> On 2015-09-25 08:02, Jiri Kosina wrote: On Fri, 25 Sep 2015,

Re: [PATCH v8 0/3] usb: xhci-platform: Configure 64-bit DMA mask if the platform is capable

2015-10-04 Thread Greg KH
On Wed, Sep 30, 2015 at 02:24:30PM -0700, Duc Dang wrote: > On Thu, Sep 17, 2015 at 11:19 AM, Duc Dang wrote: > > The xhci platform driver does not work with system that only supports > > 64-bit DMA as it requests 32-bit DMA mask during driver initialization. > > This patch set

Re: [PATCH V5 1/2] ACPI / EC: Fix broken 64bit big-endian users of 'global_lock'

2015-10-04 Thread Greg Kroah-Hartman
On Sun, Sep 27, 2015 at 03:48:24PM +0200, Rafael J. Wysocki wrote: > On Sun, Sep 27, 2015 at 12:04 AM, Viresh Kumar > wrote: > > global_lock is defined as an unsigned long and accessing only its lower > > 32 bits from sysfs is incorrect, as we need to consider other 32

Re: [PATCH 15/15] dma: remove external references to dma_supported

2015-10-04 Thread Greg KH
On Sat, Oct 03, 2015 at 05:19:39PM +0200, Christoph Hellwig wrote: > Signed-off-by: Christoph Hellwig > --- > Documentation/DMA-API.txt | 13 - > drivers/usb/host/ehci-hcd.c | 2 +- > drivers/usb/host/fotg210-hcd.c | 2 +- > drivers/usb/host/fusbh200-hcd.c |

Re: [PATCH 06/14] RFC: usb/host/fotg210: replace msleep by usleep_range

2015-10-04 Thread Peter Senna Tschudin
On Fri, Oct 2, 2015 at 7:52 PM, Alan Stern wrote: > On Fri, 2 Oct 2015, Felipe Balbi wrote: > >> On Mon, Sep 21, 2015 at 05:01:10PM +0200, Peter Senna Tschudin wrote: >> > msleep under 20ms can result in sleeping up to 20ms, which may not be >> > intended. Replace

Re: [PATCH 1/1] lsusb: Fix issue with lengthy string descriptors

2015-10-04 Thread Greg Kroah-Hartman
On Fri, Jul 31, 2015 at 12:49:10AM +0530, Muthu M wrote: > Fixed the issue in displaying lengthy string descriptor (more than 128 bytes) > > Signed-off-by: Muthu M > --- > usbmisc.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) Applied, thanks. greg k-h -- To

Re: [PATCH 06/14] RFC: usb/host/fotg210: replace msleep by usleep_range

2015-10-04 Thread Alan Stern
On Sun, 4 Oct 2015, Peter Senna Tschudin wrote: > On Fri, Oct 2, 2015 at 7:52 PM, Alan Stern wrote: > > On Fri, 2 Oct 2015, Felipe Balbi wrote: > > > >> On Mon, Sep 21, 2015 at 05:01:10PM +0200, Peter Senna Tschudin wrote: > >> > msleep under 20ms can result in

Re: Problems with printk logs and my driver

2015-10-04 Thread Alan Stern
On Sun, 4 Oct 2015, Eric Curtin wrote: > Ok so for the fun of it, I changed the VENDOR_ID and DEVICE_ID of my > keyboard to use the driver for this samsung Wireless keyboard and > mouse, crazy I know since I have a different piece of hardware, but I > wanted to see what happens or at least does

[PATCH 1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/host/ehci-pci.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) Index: usb/drivers/usb/host/ehci-pci.c

[PATCH 5/8] dwc3-pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/dwc3/dwc3-pci.c | 17 +++-- 1 file changed, 7 insertions(+), 10 deletions(-) Index: usb/drivers/usb/dwc3/dwc3-pci.c

[PATCH 8/8] bdc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/gadget/udc/bdc/bdc_pci.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Index: usb/drivers/usb/gadget/udc/bdc/bdc_pci.c

[PATCH 7/8] pch_udc: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/gadget/udc/pch_udc.c |9 - 1 file changed, 4 insertions(+), 5 deletions(-) Index: usb/drivers/usb/gadget/udc/pch_udc.c

[PATCH] usb: hcd: use USB_DT_*

2015-10-04 Thread Sergei Shtylyov
Fix using the bare numbers to set the 'bDescriptorType' descriptor fields while the values are #define'd in . Signed-off-by: Sergei Shtylyov --- The patch is against the 'usb-next' branch of Greg KH's 'usb.git' repo. I's been laying around from the end of

[PATCH 0/8] USB: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Hello. Here's a set of 8 patches against the 'usb-next' branch of Greg KH's 'usb.git' repo. It's to eliminate the use of the PCI_DEVICE() macro where less verbose PCI_VDEVICE() should have been used. [1/8] ehci-pci: use PCI_VDEVICE() instead of PCI_DEVICE() [2/8] ohci-pci:-use-PCI_VDEVICE()

[PATCH 2/8] ohci-pci:-use-PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/host/ohci-pci.c | 20 ++-- 1 file changed, 10 insertions(+), 10 deletions(-) Index: usb/drivers/usb/host/ohci-pci.c

[PATCH 3/8] chipidea: ci_hdrc_pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/chipidea/ci_hdrc_pci.c |6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) Index: usb/drivers/usb/chipidea/ci_hdrc_pci.c

[PATCH 4/8] dwc2: pci: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/dwc2/pci.c |5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) Index: usb/drivers/usb/dwc2/pci.c

[PATCH 6/8] amd5536udc: use PCI_VDEVICE() instead of PCI_DEVICE()

2015-10-04 Thread Sergei Shtylyov
Fix using the PCI_DEVICE() macro instead of less verbose PCI_VDEVICE(). Signed-off-by: Sergei Shtylyov --- drivers/usb/gadget/udc/amd5536udc.c |2 +- 1 file changed, 1 insertion(+), 1 deletion(-) Index: usb/drivers/usb/gadget/udc/amd5536udc.c

Re: [PATCH] usbhid: Fix for the WiiU adapter from Mayflash

2015-10-04 Thread Jiri Kosina
On Sat, 3 Oct 2015, Felipe Balbi wrote: > > The WiiU adapter from Mayflash (see > > http://www.mayflash.com/Products/NINTENDOWiiU/W009.html) is not > > working correctly. > > > > The "XInput" mode works fine, the controller is recognized as a xbox > > controller. But it is only possible to

Re: [PATCH v4 1/5] gadget: Introduce the notifier functions

2015-10-04 Thread Mark Brown
On Fri, Oct 02, 2015 at 02:11:25PM -0500, Felipe Balbi wrote: > On Fri, Oct 02, 2015 at 07:49:09PM +0100, Mark Brown wrote: > > On Fri, Oct 02, 2015 at 12:23:11PM -0500, Felipe Balbi wrote: > > > > Things more difficult, if nothing else it means we need to get whatever > > > > userspace component

RE: [PATCH] usb-host: Remove fusbh200 driver

2015-10-04 Thread 江峰興
Hi Balbi, >> John Feng-Hsin Chiang, can you confirm that from your side the >> fusbh200 driver can be deleted? >... but let's get this confirmation. Yes, you can delete fusbh200. Best Regards, John Chiang -Original Message- From: Felipe Balbi [mailto:ba...@ti.com] Sent: Sunday,