Re: [PATCH 5/6] phy: qcom-usb-hs: Fix unbalanced notifier registration

2018-08-23 Thread Bjorn Andersson
On Tue 21 Aug 06:55 PDT 2018, Loic Poulain wrote: > Phy power on/off cycle can happen several times during device life. > We then need to balance the extcon notifier registration accordingly. > > Fixes: f0b5c2c96370 ("phy: qcom-usb-hs: Replace the extcon API") > Signed-off-by: Loic Poulain >

Re: [PATCH 1/6] usb: chipidea: Add dynamic pinctrl selection

2018-08-23 Thread Bjorn Andersson
On Tue 21 Aug 06:55 PDT 2018, Loic Poulain wrote: > Some hardware implementations require to configure pins differently > according to the USB role (host/device), this can be an update of the > pins routing or a simple GPIO value change. > > This patch introduces new optional "host" and "device"

Re: [PATCH v7 1/4] reset: Add APIs to manage array of resets

2017-11-01 Thread Bjorn Andersson
On Fri 20 Oct 05:20 PDT 2017, Philipp Zabel wrote: > Hi, > > On Thu, 2017-10-19 at 11:54 -0700, Bjorn Andersson wrote: > > On Wed 19 Jul 08:59 PDT 2017, Philipp Zabel wrote: > > > > > From: Vivek Gautam <vivek.gau...@codeaurora.org> > > > &

Re: [PATCH v2 1/3] usb: host: remove ehci-msm.c

2017-10-30 Thread Bjorn Andersson
On Thu 26 Oct 08:06 PDT 2017, Alan Stern wrote: > On Thu, 26 Oct 2017, Alex Elder wrote: > > > No Qualcomm SoC requires the "ehci-msm.c" code any more. So remove it. > > What about old Qualcomm SoCs? What should they use instead? > These drivers where unfortunately broken by design (host

Re: [PATCH v7 1/4] reset: Add APIs to manage array of resets

2017-10-19 Thread Bjorn Andersson
On Wed 19 Jul 08:59 PDT 2017, Philipp Zabel wrote: > From: Vivek Gautam > > Many devices may want to request a bunch of resets and control them. So > it's better to manage them as an array. Add APIs to _get() an array of > reset_control, reusing the _assert(),

Re: [PATCH 11/15] remoteproc: make device_type const

2017-08-24 Thread Bjorn Andersson
On Sat 19 Aug 01:22 PDT 2017, Bhumika Goyal wrote: > Make this const as it is only stored in the type field of a device > structure, which is const. > Done using Coccinelle. > > Signed-off-by: Bhumika Goyal Applied, thanks. Regards, Bjorn > --- >

Re: [RESEND PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-10-21 Thread Bjorn Andersson
On Fri 21 Oct 10:38 PDT 2016, Stephen Boyd wrote: > On 10/21, Bjorn Andersson wrote: > > hcd_alloc_coherent() and usb_alloc_coherent() ends up allocating coherent > > memory on behalf of ci_hdrc driver. But as the ci_hdrc is instantiated > > manually > > it will not

[RESEND PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-10-21 Thread Bjorn Andersson
this by assigning the dma_mem and dma_ops based on the parent's DeviceTree node. Cc: Stephen Boyd <sb...@codeaurora.org> Signed-off-by: Bjorn Andersson <bjorn.anders...@linaro.org> --- Hi Peter, After (once more) debugging why USB doesn't work up on the 64-bit Qualcomm systems I real

Re: [PATCH 15/21] usb: chipidea: msm: Mux over secondary phy at the right time

2016-06-27 Thread Bjorn Andersson
On Sun 26 Jun 00:28 PDT 2016, Stephen Boyd wrote: > We need to pick the correct phy at runtime based on how the SoC > has been wired onto the board. If the secondary phy is used, take > it out of reset and mux over to it by writing into the TCSR > register. Make sure to do this on reset too,

Re: [PATCH 01/21] of: device: Support loading a module with OF based modalias

2016-06-27 Thread Bjorn Andersson
On Sun 26 Jun 00:28 PDT 2016, Stephen Boyd wrote: > In the case of ULPI devices, we want to be able to load the > driver before registering the device so that we don't get stuck > in a loop waiting for the phy module to appear and failing usb > controller probe. Currently we request the ulpi

Re: [PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-03-08 Thread Bjorn Andersson
On Tue, Mar 8, 2016 at 11:52 AM, Li Yang <le...@freescale.com> wrote: > On Wed, Mar 2, 2016 at 4:59 PM, Li Yang <le...@freescale.com> wrote: >> On Mon, Feb 22, 2016 at 4:07 PM, Bjorn Andersson >> <bjorn.anders...@linaro.org> wrote: >>> On Mon 22 Feb

Re: [PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-02-22 Thread Bjorn Andersson
On Mon 22 Feb 02:03 PST 2016, Srinivas Kandagatla wrote: > > > On 22/02/16 05:32, Bjorn Andersson wrote: > >On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set > >to be able to do DMA allocations, so use the of_dma_configure() helper > >to

Re: [PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-02-21 Thread Bjorn Andersson
On Sun 21 Feb 22:02 PST 2016, Peter Chen wrote: > On Sun, Feb 21, 2016 at 09:32:13PM -0800, Bjorn Andersson wrote: > > On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set > > to be able to do DMA allocations, so use the of_dma_configure() helper > >

[PATCH] usb: chipidea: Configure DMA properties and ops from DT

2016-02-21 Thread Bjorn Andersson
On certain platforms (e.g. ARM64) the dma_ops needs to be explicitly set to be able to do DMA allocations, so use the of_dma_configure() helper to populate the dma properties and assign an appropriate dma_ops. Signed-off-by: Bjorn Andersson <bjorn.anders...@linaro.org> --- drivers/usb/ch

Re: [PATCH v4 2/3] usb: phy: msm: fix connect/disconnect bug for dragonboard OTG port

2015-11-21 Thread Bjorn Andersson
On Fri 20 Nov 15:47 PST 2015, Tim Bird wrote: > Add support for async_irq to wake up driver from low power mode. > Without this, the power management code never calls resume. > Remove a spurious interrupt enable in the driver resume function. > > Signed-off-by: Tim Bird

Re: [Device-mainlining] [PATCH v4 1/5] gadget: Introduce the notifier functions

2015-10-07 Thread Bjorn Andersson
On Fri, Oct 2, 2015 at 10:23 AM, Felipe Balbi via device-mainlining wrote: [..] > The real difficulty here is coming up with an interface which we're agreeing > to > supporting for the next 30 years. Whatever that is, as soon as it gets exposed > to

Re: [PATCH 0/5] Rename regulator_set_optimum_mode

2015-02-25 Thread Bjorn Andersson
On Wed, Feb 11, 2015 at 7:35 PM, Bjorn Andersson bjorn.anders...@sonymobile.com wrote: Changing the name of the regulator_set_optimum_mode() to regulator_set_load() better reflects that the API is doing. Any comments on this? I'm going to propose a patch to the mmc framework calling this api

[PATCH 0/5] Rename regulator_set_optimum_mode

2015-02-11 Thread Bjorn Andersson
Changing the name of the regulator_set_optimum_mode() to regulator_set_load() better reflects that the API is doing. This series does the name change and move the current consumers over. Bjorn Andersson (5): regulator: s/regulator_set_optimum_mode/regulator_set_load/ ufs: Rename

[PATCH 4/5] usb: phy: phy-msm-usb: Rename regulator_set_optimum_mode

2015-02-11 Thread Bjorn Andersson
The function regulator_set_optimum_mode() is changing name to regulator_set_load(), so update the code accordingly. Signed-off-by: Bjorn Andersson bjorn.anders...@sonymobile.com --- drivers/usb/phy/phy-msm-usb.c | 15 +-- 1 file changed, 5 insertions(+), 10 deletions(-) diff --git

[PATCH 3/5] usb: phy: ab8500-usb: Rename regulator_set_optimum_mode

2015-02-11 Thread Bjorn Andersson
The function regulator_set_optimum_mode() is changing name to regulator_set_load(), so update the code accordingly. Signed-off-by: Bjorn Andersson bjorn.anders...@sonymobile.com --- drivers/usb/phy/phy-ab8500-usb.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers