Re: [PATCH v2 1/2] USB: serial: ark3116: Remove unused TIOCSSERIAL ioctl case.

2018-01-08 Thread Mikhail Zaytsev
On Mon, 8 Jan 2018 16:28:58 +0100 Johan Hovold <jo...@kernel.org> wrote: > On Mon, Jan 08, 2018 at 11:33:32AM +0100, Oliver Neukum wrote: > > Am Samstag, den 06.01.2018, 20:14 +0300 schrieb Mikhail Zaytsev: > > > The patch removes unused TIOCSSERIAL ioctl case an

[PATCH v2 1/2] USB: serial: ark3116: Remove unused TIOCSSERIAL ioctl case.

2018-01-06 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL ioctl case and adds the default block to the switch. This will make the ioctl return -ENOTTY to user space (e.g. setserial), because TIOCSSERIAL really isn't supported for these devices currently. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- d

[PATCH v2 0/2] USB: serial: ark3116: ioctl changes

2018-01-06 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL case from ioctl. TIOCGSERIAL case moves to the get_serial_info() function. Mikhail Zaytsev (2): USB: serial: ark3116: Remove unused TIOCSSERIAL ioctl case. USB: serial: ark3116: Move TIOCGSERIAL ioctl case to function. drivers/usb/serial/ark3116.c | 40

[PATCH v2 2/2] USB: serial: ark3116: Move TIOCGSERIAL ioctl case to function.

2018-01-06 Thread Mikhail Zaytsev
The patch moves TIOCGSERIAL ioctl case to get_serial_info function. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/serial/ark3116.c | 34 -- 1 file changed, 20 insertions(+), 14 deletions(-) diff --git a/drivers/usb/serial/ark3116.c b/d

Re: [PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl

2017-12-13 Thread Mikhail Zaytsev
On Wed, 13 Dec 2017 15:39:21 +0100 Oliver Neukum wrote: > But: > > device->maxbaudrate = 38400 > > is better than > > device->maxbaudrate = MAX_BAUD > > You see the point? Yes, I see. This is better, because it's more important to know =, but not =. thank you Oliver.

[PATCH 1/2] USB: serial: ark3116.c: Remove unused TIOCSSERIAL ioctl case.

2017-12-13 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL ioctl case and adds the default block to the switch. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/serial/ark3116.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/usb/serial/ark3116.c b/drivers/usb/

[PATCH 0/2] USB: serial: ark3116.c: ioctl changes

2017-12-13 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL case from ioctl. TIOCGSERIAL case moves to the get_serial_info() function. Some magic numbers moves to #define directives. Mikhail Zaytsev (2): USB: serial: ark3116.c: Remove unused TIOCSSERIAL ioctl case. USB: serial: ark3116.c: Move TIOCGSERIAL ioctl

[PATCH 2/2] USB: serial: ark3116.c: Move TIOCGSERIAL ioctl case to function.

2017-12-13 Thread Mikhail Zaytsev
The patch moves TIOCGSERIAL ioctl case to get_serial_info function. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/serial/ark3116.c | 35 +-- 1 file changed, 21 insertions(+), 14 deletions(-) diff --git a/drivers/usb/serial/ark3116.c b/d

Re: [PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl

2017-12-13 Thread Mikhail Zaytsev
On Wed, 13 Dec 2017 12:40:48 +0100 Oliver Neukum wrote: > They give you nothing. If you are looking at a vendor ID nothing but the > bare number makes sense. You are just making peoples' life harder when > they have to look up that definition. A symbolic name is fine if it

Re: [PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl

2017-12-13 Thread Mikhail Zaytsev
On Wed, 13 Dec 2017 11:17:28 +0100 Oliver Neukum <oneu...@suse.com> wrote: > Am Mittwoch, den 13.12.2017, 12:30 +0300 schrieb Mikhail Zaytsev: > > +#define RS232_VENDOR 0x6547 > > +#define RS232_PRODUCT 0x0232 > > +#define IRDA_VENDOR 0x18ec > > +#define IRDA

[PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl

2017-12-13 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL case from ioctl. TIOCGSERIAL case moves to the get_serial_info() function. Some magic numbers moves to #define directives. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/serial/ark3116.c | 54 ++---

[PATCH] USB: serial: ark3116.c: Remove unused TIOCSSERIAL case from ioctl

2017-12-13 Thread Mikhail Zaytsev
The patch removes unused TIOCSSERIAL case from ioctl. TIOCGSERIAL case moves to the get_serial_info() function. Any magic numbers moves to #define directives. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/serial/ark3116.c | 54 ++---

[PATCH v1] USB: storage: Remove obsolete "FIXME"

2017-11-30 Thread Mikhail Zaytsev
The fix of "FIXME: Notify the subdrivers..." doesn't actually have any real effect. The "FIXME" changed to simple comment. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/storage/usb.c | 8 1 file changed, 4 insertions(+), 4 deletions(-)

Re: [PATCH v1] USB: storage: Notify the subdrivers that they need to reinitialize the device.

2017-11-29 Thread Mikhail Zaytsev
On Wed, 29 Nov 2017 Alan Stern <st...@rowland.harvard.edu> wrote: > On Wed, 29 Nov 2017, Mikhail Zaytsev wrote: > > > This patch adds the device_reinit function into the us_data > > structure. The usb-storage driver uses this function for notify the > > subdrivers

Re: [PATCH v1] USB: storage: Notify the subdrivers that they need to reinitialize the device.

2017-11-29 Thread Mikhail Zaytsev
On 29 November 2017 at 11:27 +0100, Oliver Neukum wrote: >Hi, > the code does what it says, but why is it needed? > Which subdriver would actually implement the method? > > Regards > Oliver > Hi, There aren't any subdrivers, that implements the method. The

[PATCH v1] USB: storage: Notify the subdrivers that they need to reinitialize the device.

2017-11-29 Thread Mikhail Zaytsev
This patch adds the device_reinit function into the us_data structure. The usb-storage driver uses this function for notify the subdrivers that they need to reinitialize the device. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/storage/usb.c | 16 drive

[PATCH v1] USB: storage: Notify the subdrivers that they need to reinitialize the device.

2017-11-28 Thread Mikhail Zaytsev
This patch adds the device_reinit function into the us_data structure. The usb-storage driver uses this function for notify the subdrivers that they need to reinitialize the device. Signed-off-by: Mikhail Zaytsev <flas...@mail.ru> --- drivers/usb/storage/usb.c | 16 drive