Re: [PATCH v2 2/4] Staging: rtl8723bs: Change names to conform to the kernel code

2018-01-17 Thread Shreeya Patel
On Wed, 2018-01-17 at 14:59 +0100, Greg KH wrote: > On Wed, Jan 17, 2018 at 12:27:40AM +0530, Shreeya Patel wrote: > > > > Change names of some variables and functions to conform > > to the kernel coding style. > That's really vague, say exactly what you did here.  And

[PATCH v2 4/4] Staging: rtl8723bs: Use !x instead of NULL comparison

2018-01-16 Thread Shreeya Patel
If "x" is compared to NULL, use "!x" instead of it, so as to follow the kernel coding style. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- Changes in v2 -Rebase and resend. drivers/staging/rtl8723bs/hal/sdio_ops.c | 18 +- 1 file c

[PATCH v2 3/4] Staging: rtl8723bs: Change condition to assignment

2018-01-16 Thread Shreeya Patel
Change the conditional operator to assignment as it is not a conditional statement. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- Changes in v2 -Rebase and resend. drivers/staging/rtl8723bs/hal/sdio_ops.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH v2 2/4] Staging: rtl8723bs: Change names to conform to the kernel code

2018-01-16 Thread Shreeya Patel
Change names of some variables and functions to conform to the kernel coding style. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- Changes in v2 -Rebase and resend. drivers/staging/rtl8723bs/hal/sdio_ops.c | 714 +++ 1 file changed, 357 inse

[PATCH v2 0/4] Remove checkpatch warnings

2018-01-16 Thread Shreeya Patel
/4]. Shreeya Patel (4): Staging: rtl8723bs: Replace true with x and false with !x Staging: rtl8723bs: Change names to conform to the kernel code Staging: rtl8723bs: Change condition to assignment Staging: rtl8723bs: Use !x instead of NULL comparison drivers/staging/rtl8723bs/hal

[PATCH 2/4] Staging: rtl8723bs: Change names to conform to the kernel code

2017-12-13 Thread Shreeya Patel
Change names of some variables and functions to conform to the kernel coding style. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 186 +++ 1 file changed, 93 insertions(+), 93 deletions(-) diff

[PATCH 4/4] Staging: rtl8723bs: Use !x instead of NULL comparison

2017-12-13 Thread Shreeya Patel
If "x" is compared to NULL, use "!x" instead of it, so as to follow the kernel coding style. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 18 +- 1 file changed, 9 insertions(+), 9 deletion

[PATCH 3/4] Staging: rtl8723bs: Change condition to assignment

2017-12-13 Thread Shreeya Patel
Change the conditional operator to assignment as it is not a conditional statement. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8723

[PATCH 1/4] Staging: rtl8723bs: Replace true with x and false with !x

2017-12-13 Thread Shreeya Patel
Replace true and false keywords with "x" and "!x" respectively to follow the kernel coding style. Signed-off-by: Shreeya Patel <shreeya.patel23...@gmail.com> --- drivers/staging/rtl8723bs/hal/sdio_ops.c | 30 ++ 1 file changed, 14 insertions

[PATCH 0/4] Remove checkpatch warnings

2017-12-13 Thread Shreeya Patel
This patchset removes some warnings generated by checkpatch for cleanup of the rtl8723bs driver. Also some additional cleanups are introduced in the *[1/4] and *[3/4] patches to make the code according to the kernel coding style. Shreeya Patel (4): Staging: rtl8723bs: Replace true with x