Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-09-02 Thread Jassi Brar
On Tue, Sep 2, 2014 at 7:59 PM, Felipe Balbi wrote: > On Tue, Sep 02, 2014 at 04:04:14PM +0200, Daniel Mack wrote: >> Hi Felipe, >> >> On 08/29/2014 10:46 PM, Felipe Balbi wrote: >> > On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: >> >> Restructure some code to make it easier to read

Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-09-02 Thread Felipe Balbi
On Tue, Sep 02, 2014 at 04:04:14PM +0200, Daniel Mack wrote: > Hi Felipe, > > On 08/29/2014 10:46 PM, Felipe Balbi wrote: > > On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: > >> Restructure some code to make it easier to read. > >> > >> While at it, return -ENOMEM instead of -EINVAL

Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-09-02 Thread Daniel Mack
Hi Felipe, On 08/29/2014 10:46 PM, Felipe Balbi wrote: > On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: >> Restructure some code to make it easier to read. >> >> While at it, return -ENOMEM instead of -EINVAL if >> usb_ep_alloc_request() fails, and omit the logging in such cases >> (

Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-09-02 Thread Daniel Mack
Hi, On 09/02/2014 02:41 PM, Jassi Brar wrote: > On Sat, Aug 30, 2014 at 2:16 AM, Felipe Balbi wrote: >> Hi, >> >> On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: >>> Restructure some code to make it easier to read. >>> >>> While at it, return -ENOMEM instead of -EINVAL if >>> usb_ep_

Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-09-02 Thread Jassi Brar
Hi Felipe On Sat, Aug 30, 2014 at 2:16 AM, Felipe Balbi wrote: > Hi, > > On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: >> Restructure some code to make it easier to read. >> >> While at it, return -ENOMEM instead of -EINVAL if >> usb_ep_alloc_request() fails, and omit the logging i

Re: [PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-08-29 Thread Felipe Balbi
Hi, On Wed, Aug 27, 2014 at 07:09:03PM +0200, Daniel Mack wrote: > Restructure some code to make it easier to read. > > While at it, return -ENOMEM instead of -EINVAL if > usb_ep_alloc_request() fails, and omit the logging in such cases > (the mm core will complain loud enough). > > Signed-off-b

[PATCH v6 1/5] usb: gadget: f_uac2: restructure some code in afunc_set_alt()

2014-08-27 Thread Daniel Mack
Restructure some code to make it easier to read. While at it, return -ENOMEM instead of -EINVAL if usb_ep_alloc_request() fails, and omit the logging in such cases (the mm core will complain loud enough). Signed-off-by: Daniel Mack --- drivers/usb/gadget/function/f_uac2.c | 39 +++--