pull-request: mac80211 2015-08-14

2015-08-14 Thread Johannes Berg
Hi Dave, I'm back from vacation, and found a single bugfix waiting. It's in this pull request, but I'm not quite up to speed as to what's happening with the release. If it goes in, great; if not I've already tagged it with Cc stable anyway. Thanks, johannes The following changes since commit

Re: [PATCH] iwlwifi: out-of-bounds access in iwl_init_sband_channels

2015-08-14 Thread Kalle Valo
Adrien Schildknecht adrien+...@schischi.me writes: Hi, On 08/14/2015 03:36 AM, Adrien Schildknecht wrote: Both loops of this function compare data from the 'chan' array and then check if the index is valid. The 2 conditions should be inverted to avoid an out-of-bounds access.

Re: [PATCH 1/2] average: provide macro to create static EWMA

2015-08-14 Thread Johannes Berg
On Thu, 2015-08-13 at 17:26 -0700, David Miller wrote: From: Johannes Berg johan...@sipsolutions.net Date: Thu, 13 Aug 2015 11:11:48 +0200 From: Johannes Berg johannes.b...@intel.com Having the EWMA parameters stored in the runtime struct imposes memory requirements for the constant

About adding support for MT76x2U to Linux kernel

2015-08-14 Thread Tuomas Räsänen
Hi I'm very interested in adding support (especially AP mode) for MT76x2U USB-dongles to Linux kernel. I'm aware of the work you both have done, Felix's work on MT76x2 PCI-devices and Jakub's work to add support for MT7601U. So I guess no one knows this exact problem domain better than you

[PATCH v2] iwlwifi: out-of-bounds access in iwl_init_sband_channels

2015-08-14 Thread Adrien Schildknecht
KASan error report: == BUG: KASan: out of bounds access in iwl_init_sband_channels+0x207/0x260 [iwlwifi] at addr 8800c2d0aac8 Read of size 4 by task modprobe/329 ==

Re: [PATCH/RFT 2/2] ath10k: rename qca6174 to qca61x4

2015-08-14 Thread Kalle Valo
Michal Kazior michal.kaz...@tieto.com writes: This cleans up the naming a little bit. Both QCA6174 and QCA6164 are in practice the same as far as driving them is concerned. Unfortunately firmware paths will need to stay untouched, i.e. QCA6164 firmware will still be looked for in QCA6174

GCOV_PROFILE_ALL breaks BUILD_BUG_ON(!is_power_of_2(8))

2015-08-14 Thread Johannes Berg
+linux-kernel +#define DECLARE_EWMA(name, _factor, _weight) \ + struct ewma_##name { \ +unsigned long internal; \ + };

Re: GCOV_PROFILE_ALL breaks BUILD_BUG_ON(!is_power_of_2(8))

2015-08-14 Thread Michal Kubecek
On Fri, Aug 14, 2015 at 10:29:04AM +0200, Johannes Berg wrote: +linux-kernel +#define DECLARE_EWMA(name, _factor, _weight) \ + struct ewma_##name { \ + unsigned long internal;

Re: GCOV_PROFILE_ALL breaks BUILD_BUG_ON(!is_power_of_2(8))

2015-08-14 Thread Johannes Berg
On Fri, 2015-08-14 at 11:00 +0200, Michal Kubecek wrote: but should I have expected this? It might have something to do with the fact that is_power_of_2() being an inline function, perhaps with this compiler option it translates to something that can't be used in the context

[PATCH 2/6] staging: vt6655: replaced typedef struct tagTDES1

2015-08-14 Thread Malcolm Priestley
Create struct vnt_tdes1 that replaces members wReqCount - req_count byTCR - tcr byReserved - reserved Signed-off-by: Malcolm Priestley tvbox...@gmail.com --- drivers/staging/vt6655/desc.h| 13 ++--- drivers/staging/vt6655/device_main.c | 9 - 2 files changed, 10

[PATCH 5/6] staging: vt6655: replace typedef struct tagDEVICE_TD_INFO and structure

2015-08-14 Thread Malcolm Priestley
Create struct vnt_td_info with members mic_hdr skb buf buf_dma dwReqCount - req_count byFlags - flags In struct tagSTxDesc volatile is removed because it will generate a warning (in any case this member is not) and renaming td_info. Signed-off-by: Malcolm Priestley tvbox...@gmail.com ---

FCC's new regulations on 5Ghz Wifi

2015-08-14 Thread Xose Vazquez Perez
Hi, The FCC wants to require manufacturers to lock down devices with radio (wifi, bluetooth, etc) with DRM. More info: http://wiki.prplfoundation.org/wiki/Complying_with_FCC_rules_on_Wifi http://libreplanet.org/wiki/Save_WiFi FCC Wifi Regulation List:

[PATCH 4/6] staging: vt6655: struct tagDEVICE_TD_INFO remove dwHeaderLength

2015-08-14 Thread Malcolm Priestley
dwHeaderLength is assigned a value but that is never used. Remove variable. Signed-off-by: Malcolm Priestley tvbox...@gmail.com --- drivers/staging/vt6655/desc.h | 1 - drivers/staging/vt6655/rxtx.c | 1 - 2 files changed, 2 deletions(-) diff --git a/drivers/staging/vt6655/desc.h

[PATCH 1/6] staging: vt6655: desc.h replace typedef struct tagTDES0

2015-08-14 Thread Malcolm Priestley
create struct vnt_tdes0 replacing used members byTSR0 - tsr0 byTSR1 - tsr1 f1Owner - owner Narrowing endian differences to inside structure. Signed-off-by: Malcolm Priestley tvbox...@gmail.com --- drivers/staging/vt6655/card.c| 4 ++-- drivers/staging/vt6655/desc.h| 36

Re: set channel from radiotap headers during injection

2015-08-14 Thread Allan Matthew
Anyone have any thoughts on this? Is it possible with channel context enabled somehow? On Thu, Aug 13, 2015 at 11:22 AM, Allan Matthew allan...@gmail.com wrote: I'd like to be able to set the channel information on a per-packet basis during monitor-mode injection. Specifically, I would like

Re: [PATCH v2] staging: wilc1000: Process WARN, INFO options of debug levels from user

2015-08-14 Thread Greg KH
On Fri, Aug 14, 2015 at 10:50:07PM +0530, Chandra S Gorentla wrote: This patch enables setting the module's debug options WARN and INFO in the debugfs file 'wilc_debug_level'. This enables the user to enable logging of warning and other information. Before this change writes to this debugfs

Re: [PATCH 2/5] staging: wilc1000: change void pointer type to real type

2015-08-14 Thread Greg KH
On Fri, Aug 14, 2015 at 11:56:13AM +0530, Sudip Mukherjee wrote: On Thu, Aug 13, 2015 at 01:41:20PM +0900, Tony Cho wrote: From: Johnny Kim johnny@atmel.com This patch changes the void pointer member of the tstrHostIFmsg to the real data type because the void pointer type is

pull-request: mac80211-next 2015-08-14

2015-08-14 Thread Johannes Berg
Hi, And, in addition to the fix before, I have a -next pull request. It's actually quite big since I hadn't wanted to send one just before my vacation. Let me know if there are any issues. johannes The following changes since commit 923b352f19d9ea971ae2536eab55f5fc9e95fedf: cfg80211: use

Re: Ath10 firmware crashing in Monitor mode(Sniffer mode)

2015-08-14 Thread Ben Greear
On 08/13/2015 02:01 PM, S Prasad Kandregula wrote: Thank you Ben for immediate response, Don't mind, could you please share your firmware path. Grab one of the beta-15 builds linked from this page: http://www.candelatech.com/ath10k.php If you want the mgt-htt version, be sure to patch your

Re: About adding support for MT76x2U to Linux kernel

2015-08-14 Thread Jakub Kiciński
CC: Linus W who was hacking on mt7630e recently. On Fri, 14 Aug 2015 11:15:26 +0300, Tuomas Räsänen wrote: Hi I'm very interested in adding support (especially AP mode) for MT76x2U USB-dongles to Linux kernel. I'm aware of the work you both have done, Felix's work on MT76x2 PCI-devices and

[PATCH] mwifiex: control WLAN and bluetooth coexistence modes

2015-08-14 Thread Amitkumar Karwar
By default our chip will be in spatial coexistence mode. This patch adds a provision to change it to timeshare mode via sysfs command. Enable timeshare coexistence mode echo 1 /sys/class/net/mlan0/timeshare_coex Go back to spacial coexistence mode echo 0