Re: [PATCH] net-libertas: Better exception handling in if_spi_host_to_card_worker()

2016-01-01 Thread Julia Lawall
On Fri, 1 Jan 2016, SF Markus Elfring wrote: > From: Markus Elfring > Date: Fri, 1 Jan 2016 22:27:20 +0100 > > This issue was detected by using the Coccinelle software. > > Move the jump label directly before the desired log statement > so that the variable

Re: net/nfc: GPF in llcp_sock_getname

2016-01-01 Thread Cong Wang
On Fri, Jan 1, 2016 at 5:58 AM, Dmitry Vyukov wrote: > GPF seems to be caused by a data race on socket state. Seems you are right, I think the following patch should work: diff --git a/net/nfc/llcp_sock.c b/net/nfc/llcp_sock.c index ecf0a01..5a91997 100644 ---

[PATCH 0/3] net-iwlegacy: Fine-tuning for il_eeprom_init()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 21:25:43 +0100 A few update suggestions were taken into account from static source code analysis. Markus Elfring (3): Refactoring One check less after error detection Another refactoring

[Patch net] nfc: use GFP_USER for user-controlled kmalloc

2016-01-01 Thread Cong Wang
Reported-by: Dmitry Vyukov Cc: Lauro Ramos Venancio Cc: Aloisio Almeida Jr Cc: Samuel Ortiz Signed-off-by: Cong Wang --- net/nfc/llcp_commands.c | 2 +- 1 file

[Patch net] nfc: check sock state in llcp_sock_getname()

2016-01-01 Thread Cong Wang
llcp_sock_getname() checks llcp_sock->dev to make sure llcp_sock is already connected or bound, however, we could be in the middle of llcp_sock_bind() where llcp_sock->dev is bound and llcp_sock->service_name_len is set, but llcp_sock->service_name is not, in this case we would lead to copy some

Re: net/nfc: GPF in llcp_sock_getname

2016-01-01 Thread Cong Wang
On Fri, Jan 1, 2016 at 5:58 AM, Dmitry Vyukov wrote: > > kasan: GPF could be caused by NULL-ptr deref or user memory > accessgeneral protection fault: [#51] SMP KASAN > Modules linked in: > CPU: 2 PID: 4207 Comm: a.out Not tainted 4.4.0-rc7+ #184 > Hardware name: QEMU

[PATCH] ipw2x00: add checks for dma mapping errors

2016-01-01 Thread Alexey Khoroshilov
ipw2100_alloc_skb() and ipw2100_tx_send_data() do not check if mapping dma memory succeed. The patch adds the checks and failure handling. Found by Linux Driver Verification project (linuxtesting.org). Signed-off-by: Alexey Khoroshilov ---

Re: [PATCH 2/3] net-iwlegacy: One check less in il_eeprom_init() after error detection

2016-01-01 Thread Sergei Shtylyov
Hello. On 1/1/2016 11:31 PM, SF Markus Elfring wrote: From: Markus Elfring Date: Fri, 1 Jan 2016 21:12:29 +0100 This issue was detected by using the Coccinelle software. Adjust a jump target to avoid a check repetition before the function call

[PATCH 1/3] net-iwlegacy: Refactoring for il_eeprom_init()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 20:54:25 +0100 Return directly if a memory allocation failed at the beginning. Signed-off-by: Markus Elfring --- drivers/net/wireless/intel/iwlegacy/common.c | 8 +++- 1 file changed,

[PATCH 2/3] net-iwlegacy: One check less in il_eeprom_init() after error detection

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 21:12:29 +0100 This issue was detected by using the Coccinelle software. Adjust a jump target to avoid a check repetition before the function call "il_eeprom_free". Signed-off-by: Markus Elfring

[PATCH 3/3] net-iwlegacy: Another refactoring for il_eeprom_init()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 21:16:01 +0100 Rename a jump label according to the current Linux coding style convention. Signed-off-by: Markus Elfring --- drivers/net/wireless/intel/iwlegacy/common.c | 4 ++-- 1 file

Re: [PATCH] net-libertas: Better exception handling in if_spi_host_to_card_worker()

2016-01-01 Thread Sergei Shtylyov
Hello On 1/2/2016 12:33 AM, SF Markus Elfring wrote: From: Markus Elfring Date: Fri, 1 Jan 2016 22:27:20 +0100 This issue was detected by using the Coccinelle software. Move the jump label directly before the desired log statement so that the variable "err"

Re: net/nfc: GPF in llcp_sock_getname

2016-01-01 Thread Cong Wang
On Fri, Jan 1, 2016 at 12:58 PM, Cong Wang wrote: > > It looks like we forget to initialize ->service_name_len > and ->servicce_name before bind(). Never mind, __GFP_ZERO is passed in sk_alloc()... -- To unsubscribe from this list: send the line "unsubscribe

[PATCH] net-libertas: Better exception handling in if_spi_host_to_card_worker()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 22:27:20 +0100 This issue was detected by using the Coccinelle software. Move the jump label directly before the desired log statement so that the variable "err" will not be checked once more after it was determined that

Re: [PATCH 3/7] brcmfmac: Add support for scheduled scan mac randomization

2016-01-01 Thread Kalle Valo
Arend van Spriel writes: > On 29-12-15 21:47, Mathy Vanhoef wrote: >> On Mon, Dec 14, 2015 at 2:39 PM, Arend van Spriel wrote: >>> From: Hante Meuleman >>> >>> Scheduled scan be requested to use mac randomization. This patch >>>

[PATCH 2/6] wlcore: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang --- drivers/net/wireless/ti/wlcore/main.c | 10 +- drivers/net/wireless/ti/wlcore/ps.c | 2 +- drivers/net/wireless/ti/wlcore/scan.c | 2 +- 3 files changed, 7 insertions(+), 7

net/nfc: GPF in llcp_sock_getname

2016-01-01 Thread Dmitry Vyukov
Hello, The following program triggers GPF in llcp_sock_getname: // autogenerated by syzkaller (http://github.com/google/syzkaller) #include #include #include #include #include #include #include #include int fd; void *thr(void *arg) { struct sockaddr_nfc_llcp sa;

[PATCH 5/6] mwifiex: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang --- drivers/net/wireless/marvell/mwifiex/11h.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/drivers/net/wireless/marvell/mwifiex/11h.c

[PATCH 4/6] rtlwifi: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang --- drivers/net/wireless/realtek/rtlwifi/wifi.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/realtek/rtlwifi/wifi.h

[PATCH 1/6] cfg80211/mac80211: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang --- net/mac80211/mlme.c | 3 +-- net/wireless/mlme.c | 2 +- 2 files changed, 2 insertions(+), 3 deletions(-) diff --git a/net/mac80211/mlme.c b/net/mac80211/mlme.c index 1c342e2..ea70917 100644

[PATCH 3/6] wl1251: use to_delayed_work

2016-01-01 Thread Geliang Tang
Use to_delayed_work() instead of open-coding it. Signed-off-by: Geliang Tang --- drivers/net/wireless/ti/wl1251/ps.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/net/wireless/ti/wl1251/ps.c b/drivers/net/wireless/ti/wl1251/ps.c index

Re: [PATCH 1/2] net-ath9k_htc: Delete an unnecessary variable initialisation in ath9k_hif_usb_rx_stream()

2016-01-01 Thread Oleksij Rempel
Am 01.01.2016 um 19:23 schrieb SF Markus Elfring: > From: Markus Elfring > Date: Fri, 1 Jan 2016 19:00:53 +0100 > > Omit explicit initialisation at the beginning for one local variable > that is redefined before its first use. > > Signed-off-by: Markus Elfring

Re: [PATCH 2/2] net-ath9k_htc: Replace a variable initialisation by an assignment in ath9k_htc_set_channel()

2016-01-01 Thread Oleksij Rempel
Am 01.01.2016 um 19:25 schrieb SF Markus Elfring: > From: Markus Elfring > Date: Fri, 1 Jan 2016 19:09:32 +0100 > > Replace an explicit initialisation for one local variable at the beginning > by a conditional assignment. > > Signed-off-by: Markus Elfring

[PATCH] net-brcmfmac: Delete an unnecessary variable initialisation in brcmf_sdio_download_firmware()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 20:20:15 +0100 Omit explicit initialisation at the beginning for one local variable that is redefined before its first use. Signed-off-by: Markus Elfring ---

[PATCH 0/2] net-ath9k_htc: Fine-tuning for two function implementations

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 19:16:05 +0100 A few update suggestions were taken into account from static source code analysis. Markus Elfring (2): Delete an unnecessary variable initialisation in ath9k_hif_usb_rx_stream() Replace a variable

[PATCH 1/2] net-ath9k_htc: Delete an unnecessary variable initialisation in ath9k_hif_usb_rx_stream()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 19:00:53 +0100 Omit explicit initialisation at the beginning for one local variable that is redefined before its first use. Signed-off-by: Markus Elfring ---

[PATCH 2/2] net-ath9k_htc: Replace a variable initialisation by an assignment in ath9k_htc_set_channel()

2016-01-01 Thread SF Markus Elfring
From: Markus Elfring Date: Fri, 1 Jan 2016 19:09:32 +0100 Replace an explicit initialisation for one local variable at the beginning by a conditional assignment. Signed-off-by: Markus Elfring ---